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1. Overview 

1.1 Document Purpose and Scope 

This document is the introduction and overview to the Manual Validation Procedures 
used as part of the required set of test procedures in the certification of products to 
The Open Group COE Platform Product Standard. The Manual Validation Procedures 
are available as a series of documents, which for ease of reference are referred to as 
chapters1 as noted below. 

This document is intended for suppliers who intend to submit a product for 
certification. These test procedures, along with the components referenced in the 
program�s policy and in conjunction with the appropriate certification agreement and 
the trademark license agreement, constitute the requirements and obligations for 
achieving certification. Buyers intending to procure certified products may also find 
this document useful for understanding the manual test procedures that were 
performed as part of the certification process. 

The Open Group�s COE Platform certification program is a voluntary program, open 
to any product meeting the conformance requirements.  

1.2 Recommended Reading 

The reader is referred to the COE Platform Certification Policy for definitions and 
abbreviations used within this document. 

The reader is referred to the COE Certification Guide for high-level guidance on the 
overall testing program for the COE Platform Product Standard. 

COE Platform certification is part of The Open Brand certification program. The 
reader is referred to The Practical Guide to The Open Brand for general information 
about The Open Brand certification program  (Brand Documentation, Document No. 
X221). 

1.3 About the Manual Validation Procedures 

The Manual Validation Procedures are organized as a series of parts and chapters. 
Each chapter comprises an individual manual validation procedure. Common material 
is provided in this introduction that applies to all chapters. 

 

Part 1 contains the Manual Validation Procedures for the COE Government-Supplied 
Kernel Source Product Standard: 

Chapter 1     Kernel Overview Validation Procedure 

Chapter 2      Print Services Validation Procedure 

Chapter 3      Account and Profile Manager Validation Procedure (client) 

                                           
1Chapter references are utilized for Problem Reporting, and for change control 
updates to the Manual Validation Procedures. 



Chapter 4      Account and Profile Manager Validation Procedure (master) 

Chapter 5      Segment Installation Validation Procedure 

Chapter 6  Remote Installation Validation Procedure 

Chapter 7 Developers Toolkit and Runtime Validation Procedure 

Chapter 8      Audit Log File Validation Procedure 

 

Part 2 contains the Manual Validation Procedures for the COE Platform Standards 
Product Standard: 

Chapter 9 Simple Mail Transport Protocol (SMTP) Interoperability Validation  
              Procedure 

Chapter 10     File Transfer Protocol (FTP) Interoperability Validation Procedure 

Chapter 11     World Wide Web (WWW) Interoperability Validation Procedure 

Chapter 12     Network File System (NFS) Validation Procedure 

Chapter 13     TCP/IP and DNS Interoperability Validation Procedure 

 

2. Test Procedure Contents 

Each test procedure contains the following information: 

2.1 Scope: 

Each test procedure contains a Scope section that describes the purpose of the test 
procedure and an overview of the assurance provided by it.  

2.2 Description of test items 

Each test procedure contains a Description section describing the functionality that is 
to be exercised. 

2.3 Test Data/Media Required   

Each test procedure contains the test data and media requirements, if any. 

2.4 Setup/Equipment Required 

Each test procedure contains the setup and equipment requirements for the 
procedure. 

 

 

 

 

 



 

2.5 Required Personnel 

Each test procedure contains the required personnel and any required skills or 
knowledge. 

2.6 Change History 

 

3. How to Execute a Test Procedure 

The following requirements apply to all the manual validation procedures. 

Testing must always take place using the most recent authorized version of the 
procedure. This may mean that if a new version of a procedure becomes available 
after testing has commenced but before submission of the results some test steps 
may need to be repeated. This will not ordinarily require the complete rerun of a test 
procedure since the tests themselves will not change only the interpretation 
guidance. However, it does mean that while certain TSD�s may have been valid for 
the previous version of the test procedure they may cease to be valid for the new 
version. 

The test procedures must be executed in the sequence specified in the table of test 
procedure items that are included in each chapter. Due to the nature of some of the 
procedures it should be noted that failure to execute the manual test procedure 
steps in the order specified may cause damage to the system under test. They must 
be executed as an uninterrupted run. The �Observed Results� of each test item in the 
test procedure table must be recorded. This table of test procedure items and 
recorded results are to be submitted as a component of the certification process.  

The Kernel Overview Validation Procedure must be completed with no fail results, 
after all problem reports are resolved, before any other Manual test procedures 
should be attempted.  

3.1 Determination of Overall Test Results   

The overall PASS/FAIL result for a test procedure is determined as follows:  The 
overall test result is "PASS" if and only if all test items that have PASS/FAIL condition 
in the �Observed Result� column, have a test "PASS" result. 

3.2 Determining a Test Item�s Results  

For each test item in the test procedure table with a "Circle One:  PASS/FAIL" in the 
Observed Result column, the tester compares the directly observed Candidate 
Platform behavior with the "PASS" criteria.  Unless other PASS criteria are noted in 
the test item, the test item�s result is "PASS" if and only if the Candidate Platform 
presents all of the behaviors and conditions described in the �Expected Result� 
column for that test procedure item.  The test procedure item�s result is "FAIL" if the 
Candidate Platform fails to satisfy any of the PASS criteria. For the avoidance of 
doubt should a test step result in no apparent behavior of any kind this also 



constitutes a �FAIL� unless the absence of any behavior is defined as the expected 
outcome of the test step. 

If the test item results are "PASS", the tester will circle "PASS" and note the actual 
behaviors and conditions presented in the �Observed Result� column.  If the 
observed result precisely matches the expected result, the Observed Result column 
for the test item may contain the statement "as expected.� 

If the test procedure item results are "FAIL", the tester will circle "FAIL" in the 
Observed Result column. A �FAIL� can only be related to an already approved 
Problem Report. Insert a valid reference to an approved Problem Report from the 
Problem Reporting database. An approved Problem Report is one that has resulted in 
an agreed Interpretation of the specification, a Test Suite Deficiency, or a 
Certification System Deficiency. These apply to specific releases of the specification, 
Manual Validation Procedure, or certification system.  

In the case that the results of testing are to be subject to on-site witness testing in 
connection with �Specific Platform certification� the most recent versions of the 
Manual Validation procedures will be used. In some cases that may mean that a 
referenced TSD or other interpretations may have ceased to be valid for the purpose 
of witness testing. In exceptional cases it may be established during witness testing 
that an existing approved TSD does not justify the disregarding of a fail result and in 
that case the test procedure will be updated there and then to that effect. In such 
cases the TSD in question will no longer be acceptable for the fail result and either 
the implementation will need to pass or a new TSD will be required. Applicants 
should therefore be aware that the applicability of any referenced TSD�s might be 
subject to particular scrutiny during Witness testing. 

3.3 Problem Reporting, Waivers and Interpretations 

To report a problem on a specific procedure, the chapter and sub-procedure 
reference should be given, for example to report a problem in the Kernel Overview 
procedure, sub procedure A.1.7, the correct reference would be Chapter1/A.1.7. 

When submitting a problem report, if relevant, include the proposed impact on 
subsequent test procedures that granting the request will incur. 

More information about the procedures for applying for interpretations and waivers 
can be found on The Open Group's World Wide Web site, at the URL 

 http://www.opengroup.org/openbrand/coe/PR/ 

A searchable database of existing interpretations and waivers is also available at that 
URL. 

See Chapter 6 of the Practical Guide to The Open Brand (Document X221) for further 
information regarding policies and processes for Interpretations, Test Suite 
Deficiencies, and Temporary Waivers 
(http://www.opengroup.org/openbrand/Certification_Guide/chap06.htm). 

 

3.4 Not In Use Test Items 

Test items that are "grayed out" (i.e., the entire table row is set to a gray 
background) are to be considered to be NOT IN USE for this test version only.  
Grayed out test steps are not to be executed (they may cause unexpected problems) 



nor is observed behavior to be recorded.  These test steps may be included in the 
overall test at a future date and are retained for information purposes only.  
PASS/FAIL criteria identified in these test steps will not be used in the determination 
of the overall test result. 

3.5 Results Submission 

Sections 3 and 4 of each procedure must be completed by the applicant and 
submitted as part of a formal certification submission. Completion may either be in 
hardcopy or electronic if the pdf versions of the documents are edited using the 
Adobe Acrobat utility.  

3.6 Nomenclature 

Lower case �s� in brackets [s] denotes a blank space; lower case �r� in brackets [r] 
denotes a carriage return; lower case �s� and �r� together in brackets [s] [r] denotes 
a blank space and carriage return. 

4. Change History 

 

Initial Release Revision 1.0 02 June 2003
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1. Overview 

1.1 Introduction 

This chapter defines the Kernel Overview Manual Validation Procedure and is part of 
the required set of test procedures to be used in the certification of products to The 
Open Brand COE Platform Product Standard1.  

2. Test Purpose 

2.1 Scope  

This test procedure provides a high level test of the full range of fundamental Kernel 
Platform functionality.  Each of the other COE Platform Compliance tests provides a 
deeper (i.e. more thorough) test of specific narrower range of Kernel functionality.  
This test also assures that the Graphical User Interface (GUI) presented to the user 
for basic system operation is consistent across all compliant systems certified to the 
COE Platform Product Standard.  This test also assures that the operations invoked 
and exercised have identical results and that they are consistent across all compliant 
systems. 

2.2 Description of test items  

Functionality that will be tested using the Kernel Overview Validation Procedure is as 
follows: 

sysadmin login - Verify sysadmin login, Profile Selector, Change Password Tool, 
command line accessibility, and icon accessibility 

Adm Tool - Invokes the native operating system's administration tool. On Solaris, 
the Adm Tool icon invokes the Solaris admintool application.  

Change Machine ID (with DNS) - Allows the System Administrator to change the 
machine name or Internet Protocol (IP) address of the workstation. 

Create Action - Allows the System Administrator to create a desktop action. 

Dtterm - Opens a dtterm terminal window for the System Administrator to perform 
tasks that require the use of a command line. 

Disk Manager - Allows the System Administrator to perform file system 
management tasks, including mounting and exporting file system partitions, 
formatting hard drives and hard drive partitions, displaying available hard disk 
space, and initializing diskettes. 

 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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Edit Local Hosts - Allows the System Administrator to manage the local host table, 
which lists the computers that can be accessed from the local workstation. 

Network Installation Server and Segment Installer - Allows the System 
Administrator to load software segments onto a machine and make them available 
for other computers to install. Allows the System Administrator to install and/or 
remove software segments on the local workstation. 

Set Routes - Allows the System Administrator to configure the workstation to 
connect to the wide area network through a default router. 

Set System Time - Allows the System Administrator to set or change the value of 
the system time. 

Text Editor - Invokes a text editor application. 

Xterm - Opens an xterm terminal window for the System Administrator to perform 
tasks that require the use of a command line. 

Reboot System - Allows the System Administrator to reboot the machine. 

Shutdown System - Allows the System Administrator to prepare the machine for 
powering down. 

secman login - Verify secman login, Profile Selector, Change Password Tool, 
command line accessibility, and icon accessibility 

APM Client - Invokes the Account and Profile Manager client application. The APM 
Client administers user accounts, groups, profiles, and hosts. 

APM Server Reload - Shuts down and restarts the APM local server process 

APM Server Stop - Shuts down the APM local server process. 

APM Server Start - Restarts the APM local server process if the Security 
Administrator has shut it down. The APM local server communicates with the APM 
client and the APM master server to perform administrative operations. 

Assign Passwords - Allows the Security Administrator to assign passwords to user 
accounts. This operation requires root access to the system. 

Audit Log File Manager - Allows the Security Administrator to manage the audit 
log files, which record user login and logout information. 

Edit APM Configuration - Invokes a graphical tool that allows the Security 
Administrator to edit the APM configuration settings. 

Set Local Authentication Key � Uses the keyman account to set the local 
authentication key for the Candidate Platform and inform the Validation Host of the 
key. 

Merge Host - Copies and synchronizes APM account and profile information from an 
APM host server to the APM master server. This operation adds an APM host to the 
APM administrative domain. 

Profile Selector Configuration - Configures settings for the Profile Selector 
application. 

Remove Host - Removes a merged host from the APM administrative domain. 
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 Public Key Manager � Exports the host�s public key to a text file or imports the 
public key of a remote host. 

Logout. 

 

2.3 Test Data/Media Required   

The following segments are required to execute this test: 

OnlineDocs Segment Version 4.2.0.0. 

2.4 Setup/Equipment Required 

This test requires a Validation Cell consisting of a Validation Host and Candidate 
Platform.  

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003 

Initial Release 

 

 

 

 

 



 

  

3. Test Procedure Submission Form 

 

Test Title: Kernel Overview Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 6 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        

 

 



 

  

 

4. Test Procedure 

Start of Validation Procedure 

 Operator Action Expected Result Observed Result 

 Note -> Sections A1.1 through B1.2 should be executed prior to installing any additional segments or setting up DNS. 

A 
4.1 Verify sysadmin Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon 

Accessibility 

A.1 Verify sysadmin Login  

A.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Verify that the DII COE LOGIN screen appears. 

The DII COE LOGIN screen appears with the 
DoD security warning message and the Please 
enter your user name text box. 

Circle one:  PASS / FAIL 

 

A.1.2 Log in as the System Administrator by typing 
sysadmin in the Please enter your 
user name text box and pressing ENTER. 

The password screen appears with the Please 
enter your password text box. 

Circle one:  PASS / FAIL 

 

A.1.3 Type the password for the sysadmin account in the 
Please enter your password text box and 
press ENTER.  

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

A.1.4 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.1.5 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

A.1.6 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

A.1.7 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

A.1.8 Log in as user sysadmin with the new password. An INFORMATIONAL MESSAGE dialog box 
appears confirming COE login processing is 
complete. 

Circle one:  PASS / FAIL 

 

 

A.1.9 Click OK in the INFORMATIONAL MESSAGE 
dialog box. 

The dialog box disappears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.2 
4.2 Verify sysadmin Profile Selector Functionality 

 

A.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

On the CDE, click Profile Selector (the 
head with a question mark). 

The Profile Selector window appears with 
SA Default listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

A.2.2 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

A.3 
4.3 Verify sysadmin Change Password Tool Functionality 

 

A.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

On the CDE, access the Change Password 
Tool by clicking the arrow above the Profile 
Selector icon.  

The DII Tools menu appears. Circle one:  PASS / FAIL 

 

 

A.3.2 Select Change Password Tool.  The Change your password window 
appears. 

Circle one:  PASS / FAIL 

 

A.3.3 Enter an incorrect sysadmin password in the Old 
Password text box. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

A.3.4 Enter a valid new password in the New 
Password and Password Confirm text boxes. 

Asterisks appear in the text boxes. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.3.5 Click Submit. A Status Summary dialog box appears 
indicating the validation by sysadmin failed. 

Circle one:  PASS / FAIL 

 

A.3.6 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 

 

A.3.7 On the CDE, access the Change Password 
Tool by clicking the arrow above the Profile 
Selector icon. 

The DII Tools menu appears. Circle one:  PASS / FAIL 

 

A.3.8 Select Change Password Tool.  The Change your password window 
appears. 

Circle one:  PASS / FAIL 

 

A.3.9 Enter the correct sysadmin password in the Old 
Password text box. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

A.3.10 Enter a new password in the New Password and 
Password Confirm text boxes. 

NOTE: This password change cannot be undone. 
All test personnel should be informed of the new 
password. 

Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

A.3.11 Click Submit. A Status Summary dialog box appears 
indicating minimum password life has not expired. 

Circle one:  PASS / FAIL 

 

A.3.12 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 

 

A.3.13 On the CDE, click Exit. A Logout Confirmation dialog box appears. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 11 

 
 

 

 

 Operator Action Expected Result Observed Result 

A.3.14 Click OK. The dialog box disappears and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 

 

A.3.15 Login as sysadmin using the old password. The desktop appears. Circle one:  PASS / FAIL 

 

A.4 
4.4 Verify Command Line Access 

 

A.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Right-click on the desktop. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

A.4.2 Select Tools > Terminal. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Result column. 

NOTE: This method should be used in all 
following test steps for the operator action �Open a 
Terminal window�. 

A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

 

A.4.3 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=100(sysadmin) gid=1(other) 

NOTE: This result is OS specific. The result 
should indicate the user is sysadmin. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.4.4 At the command prompt type 
pwd  

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
/h/USERS/local/sysadmin/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 

 

 

A.4.5 At the command prompt type 
exit 

The Terminal window disappears. Circle one:  PASS / FAIL 

 

A.5 Verify Icon Access  

A.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

 

A.5.2 Select Applications > Application 
Manager.  

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Application Manager window appears. Circle one:  PASS / FAIL 

 

 

A.5.3 Double-click DII_APPS. The Application Manager – DII_APPS 
window appears. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.5.4 Double-click SysAdm. The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

B 
4.5 Verify Adm Tool Functionality 

B.1 Open the Adm Tool  

B.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Double-click Adm Tool. 

The Admintool:Users window appears.  

NOTE: This result is OS specific. The native 
operating system�s administration tool should be 
launched. 

Circle one:  PASS / FAIL 

 

B.1.2 Select File > Exit. The Admintool:Users window disappears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

 Note -> Prior to proceeding, all additional segments should be installed and the DNS 
configured on the candidate platform. 

C 
4.6 Change Machine ID Functionality  

C.1 Change the Machine  Name and IP Address Of the Workstation  

C.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Change Machine ID in the 
Application Manager – SysAdm window. 

The Change Machine Id window appears. Circle one:  PASS / FAIL 

 

 

C.1.2 In the New Machine Name text box, enter 
nohost 

NOTE: If the /etc/resolv.conf file is 
installed on the system, the Change Machine ID 
tool checks the system's host name against the 
information in the Domain Name Service (DNS). If 
the System Administrator attempts to use the 
Change Machine ID tool to change the host name 
to one that is not found in the DNS, the machine ID 
will not be changed. 

nohost appears in the New Machine Name 
text box. 

Circle one:  PASS / FAIL 

 

 

C.1.3 In the New Machine Address text box enter 
10.0.0.1 

10.0.0.1 appears in the New Machine 
Address text box. 

Circle one:  PASS / FAIL 

 

C.1.4 Click Ok. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

C.1.5 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.1.6 Click OK. A Error dialog box appears with the message: 
Could not change host ID! 

Unable to verify hostname and ip 
address with DNS. 

Circle one:  PASS / FAIL 

 

 

C.1.7 Click OK. The Error dialog box disappears. Circle one:  PASS / FAIL 

 

C.1.8 In the New Machine Name text box enter 
kpctest 

kpctest appears in the New Machine Name 
text box. 

Circle one:  PASS / FAIL 

 

C.1.9 In the New Machine Address text box enter 
204.34.175.193 

204.34.175.193 appears in the New 
Machine Address text box. 

Circle one:  PASS / FAIL 

 

C.1.10 Click Ok. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

C.1.11 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.1.12 Click OK. A Success dialog box appears with the message: 
Operation completed successfully. 

Reboot system now? 

Circle one:  PASS / FAIL 

 

 

C.1.13 Click Yes. The workstation reboots and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 
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C.2 Verify ID Change  

C.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Login as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

 

C.2.2 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

C.2.3 At the command prompt type 
cat /etc/hosts 

The contents of the /hosts file appear. Circle one:  PASS / FAIL 

 

C.2.4 Verify that the following line appears in the listing: 
204.34.175.193 kpctest loghost  

A line containing the specified information is 
present.  

The additional text “kpccp.kpc.disa.mil” 
may also be present. 

NOTE: Change Machine ID does not change 
aliases (i.e. kpccp.kpc.disa.mil). 

Circle one:  PASS / FAIL 

 

 

C.3 Restore the Machine Name and IP Address Of the Workstation  

C.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Click Profile Selector. 

The Profile Selector window appears with 
SA Default listed in the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

C.3.2 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 
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C.3.3 Click OK. The Profile Selector Results window 
appears indicating that SA Default has been 
successfully assumed. 

Circle one:  PASS / FAIL 

 

C.3.4 Click Done. The Profile Selector Results window 
and Profile Selector window disappear. 

Circle one:  PASS / FAIL 

 

C.3.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

C.3.6 Double-click Change Machine ID. The Change Machine Id window appears. Circle one:  PASS / FAIL 

 

C.3.7 In the New Machine Name text box, enter 
kpccp 

kpccp appears in the New Machine Name text 
box. 

Circle one:  PASS / FAIL 

 

C.3.8 In the New Machine Address text box enter 
204.34.175.195 

204.34.175.195 appears in the New 
Machine Address text box. 

Circle one:  PASS / FAIL 

 

C.3.9 Click Ok. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

C.3.10 Enter the Master APM Authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.3.11 Click OK. A Success dialog box appears with the message: 

Operation completed successfully. 
Reboot system now? 

Circle one:  PASS / FAIL 
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C.3.12 Click Yes. The workstation reboots and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 

 

D 
4.7 Create Action 

D.1 Create A Desktop Action  

D.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Login as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

 

D.1.2 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

D.1.3 Double-click Create Action. The Create Action window appears. Circle one:  PASS / FAIL 

 

D.1.4 In the Action Name (Icon Label) text box, 
enter Test Action. 

Test Action appears in the Action Name 
(Icon Label) text box. 

Circle one:  PASS / FAIL 

 

D.1.5 In the Command When Action Is Opened 
(Double-clicked) text box, enter 
/usr/openwin/bin/clock 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

/usr/openwin/bin/clock appears in the 
Command When Action Is Opened 
(Double-clicked) text box. 

Circle one:  PASS / FAIL 
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D.1.6 Select File > Save. A Create Action – Confirmation dialog 
box appears with the message: 
The new action Test Action has 
been placed in your home folder. 

Circle one:  PASS / FAIL 

 

 

D.1.7 Click OK. The Create Action – Confirmation 
dialog box disappears. 

Circle one:  PASS / FAIL 

 

D.2 Verify the New Desktop Action  

D.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 
NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

 

D.2.2 Select Folders > File Manager - Home. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

A File Manager - Scripts window 
appears. 

Circle one:  PASS / FAIL 

 

 

D.2.3 Verify that an icon named Test Action is 
present in the File Manager – Scripts 
window. 

The Test Action icon is present. Circle one:  PASS / FAIL 

 

D.2.4 Double-click Test Action. A clock window appears on the screen. Circle one:  PASS / FAIL 
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D.3 Remove the New Desktop Action  

D.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Right-click Test Action in the File 
Manager – Scripts window. 

A drop-down menu appears. Circle one:  PASS / FAIL 

 

D.3.2 Select Put in Trash. The Test Action icon disappears. Circle one:  PASS / FAIL 

 

D.3.3 Select File > Close in the File Manager 
– Scripts window. 

The File Manager - Scripts window 
disappears. 

Circle one:  PASS / FAIL 

 

D.3.4 Select File > Exit in the Create Action 
window. 

The Create Action window disappears. Circle one:  PASS / FAIL 

 

D.3.5 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 
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E 
4.8 DTterm 

E.1 Setup  

E.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click DTterm in the Application 
Manager – SysAdm window. 

A Terminal window appears with a login 
prompt. 

Circle one:  PASS / FAIL 

 

 

E.1.2 At the login prompt type 
sysadmin 

A Password prompt appears. Circle one:  PASS / FAIL 

 

E.1.3 At the Password prompt type the sysadmin 
password. 

A warning message is displayed and then the 
command prompt appears. 

Circle one:  PASS / FAIL 

 

E.1.4 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=100(sysadmin) gid=1(other) 

NOTE: This result is OS specific. The result 
should indicate the user is sysadmin. 

Circle one:  PASS / FAIL 

 

 

E.1.5 At the command prompt type 
pwd 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Result column. 

The system returns 
/h/USERS/local/sysadmin/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 
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E.1.6 At the command prompt type 
exit 

The Terminal window disappears. Circle one:  PASS / FAIL 

 

 

F 
4.9 Disk Manager 

F.1 Verify That the Candidate Platform Can Share (Export) A Directory  

F.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Open a Terminal window. 

A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

 

F.1.2 At the command prompt type  
su - 

The Password prompt appears. Circle one:  PASS / FAIL 

 

F.1.3 At the Password prompt type the root 
password. 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.4 At the command prompt type 
csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.5 At the command prompt type 
mkdir /kpchost.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.6 At the command prompt type 
cd /home2 

The command prompt returns. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 23 

 
 

 

 

 Operator Action Expected Result Observed Result 

F.1.7 At the command prompt type 
echo > kpccp 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.8 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

F.1.9 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

F.1.10 At the command prompt type  
su - 

The Password prompt appears. Circle one:  PASS / FAIL 

 

F.1.11 At the Password prompt type the root 
password. 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.12 At the command prompt type 
csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.13 At the command prompt type 
mkdir /kpccp.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.14 At the command prompt type 
cd /home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.15 At the command prompt type 
echo > kpchost 

The command prompt returns. Circle one:  PASS / FAIL 
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F.2 Share and Mount Candidate Platform�s /home2  

F.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Double-click Disk Manager in the 
Application Manager – SysAdm window. 

The Disk Manager window appears. Circle one:  PASS / FAIL 

 

F.2.2 Select the row containing /home2 in the 
Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

F.2.3 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.2.4 In the options text box enter  
rw=kpchost.kpc.disa.mil 

rw=kpchost.kpc.disa.mil appears in the 
text box. 

Circle one:  PASS / FAIL 

 

F.2.5 Click Export. A Confirmation dialog box appears asking if 
the directory should be exported permanently.  

Circle one:  PASS / FAIL 

 

F.2.6 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 

 

F.2.7 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.2.8 Double-click Disk Manager. The Disk Manager window appears. Circle one:  PASS / FAIL 
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F.2.9 Click Mount New. The Mount File System dialog box appears. Circle one:  PASS / FAIL 

 

F.2.10 In the FILE SYSTEM text box enter 
kpccp:/home2 

kpccp:/home2 appears in the text box. Circle one:  PASS / FAIL 

 

F.2.11 In the MOUNT POINT text box enter 
/kpccp.home2 

/kpccp.home2 appears in the text box. Circle one:  PASS / FAIL 

 

F.2.12 Click MOUNT. A Confirmation dialog box appears asking if 
the directory should be mounted permanently.  

Circle one:  PASS / FAIL 

 

F.2.13 Click Yes. The dialog boxes disappear and a row for 
kpccp:/home2 appears in the Disk Manager 
window. 

Circle one:  PASS / FAIL 

 

F.2.14 At the command prompt in the Terminal 
window, type 
cd /kpccp.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

F.2.15 At the command prompt type 
ls 

The file kpccp appears in the listing. Circle one:  PASS / FAIL 

 

F.2.16 At the command prompt type  
cd / 

The command prompt returns. Circle one:  PASS / FAIL 
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F.2.17 In the Disk Manager window, select the row 
containing /kpccp.home2 in the Mounted On 
column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

F.2.18 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

Circle one:  PASS / FAIL 

 

F.2.19 Click Yes. The dialog box disappears and the row for 
/kpccp.home2 disappears from the Disk 
Manager window. 

Circle one:  PASS / FAIL 

 

F.2.20 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Disk Manager window, select the row 
containing /home2 in the Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

 

F.2.21 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.2.22 Click Unexport. A dialog box appears asking if the directory should 
be unexported permanently. 

Circle one:  PASS / FAIL 

 

F.2.23 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 
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F.3 Share and Mount Validation Host�s /home2  

F.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Disk Manager window, select the row 
containing /home2 in the Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

 

F.3.2 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.3.3 In the options text box, enter  
rw=kpccp.kpc.disa.mil 

rw=kpccp.kpc.disa.mil appears in the text 
box. 

Circle one:  PASS / FAIL 

 

F.3.4 Click Export. A Confirmation dialog box appears asking if 
the directory should be exported permanently.  

Circle one:  PASS / FAIL 

 

F.3.5 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 

 

F.3.6 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Click Mount New. 

The Mount File System dialog box appears. Circle one:  PASS / FAIL 

 

F.3.7 In the FILE SYSTEM text box, enter 
kpchost:/home2 

kpchost:/home2 appears in the text box. Circle one:  PASS / FAIL 

 

F.3.8 In the MOUNT POINT text box enter 
/kpchost.home2 

/kpchost.home2 appears in the text box. Circle one:  PASS / FAIL 
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F.3.9 Click MOUNT. A Confirmation dialog box appears asking if 
the directory should be mounted permanently.  

Circle one:  PASS / FAIL 

 

F.3.10 Click Yes. The dialog boxes disappear and a row for 
kpchost:/home2 appears in the Disk 
Manager window. 

Circle one:  PASS / FAIL 

 

F.3.11 At the command prompt in the  Terminal 
window, type 
cd /kpchost.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

F.3.12 At the command prompt type 
ls 

The file kpchost appears in the listing. Circle one:  PASS / FAIL 

 

F.3.13 At the command prompt type  
cd / 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.3.14 In the Disk Manager window, select the row 
containing /kpchost.home2 in the Mounted 
On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

F.3.15 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

Circle one:  PASS / FAIL 

 

F.3.16 Click Yes. The dialog box disappears and the row for 
/kpchost.home2 disappears from the Disk 
Manager window. 

Circle one:  PASS / FAIL 
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F.3.17 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Disk Manager window, select the row 
containing /home2 in the Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

 

F.3.18 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.3.19 Click Unexport. A dialog box appears asking if the directory should 
be unexported permanently. 

Circle one:  PASS / FAIL 

 

F.3.20 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 

 

F.3.21 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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  F.4 
4.10 Format and mount disk partition  

 

 Warning - executing the following tests in the greyed area may corrupt the disk table of the disk under 
test. 

 

F.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

In the Disk Manager window, highlight the row 
with /test. 

The row with /test is highlighted. Circle one:  PASS / FAIL 

 

 

F.4.2 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

Circle one:  PASS / FAIL 

 

F.4.3 Click Yes. The dialog box disappears and the row for /test 
disappears from the Disk Manager window. 

Circle one:  PASS / FAIL 

 

F.4.4 In the Disk Manager window, click New FS. 

 

The New File System dialog box appears. Circle one:  PASS / FAIL 

 

F.4.5 In the DISK DEVICE text box, enter 

i.e. /dev/dsk/c0t0d0s7 

NOTE: This step is platform specific. Enter the 
device name for the test partition created during 
Validation Cell setup here and in the following 
steps. 

i.e. /dev/dsk/c0t0d0s7 is displayed. Circle one:  PASS / FAIL 
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F.4.6 Click OK. A Please wait message box is displayed while 
the partition is formatted.  The message box 
disappears and the Disk Manager window 
reappears. 

NOTE: The message box may disappear quickly. 

Circle one:  PASS / FAIL 

 

F.4.7 Click Mount New. The Mount File System dialog box is 
displayed. 

Circle one:  PASS / FAIL 

F.4.8 In the FILE SYSTEM text box enter  

 i.e.      /dev/dsk/c0t0d0s7 

i.e. /dev/dsk/c0t0d0s7 appears in the 
textbox 

Circle one:  PASS / FAIL 

F.4.9 In the MOUNT POINT text box enter 
/home3 

/home3 appears in the text box. Circle one:  PASS / FAIL 

 

F.4.10 Click MOUNT. The dialog box appears with the following 
message: 
Mount the File System Permanently?  

Circle one:  PASS / FAIL 

 

F.4.11 Click Yes. i.e. /dev/dsk/c0t0d0s7 shows /home3 in 
Mounted On column.   

 Circle one:  PASS / FAIL 

F.4.12 Highlight the row with /home3 in the Mounted 
On column. 

The row with /home3 is highlighted. Circle one:  PASS / FAIL 

F.4.13 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

 Circle one:  PASS / FAIL 

F.4.14 Click Yes. The dialog box disappears and the row for /home3 
disappears from the Disk Manager window. 

 Circle one:  PASS / FAIL 
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F.4.15 Click Exit in the Disk Manager window. The Disk Manager window disappears. Circle one:  PASS / FAIL 

 

G 
4.11 Edit Local Hosts 

G.1 Add A New Host  

G.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Edit Local Hosts in the 
Application Manager – SysAdm window. 

The Edit Hosts window appears. Circle one:  PASS / FAIL 

 

 

G.1.2 Click Add. The Add Machine window appears. Circle one:  PASS / FAIL 

 

G.1.3 In the MACHINE NAME text box, enter 
newmachine 

newmachine appears in the MACHINE NAME 
text box. 

Circle one:  PASS / FAIL 

 

 

G.1.4 In the MACHINE ADDRESS text box enter 
169.254.0.100 

169.254.0.100 appears in the MACHINE 
ADDRESS text box. 

Circle one:  PASS / FAIL 

 

G.1.5 Click OK. The Add Machine window disappears and 
newmachine shows up in the Edit Hosts 
window. 

Circle one:  PASS / FAIL 
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G.1.6 At the command prompt in the Terminal 
window type 
cat /etc/hosts 

The contents of the /hosts file are displayed. Circle one:  PASS / FAIL 

 

 

G.1.7 Verify that an entry exists for  
169.254.0.100 newmachine 

The line exists. Circle one:  PASS / FAIL 

 

G.2 Delete A Host  

G.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Select newmachine in the Edit Hosts 
window. 

The line containing newmachine is highlighted. Circle one:  PASS / FAIL 

G.2.2 Click Delete. A Confirmation Required dialog box 
appears with the following message 
Are you sure you want to remove 
host 169.254.0.100? 

Circle one:  PASS / FAIL 

G.2.3 Click Yes. The Confirmation Required dialog box 
disappears and newmachine is removed from the 
Edit Hosts window. 

Circle one:  PASS / FAIL 

G.2.4 At the command prompt in the Terminal 
window type 
cat /etc/hosts 

The contents of the hosts file are displayed. Circle one:  PASS / FAIL 



© 2003, The Open Group 
Chapter 1, Page 34 

 
 

 

 

 Operator Action Expected Result Observed Result 

G.2.5 Verify that the entry for  
169.254.0.100 newmachine  

has been removed. 

The line does not exist. Circle one:  PASS / FAIL 

G.2.6 Click Close in the Edit Hosts window. The Edit Hosts window disappears. Circle one:  PASS / FAIL 

 

H 
4.12 Network Installation Server and Segment Installer 

H.1 Load Segment To Candidate Platform  

H.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Insert the OnlineDocs (ONDOC) v 4.2.0.0 
tape into the tape drive or, if using the KPC Test 
Data CD, insert the CD into the cdrom drive. 

The tape/CD is inserted. Circle one:  PASS / FAIL 

H.1.2 Double-click Network Installation 
Server in the Application Manager – 
SysAdm window. 

The Segment Installation Server 
window appears. 

Circle one:  PASS / FAIL 
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H.1.3 If a tape is used, click Read Contents, 

 or, 

if the KPC Test Data CD is used, proceed as 
follows: 

Click Select Source, 

Click CD-ROM, 

Double-click “seg” in the Directories 
column, 

Double-click ONDOC.tar in the Files 
column, 

Click Read Contents. 

The Segment Installation Server 
window disappears while message boxes appear 
informing that the system is Checking media 
and that Read Content is in progress. 

The Segment Installation Server 
window reappears with OnlineDocs listed under 
Select Software To Load. 

Circle one:  PASS / FAIL 

H.1.4 Select OnlineDocs. OnlineDocs is highlighted. Circle one:  PASS / FAIL 

 

H.1.5 Click Release Notes. A RELEASE NOTES window opens with Release 
Notes text. 

Circle one:  PASS / FAIL 

 

H.1.6 Click OK. The RELEASE NOTES window disappears. Circle one:  PASS / FAIL 

 

H.1.7 Click Requires. A REQUIRES SEGMENTS window opens listing 
segments required before installing OnlineDocs. 

Circle one:  PASS / FAIL 

 

H.1.8 Click OK. The REQUIRES SEGMENTS window disappears. Circle one:  PASS / FAIL 
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H.1.9 Click Conflicts. An INFORMATIONAL MESSAGE dialog box 
opens informing that the Conflicts descriptor is 
not available. 

Circle one:  PASS / FAIL 

 

H.1.10 Click OK. The dialog box disappears. Circle one:  PASS / FAIL 

 

H.1.11 In the Available Disks panel select the row 
containing /home2. 

The row is highlighted. Circle one:  PASS / FAIL 

 

H.1.12 Click Load. An ENTER A PASSWORD dialog box appears.  Circle one:  PASS / FAIL 

 

H.1.13 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

H.1.14 Click OK. Control returns to the Segment 
Installation Server window. 

OnlineDocs[ALL] appears in the list under 
Segments Currently Loaded On This 
Network Server. 

Circle one:  PASS / FAIL 

H.1.15 Select Installed > View Installation 
Log. 

An Install Log window appears indicating 
OnlineDocs was successfully loaded on the 
kpccp Network Server. 

Circle one:  PASS / FAIL 

 

 

H.1.16 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 
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H.2 Install the Loaded Segment On the Candidate Platform  

H.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Segment Installer in the 
Application Manager – SysAdm window. 

The  Installer window appears. Circle one:  PASS / FAIL 

H.2.2 Click Select Source. The Select Source dialog box appears. Circle one:  PASS / FAIL 

 

H.2.3 Select LOCAL in the Host panel and NETWORK in 
the Device panel. 

The LOCAL and NETWORK radio buttons are 
highlighted. 

Circle one:  PASS / FAIL 

 

H.2.4 Click OK. The Select Source dialog box disappears. Circle one:  PASS / FAIL 

 

H.2.5 Click Read Contents. The Installer window shows OnlineDocs 
listed under Select Software To Install. 

Circle one:  PASS / FAIL 

 

H.2.6 Select OnlineDocs. OnlineDocs is highlighted. Circle one:  PASS / FAIL 

 

H.2.7 Click Install. An ENTER A PASSWORD dialog box appears. Circle one:  PASS / FAIL 

 

H.2.8 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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H.2.9 Click OK. The dialog box disappears.  

The Installer window shows OnlineDocs 
listed under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

H.3 Verify Installation  

H.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Select Installed > View Installation 
Log. 

An Install Log window appears indicating 
OnlineDocs was successfully installed. 

Circle one:  PASS / FAIL 

H.3.2 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

H.4 Test Segment De-installation  

H.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

In the list under Currently Installed 
Segments, select OnlineDocs. 

OnlineDocs is highlighted. Circle one:  PASS / FAIL 

H.4.2 Click Deinstall Software. A RESPOND TO THE QUESTION dialog box 
appears to verify that you really want to remove the 
segment. 

Circle one:  PASS / FAIL 
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H.4.3 Click No. The Installer window reappears with 
OnlineDocs still listed in the Currently 
Installed Segments panel. 

Circle one:  PASS / FAIL 

 

H.4.4 Click Deinstall Software. A RESPOND TO THE QUESTION dialog box 
appears to verify that you really want to remove the 
segment. 

Circle one:  PASS / FAIL 

 

H.4.5 Click Yes. 

 

The Installer window appears. Circle one:  PASS / FAIL 

H.4.6 Click Exit. The Installer window disappears. Circle one:  PASS / FAIL 

 

H.4.7 In the Network Installation Server 
window select OnlineDocs[ALL] under 
Segments Currently Loaded On This 
Network Server. 

OnlineDocs[ALL] is highlighted. Circle one:  PASS / FAIL 

H.4.8 Click Deinstall Software. 

 

A RESPOND TO THE QUESTION dialog box 
appears to verify that you really want to remove the 
segment. 

Circle one:  PASS / FAIL 

H.4.9 Enter the Master APM Authentication Key Asterisks appear in the text box. Circle one: PASS / FAIL 

H.4.10 Click OK. The text box closes. Circle one:  PASS / FAIL 

H.4.11 Click Exit. The Segment Installation Server 
window disappears. 

Circle one:  PASS / FAIL 

 

H.4.12 Eject the tape or CD. The tape or CD ejects. Circle one:  PASS / FAIL 
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I 
4.13 Set Routes 

I.1 Setup  

I.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

At the command prompt in the Terminal 
window, type 
netstat -nr 

Network routing information is displayed. Circle one:  PASS / FAIL 

I.1.2 Verify that there is not a line containing default. There is no default listed. Circle one:  PASS / FAIL 

 

I.1.3 Double-click Set Routes in the 
Application Manager – SysAdm window. 

The Default Router Setup window 
appears. 

Circle one:  PASS / FAIL 

 

I.1.4 In the Default Router IP Address text box, 
enter 
204.34.175.194 

204.34.175.194 appears in the text box. Circle one:  PASS / FAIL 

 

I.1.5 Click OK. A Done dialog box appears informing that the 
operation completed successfully.   

Circle one:  PASS / FAIL 

 

I.1.6 Click OK. The dialog box and the Default Router 
Setup window disappear. 

Circle one:  PASS / FAIL 

 

I.1.7 At the command prompt type 
netstat -nr 

Network routing information is displayed. Circle one:  PASS / FAIL 
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I.1.8 Verify that a line containing default is listed. default is listed with the IP address 
204.34.175.194. 

Circle one:  PASS / FAIL 

 

J 
4.14 Set System Time 

J.1 Setup  

J.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

J.1.2 Select Applications > OW Clock. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

A Clock window appears displaying the current 
local time in the current time zone. 

Circle one:  PASS / FAIL 

J.1.3 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 
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J.1.4 Double-click Set System Time in the 
Application Manager – SysAdm window. 

 

NOTE: The System Time window displays the 
local time as if the system time is GMT. Thus, the 
hour representation will be shifted by the GMT 
offset from the current local time. In the steps 
below, time entered into the System Time 
window will be interpreted, as GMT while the OW 
Clock display will be system time. 

 

NOTE: The steps below may cause the screen lock 
to engage. If so, enter the sysadmin password 
and continue. 

A System Time window appears with a date 
time group (DTG) in the form ddhhmmZ MON 
YYYY, where: 

dd represents the day of the month. 

hh represents the hour (in GMT). 

mm represents the minute. 

Z is a constant (for Zulu time). 

MON represents the three-letter month abbreviation. 

YYYY represents the four-digit year. 

The time displayed should be the same as the clock 
display shifted by the GMT offset. 

Circle one:  PASS / FAIL 

J.1.5 In the Enter DTG text box change the third and 
fourth digits (hour) to a different value. 

The value appears in the text box. Circle one:  PASS / FAIL 

 

J.1.6 Click OK. A Done dialog box appears indicating that the 
operation has completed successfully.  

Circle one:  PASS / FAIL 

 

J.1.7 Click OK. The dialog box and the System Time window 
disappear. 

Circle one:  PASS / FAIL 

 

J.1.8 Open the clock window and verify that the 
clock window displays the new time. 

The clock window displays the new time. Circle one:  PASS / FAIL 
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J.1.9 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 

 

J.1.10 Double-click Set System Time. A System Time window appears. Circle one:  PASS / FAIL 

 

J.1.11 Enter the current local time in the Enter DTG 
text box. 

The value appears in the text box. Circle one:  PASS / FAIL 

 

J.1.12 Click OK. A Done dialog box appears indicating that the 
operation has completed successfully. 

Circle one:  PASS / FAIL 

 

J.1.13 Click OK. The dialog box and the System Time window 
disappear.  

Circle one:  PASS / FAIL 

 

J.1.14 Open the clock window and verify that the 
clock window displays the current time. 

The clock window displays the current time. Circle one:  PASS / FAIL 

 

J.1.15 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 
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K 
4.15 Text Editor 

K.1 Use the Text Editor To Create A Test File  

K.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Text Edit in the Application 
Manager – SysAdm window. 

A Text Editor – (UNTITLED) window 
appears. 

Circle one:  PASS / FAIL 

K.1.2 In the text window, enter the following text: 

This text is test text. 

This text appears in the text window. Circle one:  PASS / FAIL 

 

K.1.3 Select File > Save,(Needed). A Text Editor - Save As dialog box 
appears. 

Circle one:  PASS / FAIL 

 

K.1.4 Enter TestText in the Enter file name text 
box. 

TestText appears in the Enter file name 
text box. 

Circle one:  PASS / FAIL 

 

K.1.5 Click OK. The Text Editor - Save As dialog box 
closes. 

Circle one:  PASS / FAIL 
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K.2 Verify Existence Of Test File  

K.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

K.2.2 Select Folders > File Manager – Home.  

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

A File Manager - Scripts window 
appears. 

Circle one:  PASS / FAIL 

K.2.3 Verify that an icon named TestText is present in 
the File Manager – Scripts window. 

The TestText icon is present. Circle one:  PASS / FAIL 

 

K.2.4 Double-click TestText. A Text Editor – Test Text window 
appears displaying the text: 

This text is test text. 

Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 46 

 
 

 

 

 Operator Action Expected Result Observed Result 

K.3 Delete the Test File  

K.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

In the File Manager - Scripts window, 
right-click TestText and select Put in 
Trash. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Test Text icon disappears. Circle one:  PASS / FAIL 

K.3.2 Close the File Manager - Scripts, and 
both Text Editor - TestText windows. 

The File Manager - Scripts, and both 
Text Editor - TestText windows 
disappear. 

Circle one:  PASS / FAIL 

 

L 
4.16 XTerm 

L.1 Setup  

L.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click XTerm in the Application 
Manager – SysAdm window. 

A login window appears. Circle one:  PASS / FAIL 

L.1.2 At the login prompt type 
sysadmin 

A Password prompt appears. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 47 

 
 

 

 

 Operator Action Expected Result Observed Result 

L.1.3 At the Password prompt type the sysadmin 
password. 

The DoD Security Banner is displayed and then the 
command prompt appears. 

Circle one:  PASS / FAIL 

 

L.1.4 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=100(sysadmin) gid=1(other) 

NOTE: This result is OS specific. The result 
should indicate the user is sysadmin. 

Circle one:  PASS / FAIL 

L.1.5 At the command prompt type 
pwd  

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
/h/USERS/local/sysadmin/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 

L.1.6 At the command prompt type 
exit 

The login window disappears. Circle one:  PASS / FAIL 
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M 
4.17 Reboot System 

M.1 Verify System Can Be Rebooted  

M.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Reboot System in the 
Application Manager – SysAdm window. 

A Reboot dialog box appears with the question: 
Reboot machine? 

Circle one:  PASS / FAIL 

M.1.2 Click No. The dialog box disappears. Circle one:  PASS / FAIL 

 

M.1.3 Double-click Reboot System in the 
Application Manager – SysAdm window. 

A Reboot dialog box appears with the question: 
Reboot machine? 

Circle one:  PASS / FAIL 

 

M.1.4 Click Yes. The workstation reboots and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 
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N 
4.18 Shutdown System 

N.1 Verify the System Shuts Down  

N.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Log in as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

N.1.2 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

N.1.3 Double-click Shutdown System. A Shut down dialog box appears. Circle one:  PASS / FAIL 

 

N.1.4 Click No. The Shut down dialog box disappears. Circle one:  PASS / FAIL 

 

N.1.5 Double-click Shutdown System in the 
Application Manager – SysAdmin 
window. 

A Shut down dialog box appears. Circle one:  PASS / FAIL 

 

N.1.6 Click Yes. The system shuts down and a boot prompt is 
presented. 

Circle one:  PASS / FAIL 

 

N.1.7 At the prompt enter the proper command for 
system boot. 
 

The system boots and the DII COE LOGIN 
screen appears with the DoD security warning 
message and the Please enter your user 
name text box. 

Circle one:  PASS / FAIL 
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O 
4.19 Verify secman    Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon 

Accessibility 

O.1 Verify secman Login  

O.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Verify that the DII COE LOGIN screen appears. 

The DII COE LOGIN screen appears with the 
DoD security warning message and the Please 
enter your user name text box. 

Circle one:  PASS / FAIL 

 

O.1.2 Log in as the Security Administrator by typing 
secman in the Please enter your user 
name prompt and pressing ENTER. 

The password screen appears with the Please 
enter your password text box. 

Circle one:  PASS / FAIL 

 

O.1.3 Type the password for the secman account in the 
Please enter your password text box and 
press ENTER.  

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

O.1.4 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

O.1.5 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 
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O.1.6 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

O.1.7 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

O.1.8 Log in as user secman with the new password. An INFORMATIONAL MESSAGE dialog box 
appears confirming COE login processing is 
complete. 
 

Circle one:  PASS / FAIL 

 

 

O.1.9 Click OK in the INFORMATIONAL MESSAGE 
dialog box. 

The dialog box disappears. Circle one:  PASS / FAIL 

 

O.2 Verify secman Profile Selector Functionality  

O.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Click Profile Selector (the head with a 
question mark). 

The Profile Selector window appears with 
SSO Default listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

O.2.2 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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O.3 Verify secman Change Password Tool Functionality  

O.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Access the Change Password Tool from the 
CDE Panel by selecting the arrow above the 
Profile Selector icon.  

The DII Tools menu appears. Circle one:  PASS / FAIL 

 

O.3.2 Select the Change Password Tool menu 
item.  

The Change your password window 
appears. 

Circle one:  PASS / FAIL 

 

O.3.3 Click Cancel. The Change your password window 
disappears. 

Circle one:  PASS / FAIL 

 

O.4 Verify Command Line Access  

O.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Open a Terminal window. 

A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

O.4.2 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=101(secman) gid=36(admin) 

NOTE: This result is OS specific. The result 
should indicate the user is secman. 

Circle one:  PASS / FAIL 
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O.4.3 At the command prompt type 
pwd  

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
/h/USERS/local/secman/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 

 

O.4.4 At the command prompt type 
exit 

The Terminal window disappears. Circle one:  PASS / FAIL 

 

O.5 Verify Icon Access  

O.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

O.5.2 Select Applications > Application 
Manager 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Application Manager window appears. Circle one:  PASS / FAIL 

 

O.5.3 Double-click DII_APPS. The Application Manager – DII_APPS 
window appears. 

Circle one:  PASS / FAIL 
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O.5.4 Double-click SecAdm. The Application Manager – SecAdm 
window appears with the following icons: ..(go 
up), APM Client, APM Key Server, 
APM Server Reload, APM Server 
Start, APM Server Stop, Assign 
Passwords, Audit Log File Manager, 
Edit APM Configuration, Merge 
Host, Profile Selector Config, 
Remove Host. 

Circle one:  PASS / FAIL 

 

P 
4.20 APM Client 

P.1 Create A New Account, Profile, and Group On the Candidate Platform  

P.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Client. 

An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

P.1.2 Enter the APM master authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

P.1.3 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

P.1.4 Select File > New Account. A Create Account window appears. Circle one:  PASS / FAIL 
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P.1.5 Enter the following values: 

Login: AcctCon 

Password: temp 

Password Confirm: temp 

Template: secman  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

P.1.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

P.1.7 Verify kpccp appears in the Assigned Hosts 
panel. 

Note:  If kpccp does not appear in the 
Assigned Hosts panel, double-click kpccp in 
the Available Hosts panel, which moves it to 
the Assigned Hosts panel. 

kpccp appears in the Assigned Hosts panel. Circle one:  PASS / FAIL 

 

P.1.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

P.1.9 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 

 

P.1.10 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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P.1.11 Select File > New Profile. A Create Profile window appears. Circle one:  PASS / FAIL 

 

P.1.12 In the Profile Name text box, enter  

ProCon. 

ProCon appears in the text box. Circle one:  PASS / FAIL 

 

P.1.13 Select SSO Default from the Profile 
Template drop-down list. 

SSO Default is selected. Circle one:  PASS / FAIL 

 

P.1.14 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

P.1.15 Select Sol Security Administration 
4.2.0.5 from the Segments box. 

Sol Security Administration 
4.2.0.5 is highlighted. 

Circle one:  PASS / FAIL 

 

P.1.16 In the Features box, deselect the following 
items 
Security Administration-APM Client 

Security Administration-APM Server 
Start 

Security Administration-Assign 
Passwords. 

These items are no longer checked. Circle one:  PASS / FAIL 

 

P.1.17 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

P.1.18 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 
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P.1.19 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

P.1.20 Select File > New Group. A Create Group window appears. Circle one:  PASS / FAIL 

 

P.1.21 In the Group name text box, enter  

GrpCon. 

GrpCon appears in the text box. Circle one:  PASS / FAIL 

 

P.1.22 Select admin from the Template drop-down 
list. 

admin is selected. Circle one:  PASS / FAIL 

 

P.1.23 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

P.1.24 Double-click SSO in the Assigned Accounts 
panel. 

SSO moves to the Available Accounts 
panel. 

Circle one:  PASS / FAIL 

 

P.1.25 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

P.1.26 Verify kpccp appears in the Assigned Hosts 
panel. 

kpccp appears in the Assigned Hosts panel. Circle one:  PASS / FAIL 

 

P.1.27 Click Submit. A Status Summary dialog box appears 
indicating the new group has been added. 

Circle one:  PASS / FAIL 

 

P.1.28 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 
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P.1.29 Click File > Exit. An Exit confirmation dialog box appears. Circle one:  PASS / FAIL 

 

P.1.30 Click Yes. The Account and Profile Manager 
dialog box disappears. 

Circle one:  PASS / FAIL 

 

P.2 Create A New Account, Profile, and Group On the Validation Host  

P.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

Login as secman. 

The desktop appears. Setup 

 

P.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

P.2.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Setup 

 

P.2.4 Enter the master APM authentication key. Asterisks appear in the text box. Setup 

 

P.2.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Setup 

 

P.2.6 Select File > New Account. A Create Account window appears. Setup 
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P.2.7 Enter the following values: 

Login: AcctCon 

Password: temp 

Password Confirm: temp 

Template: sysadmin  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Setup 

 

P.2.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Setup  

 

P.2.9 Click OK. The Status Summary dialog box disappears. Setup 

 

P.2.10 Click Profiles. The Profiles tab is displayed. Setup 

 

P.2.11 Select File > New Profile. A Create Profile window appears. Setup 

 

P.2.12 In the Profile Name text box, enter  

ProCon. 

ProCon appears in the text box. Setup 

 

P.2.13 Select SA Default from the Profile 
Template drop-down list. 

SA Default is selected. Setup 
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P.2.14 Click Features. The Features tab is displayed. Setup 

 

P.2.15 Select Sol System Administration 
4.2.0.5 from the Segments box. 

Sol System Administration 4.2.0.5 is 
highlighted. 

Setup 

 

P.2.16 In the Features box, deselect the following 
items: 
System Administration-Change 
Machine ID 

System Administration-Disk Manager 

System Administration-Edit Local 
Hosts. 

These items are no longer checked. Setup 

 

P.2.17 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Setup  

 

P.2.18 Click OK. The Status Summary dialog box disappears. Setup  

 

P.2.19 Click Groups. The Groups tab is displayed. Setup  

 

P.2.20 Select File > New Group. A Create Group window appears. Setup 

  

P.2.21 In the Group Name text box, enter  

GrpCon. 

GrpCon appears in the text box. Setup  
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P.2.22 Select other from the Template drop-down 
list. 

other is selected. Setup  

 

P.2.23 Click Accounts. The Accounts tab is displayed. Setup  

 

P.2.24 Double-click daemon, root and SA in the 
Assigned Accounts panel. 

daemon, root and SA move to the 
Available Accounts panel. 

Setup  

 

P.2.25 Click Hosts. The Hosts tab is displayed. Setup  

 

P.2.26 Verify kpchost appears in the Assigned 
Hosts panel. 

kpchost appears in the Assigned Hosts 
panel. 

Setup  

 

P.2.27 Click Submit. A Status Summary dialog box appears 
indicating the new group has been added. 

Setup  

 

P.2.28 Click OK. The Status Summary dialog box disappears. Setup  

 

P.2.29 Click File > Exit. An Exit Confirmation dialog box appears. Setup  

 

 

P.2.30 Click Yes. The Account and Profile Manager 
dialog box disappears. 

Setup  
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Q 
4.21 APM Server Reload 

Q.1 Setup  

Q.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Server Reload. 

An INFORMATIONAL MESSAGE box appears: 
APM Server reloaded successfully. 

Circle one:  PASS / FAIL 

 

Q.1.2 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

R 
4.22 APM Server Stop 

R.1 Setup  

R.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Server Stop. 

An INFORMATIONAL MESSAGE box appears: 
APM Server successfully stopped. 

Circle one:  PASS / FAIL 

 

R.1.2 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

R.1.3 Double-click APM Server Stop. An INFORMATIONAL MESSAGE box appears: 
APM Server already stopped. 

Circle one:  PASS / FAIL 

 

R.1.4 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 
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S 
4.23 APM Server Start 

S.1 Setup  

S.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Server Start. 

An INFORMATIONAL MESSAGE box appears: 
APM Server started successfully. 

Circle one:  PASS / FAIL 

 

S.1.2 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

S.1.3 Double-click APM Server Start. An INFORMATIONAL MESSAGE box appears: 
APM Server is already running! 

Circle one:  PASS / FAIL 

 

S.1.4 Click OK. The INFORMATIONAL MESSAGE box 
disappears.  

Circle one:  PASS / FAIL 

 

T 
4.24 Assign Passwords 

T.1 Setup  

T.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Assign passwords. 

The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

T.1.2 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 
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U 
4.25 Audit Log File Manager 

U.1 Setup  

U.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Audit Log File Manager. 

The Audit Log File Manager dialog box 
appears. 

Circle one:  PASS / FAIL 

U.1.2 Click Cancel. The Audit Log File Manager dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

V 
4.26 Edit APM Configuration 

V.1 Setup  

V.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Edit APM Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

V.1.2 In the Master Host text box, enter 
kpchost 

kpchost appears in the text box. Circle one:  PASS / FAIL 

 

V.1.3 Click Submit. A Done dialog box appears indicating: 
Operation completed successfully. 

Circle one:  PASS / FAIL 

 

V.1.4 Click OK. The dialog box and the Edit APM 
Configuration window disappear. 

Circle one:  PASS / FAIL 
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V.1.5 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

V.1.6 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 

 

W 
4.27 Set Local Authentication Key 

W.1 Set Key on Candidate Platform  

W.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Login as keyman. 

A dialog box appears indicating that the password 
needs to be changed. 

 

Setup 

 

W.1.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

W.1.3 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

W.1.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

W.1.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 66 

 
 

 

 

 Operator Action Expected Result Observed Result 

W.1.6 Log in as user keyman with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

W.1.7 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

W.1.8 Enter the Local APM authentication key. 

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

W.1.9 Click Set Key. 

 

A Message dialog box appears stating that the 
local key is set. 

Circle one:  PASS / FAIL 

 

W.1.10 Click OK. 

 

The dialog box disappears. Circle one:  PASS / FAIL 

 

W.1.11 Click Close. The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

W.1.12 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

W.1.13 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 
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W.2 Set Key on Validation Host  

W.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

Login as keyman. 

A dialog box appears indicating that the password 
needs to be changed. 

 

Setup 

 

W.2.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Setup  

W.2.3 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Setup  

W.2.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Setup 

 

Password: _____________ 

W.2.5 Re-enter the new password. The DII COE LOGIN screen appears. 

 

Setup  

W.2.6 Log in as user keyman with the new password. The desktop appears.  
 

Setup  

W.2.7 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Setup  

W.2.8 Enter the Master APM authentication key. 

 

Asterisks appear in the textbox. Setup  
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W.2.9 Click Set Client’s Local Key. 

 

The Hosts List window appears. Setup  

W.2.10 In the Additional Host text box type 
kpccp. 

 

kpccp appears in the text box. Setup  

W.2.11 Click Add Host. The Set Key For New Host dialog box 
appears. 

Setup 

W.2.12 In the New auth key and Re-enter auth 
key text boxes type the local authentication key for 
kpccp. 

Asterisks appear in the textboxes. Setup 

W.2.13 Click Submit. 

 

A Message dialog box appears stating that the 
Authentication keys are set. 

Setup  

 

W.2.14 Click OK. 

 

The Message dialog box disappears. Setup 

 

W.2.15 Click Close. 

 

The Hosts List window disappears. Setup 

 

W.2.16 Click Close. 

 

The Authentication Manager window 
disappears. 

Setup 

 

W.2.17 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Setup 
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W.2.18 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Setup  

X 
4.28 Merge Host 

X.1 Run Merge On the Candidate Platform  

X.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Login as secman. 

The desktop appears. Setup 

 

X.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

X.1.3 Double-click Merge Host in the 
Application Manager – SecAdm 
window.  

The MergeHost Tool dialog box appears with 
kpccp listed as the hostname of the New APM 
Domain Host and kpchost listed as the hostname 
of the Master APM Server. 

Circle one:  PASS / FAIL 

X.1.4 Click OK. An Input dialog box appears asking for the 
Master APM authentication key. 

Circle one:  PASS / FAIL 

 

X.1.5 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

X.1.6 Click OK. A User Conflicts window appears. 

AcctCon is highlighted in the left panel. 

Circle one:  PASS / FAIL 
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X.1.7 Click use master. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.8 Click Reset. The conflict is again indicated by red text. Circle one:  PASS / FAIL 

 

X.1.9 Click use new. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.10 Click Apply. A check is displayed next to AcctCon and 
secman is highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.11 Click use new. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.12 Click Apply. A check is displayed next to secman and 
sysadmin is highlighted in the left pane. 

Circle one:  PASS / FAIL 

 

X.1.13 Click use master. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.14 Click Apply. A check is displayed next to sysadmin and the 
right pane shows No more user conflicts. 

Circle one:  PASS / FAIL 

 

X.1.15 Click OK. A Group Conflicts window appears. 

GrpCon is highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.16 Click Apply. A check is displayed next to GrpCon and admin 
is highlighted in the left pane. 

Circle one:  PASS / FAIL 
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X.1.17 Click Apply. A check is displayed next to admin and other is 
highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.18 Click Apply. A check is displayed next to other and the right 
pane shows No more group conflicts. 

Circle one:  PASS / FAIL 

 

X.1.19 Click OK. A Profile Conflicts window appears. 
ProCon is highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.20 Click use master. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.21 Click Apply. A check is displayed next to ProCon and SA 
Default is highlighted in the left panel. 

Note: SA Default may not be listed; if not, skip 
to step X.1.24. 

Circle one:  PASS / FAIL 

 

X.1.22 Click use new. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.23 Click Apply. A check is displayed next to SA Default and the 
right pane shows No more profile 
conflicts. 

Circle one:  PASS / FAIL 

 

X.1.24 Click OK. A MergeHost Confirmation window 
appears with the following message: 
Send commands to the Master APM 
Server now? 

Circle one:  PASS / FAIL 
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X.1.25 Click OK. The MergeHost Status dialog box displays 
Finished. 

Circle one:  PASS / FAIL 

 

X.1.26 Click OK. The MergeHost Status dialog box disappears. Circle one:  PASS / FAIL 

 

X.2 Cleanup   

X.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Client. 

An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

X.2.2 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

X.2.3 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

X.2.4 Select user AcctCon. User AcctCon is highlighted. Circle one:  PASS / FAIL 

 

X.2.5 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

X.2.6 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 
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X.2.7 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for AcctCon has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

X.2.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

X.2.9 Select ProCon. ProCon is highlighted. Circle one:  PASS / FAIL 

 

X.2.10 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

X.2.11 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

X.2.12 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for ProCon has 
been removed from the Profiles tab. 

Circle one:  PASS / FAIL 

 

X.2.13 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

X.2.14 Select GrpCon. GrpCon is highlighted. Circle one:  PASS / FAIL 

 

X.2.15 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 
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X.2.16 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

X.2.17 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for GrpCon has 
been removed from the Groups tab. 

Circle one:  PASS / FAIL 

 

X.2.18 Select File > Exit. An Exit confirmation window appears. Circle one:  PASS / FAIL 

 

X.2.19 Click Yes. The Account and Profile Manager 
dialog box disappears. 

Circle one:  PASS / FAIL 

 

X.2.20 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears.  

Circle one:  PASS / FAIL 

X.2.21 In the Master Host text box, enter 
kpccp 

kpccp appears in the text box. Circle one:  PASS / FAIL 
 

X.2.22 Click Submit. A dialog box appears indicating:   

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

X.2.23 Click OK. The dialog box and the Edit APM 
Configuration window disappear. 

Circle one:  PASS / FAIL 

 

X.2.24 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

X.2.25 At the command prompt type  
su - 

The Password prompt appears. Circle one:  PASS / FAIL 
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X.2.26 At the Password prompt type the root 
password. 

The command prompt returns. Circle one:  PASS / FAIL 

 

X.2.27 At the command prompt type 
csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

X.2.28 In the Terminal window, type  
cd /h/COE/Comp/APM/bin 

The command prompt returns.  

X.2.29 In the Terminal window, type  
./APM_BecomeOwnMaster 

The command prompt returns.  

X.2.30 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

 

Login as secman. 

The desktop appears. Setup 

 

X.2.31 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

X.2.32 Double-click Remove Host in the 
Application Manager – SecAdm 
window. 

The Remove Hosts window appears. Cleanup 

X.2.33 Double-click kpccp in the Keep panel. kpccp moves to the Remove panel. Cleanup 

 

X.2.34 Click Submit. An INFORMATIONAL MESSAGE dialog box 
appears indicating: APM Server reloaded 
successfully. 

Cleanup 
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X.2.35 Click OK. A Completed dialog box appears indicating that 
kpccp has been removed. 

Cleanup 

 

X.2.36 Click OK. The dialog box and Remove Hosts window 
disappear. 

Cleanup 

 

X.2.37 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Cleanup 

 

X.2.38 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user keyman. 

The desktop appears.  
 

Setup  

X.2.39 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Setup  

X.2.40 Enter the master authentication key in the Key text 
box. 

Asterisks appear in the text box. Cleanup 

 

X.2.41 Click Set Client’s Local Key. The Hosts List window appears. Cleanup 

 

X.2.42 Select kpccp. kpccp is highlighted. Cleanup 
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X.2.43 Select Delete Host. A Confirm dialog box appears with the 
following message: 
Delete the local authentication 
keys of these hosts? 

kpccp 

Cleanup 

X.2.44 Click Yes. The dialog box disappears. Cleanup 

 

X.2.45 Click Close in the Hosts List window. The Hosts List window disappears. Cleanup 

 

X.2.46 Click Close in the Authentication 
Manager window. 

The Authentication Manager window 
disappears. 

Cleanup 

X.2.47 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Cleanup 

 

Y 
4.29 Profile Selector Config 

Y.1 Setup  

Y.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Profile Selector Config. 

The Profile Selector Configuration 
dialog box appears. 

Circle one:  PASS / FAIL 

Y.1.2 Click Cancel. The Profile Selector Configuration 
dialog box disappears. 

Circle one:  PASS / FAIL 
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Z 
4.30 Remove Host 

Z.1 Setup  

Z.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Double-click Remove Host. 

The Remove Hosts dialog box appears. Circle one:  PASS / FAIL 

Z.1.2 Click Cancel. The Remove Hosts dialog box disappears. 

 

Circle one:  PASS / FAIL 

Z.1.3 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

Z.1.4 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 

 

AA 
4.31 Public Key Manager 

AA.1 Setup  

AA.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Login as keyman. 

The desktop appears.  
 

Setup 

 

AA.1.2 Select Applications > Application 
Manager > DII_APPS > APM > Public 
Key Manager. 

The Public Key Manager window appears. Circle one:  PASS / FAIL 
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AA.1.3 Click Cancel. The Public Key Manager window 
disappears. 

Circle one:  PASS / FAIL 

ZZ 
4.32 Logout 

ZZ.1 Verify Logout  

ZZ.1.1 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

ZZ.1.2 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 

 
 

End of Validation Procedure 
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1. Overview 

1.1 Introduction 

This chapter defines the Print Services Manual Validation Procedure and is part of the 
required set of test procedures to be used in the certification of products to The Open 
Brand COE Platform Product Standard1.  

2. Test Procedure 

2.1 Scope  

This test procedure demonstrates the ability of the Candidate Platform to print ASCII 
text and postscript graphics to both a locally attached printer and a printer attached 
directly to the network. 

2.2 Description of test items 

The following functions will be exercised:  

A. Power Up and Login (Optional) 

B. Attach a Printer to the Candidate Platform 

C. From the GUI Desktop, Add a Locally Attached Printer to the Candidate 
Platform 

D. From the Command Line, Print Text and Graphics to the Locally Attached 
Printer. 

E. From the GUI Desktop, Add a Network Printer to the Candidate Platform 

F. From the Command Line, Print Text and Graphics to the Network Printer. 

G. From the GUI Desktop, Delete the Network and Locally Attached Printers 
from the Candidate Platform. 

H. Detach the Printer from the Candidate Platform 

Z. Logout (Optional) 

 

 

 

2.3 Test Data/Media Required   

                                           
1 See http://www.opengroup.org/openbrand/coe/ 



© 2003, The Open Group 
Chapter 2, page 3  

 
 

 

 Two files:  “print_tx.txt” and “print_ps.ps” located in the 
“/kpc/Printtest” directory on the Validation Host.  This directory will be NFS 

mounted on the Candidate Platform in order to make the KPC test data files available on 
the Candidate Platform.  Attachments 1 and 2 provide a visual reference for how the 
printed ASCII text and postscript graphics files should appear when printed. 

2.4 Setup/Equipment Required 

The Validation Host must be running the Printer Services available to the Candidate 
Platform. The Candidate Platform must have at least one printer that can be attached 
to the appropriate port e.g. a serial or parallel port. The Candidate Platform should 
have a root, System Administrator, secman and a regular User account created 
before the validation test run and must be network ready. 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003   

Initial Release 

 

 



 

  

3. Test Procedure Submission Form 

 

Test Title: Print Services Validation Procedure   

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 1.5 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 Operator Action Expected Result Observed Result 

A 4.1 Power-Up and Login  

A.1 Power-Up the Candidate Platform  (Optional: Use if not already powered up.)  

 A.1.1 Power up the Candidate Platform and verify that 
the DII COE Login screen appears. 

 

The DII COE login screen appears with the DoD 
security warning message and the Please enter 
your user name text box. 

Setup 

 A.2 Login to sysadmin  (Optional: Use if not already logged in.)  

 A.2.1 In the Please enter your user name text 
box, type: 
 sysadmin[r] 

The password screen appears with the 
Please enter your password text box. 

Setup 

 A.2.2 In the Please enter your password text 
box type the password for the sysadmin account 
and press [RETURN]. 

An Informational Message dialog box 
appears confirming that COE login processing is 
compete. 

Setup 

 A.2.3 Click OK in the Informational Message 
dialog box. 

The dialog box disappears. 

The menu bar, security classification and CDE 
desktop appear. 

Setup 
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A.3 Mount the KPC Test Data.  (Optional:  Use if files not already NFS mounted.)  

A.3.1 Export the /kpc filesystem on kpchost. System returns a command prompt. Setup 

A.3.2 NFS mount /kpc directory from the Validation 
Host to the Candidate Platform.  Type: 

  

 su - root 

 mount kpchost:/kpc[s]/kpc 
 exit 
 

A message confirms that the filesystem has been 
mounted. 

 

The /kpc directory is exported by the Validation 
Host. 

Setup 

A.3.3 Copy both “print_tx.txt” and 
“print_ps.ps” into the 
“/h/USERS/local/sysadmin/Scripts” 
directory.  Type: 

 

 su - root 

 cp /kpc/Printtest/*[s] 
/h/USERS/local/sysadmin/Scripts 

 exit 

 

System returns a command prompt. Setup 
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B 4.2 Attach a Printer to the Candidate Platform  

B.1 Physically Connect Printer to Candidate Platform   

B.1.1 Use cable to attach the Printer parallel port to the 
Candidate Platform parallel port. 

 

 

NOTE:  This step documents the procedure for the 
KPC �Reference Platform�.  KPC vendors should 
submit a modification to this step if their procedure 
differs.  Any connection technology may be used. 

 

Printer connectivity with Candidate Platform is 
established. 

Setup 

B.2  

Add System Software Support for Locally Attached Printer 
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B.2.1 Add printer driver (if needed - None needed for 
Sun Solaris, so this step may be ignored for that 
platform) 

 

NOTE:  This step documents the procedure for the 
KPC reference platform. KPC vendors should 
submit a modification to this step if their procedure 
differs. 

Successful installation and initialization of printer 
driver is confirmed. 

Circle one:  PASS / FAIL 

 

 

 

 

 

 

 

C 4.3 From the GUI Desktop, Add a Locally Attached Printer to the Candidate Platform 

C.1 Set up a Local  printer Using the new Printer Domain Name   

C.1.1 Open an Xterm window and enter the following 
command to determine the correct port to use. 
 
 ls /dev | grep pp 

 

The system returns the name of the local parallel 
port in the /dev directory. 

Circle one:  PASS / FAIL 

C.1.2 Right click on desktop to make menu appear.  Select 
SysAdm >Admintool: Printers > Browse 
> Printers 

The Admintool: Printers window appears.  Circle one:  PASS / FAIL 

C.1.3 Select Edit > Add > Local Printer from 
the Admintool: Printers window. 

The Add Printer window appears. Circle one:  PASS / FAIL  
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C.1.4 In the Add Printer box, type the following 
information: 
Printer Name:       KPCparallel 

  Description:        Parallel Printer 
Printer Port:        /dev/<Results of  
    Step C.1.1> 

Printer Model Type:       Postscript 
File Type:                   Postscript 
Default Printer: Check Box 

 
Click [OK] when complete. 

The new printer appears in the Admintool: 
Printers window. 
Printer Name:  KPCparallel 
Server:   kpccp 
Description:  Parallel Printer 

 Circle one:  PASS / FAIL 

D 4.4 From the Command Line, Print Text and Graphics to the Locally Attached Printer 

D.1 Open an Xterm  

D.1.1 On the Candidate Platform, Right Click on the 
desktop and select the following menu items: 
Tools> Terminal 

An Xterm window appears.  Circle one:  PASS / FAIL 

D.2 Print an ASCII Text file to the Locally Attached Printer  

D.2.1 Type: lp /kpc/Printtest/print_tx.txt Print output appears as shown in Attachment 1. Circle one:  PASS / FAIL 

D.3 Print a Postscript graphics file to the Locally Attached Printer  

D.3.1 Type: lp /kpc/Printtest/print_ps.ps Print output appears as shown in Attachment 2. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

 Note: Other print invocation methods, 
e.g."Drag and Drop" printing, may be added. 

  

E 4.5 From the GUI Desktop, add a Network Printer to the Candidate Platform.  

E.1 Add a Network Printer to the Candidate Platform.  

E.1.1 Select SysAdm > Admintool: Printers > 
Browse > Printers 

Admintool: Printers window appears. Circle one:  PASS / FAIL 

E.1.2 Select Edit > Add > Access to Printer 
from the Admintool: Printers window 

Add Printer window appears. Circle one:  PASS / FAIL 

E.1.3 In the Access to Printer box, type the 
following information: 

 

Printer Name:  kpccp 

Print Server  :  kpcnetlp 

Description:  Network Printer 

 

Check the box marked “System Default 
Printer”. 

 

Click [OK] when complete. 

 

The Add Printer box will disappear, leaving the 
ASCII printer appearing in the Admintool: 
Printers window. 

 

Printer Name:  kpccp 

Server:   kpcnetlp 

Description:  Network Printer 

Circle one:  PASS / FAIL 
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F 4.6 From the Command Line, Print Text and Graphics to the Network Printer 

F.1 Print an ASCII Text file to the Network Printer  

F.1.1 Type: 

 

lp /kpc/Printtest/print_tx.txt 

    

or 

 
/usr/lib/lp/postscript/postprint[s]/
kpc/Printtest/print_tx.txt | lp 

 

or 

 

drag the file from the file manager to the printer icon 
at the bottom of the screen. 

Print output appears as shown in Attachment 1. Circle one:  PASS / FAIL 

F.2 Print a Postscript graphics file to the Network Printer  
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F.2.1 Type:  

 

lp /kpc/Printtest/print_ps.ps 

 

or 

 

drag the file from the file manager to the printer icon 
at the bottom of the screen. 

Print output appears as shown in Attachment 2. Circle one:  PASS / FAIL 

F.3 Close the Xterm  

F.3.1 On the Candidate Platform, double-click the top left 
corner to close the Xterm window. 

The Xterm window disappears.  Circle one:  PASS / FAIL 

 Note: Other print invocation methods, 
e.g."Drag and Drop" printing, may be added. 

  

G 4.7 From the GUI Desktop, Delete the Network and Locally Attached Printers from the Candidate Platform 

G.1 Open Printer Administration Dialog Box  

G.1.1 Select SysAdm > Admintool: Printers > 
Browse >Printers  

The Admintool: Printers window opens. Circle one:  PASS / FAIL 

G.2 
4.7.1.1.1.1 Delete Locally Attached Printer from the Candidate Platform 

 

G.2.2 Click on local printer “KPCparallel”. The “KPCparallel” is selected Circle one:  PASS / FAIL 
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G.2.3 Select Edit > Delete from the Admintool: 
Printers window. 

A question will appear to confirm deletion. Circle one:  PASS / FAIL 

G.2.4 When the question appears:  “Do you really 
want to Delete Printer KPCparallel?” Click 
[Delete]. 

The message appears: “delete printer failed”. Circle one:  PASS / FAIL 

G.2.5 Click OK. The Admintool closes. Circle one:  PASS / FAIL 

G.2.6 Select SysAdm > Admintool:Printers > Browse 
> Printers 

The Admintool:Printers window opens. Circle one:  PASS / FAIL 

G.2.7 Verify the local printer does not appear. The local printer does not appear. Circle one:  PASS / FAIL 

G.3 Delete Network Printer from the Candidate Platform  

G.3.2 Click on network printer “kpccp”. The “kpccp” is selected Circle one:  PASS / FAIL 

G.3.3 Select Edit > Delete from the Admintool: 
Printers window. 

A question will appear to confirm deletion. Circle one:  PASS / FAIL 

G.3.4 When the question appears:  “Do you Really 
want to Delete Printer “kpccp?” Click 
[Delete]. 

The “kpccp” disappears indicating that the printer 
is deleted. 

Circle one:  PASS / FAIL 

G.4 Close Printer Administration Dialog Box  

G.4.1 Select Exit on the Admintool: Printers 
dialog. 

The Admintool: Printers window disappears. Circle one:  PASS / FAIL 

H 4.8 Detach the Printer from the Candidate Platform 

H.1 Disconnect the Printer from the Candidate Platform  
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H.1.1 Disconnect the cable used to attach the Printer 
parallel port to the Candidate Platform parallel 
port. 

 

NOTE:  This step documents the procedure for the 
KPC �Reference Platform�.  KPC vendors should 
submit a modification to this step if their procedure 
differs.  Any connection technology may be used. 

Printer connectivity with Candidate Platform is 
eliminated. 

Setup 

H.2 Remove System Software Supporting the Locally Attached Printer  

H.2.1 Removed printer driver (if needed - None needed 
for Sun Solaris, so this step may be ignored for 
that platform). 

 

NOTE:  This step documents the procedure for the 
KPC �Reference Platform�.  KPC vendors should 
submit a modification to this step if their procedure 
differs. 

Successful installation and initialization of printer 
driver is confirmed. 

Circle one:  PASS / FAIL 
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Z 4.9 Logout  (Optional:  

Use if no further validation is to be done.) 

Z.1 Unmount the KPC Test Data   

Z.1.1 To mount and unmount type: 

 

 su root 
 

System returns a command prompt. Shutdown 

Z.1.2 Unmount the KPC Test Data on the Candidate 
Platform.  Type: 

 

 umount /kpc 
 

System returns a command prompt. 

 

 

Shutdown 

Z.2 Verify sysadmin Logout  

 Z.2.1 Log into the Candidate Platform as sysadmin. The menu bar, security classification and DCE 
desktop appear. 

Shutdown 

Z.2.2 Select [EXIT] button from CDE. Logout confirmation window appears. Shutdown 

Z.2.3 Select [OK] System exits and the DII COE login screen appears. Shutdown 

 

 

End of Test Validation Procedure 
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1. Overview 

1.1 Introduction 

This chapter defines the Account and Profile Manager (Local APM Client)  Manual 
Validation Procedure and is part of the required set of test procedures to be used in 
the certification of products to The Open Brand COE Platform Product Standard1.  

2. Test Purpose 

2.1 Scope  

This Account and Profile Manager validation procedure provides a detailed test of the 
Client side of the Account and Profile Manager configuration software against Local 
user accounts. This test procedure establishes a multiple-host APM administrative 
domain and creates and manipulates Local accounts, groups and profiles within this 
domain. 

2.2 Description of test items  

Functionality that will be tested using the Account and Profile Manager (Local APM 
Master) Validation Procedure is as follows: 

A. Configure APM 

B. Designate the New APM Master and Configure Authentication 

C. Merge Hosts 

D. Create Local Users with Associated Profiles and Features 

E. Add a Profile to an Existing User 

F. Verify assigned Profiles and Unix permissions 

G. Augment Local Users With a New UNIX Group 

H. Deassign a Profile from a Local User 

I. Verify Deassignment of Profile from Local User 

J. Verify Assign Passwords Functionality  

K. Delete a Local Account 

L. Create a Local User with no Profile 
Test Local Account Creation on a Master System 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 M. Create and Test An Account with the Same Login Name as That of a 
Previously Deleted Account 

Create and Test a Profile Containing a Subset of the Features in a 
Segment  
Test Local Profile and Local Account Creation and Modification on a 
Master System 
Test Local Profile Creation on a Client System 

N. Verify a User with no Profiles Assigned Has no Profiles Available 

O. Add Multiple Users,  Use Templates to Predefine Account Parameters, 
and  Verify Accounts Created on One Merged Host Are Reflected On The 
Other 

P. Test Users with Multiple Derivative Profiles 
Use Templates to Predefine Profiles 

Q. Test interactions of Segments.  Test Account Modification on a Master 
System 

R. Test Session Manager's Ability to Resume the Previously Active Set of 
Profiles 

S. Log in With no Available Profile and Test Account Modification on a 
Master System 

T. Test ability to detect duplicate Local user names 

U. Test Ability to Detect Duplicate Profiles 

V. Test Ability to Detect Duplicate UNIX Groups 

W. Delete a Profile and Verify Local Users Cannot Assume a Profile Already 
Assigned to Them After the Profile Has Been Deleted 

X. Reset Test Cell for Additional Testing 

Y. Remove Hosts 

Z. Log out of the Candidate Platform (kpccp) and the Validation Host 
(kpchost) 
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2.3 Setup/Equipment Required 

The Validation Host (hostname: kpchost) is configured as an APM Client. 

The Candidate Platform (hostname: kpccp) is configured as an APM Master of the 
Validation Host. 

 

2.4 Required Media 

None 

2.5 Required Personnel   

One (1) tester.  The tester must be familiar with POSIX/UNIX application platforms, 
but need not be familiar with the Common Operating Environment (COE). 

2.6 Known Problems 

None 

2.7 Change History 

June 02, 2003   

Initial Release 

 

 



 

 

3. Test Procedure Submission Form 

Test Title: Account and Profile Manager (Local APM Client) Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime:  8 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        

 

 

 

 

 



© 2003, The Open Group 
Chapter 3, Page 7 

Revision: 1.0 
 

 

 Start of Validation Procedure 

4. Test Procedure 

 

 Operator Action Expected Result Observed Result 

A 4.1 Configure APM 

A.1 On the Candidate Platform (kpccp) Configure APM For Testing  

A.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

A.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

A.1.3 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

A.1.4 Under Local Options, set Log Level to 
Trace. 

Trace is selected. Circle one:  PASS / FAIL 

 

 

A.1.5 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.1.6 Select Manage Hosts. Manage Hosts is selected. Circle one:  PASS / FAIL 

 

 

A.1.7 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

A.1.8 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

A.2 On the Validation Host (kpchost) Configure APM For Testing  

A.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

A.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

A.2.3 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 9 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

A.2.4 Under Local Options, set Log Level to 
Trace. 

Trace is selected. Circle one:  PASS / FAIL 

 

 

A.2.5 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

A.2.6 Select Manage Hosts. Manage Hosts is selected. Circle one:  PASS / FAIL 

 

 

A.2.7 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

A.2.8 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

A.2.9 Log out. 

 
The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

B 4.2 Designate the New APM Master and Configure Authentication 

B.1 On the Candidate Platform (kpccp) Configure the Validation Host (kpchost) As the APM Master  

B.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Double-click Edit APM Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

B.1.2 Local Options: Set Master Host to 
kpchost. 

Dialog box accepts input. Circle one:  PASS / FAIL 

 

 

B.1.3 Local Options: Ensure Enable 
Authentication is selected. 

Enable Authentication is checked. Circle one:  PASS / FAIL 

 

 

B.1.4 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

B.1.5 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

B.1.6 Log out. The DII COE LOGIN screen appears. 

 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

B.2 On the Candidate Platform (kpccp) Set the Local APM Authentication Key  

B.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as keyman. 

The desktop appears. Setup 

 

B.2.2 Select Applications > Application 
Manager > DII_APPS > APM. 

The Application Manager – APM appears. 

 

Setup 

 

B.2.3 Double-click Authentication Manager. The Authentication Manager window 
appears. 

Setup  

 

B.2.4 Enter the Local Auth Key in the text box. Record 
the Local Authentication Key here. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

Local Authentication Key: 

_____________________ 

B.2.5 Click Set Key. A Message box appears stating:  
The local key is set. 

Circle one:  PASS / FAIL 

 

 

B.2.6 Click OK. The Message box disappears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

B.2.7 Click Close. The Authentication Manager window 
disappears. 

Circle one:  PASS / FAIL 

 

 

B.2.8 Log out. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

B.3 On the Validation Host (kpchost) Store An Encrypted Copy Of the Client�s APM Key  

B.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as keyman. 

The desktop appears. Setup 

 

 

B.3.2 Select Applications > Application 
Manager > DII_APPS > APM. 

The Application Manager – APM window 
appears. 

Setup 

 

 

B.3.3 Double-click Authentication Manager. The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

 

B.3.4 Enter the Master Auth Key in the text box. Record 
the Master Authentication Key here. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

Master Authentication Key: 

_____________________ 
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 Operator Action Expected Result Observed Result 

B.3.5 Click Set Master Key. A Confirm dialog box appears with the following 
message: 
You will have to re-enter local 
auth keys after the master auth 
key is changed. 
Are you sure you want to 
initialize master key? 

Circle one:  PASS / FAIL 

 

 

B.3.6 Click Yes. A Message box appears with the following 
message: 
Master authentication key is 
reset. 

Circle one:  PASS / FAIL 

 

 

B.3.7 Click OK. The Message box disappears. Circle one:  PASS / FAIL 

 

 

B.3.8 Click Set Client’s Local Key. The Hosts List window appears. Circle one:  PASS / FAIL 

 

 

B.3.9 In the Additional Host text box, enter 
kpccp 

kpccp appears in the text box. Circle one:  PASS / FAIL 
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B.3.10 Click Add Host. The Set Key for New Host window 
appears. 

Circle one:  PASS / FAIL 

 

 

B.3.11 Enter the Candidate Platform's APM authentication 
key (from step B.2.4) twice in the text boxes. 

Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

B.3.12 Click Submit. The Message window appears, indicating: 
Authentication keys are set. 

Circle one:  PASS / FAIL 

 

 

B.3.13 Click OK. The Message window disappears. Circle one:  PASS / FAIL 

 

 

B.3.14 In the Hosts List window, click Close. The Host List window disappears. Circle one:  PASS / FAIL 

 

 

B.3.15 In the Authentication Manager window, 
click Close. 

The Authentication Manager window 
disappears. 

Circle one:  PASS / FAIL 
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B.3.16 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

C 4.3 Merge Hosts 

C.1 Merge Hosts From the Candidate Platform (kpccp)  

C.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

 
Log in as secman. 

The desktop appears. Circle one:  PASS / FAIL 

 

C.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

C.1.3 In the Application Manager – SecAdm 
dialog box, double-click Merge Host. 

The MergeHost Tool dialog box appears. Circle one:  PASS / FAIL 

 

 

C.1.4 Verify that kpchost is in the Master APM 
Server section. 

kpchost appears in the text box. Circle one:  PASS / FAIL 

 

 

C.1.5 Verify that kpccp is in the New APM Domain 
Host section. 

kpccp appears in the text box. Circle one:  PASS / FAIL 
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C.1.6 Click OK. An Input dialog box appears asking for the 
master APM authentication key.  

Circle one:  PASS / FAIL 

 

 

C.1.7 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.1.8 Click OK. The MergeHost Tool dialog box disappears. 
The progress of the merge is tracked in the 
MergeHost Status window.  

Do not expect conflicts.  However, if a conflict is 
detected with the SA Default features, click 
use master, click Apply and click OK to clear 
the conflict. 

The MergeHost Warnings window appears. 
The MergeHost Confirmation window 
appears. 

Circle one:  PASS / FAIL 

 

 

C.1.9 Click OK in the MergeHost Confirmation 
dialog box to send the commands and finish the 
merge. 

The MergeHost Status window reads: 
Finished.  

Circle one:  PASS / FAIL 

C.1.10 Click OK in the MergeHost Status window. The MergeHost Status window and 
MergeHost Warnings window disappear. 

Circle one:  PASS / FAIL 
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D 4.4 Create Local Users With Associated Profiles and Features 

D.1 Create A New Account On the Candidate Platform (kpccp)  

D.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Application Manager – SecAdm 
dialog box, double-click APM Client. 

An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

D.1.2 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

D.1.3 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

D.1.4 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 
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D.1.5 Enter the following values: 

Login: Ltest1m 

Password: temp 

Password Confirm: temp 

Template: secman  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

D.1.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

D.1.7 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

D.1.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

D.1.9 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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D.2 Verify the New Account On the Candidate Platform (kpccp)  

D.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

 

Verify that the focus remains on the Accounts 
tab. 

The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 

D.2.2 Verify the entries for Ltest1m. The parameters listed for user Ltest1m match 
those below:  

 Login:   Ltest1m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SSO Default 

 Assigned Groups: admin 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

Circle one:  PASS / FAIL 

 

 

D.2.3 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

D.2.4 At the command prompt type 
cd /h/USERS  

The command prompt returns. Circle one:  PASS / FAIL 
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D.2.5 At the command prompt type 
ls -la global 

A directory Ltest1m is not listed. Circle one:  PASS / FAIL 

 

 

D.2.6 At the command prompt type 
ls -la local 

A directory Ltest1m is listed. Circle one:  PASS / FAIL 

 

 

E 4.5 Add A Profile To An Existing User 

E.1 Add A Profile To Ltest1m On the Candidate Platform (kpccp)  

E.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, under Accounts, double-click user 
Ltest1m. 

A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

E.1.2 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

E.1.3 Double-click SA Default. Profile SA Default moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 
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E.1.4 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 

 

 

E.1.5 Click OK to clear the Status Summary. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

E.2 Verify the New Profile On the Candidate Platform (kpccp)  

E.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> Accounts.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

E.2.2 Under the Accounts tab, examine the entry for 
Ltest1m. 

In the Profiles column, user Ltest1m has 
SSO Default and SA Default assigned. 

Circle one:  PASS / FAIL 

 

 

E.2.3 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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F 4.6 Verify Assigned Profiles and Unix Permissions 

F.1 Login As Ltest1m and Assign Profiles On the Candidate Platform (kpccp)  

F.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

F.1.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

F.1.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

F.1.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

F.1.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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F.1.6 Log in as user Ltest1m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

F.1.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.1.8 Double-click SSO Default. Profile SSO Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

F.1.9 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

F.1.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

F.1.11 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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F.1.12 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.1.13 Set Profile Selection Criteria to 
Multiple. 

Profile Selection Criteria is set to 
Multiple. 

Circle one:  PASS / FAIL 

 

 

F.1.14 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 

 

 

F.1.15 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.1.16 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

F.1.17 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 
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F.1.18 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

F.2 Verify That User Ltest1m Can Launch secman (SecAdm) Icons But Not sysadmin (SysAdm) 
Icons On the Candidate Platform (kpccp) 

 

F.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Application Manager – SecAdm 
window, double-click Assign Passwords. 

The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

F.2.2 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.2.3 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.2.4 Double-click Change Machine ID. An INFORMATIONAL MESSAGE dialog box 
appears with the message: 
You do not have permission to 
launch /h/AcctGrps/SysAdm/bin/ 

SAChangeMachineId. 

Circle one:  PASS / FAIL 
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F.2.5 Click OK. The INFORMATIONAL MESSAGE dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.2.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

F.3 Login As Ltest1m and Assign Profiles On the Validation Host (kpchost)  

F.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

F.3.2 Click OK. A command line window opens with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

F.3.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

F.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 
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F.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

F.3.6 Log in as user Ltest1m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

F.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.3.8 Double-click SSO Default. Profile SSO Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

F.3.9 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

F.3.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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F.3.11 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.3.12 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.3.13 Set Profile Selection Criteria to 
Multiple. 

Profile Selection Criteria is set to 
Multiple. 

Circle one:  PASS / FAIL 

 

 

F.3.14 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 

 

 

F.3.15 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.3.16 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 
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F.3.17 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

F.3.18 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

F.4 Verify That User Ltest1m Can Launch secman (SecAdm) Icons But Not sysadmin (SysAdm) 
Icons On the Validation Host (kpchost) 

 

F.4.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Application Manager – SecAdm 
window, double-click Assign Passwords. 

The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

F.4.2 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.4.3 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 
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F.4.4 Double-click Change Machine ID. An INFORMATIONAL MESSAGE dialog box 
appears with the message: 
You do not have permission to 
launch /h/AcctGrps/SysAdm/bin/ 
SAChangeMachineId. 

Circle one:  PASS / FAIL 

 

 

F.4.5 Click OK. The INFORMATIONAL MESSAGE dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.4.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

G 4.7 Augment Local Users With A New UNIX Group 

G.1 Add Unix Group other To User Ltest1m On the Candidate Platform (kpccp)  

G.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

G.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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G.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

G.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

G.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

G.1.6 Select user Ltest1m. User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

G.1.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

G.1.8 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 
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G.1.9 Double-click other. other moves to the Assigned Groups panel. Circle one:  PASS / FAIL 

 

 

G.1.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 

 

 

G.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

G.1.12 Select View > Refresh Catalog > 
Groups. 

The Account and Profile Manager 
dialog box is refreshed. 

Circle one:  PASS / FAIL 

 

 

G.1.13 Verify that the focus remains on the Accounts 
tab. 

The Accounts tab is displayed. Circle one:  PASS / FAIL 
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G.1.14 Verify the entries for Ltest1m. The parameters listed for user Ltest1m match 
those below:  

 Login:   Ltest1m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SSO Default,  
    SA Default 

 Assigned Groups: admin, other 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

Circle one:  PASS / FAIL 

 

 

G.1.15 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

G.2 Verify That User Ltest1m Can Launch secman (SecAdm) and sysadmin (SysAdm) Icons On the 
Candidate Platform (kpccp) 

 

G.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

G.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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G.2.3 Double-click Assign Passwords. The Assign Passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

G.2.4 Click Cancel. The Assign Passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.2.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

G.2.6 Double-click Change Machine ID. The Change Machine Id dialog box appears. Circle one:  PASS / FAIL 

 

 

G.2.7 Click Cancel. The Change Machine Id dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.2.8 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 35 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

G.3 Verify That User Ltest1m Can Launch secman (SecAdm) and sysadmin (SysAdm) Icons On the 
Validation Host (kpchost) 

 

G.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

G.3.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

G.3.3 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

G.3.4 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.3.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

G.3.6 Double-click Change Machine ID. The Change Machine Id dialog box appears. Circle one:  PASS / FAIL 
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G.3.7 Click Cancel. The Change Machine Id dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.3.8 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

H 4.8 Deassign A Profile From A Local User 

H.1 Deassign Profile SSO Default From User Ltest1m On the Candidate Platform (kpccp)  

H.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

H.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

H.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

H.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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H.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

H.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 

 

 

H.1.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

H.1.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

H.1.9 Double-click SSO Default. Profile SSO Default moves to the 
Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

H.1.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 
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H.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

H.1.12 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

I 4.9 Verify Deassignment Of Profile From Local User 

I.1 Verify Deassignment On the Candidate Platform (kpccp)  

I.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

I.1.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

I.1.3 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

I.1.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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I.1.5 Select Applications > Application 
Manager > DII_APPS. 

SysAdm is the only folder present in the 
Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

I.1.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

I.2 Verify Deassignment On the Validation Host (kpchost)  

I.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

I.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

I.2.3 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

I.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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I.2.5 Select Applications > Application 
Manager > DII_APPS. 

SysAdm and IPENT are the only folders present in 
the Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

I.2.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

J 4.10 Verify Assign Passwords Functionality  

NOTE: To enable concurrent password changes, ensure the root passwords are the same on both hosts 

J.1 Assign A New Password On the Candidate Platform (kpccp)  

J.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

J.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

J.1.3 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 41 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

J.1.4 Select user Ltest1m.  User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

J.1.5 Click Submit. The Assign password dialog box appears. Circle one:  PASS / FAIL 

 

 

J.1.6 In the Trusted User Password text box, 
enter the kpccp root password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.7 In the New Password text box enter password 
temp for Ltest1m.  

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.8 In the Password Confirm text box enter the 
same new password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.9 At Hosts, click Select and select kpccp. kpccp is  highlighted. Circle one:  PASS / FAIL 
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J.1.10 Click Submit. A Status Summary window shows a green 
checkmark and status value of 0. 

Circle one:  PASS / FAIL 

 

 

J.1.11 Click OK. Control returns to the Assign passwords 
dialog box. 

Circle one:  PASS / FAIL 

 

 

J.1.12 Select user Ltest1m.  User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

J.1.13 Click Submit. The Assign password dialog box appears. Circle one:  PASS / FAIL 

 

 

J.1.14 In the Trusted User Password text box, 
enter the kpchost root password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.15 In the New Password text box enter password 
temp for Ltest1m.  

Asterisks appear in the text box. Circle one:  PASS / FAIL 
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J.1.16 In the Password Confirm text box enter the 
same new password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.17 At Hosts, click Select and select kpchost. kpchost is  highlighted. Circle one:  PASS / FAIL 

 

 

J.1.18 Click Submit. A Status Summary window shows a green 
checkmark and status value of 0. 

Circle one:  PASS / FAIL 

 

 

J.1.19 Click OK. Control returns to the Assign passwords 
dialog box. 

Circle one:  PASS / FAIL 

 

 

J.1.20 Click Cancel. The Assign passwords dialog box disappears. Circle one:  PASS / FAIL 

 

 

J.1.21 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 
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J.2 Verify the Password Change On the Candidate Platform (kpccp)  

J.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m with the password temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

J.2.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

J.2.3 Enter the password temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

J.2.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

J.2.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

J.2.6 Log in as user Ltest1m with new password. The desktop appears.  
 

Circle one:  PASS / FAIL 
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J.2.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

J.2.8 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

J.2.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

J.2.10 Select Applications > Application 
Manager > DII_APPS. 

SysAdm is the only folder present in the 
Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

J.2.11 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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J.3 Verify the Password Change On the Validation Host (kpchost)  

J.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m with the password temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

J.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

J.3.3 Enter the password temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

J.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

J.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

J.3.6 Log in as user Ltest1m with new password. The desktop appears. 

 

Circle one:  PASS / FAIL 
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J.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

J.3.8 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

J.3.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

J.3.10 Select Applications > Application 
Manager > DII_APPS. 

SysAdm and IPENT are the only folders present in 
the Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

J.3.11 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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K 4.11 Delete A Local Account 

K.1 Delete An Account On the Candidate Platform (kpccp)  

K.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user secman. 

The desktop appears. Setup 

 

 

K.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

K.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

K.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

K.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

K.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 
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K.1.7 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

K.1.8 Click Yes to confirm deletion. A Status Summary window appears. All 
entries show a green checkmark icon and a 
Status value of 0. 

Circle one:  PASS / FAIL 

 

 

K.1.9 Click OK to clear the Status Summary. Control returns to the Account and Profile 
Manager dialog box. User Ltest1m is no 
longer listed under the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

K.1.10 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

K.1.11 At the command prompt type 
cd /h/USERS 

The command prompt returns. Setup 

 

 

K.1.12 At the command prompt type 
ls -la global  

Ltest1m is not present in the global 
subdirectory. 

Circle one:  PASS / FAIL 
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K.1.13 At the command prompt type 
ls -la local  

Ltest1m is not present in the local 
subdirectory. 

Circle one:  PASS / FAIL 

 

 

K.1.14 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

K.1.15 Attempt to log in as user Ltest1m. Console login FAILS for user Ltest1m. Circle one:  PASS / FAIL 

 

 

K.2 Verify Account Deletion On the Validation Host (kpchost)  

K.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user secman. 

The desktop appears. Setup 

 

 

K.2.2 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

K.2.3 At the command prompt type 
cd /h/USERS  

The command prompt returns. Setup 
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K.2.4 At the command prompt type 
ls -la global 

Ltest1m is not present in the global 
subdirectory. 

Circle one:  PASS / FAIL 

 

 

K.2.5 At the command prompt type 
ls -la local 

Ltest1m is not present in the local 
subdirectory. 

Circle one:  PASS / FAIL 

 

 

K.2.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

K.2.7 Attempt to log in as user Ltest1m. Console login FAILS for user Ltest1m. Circle one:  PASS / FAIL 

 

 

L 4.12 Create A Local User With No Profile - Test Local Account Creation On A Master System 

L.1 Create A New Account On the Validation Host (kpchost)  

L.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user secman. 

The desktop appears. Setup 

 

 

L.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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L.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

L.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

L.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

L.1.6 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

L.1.7 Enter the following values: 

Login: nopro1m 

Password: temp 

Password Confirm: temp 

Template: secman  

Home server: EACH HOST 

Manage as: Local  

Each item is filled in. Circle one:  PASS / FAIL 
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L.1.8 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

L.1.9 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

L.1.10 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

L.1.11 Double-click SSO Default in the Assigned 
Profiles panel. 

Profile SSO Default moves to the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

L.1.12 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

L.1.13 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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L.1.14 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

L.2 Verify the No-Profile Account On the Candidate Platform (kpccp)  

L.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user nopro1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

L.2.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

L.2.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

L.2.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

L.2.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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L.2.6 Log in as user nopro1m with new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

L.2.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

L.2.8 Verify that no profiles are listed in the 
Available Profiles or Selected 
Profiles panels. 

No profiles are listed in the Available 
Profiles or Selected Profiles panels. 

Circle one:  PASS / FAIL 

 

 

L.2.9 Click Cancel. The Profile Selector window 
disappears. 

Circle one:  PASS / FAIL 

 

 

L.2.10 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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L.3 Verify the No-Profile Account On the Validation Host (kpchost)  

L.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user nopro1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

L.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

L.3.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

L.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

L.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

L.3.6 Log in as user nopro1m with new password. The desktop appears. 

 

Circle one:  PASS / FAIL 
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L.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

L.3.8 Verify that no profiles are listed in the 
Available Profiles or Selected 
Profiles panels. 

No profiles are listed in the Available 
Profiles or Selected Profiles panels. 

Circle one:  PASS / FAIL 

 

 

L.3.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

L.3.10 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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M 

4.13  Create and test account  

Create and Test An Account with the Same Login Name As That Of A Previously Deleted Account 

Create and Test A Profile Containing A Subset Of the Features In A Segment  

Test Local Profile and Local Account Creation and Modification On A Master System 

Test Local Profile Creation On A Client System 

M.1 Create A New Profile (SSO Test) Incorporating Segment Security Administration and 
Assign Several (But Not All Available) Features To the Profile On the Validation Host (kpchost) 

 

M.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user secman. 

The desktop appears. Setup 

 

 

M.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

M.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

M.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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M.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

M.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

M.1.7 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

M.1.8 Enter the following values: 

Profile Name: SSO Test 

Profile Template: SSO Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

M.1.9 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

M.1.10 Select SOL Security Administration in 
the Segments panel. 

SOL Security Administration is 
highlighted. The SOL Security 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 
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M.1.11 Deselect APM Server Start, Audit Log 
File Manager, and Profile Selector 
Config in the Features panel. 

There are no check marks next to APM Server 
Start, Audit Log File Manager, and 
Profile Selector Config. 

Circle one:  PASS / FAIL 

 

 

M.1.12 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

M.1.13 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

M.1.14 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

 

M.1.15 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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M.2 Create A New Profile (SA Test) Incorporating Segment System Administration and 
Assign Several (But Not All Available) Features To the Profile On the Candidate Platform (kpccp) 

 

M.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user secman. 

The desktop appears. Setup 

 

 

M.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

M.2.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

M.2.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

M.2.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

M.2.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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M.2.7 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

M.2.8 Enter the following values: 

Profile Name: SA Test 

Profile Template: SA Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

M.2.9 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

M.2.10 Select SOL System Administration in the 
Segments panel. 

SOL System Administration is 
highlighted. The SOL System 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 

 

 

M.2.11 Deselect Adm Tool, Disk Manager, and 
Network Installation Server in the 
Features panel. 

There are no check marks next to Adm Tool, 
Disk Manager, and Network 
Installation Server. 

Circle one:  PASS / FAIL 

 

 

M.2.12 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 
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M.2.13 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

M.2.14 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

 

M.2.15 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

M.3 Re-create the Ltest1m Account On the Validation Host (kpchost)  

M.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, click Accounts. 

The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 

M.3.2 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 
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M.3.3 Enter the following values: 

Login: Ltest1m 

Password: temp 

Password Confirm: temp 

Template: None  

Home server: EACH HOST 

Manage as: Local  

Default Group: admin 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

M.3.4 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

M.3.5 Double-click SSO Test. Profile SSO Test moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

M.3.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

M.3.7 Double-click kpccp and kpchost. kpccp and kpchost move to the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 
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M.3.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

M.3.9 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

M.3.10 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

M.4 Verify the Parameters Of the New Account On the Candidate Platform (kpccp)   

M.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

M.4.2 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 
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M.4.3 Verify the entries for Ltest1m. The parameters listed for user Ltest1m match 
those below:  

 Login:   Ltest1m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SSO Test 

 Assigned Groups: admin 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

Circle one:  PASS / FAIL 

 

 

M.4.4 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

M.4.5 At the command prompt type 
cd /h/USERS  

The command prompt returns. Setup 

 

 

M.4.6 At the command prompt type 
ls -la global 

A directory Ltest1m is not listed. Circle one:  PASS / FAIL 
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M.4.7 At the command prompt type 
ls -la local 

A directory Ltest1m is listed. Circle one:  PASS / FAIL 

 

 

M.4.8 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

M.5 Test the Ltest1m Account On the Candidate Platform (kpccp)  

M.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

M.5.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

M.5.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

M.5.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 
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M.5.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

M.5.6 Log in as user Ltest1m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

M.5.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

M.5.8 Verify that SSO Test is the only profile listed. Profile SSO Test is the only profile listed. Circle one:  PASS / FAIL 

 

 

M.5.9 Double-click SSO Test. Profile SSO Test moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

M.5.10 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 
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M.5.11 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

M.5.12 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

M.5.13 Verify the icons for APM Server Start, 
Audit Log File Manager, and Profile 
Selector Config are not displayed. 

The icons for APM Server Start, Audit 
Log File Manager, and Profile 
Selector Config are not displayed. 

Circle one:  PASS / FAIL 

 

 

M.5.14 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

M.5.15 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

M.5.16 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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M.6 Test the Ltest1m Account On the Validation Host (kpchost)  

M.6.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

M.6.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

M.6.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

M.6.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

M.6.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

M.6.6 Log in as user Ltest1m with the new password. The desktop appears. 

 

Circle one:  PASS / FAIL 
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M.6.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

M.6.8 Verify that SSO Test is the only profile listed. Profile SSO Test is the only profile listed. Circle one:  PASS / FAIL 

 

 

M.6.9 Double-click SSO Test. Profile SSO Test moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

M.6.10 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

M.6.11 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

M.6.12 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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M.6.13 Verify the icons for APM Server Start, 
Audit Log File Manager, and Profile 
Selector Config are not displayed. 

The icons for APM Server Start, Audit 
Log File Manager, and Profile 
Selector Config are not displayed. 

Circle one:  PASS / FAIL 

 

 

M.6.14 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

M.6.15 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

M.6.16 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

N 4.14 Verify A User With No Profiles Assigned Has No Profiles Available 

N.1 Deassign Profile SSO Test From User Ltest1m On the Candidate Platform (kpccp)  

N.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user secman. 

The desktop appears. Setup 

 

 

N.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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N.1.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

N.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

N.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

N.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 

 

 

N.1.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

N.1.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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N.1.9 Double-click SSO Test. Profile SSO Test moves to the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

N.1.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 

 

 

N.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

N.1.12 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

N.2 Verify No Profiles Are Available On the Candidate Platform (kpccp)  

N.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

N.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 
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N.2.3 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

N.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

N.2.5 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

N.3 Verify No Profiles Are Available On the Validation Host (kpchost)  

N.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

N.3.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

N.3.3 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 
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N.3.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

N.3.5 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

N.4 Reassign Profile SSO Test To User Ltest1m On the Candidate Platform (kpccp)  

N.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

N.4.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

N.4.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

N.4.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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N.4.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

N.4.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 

 

 

N.4.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

N.4.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

N.4.9 Double-click SSO Test. Profile SSO Test moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

N.4.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 
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N.4.11 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

O 
4.15  Multi-user account functions 

Add Multiple Users, Use Templates To Predefine Account Parameters, and Verify Accounts Created On One Merged Host Are 
Reflected On The Other 

O.1 Add A New User On the Candidate Platform (kpccp)  

O.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, select File > New Account. 

The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

O.1.2 Click Identification. The Identification tab is displayed. Circle one:  PASS / FAIL 
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O.1.3 Enter the following values: 

Login: Ltest2m 

Password: temp 

Password Confirm: temp 

Template: sysadmin  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

O.1.4 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

O.1.5 Verify only group other appears in the 
Assigned Groups panel. 

Only group other appears in the Assigned 
Groups panel. 

Circle one:  PASS / FAIL 

 

 

O.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

O.1.7 Verify SA Default appears in the Assigned 
Profiles panel. 

Profile SA Default appears in the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 
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O.1.8 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

O.1.9 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

O.1.10 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

O.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

O.2 Add A New User On the Validation Host (kpchost)  

O.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

O.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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O.2.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

O.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

O.2.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

O.2.6 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

O.2.7 Enter the following values: 

Login: Ltest3m 

Password: temp 

Password Confirm: temp 

Template: None  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 
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O.2.8 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

O.2.9 Verify no groups are in the Assigned Groups 
panel. 

No groups are in the Assigned Groups panel. Circle one:  PASS / FAIL 

 

 

O.2.10 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

O.2.11 Double-click SA Test. Profile SA Test moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

O.2.12 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

O.2.13 Double-click kpccp and kpchost. kpccp and kpchost move to the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 
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O.2.14 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

O.2.15 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

O.3 Verify the Two New Users On the Candidate Platform (kpccp)  

O.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

O.3.2 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 84 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

O.3.3 Verify the entries for Ltest2m and Ltest3m. The parameters listed for user Ltest2m match 
those below.  

 Login:   Ltest2m 

 Default Group: other 

 Home Server:  each host 

 Profiles:  SA Default 

 Assigned Groups: other 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

The parameters listed for user Ltest3m match 
those below.  

 Login:   Ltest3m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SA Test 

 Assigned Groups: admin 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

Circle one:  PASS / FAIL 
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O.3.4 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

O.3.5 At the command prompt type 
cd /h/USERS  

The command prompt returns. Setup 

 

 

O.3.6 At the command prompt type 
ls -la global 

Directories Ltest2m and Ltest3m are not listed. Circle one:  PASS / FAIL 

 

 

O.3.7 At the command prompt type 
ls -la local 

Directories Ltest2m and Ltest3m are listed. Circle one:  PASS / FAIL 
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P 4.16 Test Users with Multiple Derivative Profiles 

Use Templates To Predefine Profiles 

P.1 Create A New Profile SA Multiple Incorporating Segment Security Administration and 
Assign Several (Or All Available) Features To the Profile On the Candidate Platform (kpccp) 

 

P.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, click Profiles. 

The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

P.1.2 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

P.1.3 Enter the following values: 

Profile Name: SA Multiple 

Profile Template: SA Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

P.1.4 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

P.1.5 Select SOL System Administration in the 
Segments panel. 

SOL System Administration is 
highlighted. The SOL System 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 
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P.1.6 Deselect Disk Manager, Reboot System, 
and Set System Time in the Features 
panel. 

There are no check marks next to Disk 
Manager, Reboot System, and Set 
System Time. 

Circle one:  PASS / FAIL 

 

 

P.1.7 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

P.1.8 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

P.1.9 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

 

P.1.10 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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Q 4.17 Test Interactions Of Segments.  

Test Account Modification On a Master System 

Q.1 Assign New Groups To Ltest2m and Ltest3m On the Validation Host (kpchost)  

Q.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

Q.1.2 Select user Ltest2m. User Ltest2m entry is highlighted. Circle one:  PASS / FAIL 

 

 

Q.1.3 Select Edit > Modify. A Modify Account: Ltest2m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

Q.1.4 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.5 Double-click admin. admin moves to the Assigned Groups panel. Circle one:  PASS / FAIL 
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Q.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.7 Double-click SA Multiple. Profile SA Multiple moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.1.8 Click Submit. A Status Summary dialog box appears 
indicating user Ltest2m was modified. 

Circle one:  PASS / FAIL 

 

 

Q.1.9 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

Q.1.10 Select user Ltest3m. User Ltest3m entry is highlighted. Circle one:  PASS / FAIL 

 

 

Q.1.11 Select Edit > Modify. A Modify Account: Ltest3m dialog box 
appears. 

Circle one:  PASS / FAIL 
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Q.1.12 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.13 Double-click other. other moves to the Assigned Groups panel. Circle one:  PASS / FAIL 

 

 

Q.1.14 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.15 Double-click SA Multiple. Profile SA Multiple moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.1.16 Click Submit. A Status Summary dialog box appears 
indicating user Ltest3m was modified. 

Circle one:  PASS / FAIL 

 

 

Q.1.17 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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Q.2 Verify Modifications On the Candidate Platform (kpccp)  

Q.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All. 

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

Q.2.2 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 
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Q.2.3 Verify the entries for Ltest2m and Ltest3m. The parameters listed for user Ltest2m match 
those below:  

 Login:   Ltest2m 

 Default Group: other 

 Home Server:  each host 

 Profiles:  SA Default, 
    SA Multiple 

 Assigned Groups: admin, other 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

The parameters listed for user Ltest3m match 
those below.  

 Login:   Ltest3m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SA Test, 
    SA Multiple 

 Assigned Groups: admin, other 

 Shell:   /bin/csh 

 Hosts:   kpccp, kpchost 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 93 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

Q.2.4 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

Q.3 Verify Ltest1m User�s Access To Its Assigned Icon On the Candidate Platform (kpccp)  

Q.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Log in as user Ltest1m.  

The desktop appears.  Circle one:  PASS / FAIL 

 

 

Q.3.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

Q.3.3 Double-click SSO Test. Profile SSO Test moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.3.4 Click OK. A Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

Q.3.5 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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Q.3.6 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

Q.3.7 Verify the icons for APM Server Start, 
Audit Log File Manager, and Profile 
Selector Config are not displayed. 

The icons for APM Server Start, Audit 
Log File Manager, and Profile 
Selector Config are not displayed. 

Circle one:  PASS / FAIL 

 

 

Q.3.8 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

Q.3.9 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

Q.3.10 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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Q.4 Verify Ltest2m User�s Access To Its Assigned Icon On the Candidate Platform (kpccp)  

Q.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest2m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

Q.4.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

Q.4.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

Q.4.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

Q.4.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

Q.4.6 Log in as user Ltest2m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 
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Q.4.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

Q.4.8 Double-click Profiles SA Default and SA 
Multiple in the Available Profiles 
panel. 

Profiles SA Default and SA Multiple move 
to the Selected Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.4.9 Click OK. A Profile Selector Results window 
appears stating that the profiles were successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

Q.4.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

Q.4.11 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 
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Q.4.12 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

Q.5 Verify Ltest3m User�s Access To Its Assigned Icon On the Candidate Platform (kpccp)  

Q.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest3m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

Q.5.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

Q.5.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

Q.5.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

Q.5.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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Q.5.6 Log in as user Ltest3m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

Q.5.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

Q.5.8 Double-click Profiles SA Test and SA 
Multiple in the Available Profiles 
panel. 

Profiles SA Test and SA Multiple move to 
the Selected Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.5.9 Click OK. A Profile Selector Results window 
appears stating that the profiles were successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

Q.5.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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Q.5.11 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Edit Local 
Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, XTerm. 

NOTE: This is the complete list of SysAdm 
features except Disk Manager. 

Circle one:  PASS / FAIL 

 

 

Q.5.12 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

R 4.18 Test Session Manager's Ability To Resume the Previously Active Set Of Profiles 

R.1 Verify Available Profiles and Icons For Ltest2m On the Candidate Platform (kpccp)  

R.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest2m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

R.1.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 
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R.1.3 Verify that no profiles are listed in the 
Available Profiles panel and SA 
Default and SA Multiple are listed in the 
Selected Profiles panel. 

No profiles are listed in the Available 
Profiles panel and SA Default and SA 
Multiple are listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

R.1.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

R.1.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

R.1.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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R.2 Verify Available Profiles and Icons For Ltest3m On the Candidate Platform (kpccp)  

R.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest3m.  

The desktop appears. Circle one:  PASS / FAIL 

 

 

R.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

R.2.3 Verify that no profiles are listed in the 
Available Profiles panel and SA Test 
and SA Multiple are listed in the Selected 
Profiles panel. 

No profiles are listed in the Available 
Profiles panel and SA Test and SA 
Multiple are listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

R.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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R.2.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Edit Local 
Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, XTerm. 

NOTE: This is the complete list of SysAdm 
features except Disk Manager. 

Circle one:  PASS / FAIL 

 

 

R.2.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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S 4.19 Log In With No Available Profile and Test Account Modification On A Master System 

S.1 Deassign Profiles SA Test and SA Multiple From User Ltest3m On the Validation Host 
(kpchost) 

 

S.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, select user Ltest3m. 

User Ltest3m is highlighted. Circle one:  PASS / FAIL 

 

 

S.1.2 Select Edit > Modify. A Modify Account: Ltest3m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

S.1.3 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

S.1.4 Double-click SA Test and SA Multiple. Profiles SA Test and SA Multiple move to 
the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

S.1.5 Click Submit. A Status Summary dialog box appears 
indicating user Ltest3m was modified. 

Circle one:  PASS / FAIL 
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S.1.6 Click OK. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

S.1.7 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

S.2 Verify Ltest3m User No Longer Has Access To Its Previously Assigned Icon On the Candidate 
Platform (kpccp) 

 

S.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Log in as user Ltest3m.  

The desktop appears. Circle one:  PASS / FAIL 

 

 

S.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

S.2.3 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

S.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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S.2.5 Select Applications > Application 
Manager > DII_APPS. 

..(go up) is the only icon displayed. Circle one:  PASS / FAIL 

 

 

S.2.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

S.3 Verify Ltest3m User No Longer Has Access To Its Previously Assigned Icon On the Validation 
Host (kpchost) 

 

S.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest3m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

S.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

S.3.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 
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S.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

S.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

S.3.6 Log in as user Ltest3m with the new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 

S.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

S.3.8 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

S.3.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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S.3.10 Select Applications > Application 
Manager > DII_APPS. 

..(go up) is the only icon displayed. Circle one:  PASS / FAIL 

 

 

S.3.11 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

T 4.20 Test Ability To Detect Duplicate Local User Names 

T.1 Attempt To Add A User Account That Already Exists On the Candidate Platform (kpccp)  

T.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

T.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

T.1.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

T.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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T.1.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

T.1.6 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

T.1.7 Click Identification. The Identification tab is displayed. Circle one:  PASS / FAIL 

 

 

T.1.8 Enter the following values: 

Login: Ltest2m 

Password: temp 

Password Confirm: temp 

Template: sysadmin  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

T.1.9 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 
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T.1.10 Verify only group other appears in the 
Assigned Groups panel. 

Only group other appears in the Assigned 
Groups panel. 

Circle one:  PASS / FAIL 

 

 

T.1.11 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

T.1.12 Verify SA Default appears in the Assigned 
Profiles panel. 

SA Default appears in the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

T.1.13 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

T.1.14 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

T.1.15 Click Submit. An Error dialog box appears with the message: 
Login name already exists. 

Circle one:  PASS / FAIL 
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T.1.16 Click OK. The Error dialog box disappears. Circle one:  PASS / FAIL 

 

 

T.1.17 Click Cancel. Control returns to the Account and Profile 
Manager dialog box. Only the original user 
Ltest2m is listed under the Accounts tab. No 
parameters of that or any other account have 
changed. 

Circle one:  PASS / FAIL 

 

 

U 4.21 Test Ability To Detect Duplicate Profiles 

U.1 Attempt To Create A Duplicate Profile SSO Test On the Candidate Platform (kpccp)  

U.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, click Profiles. 

The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

U.1.2 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

U.1.3 Enter the following values: 

Profile Name: SSO Test 

Profile Template: SSO Default  

Each item is filled in. Circle one:  PASS / FAIL 
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U.1.4 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

U.1.5 Select SOL Security Administration in 
the Segments panel. 

SOL Security Administration is 
highlighted. The SOL Security 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 

 

 

U.1.6 Click Select All. All Features are selected. Circle one:  PASS / FAIL 

 

 

U.1.7 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

U.1.8 Verify kpccp and kpchost appear in the 
Assigned Hosts panel. 

kpccp and kpchost appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

U.1.9 Click Submit. An Error dialog box appears with the message: 
Profile name already exists. 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 112 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

U.1.10 Click OK. The Error dialog box disappears. Circle one:  PASS / FAIL 

 

 

U.1.11 Click Cancel. Control returns to the Profiles tab of the 
Account and Profile Manager dialog 
box. Only the original Profile SSO Test is listed 
under the Profiles tab. No parameters of that or 
any other Profile have changed. 

Circle one:  PASS / FAIL 

 

 

U.2 Attempt To Create A Duplicate Profile SSO Test But With No Hosts Selected On the Candidate 
Platform (kpccp) 

 

U.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, select File > New Profile. 

The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

U.2.2 Enter the following values: 

Profile Name: SSO Test 

Profile Template: SSO Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

U.2.3 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 
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U.2.4 Select SOL Security Administration in 
the Segments panel. 

SOL Security Administration is 
highlighted. The SOL Security 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 

 

 

U.2.5 Click Select All. All Features are selected. Circle one:  PASS / FAIL 

 

 

U.2.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

U.2.7 Double-click kpccp and kpchost. kpccp and kpchost move to the Available 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

U.2.8 Click Submit. A dialog box appears with the following message: 
You have not selected any hosts 
for this profile! Continue? 

Circle one:  PASS / FAIL 

 

 

U.2.9 Click Yes. An Error dialog box appears with the message: 
Profile name already exists. 

Circle one:  PASS / FAIL 
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U.2.10 Click OK. Control returns to the Create Profile 
window. 

Circle one:  PASS / FAIL 

 

 

U.2.11 Click Cancel. Control returns to the Profiles tab of the 
Account and Profile Manager dialog 
box. Only the original Profile SSO Test is listed 
under the Profiles tab. No parameters of that or 
any other Profile have changed. 

Circle one:  PASS / FAIL 

 

 

V 4.22 Test Ability To Detect Duplicate UNIX Groups 

V.1 Attempt To Create A Duplicate Unix Group admin On the Candidate Platform (kpccp)  

V.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, click Groups.  

The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

V.1.2 Select File > New Group. The Create Group dialog box appears. Circle one:  PASS / FAIL 

 

 

V.1.3 Enter the following values: 

Group name: admin 

Template: admin  

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 
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V.1.4 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

V.1.5 Double-click kpccp and kpchost. kpccp and kpchost move to the Available 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

V.1.6 Click Submit. A dialog box appears with the following message: 
You have not selected any hosts 
for this group! Continue? 

Circle one:  PASS / FAIL 

 

 

V.1.7 Click Yes. An Error window appears with the message:  

Group name in use. 

Circle one:  PASS / FAIL 

 

 

V.1.8 Click OK. Control returns to the Create Group dialog box. Circle one:  PASS / FAIL 

 

 

V.1.9 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 
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V.1.10 Double-click kpccp and kpchost. kpccp and kpchost move to the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

V.1.11 Click Identification. The Identification tab is displayed. Circle one:  PASS / FAIL 

 

 

V.1.12 Select Domain from the Manage As drop-down 
list. 

Domain is selected. Circle one:  PASS / FAIL 

 

 

V.1.13 Click Submit. An Error window appears with the message:  

Group name in use. 

Circle one:  PASS / FAIL 

 

 

V.1.14 Click OK. Control returns to the Create Group dialog box. Circle one:  PASS / FAIL 

 

 

V.1.15 Click Cancel. Control returns to the Groups tab of the 
Account and Profile Manager dialog 
box. Only the original Group admin is listed under 
the Groups tab. No parameters of that or any other 
Group have changed. 

Circle one:  PASS / FAIL 
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V.2 Verify No Duplicate Accounts, Groups, or Profiles Have Been Created On the Validation Host 
(kpchost) 

 

V.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

V.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

V.2.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

V.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

V.2.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

V.2.6 Click Accounts. The Accounts tab is displayed. No two user 
Accounts have the same name. 

Circle one:  PASS / FAIL 
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V.2.7 Click Profiles. The Profiles tab is displayed. No two Profiles 
have the same name. 

Circle one:  PASS / FAIL 

 

 

V.2.8 Click Groups. The Groups tab is displayed. No two Groups 
have the same name. 

Circle one:  PASS / FAIL 

 

 

V.2.9 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

W 4.23 Delete A Profile and Verify Local Users Cannot Assume A Profile Already Assigned To Them After the Profile Has Been Deleted 

W.1 Delete the Profile SA Multiple On the Candidate Platform (kpccp)  

W.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, click Profiles. 

The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

W.1.2 Select SA Multiple. SA Multiple is highlighted. Circle one:  PASS / FAIL 
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W.1.3 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

W.1.4 Click Yes to confirm deletion. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

W.1.5 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for SA 
Multiple has been removed from the 
Profiles tab. 

Circle one:  PASS / FAIL 

 

 

W.1.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

W.2 Verify Available Profiles and Icons For User Ltest2m On the Candidate Platform (kpccp)  

W.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user Ltest2m.  

The desktop appears. Circle one:  PASS / FAIL 

 

 

W.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 
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W.2.3 Verify SA Default is listed in the Selected 
Profiles panel. 

SA Default is listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

W.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

W.2.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

W.2.6 Double-click Edit Local Hosts. The Edit Hosts dialog box appears. Circle one:  PASS / FAIL 

 

 

W.2.7 Click Close. The Edit Hosts dialog box disappears. Circle one:  PASS / FAIL 
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W.2.8 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

W.3 Verify Available Profiles and Icons For User Ltest2m On the Validation Host (kpchost)  

W.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest2m with password temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

W.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

W.3.3 Enter the current password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

W.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

W.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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W.3.6 Log in as user Ltest2m with the new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 

W.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

W.3.8 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

W.3.9 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

W.3.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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W.3.11 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

W.3.12 Double-click Set Routes. The Default Router Setup dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

W.3.13 Click Cancel. The Default Router Setup dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

W.3.14 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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X 4.24 Reset Test Cell For Additional Testing 

X.1 Clean Up Files Generated During Test Execution On the Candidate Platform (kpccp)  

X.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

X.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

X.1.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

X.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

X.1.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

X.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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X.1.7 Select SA Test. SA Test is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.8 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.9 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.10 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for SA Test has 
been removed from the Profiles tab. 

Circle one:  PASS / FAIL 

 

 

X.1.11 Select SSO Test. SSO Test is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.12 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 
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X.1.13 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.14 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for SSO Test 
has been removed from the Profiles tab. 

Circle one:  PASS / FAIL 

 

 

X.1.15 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 

X.1.16 Select user Ltest1m. User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.17 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.18 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 
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X.1.19 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for Ltest1m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.20 Select user Ltest2m. User Ltest2m is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.21 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.22 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.23 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for Ltest2m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.24 Select user Ltest3m. User Ltest3m is highlighted. Circle one:  PASS / FAIL 
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X.1.25 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.26 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.27 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for Ltest3m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.28 Select user nopro1m. User nopro1m is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.29 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.30 Click Yes. A Status Summary window appears indicating 
the account was successfully deleted. 

Circle one:  PASS / FAIL 
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X.1.31 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for nopro1m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.32 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Cleanup 

 

 

X.1.33 At the command prompt type 
cd /h/USERS  

The command prompt returns. Cleanup 

 

 

X.1.34 At the command prompt type 
ls -la global 

Directories Ltest1m, Ltest2m, Ltest3m 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.1.35 At the command prompt type 
ls -la local 

Directories Ltest1m, Ltest2m, Ltest3m 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.1.36 At the command prompt type 
su - 

The Password prompt appears. Cleanup 
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X.1.37 At the command prompt type the root password. The command prompt returns. Cleanup 

 

 

X.1.38 At the command prompt type 
csh 

The command prompt returns. Cleanup 

 

 

X.1.39 At the command prompt type 
cd /var/dt/appconfig/appmanager 

The command prompt returns. Cleanup 

 

 

X.1.40 At the command prompt type 
ls -l 

Ltest1m, Ltest2m, Ltest3m, nopro1m 
are not listed. 

Circle one:  PASS / FAIL 

 

 

X.1.41 In the Application Manager – SecAdm 
window, double-click Profile Selector 
Config. 

The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

X.1.42 Set Profile Selection Criteria to 
Single. 

Profile Selection Criteria is set to 
Single. 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 3, Page 131 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

X.1.43 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 

 

 

X.2 Verify Accounts and Profiles Have Been Removed From the Validation Host (kpchost)  

X.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Cleanup 

 

 

X.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Cleanup 

 

 

X.2.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

X.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

X.2.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 
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X.2.6 Click Accounts. The Accounts tab is displayed. Accounts 
Ltest1m, Ltest2m, Ltest3m, and 
nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.7 Click Profiles. The Profiles tab is displayed. Profiles SA 
Test, SSO Test, and SA Multiple are 
not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.8 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Cleanup 

 

 

X.2.9 At the command prompt type 
cd /h/USERS  

The command prompt returns. Cleanup 

 

 

X.2.10 At the command prompt type 
ls -la global 

Directories Ltest1m, Ltest2m, Ltest3m, 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.11 At the command prompt type 
ls -la local 

Directories Ltest1m, Ltest2m, Ltest3m, 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 
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X.2.12 At the command prompt type 
cd /var/dt/appconfig/appmanager 

The command prompt returns. Cleanup 

 

 

X.2.13 At the command prompt type 
ls -l 

Ltest1m, Ltest2m, Ltest3m,and 
nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.14 In the Application Manager – SecAdm 
window, double-click Edit APM 
Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

X.2.15 Under Local Options, set Log Level to 
Information. 

Information is selected. Circle one:  PASS / FAIL 

 

 

X.2.16 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

X.2.17 Deselect Manage Hosts. Manage Hosts is deselected. Circle one:  PASS / FAIL 
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X.2.18 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

X.2.19 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

X.2.20 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

X.2.21 Set Profile Selection Criteria to 
Single. 

Profile Selection Criteria is set to 
Single. 

Circle one:  PASS / FAIL 

 

 

X.2.22 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 
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Y 4.25 Remove Hosts 

Y.1 Remove Merged Hosts From the APM Master (kpchost)  

Y.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Application Manager – SecAdm 
dialog box, double-click Remove Host. 

The Remove Hosts dialog box appears. Circle one:  PASS / FAIL 

 

 

Y.1.2 In the Keep panel, double-click kpccp. kpccp moves to the Remove panel. Circle one:  PASS / FAIL 

 

 

Y.1.3 Click Submit. An INFORMATIONAL MESSAGE window states: 
APM Server reloaded successfully. 

Circle one:  PASS / FAIL 

 

 

Y.1.4 Click OK. A Completed window states:  
Removed: kpccp 

Circle one:  PASS / FAIL 

 

 

Y.1.5 Click OK. The Remove Host dialog box disappears. Circle one:  PASS / FAIL 
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Y.1.6 Double-click APM Server Stop. An INFORMATIONAL MESSAGE box states: 
APM Server successfully stopped. 

Circle one:  PASS / FAIL 

 

 

Y.1.7 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.1.8 Double-click APM Server Start. A INFORMATIONAL MESSAGE box states:  

APM Server started successfully. 

Circle one:  PASS / FAIL 

 

 

Y.1.9 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.1.10 Log out. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

Y.1.11 Log in as keyman. The desktop appears. Cleanup  

 

Y.1.12 Select Applications > Application 
Manager > DII_APPS > APM. 

  The Application Manager – APM window 
  appears. 

Cleanup 

 

Y.1.13 Double-click Authentication Manager. The Authentication Manager window 
appears. 

Cleanup 
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Y.1.14 Enter the master authentication key in the Key text 
box. 

Asterisks appear in the text box. Cleanup 

 

Y.1.15 Click Set Client’s Local Key. The Hosts List window appears. Cleanup 

 

Y.1.16 Select kpccp. kpccp is highlighted. Cleanup 

 

Y.1.17 Select Delete Host. A Confirm dialog box appears with the 
following message: 
Delete the local authentication 
keys of these hosts? 

kpccp 

Cleanup 

Y.1.18 Click Yes. The dialog box disappears. Cleanup 

 

Y.1.19 Click Close in the Hosts List window. The Hosts List window disappears. Cleanup 

 

Y.1.20 Click Close in the Authentication 
Manager window. 

The Authentication Manager window 
disappears. 

Cleanup 
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Y.2 Configure the Local Host As the APM Master On the Candidate Platform (kpccp)  

Y.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Application Manager – SecAdm 
window, double-click Edit APM 
Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

Y.2.2 In the Master Host text box, enter kpccp. kpccp appears in the text box. Circle one:  PASS / FAIL 

 

 

Y.2.3 Click Submit. Done window states:  

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

Y.2.4 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.2.5 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

Y.2.6 Under Local Options, set Log Level to 
Information. 

Information is selected. Circle one:  PASS / FAIL 
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Y.2.7 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

Y.2.8 Deselect Manage Hosts. Manage Hosts is deselected. Circle one:  PASS / FAIL 

 

 

Y.2.9 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

Y.2.10 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.2.11 In the Terminal window, type  
cd /h/COE/Comp/APM/bin 

The command prompt returns.  

Y.2.12 In the Terminal window, type  
./APM_BecomeOwnMaster 

The command prompt returns.  

Y.2.13 In the Terminal window, type  
ps -eaf | grep `cat [s] 
/h/COE/Comp/APM/data/APMServer.pid` 

The APM Server process is listed. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 3, Page 140 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

Y.3 Verify Validation Host (kpchost) Removed From the Candidate Platform (kpccp)  

Y.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All. 

The Account and Profile Manager 
dialog box is refreshed. 

Circle one:  PASS / FAIL 

 

 

Y.3.2 Select Accounts. The Accounts tab is displayed. In the Hosts 
column, only kpccp appears. 

Circle one:  PASS / FAIL 

 

 

Z 
4.26 Log Out of the Candidate Platform (kpccp) and the Validation Host (kpchost) 

End of Test Validation Procedure  
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1. Overview 

1.1 Introduction 

This chapter defines the Account and Profile Manager (Local APM Master) and is part of the 
required set of test procedures to be used in certification of products to the COE Platform 
Product Standard1.  

2. Test Purpose 

2.1 Scope  

This Account and Profile Manager validation procedure provides a detailed test of the Master 
side of the Account and Profile Manager configuration software against Local user accounts. 
This test procedure establishes a multiple-host APM administrative domain and creates and 
manipulates Local accounts, groups and profiles within this domain. 

2.2 Description of test items  

Functionality that will be tested using the Account and Profile Manager (Local APM Master) 
Validation Procedure is as follows: 

A. Configure APM 

B. Designate the New APM Master and Configure Authentication 

C. Merge Hosts 

D. Create Local Users with Associated Profiles and Features 

E. Add a Profile to an Existing User 

F. Verify assigned Profiles and Unix permissions 

G. Augment Local Users With a New UNIX Group 

H. Deassign a Profile from a Local User 

I. Verify Deassignment of Profile from Local User 

J. Verify Assign Passwords Functionality  

K. Delete a Local Account 

L. Create a Local User with no Profile 
Test Local Account Creation on a Master System 

M. Create and Test An Account with the Same Login Name as That of a Previously Deleted Account 
Create and Test a Profile Containing a Subset of the Features in a Segment  

                                           
1 See http://www.opengroup.org/openbrand/coe/ 



© 2003, The Open Group 
Chapter 4, Page 4 

 
 

 

 Test Local Profile and Local Account Creation and Modification on a Master System 
Test Local Profile Creation on a Client System 

N. Verify a User with no Profiles Assigned Has no Profiles Available 

O. Add Multiple Users,  Use Templates to Predefine Account Parameters, and  Verify Accounts Created on 
One Merged Host Are Reflected On The Other 

P. Test Users with Multiple Derivative Profiles 
Use Templates to Predefine Profiles 

Q. Test interactions of Segments.  Test Account Modification on a Master System 

R. Test Session Manager's Ability to Resume the Previously Active Set of Profiles 

S. Log in With no Available Profile and Test Account Modification on a Master System 

T. Test ability to detect duplicate Local user names 

U. Test Ability to Detect Duplicate Profiles 

V. Test Ability to Detect Duplicate UNIX Groups 

W. Delete a Profile and Verify Local Users Cannot Assume a Profile Already Assigned to Them After the 
Profile Has Been Deleted 

X. Reset Test Cell for Additional Testing 

Y. Remove Hosts 

Z. Log out of the Validation Host (kpchost) and the Candidate Platform (kpccp) 
 

2.3 Setup/Equipment Required 

This test requires a Validation Cell consisting of a Validation Host and Candidate Platform. 

The Validation Host (hostname: kpchost) is configured as an APM Client. 

The Candidate Platform (hostname: kpccp) is configured as an APM Master of the 
Validation Host. 

2.4 Required Media 

 

None 
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2.5 Required Personnel   

One (1) tester.  The tester must be familiar with POSIX/UNIX application platforms, but 
need not be familiar with the Common Operating Environment (COE). 

2.6 Known Problems 

None 

2.7 Change History 

June 02, 2003  

Initial Release



 

 

 

3. Test Procedure Form 

Test Title: Account and Profile Manager (Local APM Master) Validation Procedure 

Candidate Platform:     Date:   

Tester:      Estimated Runtime:  8 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 

 Operator Action Expected Result Observed Result 

A 4.1 Configure APM 

A.1 On the Validation Host (kpchost) Configure APM For Testing  

A.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

A.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

A.1.3 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

A.1.4 Under Local Options, set Log Level to 
Trace. 

Trace is selected. Circle one:  PASS / FAIL 
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A.1.5 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

A.1.6 Select Manage Hosts. Manage Hosts is selected. Circle one:  PASS / FAIL 

 

 

A.1.7 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

A.1.8 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

A.2 On the Candidate Platform (kpccp) Configure APM For Testing  

A.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

A.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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A.2.3 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

A.2.4 Under Local Options, set Log Level to 
Trace. 

Trace is selected. Circle one:  PASS / FAIL 

 

 

A.2.5 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

A.2.6 Select Manage Hosts. Manage Hosts is selected. Circle one:  PASS / FAIL 

 

 

A.2.7 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

A.2.8 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

A.2.9 Log out. 

 
The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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B 4.2 Designate the New APM Master and Configure Authentication 

B.1 On the Validation Host (kpchost) Configure the Candidate Platform (kpccp) As the APM Master  

B.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Double-click Edit APM Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

B.1.2 Local Options: Set Master Host to 
kpccp. 

Dialog box accepts input. Circle one:  PASS / FAIL 

 

 

B.1.3 Local Options: Ensure Enable 
Authentication is selected. 

Enable Authentication is checked. Circle one:  PASS / FAIL 

 

 

B.1.4 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

B.1.5 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

B.1.6 Log out. The DII COE LOGIN screen appears. 

 

Circle one:  PASS / FAIL 
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B.2 On the Validation Host (kpchost) Set the Local APM Authentication Key  

B.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as keyman. 

The desktop appears. Setup 

 

B.2.2 Select Applications > Application 
Manager > DII_APPS > APM. 

The Application Manager – APM appears. 

 

Setup 

 

B.2.3 Double-click Authentication Manager. The Authentication Manager window 
appears. 

Setup  

 

B.2.4 Enter the Local Auth Key in the text box. Record 
the Local Authentication Key here. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

Local Authentication Key: 

_____________________ 

B.2.5 Click Set Key. A Message box appears stating:  
The local key is set. 

Circle one:  PASS / FAIL 

 

 

B.2.6 Click OK. The Message box disappears. Circle one:  PASS / FAIL 
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B.2.7 Click Close. The Authentication Manager window 
disappears. 

Circle one:  PASS / FAIL 

 

 

B.2.8 Log out. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

B.3 On the Candidate Platform (kpccp) Store An Encrypted Copy Of the Client�s APM Key  

B.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as keyman. 

The desktop appears. Setup 

 

 

B.3.2 Select Applications > Application 
Manager > DII_APPS > APM. 

The Application Manager – APM window 
appears. 

Setup 

 

 

B.3.3 Double-click Authentication Manager. The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

 

B.3.4 Enter the Master Auth Key in the text box. Record 
the Master Authentication Key here. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

Master Authentication Key: 

_____________________ 



© 2003, The Open Group 
Chapter 4, Page 13 

 
 

 

 

 Operator Action Expected Result Observed Result 

B.3.5 Click Set Master Key. A Confirm dialog box appears with the following 
message: 
You will have to re-enter local 
auth keys after the master auth 
key is changed. 

Are you sure you want to 
initialize master key? 

Circle one:  PASS / FAIL 

 

 

B.3.6 Click Yes. A Message box appears with the following 
message: 
Master authentication key is 
reset. 

Circle one:  PASS / FAIL 

 

 

B.3.7 Click OK. The Message box disappears. Circle one:  PASS / FAIL 

 

 

B.3.8 Click Set Client’s Local Key. The Hosts List window appears. Circle one:  PASS / FAIL 

 

 

B.3.9 In the Additional Host text box, enter 
kpchost 

kpchost appears in the text box. Circle one:  PASS / FAIL 
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B.3.10 Click Add Host. The Set Key for New Host window 
appears. 

Circle one:  PASS / FAIL 

 

 

B.3.11 Enter the kpchost's APM authentication key 
(from step B.2.4) twice in the text boxes. 

Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

B.3.12 Click Submit. The Message window appears, indicating: 
Authentication keys are set. 

Circle one:  PASS / FAIL 

 

 

B.3.13 Click OK. The Message window disappears. Circle one:  PASS / FAIL 

 

 

B.3.14 In the Hosts List window, click Close. The Hosts List window disappears. Circle one:  PASS / FAIL 

 

 

B.3.15 In the Authentication Manager window, 
click Close. 

The Authentication Manager window 
disappears. 

Circle one:  PASS / FAIL 
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B.3.16 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

C 4.3 Merge Hosts 

C.1 Merge Hosts From the Validation Host (kpchost)  

C.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

 

Log in as secman. 

The desktop appears. Circle one:  PASS / FAIL 

 

C.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

C.1.3 In the Application Manager – SecAdm 
dialog box, double-click Merge Host. 

The MergeHost Tool dialog box appears. Circle one:  PASS / FAIL 

 

 

C.1.4 Verify that kpccp is in the Master APM 
Server section. 

kpccp appears in the text box. Circle one:  PASS / FAIL 

 

 

C.1.5 Verify that kpchost is in the New APM 
Domain Host section.  
 

kpchost appears in the text box. Circle one:  PASS / FAIL 
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C.1.6 Click OK. An Input dialog box appears asking for the 
master APM authentication key.  

 

Circle one:  PASS / FAIL 

 

 

C.1.7 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.1.8 Click OK. The MergeHost Tool dialog box disappears. 
The progress of the merge is tracked in the 
MergeHost Status window.  

Do not expect conflicts.  However, if a conflict is 
detected with the SA Default features, click 
use master, click Apply and click OK to clear 
the conflict. 

The MergeHost Warnings window appears. 
The MergeHost Confirmation window 
appears. 

Circle one:  PASS / FAIL 

 

 

C.1.9 Click OK in the MergeHost Confirmation 
dialog box to send the commands and finish the 
merge. 

The MergeHost Status window reads: 
Finished  

Circle one:  PASS / FAIL 

 

C.1.10 Click OK in the MergeHost Status window. The MergeHost Status window and 
MergeHost Warnings window disappear. 

Circle one:  PASS / FAIL 
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D 4.4 Create Local Users with Associated Profiles and Features 

D.1 Create A New Account On the Validation Host (kpchost)  

D.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Application Manager – SecAdm 
dialog box, double-click APM Client. 

An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

D.1.2 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

D.1.3 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

D.1.4 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 
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D.1.5 Enter the following values: 

Login: Ltest1m 

Password: temp 

Password Confirm: temp 

Template: secman  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

D.1.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

D.1.7 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

D.1.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

D.1.9 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 19 

 
 

 

 

 Operator Action Expected Result Observed Result 

D.2 Verify the New Account on the Validation Host (kpchost)  

D.2.1 Verify that the focus remains on the Accounts 
tab. 

The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 

D.2.2 Verify the entries for Ltest1m. The parameters listed for user Ltest1m match 
those below:  

 Login:   Ltest1m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SSO Default 

 Assigned Groups: admin 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

Circle one:  PASS / FAIL 

 

 

D.2.3 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

D.2.4 At the command prompt type 
cd /h/USERS  

The command prompt returns. Circle one:  PASS / FAIL 
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D.2.5 At the command prompt type 
ls -la global 

A directory Ltest1m is not listed. Circle one:  PASS / FAIL 

 

 

D.2.6 At the command prompt type 
ls -la local 

A directory Ltest1m is listed. Circle one:  PASS / FAIL 

 

 

E 4.5 Add A Profile To An Existing User 

E.1 Add A Profile To Ltest1m On the Validation Host (kpchost)  

E.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

In the Account and Profile Manager 
dialog box, under Accounts, double-click user 
Ltest1m. 

A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

E.1.2 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

E.1.3 Double-click SA Default. Profile SA Default moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 
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E.1.4 Click Submit. A Status Summery dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 

 

 

E.1.5 Click OK to clear the Status Summary. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

E.2 Verify the New Profile On the Validation Host (kpchost)  

E.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> Accounts.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

E.2.2 Under the Accounts tab, examine the entry for 
Ltest1m. 

In the Profiles column, user Ltest1m has 
SSO Default and SA Default assigned. 

Circle one:  PASS / FAIL 

 

 

E.2.3 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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F 4.6 Verify Assigned Profiles and Unix Permissions 

F.1 Login As Ltest1m and Assign Profiles On the Validation Host (kpchost)  

F.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

F.1.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

F.1.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

F.1.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

F.1.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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F.1.6 Log in as user Ltest1m with the new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 

F.1.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.1.8 Double-click SSO Default. Profile SSO Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

F.1.9 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

F.1.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

F.1.11 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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F.1.12 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.1.13 Set Profile Selection Criteria to 
Multiple. 

Profile Selection Criteria is set to 
Multiple. 

Circle one:  PASS / FAIL 

 

 

F.1.14 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 

 

 

F.1.15 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.1.16 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

F.1.17 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 
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F.1.18 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

F.2 Verify That User Ltest1m Can Launch secman (SecAdm) Icons But Not sysadmin (SysAdm) 
Icons On the Validation Host (kpchost) 

 

F.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Application Manager – SecAdm 
window, double-click Assign Passwords. 

The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

F.2.2 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.2.3 Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.2.4 Double-click Change Machine ID. An INFORMATIONAL MESSAGE dialog box 
appears with the message: 
You do not have permission to 
launch /h/AcctGrps/SysAdm/bin/ 
SAChangeMachineId. 

Circle one:  PASS / FAIL 
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F.2.5 Click OK. The INFORMATIONAL MESSAGE dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.2.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

F.3 Login As Ltest1m and Assign Profiles On the Candidate Platform (kpccp)  

F.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

F.3.2 Click OK. A command line window opens with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

F.3.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

F.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 
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F.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

F.3.6 Log in as user Ltest1m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

F.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.3.8 Double-click SSO Default. Profile SSO Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

F.3.9 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

F.3.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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F.3.11 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.3.12 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.3.13 Set Profile Selection Criteria to 
Multiple. 

Profile Selection Criteria is set to 
Multiple. 

Circle one:  PASS / FAIL 

 

 

F.3.14 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 

 

 

F.3.15 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

F.3.16 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 
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F.3.17 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

F.3.18 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

F.4 Verify That User Ltest1m Can Launch secman (SecAdm) Icons But Not sysadmin (SysAdm) 
Icons On the Candidate Platform (kpccp) 

 

F.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Application Manager – SecAdm 
window, double-click Assign Passwords. 

The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

F.4.2 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.4.3 Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 
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F.4.4 Double-click Change Machine ID. An INFORMATIONAL MESSAGE dialog box 
appears with the message: 
You do not have permission to 
launch /h/AcctGrps/SysAdm/bin/ 
SAChangeMachineId. 

Circle one:  PASS / FAIL 

 

 

F.4.5 Click OK. The INFORMATIONAL MESSAGE dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

F.4.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

G 4.7 Augment Local Users With A New UNIX Group 

G.1 Add Unix Group other to User Ltest1m On the Validation Host (kpchost)  

G.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

G.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 



© 2003, The Open Group 
Chapter 4, Page 31 

 
 

 

 

 Operator Action Expected Result Observed Result 

G.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

G.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

G.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

G.1.6 Select user Ltest1m. User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

G.1.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

G.1.8 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 
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G.1.9 Double-click other. other moves to the Assigned Groups panel. Circle one:  PASS / FAIL 

 

 

G.1.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 

 

 

G.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

G.1.12 Select View > Refresh Catalog > 
Groups. 

The Account and Profile Manager 
dialog box is refreshed. 

Circle one:  PASS / FAIL 

 

 

G.1.13 Verify that the focus remains on the Accounts 
tab. 

The Accounts tab is displayed. Circle one:  PASS / FAIL 
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G.1.14 Verify the entries for Ltest1m. The parameters listed for user Ltest1m match 
those below:  

 Login:   Ltest1m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SSO Default,  
    SA Default 

 Assigned Groups: admin, other 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

Circle one:  PASS / FAIL 

 

 

G.1.15 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

G.2 Verify That User Ltest1m Can Launch secman (SecAdm) and sysadmin (SysAdm) Icons On the 
Validation Host (kpchost) 

 

G.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

G.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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G.2.3 Double-click Assign Passwords. The Assign Passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

G.2.4 Click Cancel. The Assign Passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.2.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

G.2.6 Double-click Change Machine ID. The Change Machine Id dialog box appears. Circle one:  PASS / FAIL 

 

 

G.2.7 Click Cancel. The Change Machine Id dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.2.8 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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G.3 Verify That User Ltest1m Can Launch secman (SecAdm) and sysadmin (SysAdm) Icons On the 
Candidate Platform (kpccp) 

 

G.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

G.3.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

G.3.3 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

G.3.4 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.3.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

G.3.6 Double-click Change Machine ID. The Change Machine Id dialog box appears. Circle one:  PASS / FAIL 
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G.3.7 Click Cancel. The Change Machine Id dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

G.3.8 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

H 4.8 Deassign A Profile From a Local User 

H.1 Deassign Profile SSO Default From User Ltest1m On the Validation Host (kpchost)  

H.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

H.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

H.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

H.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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H.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

H.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 

 

 

H.1.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

H.1.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

H.1.9 Double-click SSO Default. Profile SSO Default moves to the 
Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

H.1.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 
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H.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

H.1.12 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

I 4.9 Verify Deassignment Of Profile From Local User 

I.1 Verify Deassignment On the Validation Host (kpchost)  

I.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

I.1.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

I.1.3 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

I.1.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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I.1.5 Select Applications > Application 
Manager > DII_APPS. 

SysAdm and IPENT are the only folders present in 
the Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

I.1.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

I.2 Verify Deassignment On the Candidate Platform (kpccp)  

I.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

I.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

I.2.3 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

I.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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I.2.5 Select Applications > Application 
Manager > DII_APPS. 

SysAdm is the only folder present in the 
Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

I.2.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

J 4.10 Verify Assign Passwords Functionality  

J.1 Assign A New Password On the Validation Host (kpchost)  

J.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

J.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

J.1.3 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

J.1.4 Select user Ltest1m.  User Ltest1m is highlighted. Circle one:  PASS / FAIL 
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J.1.5 Click Submit. The Assign password dialog box appears. Circle one:  PASS / FAIL 

 

 

J.1.6 In the Trusted User Password text box, 
enter the kpccp root password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.7 In the New Password text box enter password 
temp for Ltest1m.  

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.8 In the Password Confirm text box enter the 
same new password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.9 At Hosts, click Select and select kpccp. kpccp is  highlighted. Circle one:  PASS / FAIL 

 

 

J.1.10 Click Submit. A Status Summary window shows a green 
checkmark and status value of 0. 

Circle one:  PASS / FAIL 
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J.1.11 Click OK. Control returns to the Assign passwords 
dialog box. 

Circle one:  PASS / FAIL 

 

 

J.1.12 Select user Ltest1m.  User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

J.1.13 Click Submit. The Assign password dialog box appears. Circle one:  PASS / FAIL 

 

 

J.1.14 In the Trusted User Password text box, 
enter the kpchost root password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.15 In the New Password text box enter password 
temp for Ltest1m.  

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.1.16 In the Password Confirm text box enter the 
same new password. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 
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J.1.17 At Hosts, click Select and select kpchost. kpchost is  highlighted. Circle one:  PASS / FAIL 

 

 

J.1.18 Click Submit. A Status Summary window shows a green 
checkmark and status value of 0. 

Circle one:  PASS / FAIL 

 

 

J.1.19 Click OK. Control returns to the Assign passwords 
dialog box. 

Circle one:  PASS / FAIL 

 

 

J.1.20 Click Cancel. The Assign passwords dialog box disappears. Circle one:  PASS / FAIL 

 

 

J.1.21 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 
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J.2 Verify the Password Change On the Validation Host (kpchost)  

J.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m with the password temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

J.2.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

J.2.3 Enter the password temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

J.2.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

J.2.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

J.2.6 Log in as user Ltest1m with new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 45 

 
 

 

 

 Operator Action Expected Result Observed Result 

J.2.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

J.2.8 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

J.2.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

J.2.10 Select Applications > Application 
Manager > DII_APPS. 

SysAdm and IPENT are the only folders present in 
the Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

J.2.11 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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J.3 Verify the Password Change On the Candidate Platform (kpccp)  

J.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m with the password temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

J.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

J.3.3 Enter the password temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

J.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password:_____________ 

 

J.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

J.3.6 Log in as user Ltest1m with new password. The desktop appears.  
 

Circle one:  PASS / FAIL 
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J.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

J.3.8 Verify that SA Default is the only profile listed 
in the Selected Profiles panel and that no 
profiles are listed in the Available Profiles 
panel. 

SA Default is the only profile listed in the 
Selected Profiles panel and no profiles are 
listed in the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

J.3.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

J.3.10 Select Applications > Application 
Manager > DII_APPS. 

SysAdm is  the only folder present in the 
Application Manager – DII_APPS 
window. 

Circle one:  PASS / FAIL 

 

 

J.3.11 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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K 4.11 Delete A Local Account 

K.1 Delete An Account On the Validation Host (kpchost)  

K.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user secman. 

The desktop appears. Setup 

 

 

K.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

K.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

K.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

K.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

K.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 
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K.1.7 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

K.1.8 Click Yes to confirm deletion. A Status Summary window appears. All 
entries show a green checkmark icon and a 
Status value of 0. 

Circle one:  PASS / FAIL 

 

 

K.1.9 Click OK to clear the Status Summary. Control returns to the Account and Profile 
Manager dialog box. User Ltest1m is no 
longer listed under the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

K.1.10 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

K.1.11 At the command prompt type 
cd /h/USERS 

The command prompt returns. Setup 

 

 

K.1.12 At the command prompt type 
ls -la global  

Ltest1m is not present in the global 
subdirectory. 

Circle one:  PASS / FAIL 
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K.1.13 At the command prompt type 
ls -la local  

Ltest1m is not present in the local 
subdirectory. 

Circle one:  PASS / FAIL 

 

 

K.1.14 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

K.1.15 Attempt to log in as user Ltest1m. Console login FAILS for user Ltest1m. Circle one:  PASS / FAIL 

 

 

K.2 Verify Account Deletion On the Candidate Platform (kpccp)  

K.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user secman. 

The desktop appears. Setup 

 

 

K.2.2 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

K.2.3 At the command prompt type 
cd /h/USERS  

The command prompt returns. Setup 
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K.2.4 At the command prompt type 
ls -la global 

Ltest1m is not present in the global 
subdirectory. 

Circle one:  PASS / FAIL 

 

 

K.2.5 At the command prompt type 
ls -la local 

Ltest1m is not present in the local 
subdirectory. 

Circle one:  PASS / FAIL 

 

 

K.2.6 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

K.2.7 Attempt to log in as user Ltest1m. Console login FAILS for user Ltest1m. Circle one:  PASS / FAIL 
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L 
4.12 Create A Local User With No Profile 

4.13 Test Local Account Creation On A Master System 

L.1 Create A New Account On the Candidate Platform (kpccp)  

L.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user secman. 

The desktop appears. Setup 

 

 

L.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

L.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

L.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

L.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 
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L.1.6 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

L.1.7 Enter the following values: 

Login: nopro1m 

Password: temp 

Password Confirm: temp 

Template: secman  

Home server: EACH HOST 

Manage as: Local  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

L.1.8 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

L.1.9 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

L.1.10 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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L.1.11 Double-click SSO Default in the Assigned 
Profiles panel. 

Profile SSO Default moves to the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

L.1.12 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

L.1.13 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

L.1.14 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

L.2 Verify the No-Profile Account On the Validation Host (kpchost)  

L.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user nopro1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

L.2.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 
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L.2.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

L.2.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password:_____________ 

 

L.2.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

L.2.6 Log in as user nopro1m with new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 

L.2.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

L.2.8 Verify that no profiles are listed in the 
Available Profiles or Selected 
Profiles panels. 

No profiles are listed in the Available 
Profiles or Selected Profiles panels. 

Circle one:  PASS / FAIL 
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L.2.9 Click Cancel. The Profile Selector window 
disappears. 

Circle one:  PASS / FAIL 

 

 

L.2.10 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

L.3 Verify The No-Profile Account On the Candidate Platform (kpccp)  

L.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user nopro1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

L.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

L.3.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

L.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password:_____________ 
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L.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

L.3.6 Log in as user nopro1m with new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

L.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

L.3.8 Verify that no profiles are listed in the 
Available Profiles or Selected 
Profiles panels. 

No profiles are listed in the Available 
Profiles or Selected Profiles panels. 

Circle one:  PASS / FAIL 

 

 

L.3.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

L.3.10 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 58 

 
 

 

 

 Operator Action Expected Result Observed Result 

M 

4.14 Create and Test an Account: 

Create and Test An Account With the Same Login Name As That Of A Previously Deleted Account 

Create and Test A Profile Containing A Subset Of the Features In A Segment  

Test Local Profile and Local Account Creation and Modification On A Master System 

Test Local Profile Creation On A Client System 

M.1 Create A New Profile (SSO Test) Incorporating Segment Security Administration and 
Assign Several (But Not All Available) Features To the Profile On the Candidate Platform (kpccp) 

 

M.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Log in as user secman. 

The desktop appears. Setup 

 

 

M.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

M.1.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

M.1.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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M.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

M.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

M.1.7 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

M.1.8 Enter the following values: 

Profile Name: SSO Test 

Profile Template: SSO Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

M.1.9 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

M.1.10 Select SOL Security Administration in 
the Segments panel. 

SOL Security Administration is 
highlighted. The SOL Security 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 
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M.1.11 Deselect APM Server Start, Audit Log 
File Manager, and Profile Selector 
Config in the Features panel. 

There are no check marks next to APM Server 
Start, Audit Log File Manager, and 
Profile Selector Config. 

Circle one:  PASS / FAIL 

 

 

M.1.12 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

M.1.13 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

M.1.14 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

 

M.1.15 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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M.2 Create A New Profile (SA Test) Incorporating Segment System Administration and 
Assign Several (But Not All Available) Features To the Profile On the Validation Host (kpchost) 

 

M.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user secman. 

The desktop appears. Setup 

 

 

M.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

M.2.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

M.2.4 Enter the master APM authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

M.2.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

M.2.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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M.2.7 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

M.2.8 Enter the following values: 

Profile Name: SA Test 

Profile Template: SA Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

M.2.9 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

M.2.10 Select SOL System Administration in the 
Segments panel. 

SOL System Administration is 
highlighted. The SOL System 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 

 

 

M.2.11 Deselect Adm Tool, Disk Manager, and 
Network Installation Server in the 
Features panel. 

There are no check marks next to Adm Tool, 
Disk Manager, and Network 
Installation Server. 

Circle one:  PASS / FAIL 

 

 

M.2.12 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 
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M.2.13 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

M.2.14 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

 

M.2.15 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

M.3 Re-create the Ltest1m Account On the Candidate Platform (kpccp)  

M.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, click Accounts. 

The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 

M.3.2 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 
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M.3.3 Enter the following values: 

Login: Ltest1m 

Password: temp 

Password Confirm: temp 

Template: None  

Home server: EACH HOST 

Manage as: Local  

Default Group: admin 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

M.3.4 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

M.3.5 Double-click SSO Test. Profile SSO Test moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

M.3.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

M.3.7 Double-click kpchost and kpccp. kpchost and kpccp move to the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 
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M.3.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

M.3.9 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

M.3.10 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

M.4 Verify The Parameters Of the New Account On the Validation Host (kpchost)   

M.4.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

M.4.2 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 
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M.4.3 Verify the entries for Ltest1m. The parameters listed for user Ltest1m match 
those below:  

 Login:   Ltest1m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SSO Test 

 Assigned Groups: admin 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

Circle one:  PASS / FAIL 

 

 

M.4.4 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

M.4.5 At the command prompt type 
cd /h/USERS  

The command prompt returns. Setup 

 

 

M.4.6 At the command prompt type 
ls -la global 

A directory Ltest1m is not listed. Circle one:  PASS / FAIL 
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M.4.7 At the command prompt type 
ls -la local 

A directory Ltest1m is listed. Circle one:  PASS / FAIL 

 

 

M.4.8 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

M.5 Test the Ltest1m Account On the Validation Host (kpchost)  

M.5.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

M.5.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

M.5.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

M.5.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password:_____________ 
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M.5.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

M.5.6 Log in as user Ltest1m with the new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 

M.5.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

M.5.8 Verify that SSO Test is the only profile listed. Profile SSO Test is the only profile listed. Circle one:  PASS / FAIL 

 

 

M.5.9 Double-click SSO Test. Profile SSO Test moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

M.5.10 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 
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M.5.11 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

M.5.12 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

M.5.13 Verify the icons for APM Server Start, 
Audit Log File Manager, and Profile 
Selector Config are not displayed. 

The icons for APM Server Start, Audit 
Log File Manager, and Profile 
Selector Config are not displayed. 

Circle one:  PASS / FAIL 

 

 

M.5.14 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

M.5.15 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

M.5.16 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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M.6 Test the Ltest1m Account On the Candidate Platform (kpccp)  

M.6.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

M.6.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

M.6.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

M.6.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

M.6.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

M.6.6 Log in as user Ltest1m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 
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M.6.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

M.6.8 Verify that SSO Test is the only profile listed. Profile SSO Test is the only profile listed. Circle one:  PASS / FAIL 

 

 

M.6.9 Double-click SSO Test. Profile SSO Test moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

M.6.10 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

M.6.11 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

M.6.12 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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M.6.13 Verify the icons for APM Server Start, 
Audit Log File Manager, and Profile 
Selector Config are not displayed. 

The icons for APM Server Start, Audit 
Log File Manager, and Profile 
Selector Config are not displayed. 

Circle one:  PASS / FAIL 

 

 

M.6.14 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

M.6.15 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

M.6.16 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

N 4.15 Verify A User With No Profiles Assigned Has No Profiles Available 

N.1 Deassign Profile SSO Test From User Ltest1m On the Validation Host (kpchost)  

N.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user secman. 

The desktop appears. Setup 

 

 

N.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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N.1.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

N.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

N.1.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

N.1.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 

 

 

N.1.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

N.1.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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N.1.9 Double-click SSO Test. Profile SSO Test moves to the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

N.1.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 

 

 

N.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

N.1.12 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

N.2 Verify No Profiles Are Available On the Validation Host (kpchost)  

N.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

N.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 
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N.2.3 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

N.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

N.2.5 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

N.3 Verify No Profiles Are Available On the Candidate Platform (kpccp)  

N.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest1m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

N.3.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

N.3.3 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 
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N.3.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

N.3.5 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

N.4 Reassign Profile SSO Test To User Ltest1m On the Validation Host (kpchost)  

N.4.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

N.4.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

N.4.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

N.4.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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N.4.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

 

N.4.6 Select user Ltest1m. User Ltest1m entry is highlighted. Circle one:  PASS / FAIL 

 

 

N.4.7 Select Edit > Modify. A Modify Account: Ltest1m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

N.4.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

N.4.9 Double-click SSO Test. Profile SSO Test moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

N.4.10 Click Submit. A Status Summary dialog box appears 
indicating user Ltest1m was modified. 

Circle one:  PASS / FAIL 
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N.4.11 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

O 
4.16 Multiple Add user functions: 

Add Multiple Users, Use Templates To Predefine Account Parameters, and Verify Accounts Created On One Merged Host Are 
Reflected On The Other 

O.1 Add A New User On the Validation Host (kpchost)  

O.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, select File > New Account. 

The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

O.1.2 Click Identification. The Identification tab is displayed. Circle one:  PASS / FAIL 
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O.1.3 Enter the following values: 

Login: Ltest2m 

Password: temp 

Password Confirm: temp 

Template: sysadmin  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

O.1.4 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

O.1.5 Verify only group other appears in the 
Assigned Groups panel. 

Only group other appears in the Assigned 
Groups panel. 

Circle one:  PASS / FAIL 

 

 

O.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

O.1.7 Verify SA Default appears in the Assigned 
Profiles panel. 

Profile SA Default appears in the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 
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O.1.8 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

O.1.9 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

O.1.10 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

O.1.11 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

O.2 Add A New User On the Candidate Platform (kpccp)  

O.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

O.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 
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O.2.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

O.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

O.2.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

O.2.6 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

O.2.7 Enter the following values: 

Login: Ltest3m 

Password: temp 

Password Confirm: temp 

Template: None  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 
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O.2.8 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

O.2.9 Verify no groups are in the Assigned Groups 
panel. 

No groups are in the Assigned Groups panel. Circle one:  PASS / FAIL 

 

 

O.2.10 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

O.2.11 Double-click SA Test. Profile SA Test moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

O.2.12 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

O.2.13 Double-click kpchost and kpccp. kpchost and kpccp move to the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 
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O.2.14 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

 

O.2.15 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

O.3 Verify the Two New Users On the Validation Host (kpchost)  

O.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

O.3.2 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 
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O.3.3 Verify the entries for Ltest2m and Ltest3m. The parameters listed for user Ltest2m match 
those below:  

 Login:   Ltest2m 

 Default Group: other 

 Home Server:  each host 

 Profiles:  SA Default 

 Assigned Groups: other 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

The parameters listed for user Ltest3m match 
those below.  

 Login:   Ltest3m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SA Test 

 Assigned Groups: admin 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

Circle one:  PASS / FAIL 
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O.3.4 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

 

 

O.3.5 At the command prompt type 
cd /h/USERS  

The command prompt returns. Setup 

 

 

O.3.6 At the command prompt type 
ls -la global 

Directories Ltest2m and Ltest3m are not listed. Circle one:  PASS / FAIL 

 

 

O.3.7 At the command prompt type 
ls -la local 

Directories Ltest2m and Ltest3m are listed. Circle one:  PASS / FAIL 
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P 4.17  Test Users With Multiple Derivative Profiles, Use Templates To Predefine Profiles 

P.1 Create A New Profile SA Multiple Incorporating Segment Security Administration and 
Assign Several (Or All Available) Features To the Profile On the Validation Host (kpchost) 

 

P.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, click Profiles. 

The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

P.1.2 Select File > New Profile The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

P.1.3 Enter the following values: 

Profile Name: SA Multiple 

Profile Template: SA Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

P.1.4 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

P.1.5 Select SOL System Administration in the 
Segments panel. 

SOL System Administration is 
highlighted. The SOL System 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 
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P.1.6 Deselect Disk Manager, Reboot System, 
and Set System Time in the Features 
panel. 

There are no check marks next to Disk 
Manager, Reboot System, and Set 
System Time. 

Circle one:  PASS / FAIL 

 

 

P.1.7 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

P.1.8 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

P.1.9 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

 

P.1.10 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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Q 4.18 Test Interactions Of Segments. Test Account Modification On A Master System 

Q.1 Assign New Groups To Ltest2m and Ltest3m On the Candidate Platform (kpccp)  

Q.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All.  

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

Q.1.2 Select user Ltest2m. User Ltest2m entry is highlighted. Circle one:  PASS / FAIL 

 

 

Q.1.3 Select Edit > Modify. A Modify Account: Ltest2m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

Q.1.4 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.5 Double-click admin. admin moves to the Assigned Groups panel. Circle one:  PASS / FAIL 
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Q.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.7 Double-click SA Multiple. Profile SA Multiple moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.1.8 Click Submit. A Status Summary dialog box appears 
indicating user Ltest2m was modified. 

Circle one:  PASS / FAIL 

 

 

Q.1.9 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 

 

 

Q.1.10 Select user Ltest3m. User Ltest3m entry is highlighted. Circle one:  PASS / FAIL 

 

 

Q.1.11 Select Edit > Modify. A Modify Account: Ltest3m dialog box 
appears. 

Circle one:  PASS / FAIL 
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Q.1.12 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.13 Double-click other. other moves to the Assigned Groups panel. Circle one:  PASS / FAIL 

 

 

Q.1.14 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

Q.1.15 Double-click SA Multiple. Profile SA Multiple moves to the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.1.16 Click Submit. A Status Summary dialog box appears 
indicating user Ltest3m was modified. 

Circle one:  PASS / FAIL 

 

 

Q.1.17 Click OK. Control returns to the Account and Profile 
Manager dialog box.  

Circle one:  PASS / FAIL 
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Q.2 Verify Modifications On the Validation Host (kpchost)  

Q.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All. 

The Account and Profile Manager dialog 
box is refreshed. 

Circle one:  PASS / FAIL 

 

 

Q.2.2 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 
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Q.2.3 Verify the entries for Ltest2m and Ltest3m. The parameters listed for user Ltest2m match 
those below:  

 Login:   Ltest2m 

 Default Group: other 

 Home Server:  each host 

 Profiles:  SA Default, 
    SA Multiple 

 Assigned Groups: admin, other 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

The parameters listed for user Ltest3m match 
those below.  

 Login:   Ltest3m 

 Default Group: admin 

 Home Server:  each host 

 Profiles:  SA Test, 
    SA Multiple 

 Assigned Groups: admin, other 

 Shell:   /bin/csh 

 Hosts:   kpchost, kpccp 

Circle one:  PASS / FAIL 
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Q.2.4 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

Q.3 Verify Ltest1m User�s Access To Its Assigned Icon On the Validation Host (kpchost)  

Q.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

Log in as user Ltest1m.  

The desktop appears.  Circle one:  PASS / FAIL 

 

 

Q.3.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

Q.3.3 Double-click SSO Test. Profile SSO Test moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.3.4 Click OK. A Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

Q.3.5 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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Q.3.6 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

Q.3.7 Verify the icons for APM Server Start, 
Audit Log File Manager, and Profile 
Selector Config are not displayed. 

The icons for APM Server Start, Audit 
Log File Manager, and Profile 
Selector Config are not displayed. 

Circle one:  PASS / FAIL 

 

 

Q.3.8 Double-click Assign Passwords. The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

 

Q.3.9 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

Q.3.10 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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Q.4 Verify Ltest2m User�s Access To Its Assigned Icon On the Validation Host (kpchost)  

Q.4.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest2m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

Q.4.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

Q.4.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

Q.4.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

Q.4.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

Q.4.6 Log in as user Ltest2m with the new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 96 

 
 

 

 

 Operator Action Expected Result Observed Result 

Q.4.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

Q.4.8 Double-click Profiles SA Default and SA 
Multiple in the Available Profiles 
panel. 

Profiles SA Default and SA Multiple move 
to the Selected Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.4.9 Click OK. A Profile Selector Results window 
appears stating that the profiles were successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

Q.4.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 

 

 

Q.4.11 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 
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Q.4.12 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

Q.5 Verify Ltest3m User�s Access To Its Assigned Icon On the Validation Host (kpchost)  

Q.5.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest3m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

Q.5.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

Q.5.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

Q.5.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

Q.5.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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Q.5.6 Log in as user Ltest3m with the new password. The desktop appears.  

 

Circle one:  PASS / FAIL 

 

 

Q.5.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

Q.5.8 Double-click Profiles SA Test and SA 
Multiple in the Available Profiles 
panel. 

Profiles SA Test and SA Multiple move to 
the Selected Profiles panel. 

Circle one:  PASS / FAIL 

 

 

Q.5.9 Click OK. A Profile Selector Results window 
appears stating that the profiles were successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

Q.5.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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Q.5.11 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Edit Local 
Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, XTerm. 

NOTE: This is the complete list of SysAdm 
features except Disk Manager. 

Circle one:  PASS / FAIL 

 

 

Q.5.12 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

R 4.19 Test Session Manager's Ability To Resume the Previously Active Set Of Profiles 

R.1 Verify Available Profiles and Icons For Ltest2m On the Validation Host (kpchost)  

R.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest2m. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

R.1.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 100 

 
 

 

 

 Operator Action Expected Result Observed Result 

R.1.3 Verify that no profiles are listed in the 
Available Profiles panel and SA 
Default and SA Multiple are listed in the 
Selected Profiles panel. 

No profiles are listed in the Available 
Profiles panel and SA Default and SA 
Multiple are listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

R.1.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

R.1.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

R.1.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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R.2 Verify Available Profiles and Icons For Ltest3m On the Validation Host (kpchost)  

R.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Log in as user Ltest3m.  

The desktop appears. Circle one:  PASS / FAIL 

 

 

R.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

R.2.3 Verify that no profiles are listed in the 
Available Profiles panel and SA Test 
and SA Multiple are listed in the Selected 
Profiles panel. 

No profiles are listed in the Available 
Profiles panel and SA Test and SA 
Multiple are listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

R.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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R.2.5 Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Edit Local 
Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, XTerm. 

NOTE: This is the complete list of SysAdm 
features except Disk Manager. 

Circle one:  PASS / FAIL 

 

 

R.2.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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S 4.20 Login With No Available Profile and Test Account Modification On A Master System 

S.1 Deassign Profiles SA Test and SA Multiple From User Ltest3m on the Candidate Platform 
(kpccp) 

 

S.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Account and Profile Manager 
dialog box, select user Ltest3m. 

User Ltest3m is highlighted. Circle one:  PASS / FAIL 

 

 

S.1.2 Select Edit > Modify. A Modify Account: Ltest3m dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

S.1.3 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

S.1.4 Double-click SA Test and SA Multiple. Profiles SA Test and SA Multiple move to 
the Available Profiles panel. 

Circle one:  PASS / FAIL 

 

 

S.1.5 Click Submit. A Status Summary dialog box appears 
indicating user Ltest3m was modified. 

Circle one:  PASS / FAIL 
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S.1.6 Click OK. Control returns to the Account and Profile 
Manager dialog box. 

Circle one:  PASS / FAIL 

 

 

S.1.7 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

S.2 Verify Ltest3m User No Longer Has Access To Its Previously Assigned Icon On the Validation 
Host (kpchost) 

 

S.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

Log in as user Ltest3m.  

The desktop appears. Circle one:  PASS / FAIL 

 

 

S.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

S.2.3 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

S.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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S.2.5 Select Applications > Application 
Manager > DII_APPS. 

..(go up) is the only icon displayed. Circle one:  PASS / FAIL 

 

 

S.2.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

S.3 Verify Ltest3m User No Longer Has Access To Its Previously Assigned Icon On the Candidate 
Platform (kpccp) 

 

S.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest3m. Use the initial password, 
temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

S.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

S.3.3 Enter the initial password, temp. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 
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S.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

S.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

S.3.6 Log in as user Ltest3m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

S.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

S.3.8 Verify that no profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

No profiles are listed in the Selected 
Profiles panel or the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

S.3.9 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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S.3.10 Select Applications > Application 
Manager > DII_APPS. 

..(go up) is the only icon displayed. Circle one:  PASS / FAIL 

 

 

S.3.11 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

T 4.21 Test Ability To Detect Duplicate Local User Names 

T.1 Attempt To Add A User Account That Already Exists On the Validation Host (kpchost)  

T.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

T.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

T.1.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

T.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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T.1.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

T.1.6 Select File > New Account. The Create Account dialog box appears. Circle one:  PASS / FAIL 

 

 

T.1.7 Click Identification. The Identification tab is displayed.  

 

T.1.8 Enter the following values: 

Login: Ltest2m 

Password: temp 

Password Confirm: temp 

Template: sysadmin  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

 

T.1.9 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 
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T.1.10 Verify only group other appears in the 
Assigned Groups panel. 

Only group other appears in the Assigned 
Groups panel. 

Circle one:  PASS / FAIL 

 

 

T.1.11 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

T.1.12 Verify SA Default appears in the Assigned 
Profiles panel. 

SA Default appears in the Assigned 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

T.1.13 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

T.1.14 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

T.1.15 Click Submit. An Error dialog box appears with the message: 
Login name already exists. 

Circle one:  PASS / FAIL 
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T.1.16 Click OK. The Error dialog box disappears. Circle one:  PASS / FAIL 

 

 

T.1.17 Click Cancel. Control returns to the Account and Profile 
Manager dialog box. Only the original user 
Ltest2m is listed under the Accounts tab. No 
parameters of that or any other account have 
changed. 

Circle one:  PASS / FAIL 

 

 

U 4.22 Test Ability To Detect Duplicate Profiles 

U.1 Attempt To Create A Duplicate Profile SSO Test On the Validation Host (kpchost)  

U.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, click Profiles. 

The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

U.1.2 Select File > New Profile. The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

U.1.3 Enter the following values: 

Profile Name: SSO Test 

Profile Template: SSO Default  

Each item is filled in. Circle one:  PASS / FAIL 
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U.1.4 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

 

U.1.5 Select SOL Security Administration in 
the Segments panel. 

SOL Security Administration is 
highlighted. The SOL Security 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 

 

 

U.1.6 Click Select All. All Features are selected. Circle one:  PASS / FAIL 

 

 

U.1.7 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

U.1.8 Verify kpchost and kpccp appear in the 
Assigned Hosts panel. 

kpchost and kpccp appear in the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

U.1.9 Click Submit. An Error dialog box appears with the message: 
Profile name already exists. 

Circle one:  PASS / FAIL 
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U.1.10 Click OK. The Error dialog box disappears. Circle one:  PASS / FAIL 

 

 

U.1.11 Click Cancel. Control returns to the Profiles tab of the 
Account and Profile Manager dialog box. Only the 
original Profile SSO Test is listed under the 
Profiles tab. No parameters of that or any other 
Profile have changed. 

Circle one:  PASS / FAIL 

 

 

U.2 Attempt To Create A Duplicate Profile SSO Test But With No Hosts Selected On the Validation 
Host (kpchost) 

 

U.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, select File > New Profile. 

The Create Profile dialog box appears. Circle one:  PASS / FAIL 

 

 

U.2.2 Enter the following values: 

Profile Name: SSO Test 

Profile Template: SSO Default  

Each item is filled in. Circle one:  PASS / FAIL 

 

 

U.2.3 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 
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U.2.4 Select SOL Security Administration in 
the Segments panel. 

SOL Security Administration is 
highlighted. The SOL Security 
Administration features appear in the 
Features panel. 

Circle one:  PASS / FAIL 

 

 

U.2.5 Click Select All. All Features are selected. Circle one:  PASS / FAIL 

 

 

U.2.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

U.2.7 Double-click kpchost and kpccp. kpchost and kpccp move to the Available 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

U.2.8 Click Submit. A dialog box appears with the following message: 
You have not selected any hosts 
for this profile! Continue? 

Circle one:  PASS / FAIL 

 

 

U.2.9 Click Yes. An Error dialog box appears with the message: 
Profile name already exists. 

Circle one:  PASS / FAIL 
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U.2.10 Click OK. Control returns to the Create Profile 
window. 

Circle one:  PASS / FAIL 

 

 

U.2.11 Click Cancel. Control returns to the Profiles tab of the 
Account and Profile Manager dialog 
box. Only the original Profile SSO Test is listed 
under the Profiles tab. No parameters of that or 
any other Profile have changed. 

Circle one:  PASS / FAIL 

 

 

V 4.23 Test Ability To Detect Duplicate UNIX Groups 

V.1 Attempt To Create A Duplicate Unix Group admin On the Validation Host (kpchost)  

V.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, click Groups.  

The Groups tab is displayed. Circle one:  PASS / FAIL 

 

 

V.1.2 Select File > New Group. The Create Group dialog box appears. Circle one:  PASS / FAIL 

 

 

V.1.3 Enter the following values: 

Group name: admin 

Template: admin  

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 
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V.1.4 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

 

V.1.5 Double-click kpchost and kpccp. kpchost and kpccp move to the Available 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

V.1.6 Click Submit. A dialog box appears with the following message: 
You have not selected any hosts 
for this group! Continue? 

Circle one:  PASS / FAIL 

 

 

V.1.7 Click Yes. An Error window appears with the message:  

Group name in use. 

Circle one:  PASS / FAIL 

 

 

V.1.8 Click OK. Control returns to the Create Group dialog box. Circle one:  PASS / FAIL 

 

 

V.1.9 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 
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V.1.10 Double-click kpchost and kpccp. kpchost and kpccp move to the Assigned 
Hosts panel. 

Circle one:  PASS / FAIL 

 

 

V.1.11 Click Identification. The Identification tab is displayed. Circle one:  PASS / FAIL 

 

 

V.1.12 Select Domain from the Manage As drop-down 
list. 

Domain is selected. Circle one:  PASS / FAIL 

 

 

V.1.13 Click Submit. An Error window appears with the message:  

Group name in use. 

Circle one:  PASS / FAIL 

 

 

V.1.14 Click OK. Control returns to the Create Group dialog box. Circle one:  PASS / FAIL 

 

 

V.1.15 Click Cancel. Control returns to the Groups tab of the 
Account and Profile Manager dialog 
box. Only the original Group admin is listed under 
the Groups tab. No parameters of that or any other 
Group have changed. 

Circle one:  PASS / FAIL 
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V.2 Verify No Duplicate Accounts, Groups Or Profiles Have Been Created On the Candidate Platform 
(kpccp) 

 

V.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Setup 

 

 

V.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

V.2.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

V.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

V.2.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

V.2.6 Click Accounts. The Accounts tab is displayed. No two user 
Accounts have the same name. 

Circle one:  PASS / FAIL 
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V.2.7 Click Profiles. The Profiles tab is displayed. No two Profiles 
have the same name. 

Circle one:  PASS / FAIL 

 

 

V.2.8 Click Groups. The Groups tab is displayed. No two Groups 
have the same name. 

Circle one:  PASS / FAIL 

 

 

V.2.9 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Setup 

 

 

W 4.24 Delete A Profile and Verify Local Users Cannot Assume A Profile Already Assigned To Them After the Profile Has Been Deleted 

W.1 Delete the Profile SA Multiple On the Validation Host (kpchost)  

W.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

In the Account and Profile Manager 
dialog box, click Profiles. 

The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

 

W.1.2 Select SA Multiple. SA Multiple is highlighted. Circle one:  PASS / FAIL 
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W.1.3 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

W.1.4 Click Yes to confirm deletion. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

W.1.5 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for SA 
Multiple has been removed from the 
Profiles tab. 

Circle one:  PASS / FAIL 

 

 

W.1.6 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Setup 

 

 

W.2 Verify Available Profiles and Icons For User Ltest2m On the Validation Host (kpchost)  

W.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user Ltest2m.  

The desktop appears. Circle one:  PASS / FAIL 

 

 

W.2.2 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 
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W.2.3 Verify SA Default is listed in the Selected 
Profiles panel. 

SA Default is listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

W.2.4 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

 

W.2.5 Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

W.2.6 Double-click Edit Local Hosts. The Edit Hosts dialog box appears. Circle one:  PASS / FAIL 

 

 

W.2.7 Click Close. The Edit Hosts dialog box disappears. Circle one:  PASS / FAIL 
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W.2.8 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

W.3 Verify Available Profiles and Icons For User Ltest2m On the Candidate Platform (kpccp)  

W.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Log in as user Ltest2m with password temp. 

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

 

W.3.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

W.3.3 Enter the current password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

W.3.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

W.3.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 122 

 
 

 

 

 Operator Action Expected Result Observed Result 

W.3.6 Log in as user Ltest2m with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

 

W.3.7 On the CDE, click Profile Selector. The Profile Selector window appears. Circle one:  PASS / FAIL 

 

 

W.3.8 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

W.3.9 Click OK. The Profile Selector Results window 
appears stating that the profile was successfully 
assumed. 

Circle one:  PASS / FAIL 

 

 

W.3.10 Click Done. The Profile Selector window and the 
Profile Selector Results window 
disappear. 

Circle one:  PASS / FAIL 
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W.3.11 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

W.3.12 Double-click Set Routes. The Default Router Setup dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

W.3.13 Click Cancel. The Default Router Setup dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

 

W.3.14 Log out of the Candidate Platform (kpccp). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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X 4.25 Reset Test Cell for Additional Testing 

X.1 Clean Up Files Generated During Test Execution On the Validation Host (kpchost)  

X.1.1 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as secman. 

The desktop appears. Setup 

 

 

X.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

 

X.1.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

X.1.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

X.1.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

 

X.1.6 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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X.1.7 Select SA Test. SA Test is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.8 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.9 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.10 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for SA Test has 
been removed from the Profiles tab. 

Circle one:  PASS / FAIL 

 

 

X.1.11 Select SSO Test. SSO Test is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.12 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 
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X.1.13 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.14 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for SSO Test 
has been removed from the Profiles tab. 

Circle one:  PASS / FAIL 

 

 

X.1.15 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

 

X.1.16 Select user Ltest1m. User Ltest1m is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.17 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.18 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 
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X.1.19 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for Ltest1m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.20 Select user Ltest2m. User Ltest2m is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.21 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.22 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.23 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for Ltest2m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.24 Select user Ltest3m. User Ltest3m is highlighted. Circle one:  PASS / FAIL 
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X.1.25 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.26 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 

 

 

X.1.27 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for Ltest3m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.28 Select user nopro1m. User nopro1m is highlighted. Circle one:  PASS / FAIL 

 

 

X.1.29 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

 

X.1.30 Click Yes. A Status Summary window appears indicating 
the account was successfully deleted. 

Circle one:  PASS / FAIL 
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X.1.31 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for nopro1m has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

 

X.1.32 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Cleanup 

 

 

X.1.33 At the command prompt type 
cd /h/USERS  

The command prompt returns. Cleanup 

 

 

X.1.34 At the command prompt type 
ls -la global 

Directories Ltest1m, Ltest2m, Ltest3m 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.1.35 At the command prompt type 
ls -la local 

Directories Ltest1m, Ltest2m, Ltest3m 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.1.36 At the command prompt type 
su - 

The Password prompt appears. Cleanup 
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X.1.37 At the command prompt type the root password. The command prompt returns. Cleanup 

 

 

X.1.38 At the command prompt type 
csh 

The command prompt returns. Cleanup 

 

 

X.1.39 At the command prompt type 
cd /var/dt/appconfig/appmanager 

The command prompt returns. Cleanup 

 

 

X.1.40 At the command prompt type 
ls -l 

Ltest1m, Ltest2m, Ltest3m, nopro1m 
are not listed. 

Circle one:  PASS / FAIL 

 

 

X.1.41 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

X.1.42 Set Profile Selection Criteria to 
Single. 

Profile Selection Criteria is set to 
Single. 

Circle one:  PASS / FAIL 
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X.1.43 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 

 

 

X.2 Verify Accounts and Profiles Have Been Removed From the Candidate Platform (kpccp)  

X.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Login as secman. 

The desktop appears. Cleanup 

 

 

X.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Cleanup 

 

 

X.2.3 Double-click APM Client. An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

 

X.2.4 Enter the APM master authentication Key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

X.2.5 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 
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X.2.6 Click Accounts. The Accounts tab is displayed. Accounts 
Ltest1m, Ltest2m, Ltest3m and nopro1m 
are not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.7 Click Profiles. The Profiles tab is displayed. Profiles SA 
Test, SSO Test and SA Multiple are not 
listed. 

Circle one:  PASS / FAIL 

 

 

X.2.8 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Cleanup 

 

 

X.2.9 At the command prompt type 
cd /h/USERS  

The command prompt returns. Cleanup 

 

 

X.2.10 At the command prompt type 
ls -la global 

Directories Ltest1m, Ltest2m, Ltest3m 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.11 At the command prompt type 
ls -la local 

Directories Ltest1m, Ltest2m, Ltest3m 
and nopro1m are not listed. 

Circle one:  PASS / FAIL 
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X.2.12 At the command prompt type 
cd /var/dt/appconfig/appmanager 

The command prompt returns. Cleanup 

 

 

X.2.13 At the command prompt type 
ls -l 

Ltest1m, Ltest2m, Ltest3m, nopro1m 
are not listed. 

Circle one:  PASS / FAIL 

 

 

X.2.14 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

X.2.15 Under Local Options, set Log Level to 
Information. 

Information is selected. Circle one:  PASS / FAIL 

 

 

X.2.16 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

X.2.17 Deselect Manage Hosts. Manage Hosts is deselected. Circle one:  PASS / FAIL 
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X.2.18 Click Submit. A Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

X.2.19 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

X.2.20 Double-click Profile Selector Config. The Profile Selector Configuration 
window appears. 

Circle one:  PASS / FAIL 

 

 

X.2.21 Set Profile Selection Criteria to 
Single. 

Profile Selection Criteria is set to 
Single. 

Circle one:  PASS / FAIL 

 

 

X.2.22 Click OK. The Profile Selector Configuration 
window disappears. 

Circle one:  PASS / FAIL 
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Y 4.26 Remove Hosts 

Y.1 Remove Merged Hosts From the APM Master (kpccp)  

Y.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Application Manager – SecAdm 
dialog box, double-click Remove Host. 

The Remove Hosts dialog box appears. Circle one:  PASS / FAIL 

 

 

Y.1.2 In the Keep panel, double-click kpchost. kpchost moves to the Remove panel. Circle one:  PASS / FAIL 

 

 

Y.1.3 Click Submit. An INFORMATIONAL MESSAGE window states: 
APM Server reloaded successfully. 

Circle one:  PASS / FAIL 

 

 

Y.1.4 Click OK. A Completed window states:  
Removed: kpchost 

Circle one:  PASS / FAIL 

 

 

Y.1.5 Click OK. The Remove Host dialog box disappears. Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 4, Page 136 

 
 

 

 

 Operator Action Expected Result Observed Result 

Y.1.6 In the Application Manager – SecAdm 
dialog box, double-click APM Server Stop. 

An INFORMATIONAL MESSAGE box states: 
APM Server successfully stopped. 

Circle one:  PASS / FAIL 

 

 

Y.1.7 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.1.8 In the Application Manager – SecAdm 
dialog box, double-click APM Server Start. 

An INFORMATIONAL MESSAGE box states:  

APM Server started successfully. 

Circle one:  PASS / FAIL 

 

 

Y.1.9 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.1.10 Log out. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

Y.1.11 Log in as keyman. The desktop appears. Cleanup  

 

Y.1.12 Select Applications > Application 
Manager > DII_APPS > APM. 

  The Application Manager – APM window 
  appears. 

Cleanup 

 

Y.1.13 Double-click Authentication Manager. The Authentication Manager window 
appears. 

Cleanup 
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Y.1.14 Enter the master authentication key in the Key text 
box. 

Asterisks appear in the text box. Cleanup 

 

Y.1.15 Click Set Client’s Local Key. The Hosts List window appears. Cleanup 

 

Y.1.16 Select kpchost. kpchost is highlighted. Cleanup 

 

Y.1.17 Select Delete Host. A Confirm dialog box appears with the 
following message: 
Delete the local authentication 
keys of these hosts? 

kpchost 

Cleanup 

Y.1.18 Click Yes. The dialog box disappears. Cleanup 

 

Y.1.19 Click Close in the Hosts List window. The Hosts List window disappears. Cleanup 

 

Y.1.20 Click Close in the Authentication 
Manager window. 

The Authentication Manager window 
disappears. 

Cleanup 
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Y.2 Configure the Local Host As the APM Master On the Validation Host (kpchost)  

Y.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Application Manager – SecAdm 
window, double-click Edit APM 
Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

Y.2.2 In the Master Host text box, enter kpchost. kpchost appears in the text box. Circle one:  PASS / FAIL 

 

 

Y.2.3 Click Submit. The Done window states: Operation 
completed successfully. 

Circle one:  PASS / FAIL 

 

 

Y.2.4 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.2.5 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

 

Y.2.6 Under Local Options, set Log Level to 
Information. 

Information is selected. Circle one:  PASS / FAIL 
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Y.2.7 Click Domain Options.  The Domain tab is selected. Circle one:  PASS / FAIL 

 

 

Y.2.8 Deselect Manage Hosts. Manage Hosts is deselected. Circle one:  PASS / FAIL 

 

 

Y.2.9 Click Submit. The Done dialog box appears with the message: 

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

 

Y.2.10 Click OK. The Edit APM Configuration window 
disappears. 

Circle one:  PASS / FAIL 

 

 

Y.2.11 In the Terminal window, type  
cd /h/COE/Comp/APM/bin 

The command prompt returns.  

Y.2.12 In the Terminal window, type  
./APM_BecomeOwnMaster 

The command prompt returns.  

Y.2.13 In the Terminal window type on a single line 
ps -eaf | grep `cat [s] 
/h/COE/Comp/APM/data/APMServer.pid` 

The APM Server process is listed. Circle one:  PASS / FAIL 
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Y.3 Verify Candidate Platform (kpccp) Removed From the Validation Host (kpchost)  

Y.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Account and Profile Manager 
dialog box, select View > Refresh Catalog 
> All. 

The Account and Profile Manager 
dialog box is refreshed. 

Circle one:  PASS / FAIL 

 

 

Y.3.2 Select Accounts. The Accounts tab is displayed. In the Hosts 
column, only kpchost appears. 

Circle one:  PASS / FAIL 

 

 

Z 4.27 Log Out Of the Validation Host (kpchost) And the Candidate Platform (kpccp) 

 

End of Test Validation Procedure  
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1. Overview 

1.1 Introduction 

This chapter defines the Segment Installation Manual Validation Procedure and is 
part of the required set of test procedures to be used in the certification of products 
to The Open Brand COE Platform Product Standard1.  

 

2. Test Propose 

2.1 Scope  

This test procedure has been structured to cover the verification of proper segment 
installation by testing the features and functions of the Segment Installer and the 
Segment Installation Server.  In addition the test segments suite supplied will 
validate that the Segment Installer will install segment types and segment 
descriptors correctly and consistent with the COE I&RTS Sections 4.3,4.4 & 6. 

This test also assures that the Graphical User Interface (GUI) presented to the user 
for basic system operation is consistent across all compliant systems certified to the 
COE Platform Product Standard.  This test assures that the operations invoked and 
exercised have identical results that are consistent across all compliant systems.   
The demonstration suite for the Segment Installer and Segment Installation Server 
uses segments that are supplied to the tester in Configuration Management (CM) 
MakeInstall format on both 8mm tape and CD.  Tests listed below are designed to 
check the interoperability and integrity of the Segment Installer and Segment 
Installation Server with respect to both the commercial operating system and the 
COE environment. 

2.2 Description of test items  

Functionality that will be tested using the Segment Installation Validation Procedure 
is as follows: 

A. Pretest Setup 

B. Verify Segment Installer Feature Availability 

C. Local Devices Testing 

D. Remote Device Testing 

E. Test the Runtime Tools 

F. Segment Type Tests 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 G. Test the Process descriptor 

H. Verify Segment Installer Will Process Conflicts descriptor 

I. Verify Segment Installer Will Process Requires descriptor 

J. Network Installation Server / Network Installation Server Testing - Verify Feature Availability 

K. Local Devices Testing 

L. Remote Device Testing 

M. Network Installation Server / Network Installation Server Testing � Load Many Segments 

N. Verify  Segment Installer On the Candidate Platform (kpccp) Can Read Table Of Contents and 
Install Segments From the Network Installation Server / Network Installation Server 

O. Verify Segment Installer On the Validation Host (kpchost) Can Read Table of Contents and 
Install Segments From the Network Installation Server / Network Installation Server 

P. Network Installation Server / Network Installation Server Testing � Verify Segments Deinstall 
Correctly 

Q. Network Installation Server / Network Installation Server Testing � Load Segment 

R. Verify Segment Installer On The Candidate Platform (kpccp) Can Read Table of Contents and 
Install Segments From the Network Installation Server / Network Installation Server 

S. Segment Installation Server / Network Installation Server Testing � Verify Segments De-install 
Correctly 

T. Launch Segment Installer From the Command Line 

U. Segment Installation Post Test Cleanup.  Candidate Platform Cleanup 

V. Segment Installation Post Test Cleanup.  Validation Host Cleanup 

Z. Log Out On the Candidate Platform (kpccp) and Validation Host (kpchost) 

Appendix A 

ZZ.   Setup � Create Test Data Tape that includes segx 
 

 

2.3 Setup/Equipment Required 

 (1) Candidate Platform (kpccp) with internal hard drive, CD drive, tape drive and 
network interface. 

(2) Validation Host   (kpchost) with internal hard drive, CD drive, tape drive and 
network interface. 

(3) The Validation Host (kpchost) is configured as the DNS name server for both the 
Candidate Platform (kpccp) and the Validation Host (kpchost). 
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 2.4 Known Problems 

There is a known problem with the way the Installer and Network Installation 
Server recalculate disk usage after certain installer functions. If the displayed 
values are wrong, they may be correctly recalculated by selecting and closing 
Reserved Space. The correct Available Disks and/or Reserved Space setting may 
need to be reselected. 

2.5 Required Personnel 

One (1) tester.  The tester must be familiar with POSIX/UNIX application platforms, but 
need not be familiar with the Common Operating Environment (COE). 

2.6 Change History 

June 02, 2003  

 

 



 

 

3. Test Procedure Submission Form 

 

Test Title: Segment Installer Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 8 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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 4. Test Procedure 

Start of Validation Procedure 

 

 Operator Action Expected Result Observed Result 

A 4.1 Pretest Setup 

A.1 Test Data Installation  

A.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Login as sysadmin. 

The desktop appears. Startup 

A.1.2 Insert the COE Kernel and Toolkit Source Code, Test 
Data, and Documentation for Version 4200P6 Version 
1.0.0.0 CD-ROM into the CD-ROM drive. 

The CD-ROM is inserted. Startup 

A.1.3 Select Applications > Application Manager 
> DII_APPS. 

The Application Manager window 
appears. 

Startup  

 

A.1.4 Double-click Segment Installer in the 
Application Manager – SysAdm window. 

The Installer window appears. Setup  

 

A.1.5 Click Select Source. Select Source is selected. Setup  

 

A.1.6 Click CD-ROM. CD-ROM is selected. Setup  

 

A.1.7 Click TD42P6.tar. TD42P6.tar is selected. Setup  
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A.1.8 Click OK. The Installer window reappears. Setup  

 

A.1.9 Click Read Contents. The Installer window disappears while 
message boxes appear informing that the 
system is Checking media and then 
Read Contents in progress. 

The Installer window reappears with 
KPC Test Data for 4200P6 
Version 1.0.0.0 listed under 
Select Software To Install. 

Setup  

 

A.1.10 Select the KPC Test Data for 4200P6 Version 
1.0.0.0.  

KPC Test Data for 4200P6 
Version 1.0.0.0 is highlighted. 

Setup  

 

A.1.11 Click Install. AN ENTER A PASSWORD dialog box 
appears. 

Setup  

 

A.1.12 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Setup  

 

A.1.13 Click OK. The dialog box disappears.  

A RESPOND TO THE MESSAGE dialog 
box appears with the message  
Please insert CD Volume #1 
for the segment ‘KPC TEst 
Data for 4200P6! When you are 
ready press the OK button. 

Setup  
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A.1.14 Click OK. The Installer window reappears. Setup  

 

A.1.15 Verify that KPC Test Data for 4200P6 appears 
in the list under Currently Installed 
Segments. 

KPC Test Data for 4200P6 appears 
in the list under Currently 
Installed Segments. 

Setup  

 

A.1.16 Eject the CD-ROM. The CD-ROM ejects. Setup  

 

A.1.17 Click Exit. The Installer window disappears. Setup  

 

A.2 Setup � Create Directories On the Candidate Platform (kpccp)  

A.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Open a Terminal window. 

A Terminal window appears with a 
command line prompt. 

Startup 

A.2.2 At the command prompt type  
su  

NOTE: Do not use the "-" option. 

The Password prompt returns. Startup 

A.2.3 Enter the root password. The command prompt returns. Startup 

 

A.2.4 At the command prompt type  
csh 

The command prompt returns. Startup 
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A.2.5 At the command prompt type 
cd / 

The command prompt returns. Startup 

A.2.6 At the command prompt type                                  df –k 

NOTE: For The Segment Installation Validation 
Procedures Tests to run correctly, the following partitions 
must be mounted. 

/h, /home1, /home2.  

The following partitions are listed: 

 .  .  .  /h 
 .  .  .  /home1 
 .  .  .  /home2 

 

Setup 

A.2.7 At the command prompt type 
mkdir /kpchostdsk /kpchostcdrom 

The command prompt returns. Setup  

 

A.3 Edit Local Hosts On the Candidate Platform (kpccp)  

A.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Select Applications > Application Manager 
> DII_APPS > SysAdm. 

The Application Manager – 
SysAdm window appears. 

Setup 

A.3.2  Double-click Edit Local Hosts.       The Edit Hosts window appears. Setup 

 

A.3.3  Click Add. The Add Machine window appears. Setup 

 

A.3.4  In the Add Machine window, type: 

 MACHINE NAME:  kpchost 

 MACHINE ADDRESS:  204.34.175.194 

Input is accepted. Setup 
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A.3.5  Click OK. The Add Machine window disappears 
and the new kpchost host entry appears 
in the Edit Hosts window. 

Setup 

A.3.6  Click Close. The Edit Hosts window disappears. Setup 

 

A.4 Setup � Modify /etc/inetd.conf and /.rhosts To Enable rsh (Open Security For Remote 
Shell) On the Candidate Platform (kpccp) 

 

A.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

 

In the Terminal window, at the command prompt type 
vi /etc/inetd.conf 

The file /etc/inetd.conf is opened 
for editing. 

Setup  

 

A.4.2 Type 
/#shell 

The vi editor will place the cursor on the 
line that contains: 
#shell 

Setup  

 

A.4.3 Type 
x 

The vi editor will remove the # symbol. 

Note: There may be more than one line 
beginning with #shell.  Remove the �#� for 
all occurences. 

Setup  

 

A.4.4 Type 
:wq! 

The vi editor will write to and exit the file. 

The command prompt returns. 

Setup  
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A.4.5 At the command prompt type 
ps –eaf | grep inetd 

Process information for inetd appears 
with the process ID in the second column. 

Setup  

 

A.4.6 At the command prompt type 

kill –HUP <pid> 

where <pid> is the process ID found in the previous step. 

The command prompt returns. Setup  

 

A.4.7 In the Terminal window, at the command prompt type 
vi /.rhosts 

The file /.rhosts is opened for editing. Setup  

 

A.4.8 Type 

x 

The vi editor will removes the - symbol. Setup  

 

A.4.9 Type 
i 

The vi editor enters Insert Mode. Setup  

 

A.4.10 Type 
kpchost  

The vi editor inserts kpchost to the file. Setup  

 

A.4.11 Press 
[esc] 

The vi editor exits Insert Mode. Setup  

 

A.4.12 Type 
:wq! 

The vi editor will write to and exit the file.   

The command prompt returns. 

Setup  
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A.5 Setup � Export  /h/data/global and /home2 Directories From the Candidate Platform 
(kpccp) 

 

A.5.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Application Manager – SysAdm 
window, double-click Disk Manager. 

The Disk Manager window appears. Setup 

 

A.5.2 Select the row that contains the / partition in the 
Mounted On column. 

The row is highlighted. Setup 

 

A.5.3 Click Export FS. The Export/Unexport File 
Systems window appears. 

Setup 

A.5.4 In the options text box, type: 
rw,root=kpchost 

rw,root=kpchost appears in the 
options text box. 

Setup 

 

A.5.5 In the pathname text box, type:  
/h/data/global 

/h/data/global appears in the 
pathname text box. 

Setup 

A.5.6 Click Export. A Confirmation window appears 
asking: Export this directory 
permanently? 

Setup 

A.5.7 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Setup 

A.5.8 Select the row that contains the /home2 partition in the 
Mounted On column. 

The row is highlighted. Setup 

 



   

© 2003, The Open Group 
Chapter 5,Page 14 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

A.5.9 Click Export FS. The Export/Unexport File 
Systems window appears. 

Setup 

A.5.10 In the options text box, type: 
ro,root=kpchost 

ro,root=kpchost appears in the 
options text box. 

Setup 

 

A.5.11 In the pathname text box, verify /home2 is present. /home2 appears in the pathname text 
box. 

Setup 

A.5.12 Click Export. A Confirmation window appears 
asking: Export this directory 
permanently? 

Setup 

A.5.13 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Setup 

A.5.14 In the Terminal window, at the command prompt type 
share 

The following text is displayed: 
/h/data/global 
rw,root=kpchost 
/home2 ro,root=kpchost 

Setup 

A.6 Edit Local Hosts On the Validation Host (kpchost)  

A.6.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

Login as sysadmin. 

The desktop appears. Setup 

A.6.2 Select Applications > Application       
Manager > DII_APPS > SysAdm. 

The Application Manager – 
SysAdm window appears. 

Setup 
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A.6.3  Double click Edit Local Hosts. The Edit Hosts window appears. Setup 

 

A.6.4 Click Add. The Add Machine window appears. Setup 

 

A.6.5 In the Add Machine window type: 

MACHINE NAME:  kpccp 

MACHINE ADDRESS:  204.34.175.195 

Input is accepted. Setup 

A.6.6 Click OK. The Add Machine window disappears 
and the new kpccp host entry appears in 
the Edit Hosts window. 

Setup 

A.6.7 Click Close. The Edit Hosts window disappears. Setup 

 

A.7 Setup � Modify /etc/inetd.conf and /.rhosts To Enable rsh (Open Security For Remote 
Shell) On the Validation Host (kpchost) 

 

A.7.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

Open a Terminal window. 

A Terminal window appears with a 
command line prompt. 

Startup 

A.7.2 At the command prompt type  
su 

The Password prompt appears. Startup 

A.7.3 Enter the root password. The command prompt returns. Startup 
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A.7.4 At the command prompt type  
csh 

The command prompt returns. Startup 

A.7.5 At the command prompt type 
vi /etc/inetd.conf 

The file /etc/inetd.conf is opened 
for editing. 

Setup  

 

A.7.6 At the command prompt type 
/#shell 

The vi editor will place the cursor on the 
line that contains: 
#shell 

Setup  

 

A.7.7 At the command prompt type 
x 

The vi editor will remove the # symbol. Setup  

 

A.7.8 At the command prompt type 
:wq! 

The vi editor will write to and exit the file.   

The command prompt returns. 

Setup  

 

A.7.9 At the command prompt type 
ps –eaf | grep inetd 

Process information for inetd appears 
with the process ID in the second column. 

Setup  

 

A.7.10 At the command prompt type 

kill –HUP <pid> 

where <pid> is the process ID found in the previous step. 

The command prompt returns. Setup  

 

A.7.11 At the command prompt type 
vi /.rhosts 

The file /.rhosts is opened for editing. Setup  

 

A.7.12 Type 

x 

The vi editor will removes the � symbol. Setup  
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A.7.13 Type 
i 

The vi editor enters Insert Mode. Setup  

 

A.7.14 Type 
kpccp 

The vi editor inserts kpccp to the file. Setup  

 

A.7.15 Press 
[esc] 

The vi editor exits Insert Mode. Setup  

 

A.7.16 Type 
:wq! 

The vi editor will write to and exit the file.  

 The command prompt returns. 

Setup  

 

A.8 Setup � Export /kpc, /cdrom/kpc_4206, and /home2 On the Validation Host (kpchost)  

A.8.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

Insert the KPC Test Data CD-ROM into the CD-
ROM drive. 

The CD-ROM is inserted. Setup 

A.8.2 In the Application Manager – SysAdm window, 
double-click Disk Manager. 

The Disk Manager window appears. Setup 

A.8.3 Select the row that contains the / partition in the 
Mounted On column. 

The row is highlighted. Setup 

 

A.8.4 Click Export FS. The Export/Unexport File 
Systems window appears. 

Setup 

A.8.5 Type ro=kpccp in the options text box. ro=kpccp appears in the options text 
box. 

Setup 
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A.8.6 In the pathname text box, type:  
/kpc 

/kpc appears in the pathname text box. Setup 

A.8.7 Click Export. A Confirmation window appears 
asking: Export this directory 
permanently? 

Setup 

A.8.8 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Setup 

A.8.9 Click Export FS. The Export/Unexport File 
Systems window appears. 

Setup 

A.8.10 Type ro=kpccp in the options text box. ro=kpccp appears in the options text 
box. 

Setup 

 

A.8.11 In the pathname text box, type:  
/cdrom/kpc_4206 

/cdrom/kpc_4206 appears in the 
pathname text box. 

Setup 

A.8.12 Click Export. A Confirmation window appears 
asking: Export this directory 
permanently? 

Setup 

A.8.13 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Setup 

A.8.14 Select the row that contains the /home2 partition in the 
Mounted On column. 

The row is highlighted. Setup 
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A.8.15 Click Export FS. The Export/Unexport File 
Systems window appears. 

Setup 

A.8.16 In the options text box, type: 
ro,root=kpccp 

ro,root=kpccp appears in the text box. Setup 

 

A.8.17 In the pathname text box, verify /home2 is present. /home2 appears in the pathname text 
box. 

Setup 

A.8.18 Click Export. A Confirmation window appears 
asking: Export this directory 
permanently? 

Setup 

A.8.19 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Setup 

A.8.20 In the Terminal window, at the command prompt type 
share 

The following text is displayed: 
/kpc ro=kpccp 
/cdrom/kpc_4206 ro=kpccp 
/home2 ro,root=kpccp 

Setup 

A.9 Setup � Mount /h/data/global Directory From the Candidate Platform (kpccp) On the 
Validation Host (kpchost) 

 

A.9.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Disk Manager window, click Mount New. 

The Mount File System window 
appears. 

Setup 

 

A.9.2 In the FILE SYSTEM text box, type 
kpccp:/h/data/global 

kpccp:/h/data/global appears in 
the text box. 

Setup 
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A.9.3 In the MOUNT POINT text box, type 
/h/data/global 

/h/data/global appears in the text 
box. 

Setup 

A.9.4 Click MOUNT. A Confirmation window asks:   
Mount the File System 
Permanently? 

Setup 

A.9.5 Click  Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. kpccp:/h/data/global 
appears as a file system. 

Setup 

A.9.6 Click  Exit. The Disk Manager window disappears. Setup 

 

A.10 Setup � Mount /kpc and /cdrom/kpc_4206 Directories From the Validation Host (kpchost) 
On the Candidate Platform (kpccp) 

 

A.10.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Disk Manager window, click Mount New. 

The Mount File System window 
appears. 

Setup 

 

A.10.2 In the FILE SYSTEM text box, type  
kpchost:/kpc 

kpchost:/kpc appears in the text box. Setup 

A.10.3 In the MOUNT POINT text box, type 
/kpchostdsk 

/kpchostdsk appears in the text box. Setup 
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A.10.4 Click MOUNT. A Confirmation window asks:  
 Mount the File System 
Permanently? 

Setup 

A.10.5 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. kpchost:/kpc appears as a 
file system.  

Setup 

A.10.6 Click Mount New. The Mount File System window 
appears. 

Setup 

 

A.10.7 In the FILE SYSTEM text box, type  
kpchost:/cdrom/kpc_4206 

kpchost:/cdrom/kpc_4206 appears 
in the text box. 

Setup 

A.10.8 In the MOUNT POINT text box, type 
/kpchostcdrom 

/kpchostcdrom appears in the text box. Setup 

A.10.9 Click MOUNT . A Confirmation window asks:   
Mount the File System 
Permanently? 

Setup 

A.10.10 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. kpchost:/cdrom/kpc_4206 
appears as a file system. 

Setup 

A.10.11 Click Exit.  The Disk Manager window disappears. Setup 
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A.11 Setup � Eject the CD-ROM On the Validation Host (kpchost)  

A.11.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Terminal window, at the command prompt, type  
unshare /cdrom/kpc_4206 

The command prompt returns. Setup 

 

A.11.2 At the command prompt type 
share  

The following text is displayed: 
/kpc ro=kpccp 

/home2 ro,root=kpccp 

Setup 

 

A.11.3 At the command prompt type  
eject 

The CD-ROM is ejected. Setup 

 

B 
4.2 Verify Segment Installer Feature Availability 

B.1 Segment Installer - Main Window On the Candidate Platform (kpccp) and the Validation Host 
(kpchost) 

 

B.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost) and Candidate Platform (kpccp). 

 

In the Application Manager – SysAdm window, 
double-click Segment Installer. 

The Installer window appears. Circle one:  PASS / FAIL 

 

 

B.1.2 Verify the Installer windows on each platform are 
similar. 

Size, shape, color and textual information 
on the Candidate Platform is similar to the 
Validation Host.   

Circle one:  PASS / FAIL 
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B.1.3 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Verify at the top of the screen, the following pull-down 
menus and their contents: 
File 
Source 
Installed  
Contents  
Help (Grayed Out) 

 

NOTE:  Each of these Menu Items / Functions are 
duplicates of buttons on the main screen and either choice 
produces the same results. 

The menu items are present and contain: 
File –      Install 
            Exit  

Source -    Select Source 
            Read Contents 

Installed – Release Notes 
            Deinstall 
Software 
            View Installation 
Log 

Contents -  Release Notes 
            Required Software 
            Conflicting 
Software 

Help -      (No Action) 

Circle one:  PASS / FAIL 

 

 

B.1.4 Resize the Installer window. The Installer window resizes both 
larger and smaller.  

Circle one:  PASS / FAIL 

 

 

B.1.5 Minimize the Installer window by clicking the dot in 
the right corner of the title bar. 

The Installer window iconifies to the 
top left corner of the screen. 

Circle one:  PASS / FAIL 
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B.1.6 Restore the Installer window by double-clicking on 
the Installer icon. 

The Installer window restores to its 
previous  state. 

Circle one:  PASS / FAIL 

 

 

B.1.7 Relocate the Installer window. The Installer window relocates 
anywhere on the screen. 

Circle one:  PASS / FAIL 

 

 

B.1.8 Double-click the upper left corner of the Installer 
window. 

The Installer window disappears. Circle one:  PASS / FAIL 

 

 

B.1.9 In the Application Manager – SysAdm window, 
double-click Segment Installer.  

The Installer window appears. Circle one:  PASS / FAIL 

 

 

B.2 Source Area - Verify Buttons and Fields Are Present On the Candidate Platform (kpccp)  

B.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Verify the following Source fields are present: 

Host: 
Device: 

All fields are present. Circle one:  PASS / FAIL 

 

 

B.2.2 Verify the following buttons are present: 
Select Source 
Read Contents 

All buttons are present. Circle one:  PASS / FAIL 
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B.2.3 Verify the information displayed in the Source field is 
correct: 

Host:  LOCAL  kpccp 
Device: DAT  

The display reflects the current 
configuration. 

Circle one:  PASS / FAIL 

 

 

B.3 Select Source - Verify the Functionality of the Select Source Window; Select  Each Option 
On the Candidate Platform (kpccp) 

 

B.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Source field, click Select Source. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

B.3.2 Verify the following radio buttons are present: 

Host:                       Device: 
LOCAL         DISK      CD-ROM 
REMOTE        DAT       EXABYTE 
              NETWORK   OTHER 

All radio buttons are present and LOCAL  
and DAT are selected. 

NOTE: Only certain combinations work. 

LOCAL - ALL  (NETWORK doesn�t care) 

REMOTE � DAT, EXABYTE, OTHER  

NOTE:  DISK and CD-ROM are accessible 
from a remote device if shared and 
mounted. 

Circle one:  PASS / FAIL 

 

 

B.3.3 In the Host field, verify LOCAL is selected.  

 

LOCAL is selected. Circle one:  PASS / FAIL 
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B.3.4 In the Device field , select DISK. 
 

 

The Select File window appears. Circle one:  PASS / FAIL 

 

 

B.3.5 Verify the existence of the following four sections: 
Filter 
Directories 
Files 
Selection 

Each of these sections is present.  The 
filtering section at the top can be used to 
find a particular file. 

Circle one:  PASS / FAIL 

 

 

B.3.6 Verify the existence of four buttons at the bottom of the 
Select File window: 

OK, Filter, Cancel, Help 

All buttons are present. Circle one:  PASS / FAIL 

 

 

B.3.7 Click Cancel. The Select File window disappears. Circle one:  PASS / FAIL 

 

 

B.3.8 Click OK. The Select Source window 
disappears and the Installer window 
reappears. 

Circle one:  PASS / FAIL 

 

 

B.3.9 Verify the information presented in the following fields is 
correct: 

Host:  LOCAL  kpccp 
Device: DISK 

The display reflects the tester�s selections. Circle one:  PASS / FAIL 
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B.3.10 In the Source field, click Select Source. The Select Source window appears. Circle one:  PASS / FAIL 

 

 

B.3.11 In the Host field, verify LOCAL is selected. 

 

LOCAL is selected. 

 

Circle one:  PASS / FAIL 

 

 

B.3.12 In the Device field, select CD-ROM. The Select File window appears. Circle one:  PASS / FAIL 

 

 

B.3.13 Verify the existence of the following four sections: 
Filter 
Directories 
Files 
Selection 

Each of these sections is present.  The 
filtering section at the top can be used to 
find a particular file. 

Circle one:  PASS / FAIL 

 

 

B.3.14 Verify the existence of four buttons at the bottom of the 
Select File window: 

OK, Filter, Cancel, Help 

All buttons are present. 
 

Circle one:  PASS / FAIL 

 

 

B.3.15 Click Cancel. The Select File window disappears. Circle one:  PASS / FAIL 
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B.3.16 In the Device field, select EXABYTE. EXABYTE is selected. Circle one:  PASS / FAIL 

 

 

B.3.17 In the Device field, select OTHER. A text box appears for manually entering a 
device. 

Circle one:  PASS / FAIL 

 

 

B.3.18 Enter the device path in the text box, e.g., 
/dev/rmt/0mn. 

The device path appears in the text box. Circle one:  PASS / FAIL 

 

 

B.3.19 Click OK. The Installer window appears and the 
Source field displays:  

Host:  LOCAL kpccp 
Device: <device path> 

where <device path> is the device file 
entered in the previous step, e.g., 
/dev/rmt/0mn 

Circle one:  PASS / FAIL 

 

 

B.3.20 In the Source field, click Select Source. The Select Source window appears. Circle one:  PASS / FAIL 
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B.3.21 In the Device field, click DAT. DAT is selected. Circle one:  PASS / FAIL 

 

 

B.3.22 Click OK. The Installer window appears and the 
Source field displays:  

Host:  LOCAL  kpccp 
Device: DAT 

Circle one:  PASS / FAIL 
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B.4 Available Disks Field Display On the Candidate Platform (kpccp)  

B.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Verify the Available Disks field displays the 
following columns: 
Disk   Actual   Available   Selected   
Reserved 

Verify the button Reserved Space appears (grayed 
out). 

  Disk      Actual    Available    Selected    
Reserved 

  /h 
  /home1   8.56MB    6.85MB     0.0 MB    
1.71MB 
  /home2 

 

                                          [ Reserved 
Space ] 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

Circle one:  PASS / FAIL 

 

 

B.5 Available Disks  - Reserved Space  -  Override Disk Space Allocation Window On the Candidate 
Platform (kpccp) 

 

B.5.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Select partition /home1 from the Available Disks 
field. 

/home1 is highlighted. 

 

Circle one:  PASS / FAIL 

 

 

B.5.2 In the Available Disks field, click Reserved 
Space.  

An Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 
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B.5.3 Verify the default value of Override Disk Space 
Limits. 

 

The default value is set to 80%. 

 

Circle one:  PASS / FAIL 

 

 

B.5.4 Click on the Override Disk Space Limits 
button to show the pull-down menu. 

 

The Override Disk Space Limits 
are: 

80% (selected by default) 
90% 
95% 
99% 

Circle one:  PASS / FAIL 

 

 

B.5.5 Select 90%. The Override Disk Space Limits 
selection changes to 90%.  

 

Circle one:  PASS / FAIL 

 

 

B.5.6 Verify the Clear and Set to Default box is not 
selected. 

 

The Clear and Set to Default 
box is not selected. 

 

Circle one:  PASS / FAIL 

 

 

B.5.7 Select and deselect the Clear and Set to 
Default box. 

 

The box toggles on and off. Circle one:  PASS / FAIL 

 

 

B.5.8 Click Cancel. The Override Disk Space 
Allocation window disappears and the 
Disk values remain unchanged. 

Circle one:  PASS / FAIL 
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B.5.9 In the Available Disks field, click Reserved 
Space.  

The Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 

 

 

B.5.10 Click on the Override Disk Space Limits 
button to show the pull-down menu. 

 

The Override Disk Space Limits 
pull-down menu appears. 

 

Circle one:  PASS / FAIL 

 

 

B.5.11 Select 99%. 

 

The Override Disk Space Limits 
selection changes to 99%.  

 

Circle one:  PASS / FAIL 

 

 

B.5.12 Click OK. The Available Disks field displays 
the following approximate values: 

   Disk      Actual    Available    Selected    
Reserved 

  /home1   8.56MB    8.48MB     0.0 MB    
0.09MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

Circle one:  PASS / FAIL 

 

 

B.5.13 In the Available Disks field, click Reserved 
Space.  

The Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 
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B.5.14 Verify the Override Disk Space Limits 
selection is returned to 80%.   

The Override Disk Space Limits 
selection is returned to 80%. 

Circle one:  PASS / FAIL 

 

 

B.5.15 Click OK. The Available Disks field displays 
the following approximate values: 

  Disk      Actual    Available    Selected    
Reserved 

  /home1   8.56MB    6.80MB     0.0 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

Circle one:  PASS / FAIL 
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B.6 Available Disks  -  Verify the Information Presented for Actual Disk Size Is Correct On the 
Candidate Platform (kpccp) 

 

B.6.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window, at the command prompt type 
df -k 

The /home1 disk space information is 
listed as follows: 

Kbytes   used    available     Mounted on 

 9751        61        8715           /home1 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

Circle one:  PASS / FAIL 

 

 

B.6.2 To verify the disk space values shown in the 
Available Disks field, /home1, perform the 
following calculations: 

Actual = avail(df -k) / 1024 

Reserved = kbytes(df -k) * .9 * .2 / 1024 

Available = Actual - Reserved 

Results are within 10 K of the values listed 
in the Available Disks field.  The 
values listed in the Installer window 
concur. 

Actual     = 8.56MB 

Reserved = 1.71MB 

Available = 8.56 � 1.71 = 6.80MB 

Circle one:  PASS / FAIL 

 

Actual:___________ 

Reserved:_________ 

Available:_________ 

 

B.6.3 In the Installer window, select /home1 in the 
Available Disks field. 

  

/home1 is highlighted. 

 

Circle one:  PASS / FAIL 

 

 

B.6.4 In the Source field, click Select Source. 
  

 

The Select Source window appears. Circle one:  PASS / FAIL 
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B.6.5 In the Device field, select DISK.  The Select File window appears. Circle one:  PASS / FAIL 

 

 

B.6.6 In the Filter text box type  
/kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

B.6.7 In the Files field, double-click bigseg.tar. The Select File window disappears 
and the Installer window reappears. 

Circle one:  PASS / FAIL 

 

 

B.6.8 Click Read Contents. The Installer window returns with Big 
Test Segment appearing in the Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

B.6.9 Select Big Test Segment in the Select 
Software To Install field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. The Selected column in 
the Available Disks field changes 
from 0.00MB to 0.10MB. 

Circle one:  PASS / FAIL 

 

 

B.6.10 At the bottom of the Installer window, click 
Install. 

An ENTER A PASSWORD dialog box 
appears asking for the Master APM 
Authentication key. 

Circle one:  PASS / FAIL 
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B.6.11 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

B.6.12 Click OK. Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Install field. Big 
Test Segment appears in the 
Currently Installed Segments 
field. 

Circle one:  PASS / FAIL 

 

 

B.6.13 In the Available Disks field, verify the /home1 
partition values have changed. 

 The Available Disks field displays 
the following approximate values: 

 Disk      Actual      Available    Selected    
Reserved 

/home1   8.46MB    6.70MB      0.0 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 

 

 

B.6.14 In the Currently Installed Segments field, 
select Big Test Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 
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B.6.15 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment  

Circle one:  PASS / FAIL 

 

 

B.6.16 Click Yes. Big Test Segment deinstalls correctly 
and is no longer preceded by an * in the 
Select Software To Install 
field. Big Test Segment no longer 
appears in the Currently Installed 
Segments field. 

Circle one:  PASS / FAIL 

 

  

 

B.7 Available Disks - Reserve Space 99% � Verify Segment Installation On the Candidate Platform 
(kpccp) 

 

B.7.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp).  

In the  Terminal window, at the command prompt type 
cd /home1 

The command prompt returns. Setup 

 

 

B.7.2 At the command prompt type 
mkfile 4m fillspace 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the Observed 
Result column. 

The command prompt returns. Setup 

 



   

© 2003, The Open Group 
Chapter 5,Page 38 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

B.7.3 In the Available Disks field select /home1. /home1 is highlighted. Circle one:  PASS / FAIL 

 

 

B.7.4 In the Available Disks field, click Reserved 
Space. 

The Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 

 

 

B.7.5 Change the Override Disk Space Limits value 
from 80% to 99%.   

The 99% toggle is selected. Circle one:  PASS / FAIL 

 

 

B.7.6 Click OK. 

 

 The Available Disks field displays 
the following approximate values: 

Disk       Actual    Available    Selected    
Reserved 

 /home1   4.55MB   4.47MB     0.0 MB    
0.09MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 
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B.7.7 In the Select Software To Install field, select 
Big Test Segment. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. The Selected field in the 
Available Disks field changes from 
0.0MB to 0.10MB. 

Circle one:  PASS / FAIL 

 

 

B.7.8 At the bottom of the Installer window, select 
Install. 

 

Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Install field. Big 
Test Segment appears in the 
Currently Installed Segments 
field. 

Circle one:  PASS / FAIL 

 

 

B.7.9 In the Available Disks field verify the  /home1 
partition values have changed. 

 The Available Disks field displays 
the following approximate values: 

 Disk       Actual      Available    Selected   
Reserved 

 /home1   4.45MB     4.37MB      0.0 MB    
0.09MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 40 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

B.7.10 In the Currently Installed Segments window 
select Big Test Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 

 

 

B.7.11 Click Deinstall Software. 

 

A Respond to the Question 
dialog box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 

 

 

B.7.12 Click Yes. Big Test Segment deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To 
Install field. Big Test Segment 
no longer appears in the Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 

 

  

 

B.8 Available Disks - No Space � Verify Segment Installation Roll Over on the Candidate Platform 
(kpccp) 

 

B.8.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Available Disks field select /home1. 

/home1 is highlighted. Circle one:  PASS / FAIL 

 

 

B.8.2 In the Available Disks field click Reserved 
Space. 

 

The Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 
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B.8.3 Click OK.    The Available Disks field displays 
the  

 following approximate values: 

   Disk      Actual    Available    Selected    
Reserved 

 /home1   4.55MB    2.84MB     0.0 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

Circle one:  PASS / FAIL 

 

 

B.8.4 Select Big Test Segment in the Select 
Software To Install field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it.   

A Warning window appears stating that 
available disk space is not enough and the 
disk will be switched to next available disk. 

Circle one:  PASS / FAIL 

 

 

B.8.5 Click OK in the Warning window. 

 

The Warning window disappears. Circle one:  PASS / FAIL 
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B.8.6 At the bottom of the Installer window click 
Install. 

 

Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Install field. Big 
Test Segment appears in the 
Currently Installed Segments 
window. 
 

Circle one:  PASS / FAIL 

 

 

B.8.7 In the Available Disks field verify /home1 values 
have remained the same and the segment installed on /h 
(or the first available disk partition). 

 The Available Disks field displays 
the following approximate values: 

 Disk      Actual    Available    Selected    
Reserved 

 /home1   4.45MB    2.79MB    0.00 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 

 

 

B.8.8 In the Currently Installed Segments window 
select Big Test Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 
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B.8.9 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 

 

 

B.8.10 Click Yes. Big Test Segment deinstalls correctly. Circle one:  PASS / FAIL 

 

 

B.8.11 Click Exit. The Installer window disappears. Circle one:  PASS / FAIL 

 

 

B.9 Available Disks - No Space � Verify Segment Installation Failure On the Candidate Platform 
(kpccp) 

 

B.9.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window at the command prompt type   
cd /  

The command prompt returns. Setup 

 

 

B.9.2 At the command prompt type 
mv /home2 /newhome2  

The command prompt returns. Setup 
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B.9.3 At the command prompt type 
mkfile 950m /h/fillspace 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the Observed 
Result column. 

NOTE: The file size parameter may vary, depending on 
the size of the /h partition. Create a file large enough to 
fill the /h partition up to at least 85%. 

NOTE: The command may take a few 
moments to complete. 

The command prompt returns. 

Setup 

 

 

B.9.4 In the Application Manager – SysAdm 
window, double-click Segment Installer. 

The Installer window appears. Circle one:  PASS / FAIL 

 

B.9.5 Click Select Source in the Source field. The Select Source window appears. Circle one:  PASS / FAIL 

 

 

B.9.6 In the Device field, click DISK. 

 

The Select File window appears. Circle one:  PASS / FAIL 

 

 

B.9.7 In the Filter text box type  
/kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

B.9.8 In the Files field, double-click bigseg.tar The Installer window reappears. Circle one:  PASS / FAIL 
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B.9.9 In the Available Disks field, select /home1. /home1 is highlighted. Circle one:  PASS / FAIL 

 

 

B.9.10 In the Source field click Read Contents. The Installer window reappears with 
Big Test Segment under the Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

B.9.11 Select Big Test Segment in the Select 
Software to Install field. 

A Warning window appears stating that 
available disk space is not enough. You 
may increase the available disk space using 
the Reserved Space Override. 

Circle one:  PASS / FAIL 

 

 

B.9.12 Click OK. The Warning window disappears.  

Control returns to the Installer 
window. 

Circle one:  PASS / FAIL 

 

 

B.9.13 In the Terminal window, at the command prompt type  
cd / 

The command prompt returns. Cleanup 

B.9.14 At the command prompt type 
mv /newhome2 /home2 

The command prompt returns. Cleanup 

B.9.15 At the command prompt type 
rm /h/fillspace /home1/fillspace 

The command prompt returns. Cleanup 
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C 4.3 Local Devices Testing 

C.1 Verify Segment Installer  Can Read Table Of Contents and Install Segments From A Local 
Tape Drive (DAT) On the Candidate Platform (kpccp) 

 

C.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

C.1.2 In the Host field, verify LOCAL is selected. LOCAL is selected. Circle one:  PASS / FAIL 

 

 

C.1.3 In the Device field, select DAT. DAT is selected. 

 

Circle one:  PASS / FAIL 

 

 

C.1.4 Select OK. The Installer window reappears and 
the Source field displays:  

Host:  LOCAL  kpccp 
Device: DAT 

Circle one:  PASS / FAIL 

 

 

C.1.5 Insert the Test Segment segx tape into the local 
device. 

Note: Refer to Step ZZ. Appendix A for instructions on 
creating the segx tape. 

The tape drive initializes properly. Circle one:  PASS / FAIL 
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C.1.6 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, the 
Installer displays Test Segment 
segx in the Select Software To 
Install field. 

Circle one:  PASS / FAIL 

 

 

C.1.7 In the Available Disks field, select /h. /h is highlighted. Circle one:  PASS / FAIL 

 

 

C.1.8 Select Test Segment segx. Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/h.  If it doesn�t, deselect the segment and 
reselect it. 

Circle one:  PASS / FAIL 

 

 

C.1.9 Click Install. The Segment Installer prompts for 
the master APM authentication key. 

Circle one:  PASS / FAIL 

 

 

C.1.10 Enter the Master APM Authentication key in the field 
provided. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 
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C.1.11 Click OK. Test Segment segx installs 
accordingly under /h. Once installed, it 
appears under the Select Software 
To Install field marked by an asterisk 
and is listed under the Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 

 

 

C.2 Verify Segment Installs and Deinstalls Correctly On the Candidate Platform (kpccp)  

C.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window appears. Circle one:  PASS / FAIL 

 

 

C.2.2 Verify the segment installed correctly. The Install Log indicates:  
Segment (Test Segment segx) 
successfully installed. 

Circle one:  PASS / FAIL 

 

 

C.2.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

C.2.4 In the Terminal window, at the command prompt, type  
ls /h/segx  

The contents of the directory is listed with 
Integ, Scripts, SegDescrip, bin, 
and data subdirectories. 

Circle one:  PASS / FAIL 
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C.2.5 In the Installer window, verify Test Segment 
segx is listed under Currently Installed 
Segments. 

Test Segment segx is listed. Circle one:  PASS / FAIL 

 

 

C.2.6 Under Currently Installed Segments select 
Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

C.2.7 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

C.2.8 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To 
Install field.  Test Segment segx 
no longer appears in the Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 

 

 

C.2.9 On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window indicates:  
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 
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C.2.10 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

C.3 Verify Window Name and Functionality Of Currently Installed Release Notes On the Candidate 
Platform (kpccp) 

 

C.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Select Release Notes below Select Software 
To Install. 

(currently grayed out). 

The Release Notes window does not 
open. 

Circle one:  PASS / FAIL 

 

 

C.3.2 Select Test Segment segx from the Select 
Software To Install field.   

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

C.3.3 Click Release Notes. The RELEASE NOTES window appears 
with the following header fields: 
Name: Test Segment segx 

Version: 1.2.3.4 

This segment is used when 
testing Segment Installer. 

Circle one:  PASS / FAIL 

 

 

C.3.4  Click OK. The RELEASE NOTES window 
disappears. 

Circle one:  PASS / FAIL 
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C.3.5 In the Select Software To Install field, click 
Requires. 

The REQUIRED SEGMENTS window 
appears with the following header fields: 
NAME: Test Segment segx 

VERSION: 1.2.3.4 

NAME                     
VERSION 

COE Component Parent      
4.0.0.0 

Circle one:  PASS / FAIL 

 

 

C.3.6  Click OK. The REQUIRED SEGMENTS window 
disappears. 

Circle one:  PASS / FAIL 

 

 

C.3.7 In the Select Software To Install field, click 
Conflicts. 

The CONFLICTING SEGMENTS window 
appears with the following header fields: 
NAME: Test Segment segx 

VERSION: 1.2.3.4 

NAME                     
VERSION Dummy Conflict 
Segment    (blank) 

Circle one:  PASS / FAIL 

 

 

C.3.8  Click OK. The CONFLICTING SEGMENTS window 
disappears. 

Circle one:  PASS / FAIL 
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C.4 Install A Segment To An Alternate Location  On the Candidate Platform (kpccp)  

C.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

 

In the Available Disks field, select  /home1. 

/home1 is highlighted. Circle one:  PASS / FAIL 

 

 

C.4.2 In the Select Software to Install field, 
deselect and reselect Test Segment segx. 

The disk listed under the Disk  column 
changes to /home1 under Select 
Software To Install. 

Circle one:  PASS / FAIL 

 

 

C.4.3 Click Install. Test Segment segx installs 
accordingly under /home1.  Once 
installed, it appears under Select 
Software To Install marked by an 
asterisk and is listed under Currently 
Installed Segments. 

Circle one:  PASS / FAIL 
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C.5 Verify Successful Installation Of Test Segment segx On the Alternate Location On the 
Candidate Platform (kpccp) 

 

C.5.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window, at the command prompt  
type 
ls -la /home1 

The contents of the directory /home1 is 
listed with segx as a subdirectory. 

Circle one:  PASS / FAIL 

 

 

C.5.2 Type  
ls -la /h  

and verify that the softlink segx −> /home1/segx is 
listed. 

The softlink segx −> /home1/segx is 
listed. 

Circle one:  PASS / FAIL 

 

 

C.5.3 In the Installer window select Test Segment 
segx in the Currently Installed Segments 
field. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

C.5.4 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 
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C.5.5 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To 
Install field.  Test Segment segx 
no longer appears in the Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 

 

 

C.5.6 In a Terminal window, type 
ls –l /home1 

There is no segx directory listed. Circle one:  PASS / FAIL 

 

C.6 Verify Segment Installer Can Read Table Of Contents and Install Segments From A Local CD-
ROM Drive On the Candidate Platform (kpccp) 

 

C.6.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Insert the KPC Test Data CD-ROM into the CD-
ROM drive. 

The CD-ROM is inserted. Circle one:  PASS / FAIL 

 

 

C.6.2 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

C.6.3 In the Device field, select CD-ROM.  The Select File window appears. Circle one:  PASS / FAIL 
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C.6.4 Enter the following in the Selection text box: 
/cdrom/kpc_4206/segx.tar 

/cdrom/kpc_4206/segx.tar appears 
in the text box. 

Circle one:  PASS / FAIL 

 

 

C.6.5 Click OK. The Installer window reappears. Circle one:  PASS / FAIL 

 

 

C.6.6 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, the 
Installer displays the Select 
Software To Install field.  

Circle one:  PASS / FAIL 

 

 

C.6.7 In the Available Disks field, verify /home1 is 
selected. 

/home1 is highlighted. Circle one:  PASS / FAIL 

 

 

C.6.8 In the Select Software To Install field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 
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C.6.9 Click Install. The following message appears: 
Please Insert CD Volume #1 
for the segment ‘Test Segment 
segx’. 
When you are ready press the 
OK button. 

Circle one:  PASS / FAIL 

 

 

C.6.10 Click OK. Test Segment segx installs 
accordingly under /home1. Once installed, 
it appears under Select Software To 
Install marked by an asterisk and is 
listed under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

C.7 Verify Segment Installs and Deinstalls Correctly On the Candidate Platform (kpccp)  

C.7.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window appears. Circle one:  PASS / FAIL 

 

 

C.7.2 Verify the segment installed correctly. The Install Log indicates:  
Segment (Test Segment segx) 
successfully installed. 

Circle one:  PASS / FAIL 

 

 

C.7.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 
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C.7.4 At the command prompt type 
ls –la /home1/segx 

The directory segx is listed with Integ, 
Scripts, SegDescrip, bin, and data 
subdirectories. 

Circle one:  PASS / FAIL 

 

 

C.7.5 In the Installer window, verify Test Segment 
segx is listed under Currently Installed 
Segments. 

The segment is listed. Circle one:  PASS / FAIL 

 

 

C.7.6 In the Currently Installed Segments field, 
select Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

C.7.7 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

C.7.8 Click Yes. The segment deinstalls and is not listed 
under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

C.7.9 On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window indicates:  
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 
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C.7.10 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

C.7.11 At the command prompt type  
eject 

The CD-ROM is ejected. Circle one:  PASS / FAIL 

C.8 Verify Segment Installer Can Read Table Of Contents and Install Segments From A Local Other 
Device On the Candidate Platform (kpccp) 

 

C.8.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

C.8.2 In the Device field, click OTHER. OTHER is selected. 

A text box appears for manually entering a 
device path. 

Circle one:  PASS / FAIL 

 

 

C.8.3 In the OTHER text box, enter the device path of the local 
tape drive: e.g. /dev/rmt/0mn 

The text box accepts user input. Circle one:  PASS / FAIL 

 

 

C.8.4 Click OK. The Installer window reappears with 
correct information in the Source field. 

Circle one:  PASS / FAIL 
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C.8.5 Ensure the segx test tape is loaded in the local tape 
drive. 

The tape is loaded. Setup 

 

 

C.8.6 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, The 
Installer displays the Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

C.8.7 In the Select Software To Install field, select 
Test Segment segx.  

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 

C.8.8 Click Install. Test Segment segx installs 
accordingly under /home1.  Once 
installed, it appears under Select 
Software To Install marked by an 
asterisk and is listed under Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 
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C.9 Verify Segment Installs and Deinstalls Correctly On the Candidate Platform (kpccp)  

C.9.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window appears. Circle one:  PASS / FAIL 

 

 

C.9.2 Verify the segment installed correctly. The Install Log indicates:  
Segment (Test Segment segx) 
successfully installed. 

Circle one:  PASS / FAIL 

 

 

C.9.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

C.9.4 At the command prompt type 
ls –la /home1/segx 

The directory segx is listed with Integ, 
Scripts, SegDescrip, bin, and data 
subdirectories. 

Circle one:  PASS / FAIL 

 

 

C.9.5 In the Installer window, verify Test Segment 
segx is listed under Currently Installed 
Segments. 

Test Segment segx is listed. Circle one:  PASS / FAIL 

 

 

C.9.6 In the Currently Installed Segments field, 
select Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 
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C.9.7 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

C.9.8 Click Yes. The segment deinstalls and is not listed 
under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

C.9.9 On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window indicates:  
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 

 

 

C.9.10 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

C.9.11 In a Terminal window, type 
ls –l /home1 

There is no segx directory listed. Circle one:  PASS / FAIL 

 

C.9.12 At the command prompt type  
mt rewoffl  

 

The tape is ejected. Setup 
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C.10 Verify Segments Can Be Read and Install Segments From A Local Tape Drive  
(Select Source  -  EXABYTE)  Optional test if vendor supports Exabyte drives 

 

D 4.4 Remote Testing 

D.1 Verify Segments Can Be Read, Installed and De-installed From A Remote Tape Device  (DAT) On 
the Candidate Platform (kpccp) 

 

D.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source in 
the Source field.  

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

D.1.2 In the Host field, select REMOTE. REMOTE is selected and a NAME text box 
appears. 

Circle one:  PASS / FAIL 

 

 

D.1.3 Type kpchost in the NAME text box. kpchost appears in the NAME text box. 

 

Circle one:  PASS / FAIL 

 

 

D.1.4 In the Device field, select DAT. DAT is selected. Circle one:  PASS / FAIL 
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D.1.5 Click OK. The Select Source window 
disappears. In the Source window of the 
Installer, the Host: entry says 
REMOTE and the correct machine name.  
Also the Device: entry selects the tape 
device you are using. 

Circle one:  PASS / FAIL 

 

 

D.1.6 Insert the Test Segment segx tape into 
kpchost’s tape drive.  

The tape drive initializes properly. Circle one:  PASS / FAIL 

 

 

D.1.7 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, The 
Installer displays the Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

D.1.8 In the Select Software To Install window, 
select Test Segment segx. 

 

Test Segment segx is highlighted 
and the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

  
 

D.1.9 Click Install. The segment installs under /home1. 

 

Circle one:  PASS / FAIL 

 

D.1.10 In the Currently Installed Segments field, 
select Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 
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D.1.11 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

D.1.12 Click Yes. The segment deinstalls and is not listed 
under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

D.2 Verify Segments Can Be Read, Installed and De-installed From A Remote OTHER Device On the 
Candidate Platform (kpccp)  

 

D.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source, 
in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

D.2.2 In the Host field verify that REMOTE is selected. REMOTE is selected. Circle one:  PASS / FAIL 

 

 

D.2.3 In the Device field, click OTHER. A text box appears to the right of the 
OTHER device selection. 

Circle one:  PASS / FAIL 
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D.2.4 In the OTHER text box, enter the appropriate device path 
for the remote tape drive, e.g., /dev/rmt/0mn. 

/dev/rmt/0mn appears in the text box. Circle one:  PASS / FAIL 

 

 

D.2.5 Click OK. The Select Source window 
disappears. In the Source window of the 
Installer, the Host: entry says 
REMOTE and the correct machine name.  
Also the Device: entry displays the other 
device path. 

Circle one:  PASS / FAIL 

 

 

D.2.6 Ensure the segx test tape is loaded in the local tape 
drive. 

The tape is loaded. Setup 

 

 

D.2.7 Under Source, Click Read Contents. The Installer window returns with a 
Select Software To Install 
field. 

Circle one:  PASS / FAIL 

 

 

D.2.8 Select Test Segment segx. 

 

Test Segment segx is highlighted 
and the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

  
 

D.2.9 Click Install. The segment installs under /home1. Circle one:  PASS / FAIL 
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D.2.10 In the Currently Installed Segments field, 
select Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

D.2.11 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

D.2.12 Click Yes. The segment deinstalls and is not listed 
under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

D.2.13 NOTE: Perform the following step on the Validation 
Host (kpchost). 

At the command prompt type  
mt rewoffl  

 

The tape is ejected. Setup 
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D.3 Verify Segments Can Be Read, Installed and De-installed From A Remote DISK Drive On the 
Candidate Platform (kpccp) 

 

D.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source, 
in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

D.3.2 In the Host field verify that REMOTE is selected. REMOTE is selected. Circle one:  PASS / FAIL 

 

 

D.3.3 In the Device field, click DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

D.3.4 In the Filter text box type: /kpchostdsk/si/* 
[r] 

/kpchostdsk/si/* appears in the text 
box. 

Circle one:  PASS / FAIL 

 

 

D.3.5 In the Files field double-click bigseg.tar. The Select File window disappears.  

The Installer window reappears. 

Circle one:  PASS / FAIL 

 

 

D.3.6 Click Read Contents. The Installer window returns with Big 
Test Segment appearing in the Select 
Software To Install field. 

Circle one:  PASS / FAIL 
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D.3.7 Select Big Test Segment in the Select 
Software To Install field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

 

Circle one:  PASS / FAIL 

 

 

D.3.8 At the bottom of the Installer window select 
Install. 

Test Segment segx installs 
accordingly under /home1.  Once 
installed, it appears under Select 
Software To Install marked by an 
asterisk and is listed under Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 

 

 

D.3.9 In the Currently Installed Segments field 
select Big Test Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 

 

 

D.3.10 Click Deinstall Software. 

 

A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 
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D.3.11 Click Yes. Big Test Segment deinstalls correctly. Circle one:  PASS / FAIL 

 

  

 

D.4 Resume the Export Of the CD-ROM Drive (Share the Root Directory Of the Installed CD) On the 
Validation Hosts (kpchost) 

 

D.4.1 NOTE: Perform the following steps on the Validation 
host (kpchost). 

Insert the KPC Test Data CD-ROM into the CD-
ROM drive. 

The CD-ROM is inserted. Setup 

D.4.2 In the Terminal window, at the command prompt type 
share –o ro=kpccp /cdrom/kpc_4206 

The command prompt returns. Setup 

D.4.3 At the command prompt type 
share  

The following text is displayed: 
/kpc ro=kpccp 

/home2 ro,root=kpccp 

/cdrom/kpc_4206 ro=kpccp 

Setup 
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D.5 Verify Segments Can Be read and Installed From A Remote CD-ROM Drive (Share and Mount 
the Root Directory Of the Installed CD) On the Candidate Platform (kpccp) 

 

D.5.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source, 
in the Source field. 

The Select Source window appears. Setup 

 

D.5.2 In the Host field SELECT REMOTE. REMOTE is selected. Circle one:  PASS / FAIL 

 

 

D.5.3 Type kpchost in the NAME test box. kpchost appears in the NAME test box. Circle one:  PASS / FAIL 

 

 

D.5.4 In the Device field, click CD-ROM. The Select File window appears. Circle one:  PASS / FAIL 

 

 

D.5.5 Enter the following in the Selection text box: 
/kpchostcdrom/segx.tar 

/kpchostcdrom/segx.tar appears in 
the text box. 

Circle one:  PASS / FAIL 

 

 

D.5.6 Click OK. The Installer window reappears. Circle one:  PASS / FAIL 
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D.5.7 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, the 
Installer displays the Select 
Software To Install field.  

Circle one:  PASS / FAIL 

 

 

D.5.8 In the Available Disks field select /home1 /home1 is highlighted. Circle one:  PASS / FAIL 

 

 

D.5.9 In the Select Software To Install field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 

D.5.10 Click Install. The following message appears: 
Please Insert CD Volume #1 
for the segment ‘Test Segment 
segx’. 
When you are ready press the 
OK button. 

Circle one:  PASS / FAIL 

 

 

D.5.11 Click OK. Test Segment segx installs 
accordingly under /home1.  Once 
installed, it appears under Select 
Software To Install marked by an 
asterisk and is listed under the 
Currently Installed Segments 
field. 

Circle one:  PASS / FAIL 
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D.5.12 In the Currently Installed Segments field, 
select Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

D.5.13 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

D.5.14 Click Yes. The segment deinstalls and is not listed 
under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

D.5.15 Click Exit. 

 

The Installer window closes. Circle one:  PASS / FAIL 

D.6 Cleanup � Eject the CD-ROM On the Validation Host (kpchost)  

D.6.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Terminal window, at the command prompt type  
unshare /cdrom/kpc_4206 

The command prompt returns. Cleanup 

D.6.2 At the command prompt type 
share  

The following text is displayed: 
/kpc ro=kpccp 

/home2 ro,root=kpccp 

Cleanup 
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D.6.3 At the command prompt type  
eject 

The CD-ROM is ejected. Cleanup 

D.7 Verify Segments Can Be Read and Install Segments From A Remote tape drive  (Select Source  -  
EXABYTE) 
Optional test if vendor supports Exabyte drives 

 

E 4.5 Test the Runtime Tools 

E.1 Install the Runtime Tools Segment On the Candidate Platform (kpccp) 

NOTE: Any incorrect input in the steps below will cause the Runtime Tools Segment to fail to 
load.  To determine where the failure occurred, search the /tmp/out.log file for the word 
FAILED.  Then run step E.1 again. 

 

E.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window, at the command prompt type 
the following as sysadmin: 
/h/COE/bin/COEInstaller |& tee [s] 

/tmp/out.log 

The Installer window opens and 
displays messages in the terminal. 

Circle one:  PASS / FAIL 

 

 

E.1.2 In the Installer window, click Select Source in 
the Source field. 

The Select Source dialog box 
appears. 

Circle one:  PASS / FAIL 
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E.1.3 In the Host field, verify LOCAL is selected. LOCAL is selected. Circle one:  PASS / FAIL 

 

 

E.1.4 In the Device field, select DISK.  The Select File dialog box appears. Circle one:  PASS / FAIL 

 

 

E.1.5 In the Selection text box, type 
/kpc/si/RTTseg.tar 

/kpc/si/RTTseg.tar appears in the 
text box. 

Circle one:  PASS / FAIL 

 

 

E.1.6 Click OK. The Select File and Select 
Source dialog boxes disappear. 

Circle one:  PASS / FAIL 

 

 

E.1.7 In the Source field, click Read Contents. The Installer window shows 
Runtime  Tools Test Segment 
listed under Select Software To 
Install. 

Circle one:  PASS / FAIL 

 

 

E.1.8 Select Runtime Tools Test Segment. Runtime Tools Test Segment is 
highlighted and the Disk column in the 
Select Software To Install field 
displays /h. 

Circle one:  PASS / FAIL 
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E.1.9 Click Install. An ENTER A PASSWORD dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

E.1.10 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

E.1.11 Click OK. A dialog box appears stating: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Runtime Tools Test 
Segment’ 

Then a sequence of dialog boxes appears. 

Circle one:  PASS / FAIL 

 

 

E.1.12 Enter the requested text in each dialog box. An ENTER A RESPONSE dialog box 
appears: 
Enter exactly “Now is the 
time” (expect beeps), click 
OK:  

Circle one:  PASS / FAIL 

 

 

E.1.13 In the text box, type  

 
Now is the time 

Now is the time is entered in the text 
box. 

NOTE: The word �time� is not displayed. 

Circle one:  PASS / FAIL 
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E.1.14 Click OK. An ENTER A RESPONSE dialog box 
appears: 
Enter exactly “Test*_1%-@”, 
click OK: 

Circle one:  PASS / FAIL 

 

 

E.1.15 In the text box, type  

 
Test*_1%-@ 

Test*_1%-@ is entered in the text box. 

 

Circle one:  PASS / FAIL 

 

 

E.1.16 Click OK. An ENTER A RESPONSE dialog box 
appears: 
Enter exactly “9”, click OK: 

Circle one:  PASS / FAIL 

 

 

E.1.17 In the text box, type  
9 

9 is entered in the text box. 

 

Circle one:  PASS / FAIL 

 

 

E.1.18 Click OK. An ENTER A RESPONSE dialog box 
appears: 
Enter nothing, click OK: 

Circle one:  PASS / FAIL 

 

 

E.1.19 Click OK. An ENTER A RESPONSE dialog box 
appears: 
Enter exactly “0123456789” 5 
times in sequence (expect 
beeps), click OK: 

Circle one:  PASS / FAIL 
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E.1.20 In the text box, type 
01234567890123456789012345678901234567
890123456789 

01234567890123456789012345678
901234567890123456789 is entered 
in the text box. 

NOTE: 4 sets of 0123456789 will appear 
in the text box. 

Circle one:  PASS / FAIL 

 

 

E.1.21 Click OK. An ENTER A RESPONSE dialog box 
appears: 
COEPrompt is similar to 
COEMsg, but expects the user 
to enter a response.  The 
syntax is:  “COEPrompt 
{parameters} msg” where msg 
is the string to display.   

Enter “Yes” exactly and click 
OK if the above sentence is 
complete.  Otherwise, enter 
nothing and click OK: 

Circle one:  PASS / FAIL 

 

 

E.1.22 In the text box, type 
Yes 

Yes is entered in the text box. 

 

Circle one:  PASS / FAIL 

 

 

E.1.23 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
Can you read this prompt? 

Circle one:  PASS / FAIL 
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E.1.24 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, if the 
message says only ’Hello’ 
click the No button; 
otherwise click Yes. 

For all following prompts, if 
no message appears, click the 
button on the right.   

To continue, type nothing and 
click OK below: 

Circle one:  PASS / FAIL 

 

 

E.1.25 Click OK. A RESPOND TO THE QUESTION 
dialog box appears with the following: 
Hello 

Circle one:  PASS / FAIL 

 

 

E.1.26 Click No. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
True and False, click the 
True button.  Otherwise, 
click the button on the 
right. 

Circle one:  PASS / FAIL 
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E.1.27 Click True. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
True and False, click the 
False button.  Otherwise, 
click the button on the left. 

Circle one:  PASS / FAIL 

 

 

E.1.28 Click False. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
Accept and Cancel, click the 
Accept button.  Otherwise, 
click the button on the 
right. 

Circle one:  PASS / FAIL 

 
 

E.1.29 Click Accept. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
Accept and Cancel, click the 
Cancel button.  Otherwise, 
click the button on the left. 

Circle one:  PASS / FAIL 

 

 

E.1.30 Click Cancel. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
Exit and Cancel, click the 
Exit button.  Otherwise, 
click the button on the 
right. 

Circle one:  PASS / FAIL 
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E.1.31 Click Exit. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
“Exit or Cancel” and 
“Continue”, click the “Exit 
or Cancel” button.  
Otherwise, click the button 
on the right. 

Circle one:  PASS / FAIL 

 

 

E.1.32 Click Exit or Cancel. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show Yes 
and No, click the Yes button.  
Otherwise, click the button 
on the right. 

Circle one:  PASS / FAIL 

 

 

E.1.33 Click Yes. A RESPOND TO THE QUESTION 
dialog box appears: 
If the buttons below show 
True and False, click the 
True button. Otherwise, click 
the button on the right. 

Circle one:  PASS / FAIL 
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E.1.34 Click True. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, if the 
message is exactly “Test*_1%-
@”, and Yes and No buttons 
are shown, click the No 
button.  Otherwise, click the 
button on the left. 

Type nothing and click OK to 
continue: 

Circle one:  PASS / FAIL 

 

 

E.1.35 Click OK. A RESPOND TO THE QUESTION 
dialog box appears with the following: 
Test*_1%-@ 

Circle one:  PASS / FAIL 

 

 

E.1.36 Click No. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, if the 
message area is blank, and 
Yes and No buttons are shown, 
click the Yes button.  
Otherwise, click the button 
on the right. 

Type nothing and click OK to 
continue: 

Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 82 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

E.1.37 Click OK. A RESPOND TO THE QUESTION 
dialog box appears with no message. 

Circle one:  PASS / FAIL 

 

 

E.1.38 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, write 
down the message shown and 
click the OK button. 

Type nothing and click OK to 
continue:  

Circle one:  PASS / FAIL 

 

 

E.1.39 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Test*_1%-@ 

Circle one:  PASS / FAIL 

 

 

E.1.40 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
On the next prompt, write 
down the message shown and 
click the OK button. 

Was the previous message 
exactly “Test*_1%-@”? 

Circle one:  PASS / FAIL 

 

 

E.1.41 Click Yes. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Test 

Circle one:  PASS / FAIL 
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E.1.42 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
On the next prompt, write 
down the message shown and 
click the OK button. 

Was the previous message 
exactly “Test”? 

Circle one:  PASS / FAIL 

 

 

E.1.43 Click Yes. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Single quote pass 

Circle one:  PASS / FAIL 

 

 

E.1.44 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
On the next prompt, write 
down the message shown and 
click the OK button. 

Was the previous message 
exactly “Single quote pass”? 

Circle one:  PASS / FAIL 

 

 

E.1.45 Click Yes. An INFORMATIONAL MESSAGE dialog 
box appears with no message. 

Circle one:  PASS / FAIL 
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E.1.46 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
On the next prompt, remember 
the message shown and click 
the OK button. 

Was the previous message 
blank? 

Circle one:  PASS / FAIL 

 

 

E.1.47 Click Yes. An INFORMATIONAL MESSAGE dialog 
box appears: 
I pledge allegiance to the 
flag of the United States of 
America And to the republic 
for which it stands one 
nation, under God, 
indivisible, with liberty and 
justice for all. 

Circle one:  PASS / FAIL 

 

 

E.1.48 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
On the next prompt, remember 
the message shown and click 
the OK button. 

Was the previous message the 
complete pledge of 
allegiance? 

Circle one:  PASS / FAIL 
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E.1.49 Click Yes. An ENTER A PASSWORD dialog box 
appears: 
Enter exactly “password” for 
both, click OK: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.50 Type password in both text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.51 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
Did the password entry fields 
only display asterisks (*) as 
you typed? 

Circle one:  PASS / FAIL 

 

 

E.1.52 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, enter 
“sample” for the password and 
click OK. 

Enter nothing here and click 
OK to continue. 

Circle one:  PASS / FAIL 
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E.1.53 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.54 Type sample in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

E.1.55 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompt, did 
only the password entry field 
appear, with no message, and 
no verify field? 

Circle one:  PASS / FAIL 

 

 

E.1.56 Click Yes. An ENTER A PASSWORD dialog box 
appears: 
Enter exactly ‘password’ 

Password (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.57 Type password in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 87 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

E.1.58 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompt, did 
only the password entry field 
appear, with no verify field? 

Circle one:  PASS / FAIL 

 

 

E.1.59 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, enter 
“test1234” for the password, 
verify and click OK. 

Enter nothing here and click 
OK to continue: 

Circle one:  PASS / FAIL 

 

 

E.1.60 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.61 Type test1234 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 
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E.1.62 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompt, did 
both the password and verify 
fields appear, with no 
message? 

Circle one:  PASS / FAIL 

 

 

E.1.63 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
On the next prompt, enter 
“Test*_1%-@” for the 
password, verify and click 
OK. 

Enter nothing here and click 
OK to continue: 

Circle one:  PASS / FAIL 

 
 

E.1.64 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.65 Type Test*_1%-@ in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 
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E.1.66 Click OK. An ENTER A PASSWORD dialog box 
appears: 
The first time you see this 
prompt, enter 
“012345678901234” for the 
password and verification and 
click OK. This should return 
an error message – write it 
down.  The second time, enter 
“tested” and click OK. 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.67 Type 012345678901234 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.68 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 14 
characters in length! 

Circle one:  PASS / FAIL 
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E.1.69 Click OK. An ENTER A PASSWORD dialog box 
appears: 
The first time you see this 
prompt, enter 
“012345678901234” for the 
password and verification and 
click OK. This should return 
an error message – write it 
down.  The second time, enter 
“tested” and click OK. 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.70 Type tested in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.71 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompts, did 
you receive one error message 
indicating that the password 
must be 6 – 14 characters in 
length? 

Circle one:  PASS / FAIL 
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E.1.72 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
For the next two prompts, 
duplicate the prompt message 
in the password field and 
click OK. 

Enter nothing here and click 
OK to continue: 

Circle one:  PASS / FAIL 

 

 

E.1.73 Click OK. An ENTER A PASSWORD dialog box 
appears: 
Test*_1%-@ 

Password (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.74 Type Test*_1%-@ in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

E.1.75 Click OK. An ENTER A PASSWORD dialog box 
appears: 
%TestCase 

Password (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.76 Type %TestCase in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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E.1.77 Click OK. An ENTER A RESPONSE dialog box 
appears: 
For the next three prompts, 
enter nothing in the password 
field and click OK. 

Enter nothing here and click 
OK to continue: 

Circle one:  PASS / FAIL 

 

 

E.1.78 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.79 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.80 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 
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E.1.81 Click OK. An ENTER A RESPONSE dialog box 
appears: 
For the next three prompts, 
enter “01234567890” in the 
password and verify fields 
and click OK. Respond to each 
error message by clicking OK. 

Enter nothing here and click 
OK to continue: 

Circle one:  PASS / FAIL 

 

 

E.1.82 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.83 Type 01234567890 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.84 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 10 
characters in length! 

Circle one:  PASS / FAIL 
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E.1.85 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.86 Type 01234567890 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.87 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 10 
characters in length! 

Circle one:  PASS / FAIL 

 

 

E.1.88 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.89 Type 01234567890 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.90 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 10 
characters in length! 

Circle one:  PASS / FAIL 
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E.1.91 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompt, did 
you receive 3 error messages 
indicating that the password 
must be 6 – 10 characters in 
length? 

Circle one:  PASS / FAIL 

 

 

E.1.92 Click Yes. An ENTER A PASSWORD dialog box 
appears: 
Enter ‘012345678’. Click OK 
on errors 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.93 Type 012345678 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.94 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 8 
characters in length! 

Circle one:  PASS / FAIL 
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E.1.95 Click OK. An ENTER A PASSWORD dialog box 
appears: 
Enter ‘012345678’. Click OK 
on errors 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.96 Type 012345678 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.97 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 8 
characters in length! 

Circle one:  PASS / FAIL 

 

 

E.1.98 Click OK. An ENTER A PASSWORD dialog box 
appears: 
Enter ‘012345678’. Click OK 
on errors 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.99 Type 012345678 in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 
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E.1.100 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the following: 
Password must be 6 to 8 
characters in length! 

Circle one:  PASS / FAIL 

 

 

E.1.101 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompts, did 
you receive 3 error messages 
indicating that the password 
must be 6 – 8 characters in 
length? 

Circle one:  PASS / FAIL 

 

 

E.1.102 Click Yes. An ENTER A RESPONSE dialog box 
appears: 
For the next prompt, enter 
“testing” in the password and 
verify fields and click OK. 

Enter nothing here and click 
OK to continue: 

Circle one:  PASS / FAIL 

 

 

E.1.103 Click OK. An ENTER A PASSWORD dialog box 
appears: 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 
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E.1.104 Type testing in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.105 Click OK. An ENTER A PASSWORD dialog box 
appears: 
COEPromptPasswd is similar to 
COEPrompt in syntax and 
operation. It is intended to 
be used in PreInstall and 
PostInstall to ask the user 
for a password. 

Enter ‘testing’ 

Password (text box) 

Verify   (text box) 

Circle one:  PASS / FAIL 

 

 

E.1.106 Type testing in the text boxes. Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

E.1.107 Click OK. A RESPOND TO THE QUESTION 
dialog box appears: 
In the previous prompt, did 
the message appear on several 
lines ? 

Circle one:  PASS / FAIL 
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E.1.108 Click Yes. 

NOTE: Any incorrect input in the above steps will 
cause the Runtime Tools Segment to fail to load.  To 
determine where the failure occurred, search the 
/tmp/out.log file for the word FAILED.  Then run 
step E.1 again. 

The following dialog box appears: 
Building segment lists… 

The Installer window returns to the 
forefront and shows Runtime Tools 
Segment listed under Currently 
Installed Segments. 

Circle one:  PASS / FAIL 

 

 

E.1.109 Open another Terminal window. A Terminal window appears with a 
command line prompt. 

Setup 

E.1.110 At the command prompt type 
grep FAILED /tmp/out.log 

The command prompt returns without any 
Sub-test 

indicated as FAILED. 

Circle one:  PASS / FAIL 

 

 

E.2 Deinstall the Runtime Tools Segment On the Candidate Platform (kpccp)  

E.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Segment Installer window, select the 
Runtime Tools Test Segment segment in the 
Currently Installed Segments field. 

The Runtime Tools Test Segment 
segment in the Currently 
Installed      Segments field is 
highlighted. 

Cleanup 

E.2.2 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove 
the segments? 

Runtime Tools Test Segment 

Cleanup 
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E.2.3 Click Yes. The following dialog box appears: 
Segment deinstallation in 
progress... 

Control returns to the Segment 
Installer window. 

Cleanup 

E.2.4 When removal is complete, check both the Currently 
Installed Segments field and the 
Select Software to Install field. 

The Runtime Tools Test Segment 
is no longer listed in the Currently 
Installed Segments field. 

An asterisk (*) no longer appears next to the 
Runtime Tools Test Segment 
segment in the 
Select Software to Install 
field. 

Cleanup 

E.2.5 Click Exit in the bottom menu bar of the Segment 
Installer. 

The Segment Installer window 
disappears. 

Cleanup 
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F 4.6 Segment Type Tests 

F.1 Verify That All Segment Types Can Be Installed By the Segment Installer On the Candidate 
Platform (kpccp) 

 

F.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Application Manager – SysAdm window, 
double-click Segment Installer. 

The Installer window appears. Setup 

F.1.2 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Setup 

F.1.3 In the Device field, click DISK. The DISK option is selected and the 
Select File dialog box appears. 

Setup 

F.1.4 In the Filter text box, type 
/kpc/si/* [r] 

/kpc/si/* appears in the text box. Setup 

F.1.5 In the Files field, double-click on the following entry: 
all_types.tar 

The Installer window reappears. Circle one:  PASS / FAIL 
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F.1.6 In the Source field, click Read Contents. 

NOTE: Resize the Installer window to view all 
segments. 

The following segments appear in the 
Select Software To Install 
field: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Data-Global Segment 

Sample Data-Local Segment 

Sample Data-Segment Segment 

Sample Software Segment 

SampleSW.P1 

Circle one:  PASS / FAIL 

 

 

F.1.7 Select the following segments in the 
Select Software To Install field: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Software Segment 

All requested segments in the 
Select Software To Install 
field are highlighted. 

Circle one:  PASS / FAIL 

 

 

F.1.8 Click Install. An ENTER A PASSWORD dialog box 
appears asking for the Master APM 
Authentication key. 

Circle one:  PASS / FAIL 
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F.1.9 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

F.1.10 Click OK. The working box may be blank, or the 
following dialog boxes will appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Aggregate 
Segment’ 

Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Aggregate 
Child Segment’ 

PreInstall installation 
directory is 
/h/AcctGrps/SampleAcctGrp 

Circle one:  PASS / FAIL 
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F.1.11 Click OK. The working box may be blank, or the 
following dialog boxes will appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Account 
Group Segment’ 

PostInstall installation 
directory is 
/h/AcctGrps/SampleAcctGrp 

Circle one:  PASS / FAIL 

 

 

F.1.12 Click OK. The following dialog box appears: 
PreInstall installation 
directory is 
/h/COE/Comp/SampleCOEChild 

Circle one:  PASS / FAIL 

 

 

F.1.13 Click OK. The following dialog boxes appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Sample COE Child 
Segment’ 
PostInstall installation 
directory is 
/h/COE/Comp/SampleCOEChild 

Circle one:  PASS / FAIL 
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F.1.14 Click OK. The following dialog boxes appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Sample COTS 
Segment’ 
PreInstall installation 
directory is /h/SampleSW 

Circle one:  PASS / FAIL 

 

 

F.1.15 Click OK. The following dialog boxes appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Software 
Segment’ 
PostInstall installation 
directory is /h/SampleSW 

Circle one:  PASS / FAIL 

 

 

F.1.16 Click OK. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the 
forefront. 

Circle one:  PASS / FAIL 
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F.1.17 When installation is complete, check both the 
Currently Installed Segments field and the 
Select Software To Install field. 

NOTE: Resize the Installer window to view all 
segments. 

The following segments are listed in the 
Currently Installed Segments 
field: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Software Segment 

An asterisk (*) appears next to the 
aforementioned segments in the 
Select Software To Install 
field. 

Circle one:  PASS / FAIL 

 

 

F.1.18 Select the following segments in the 
Select Software To Install field: 
Sample Data-Global Segment 

Sample Data-Local Segment 

Sample Data-Segment Segment 

SampleSW.P1 

All requested segments in the 
Select Software To Install 
field are highlighted. 

Circle one:  PASS / FAIL 
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F.1.19 Click Install. The working box may be blank, or the 
following dialog boxes will appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Data-Global 
Segment’ 

Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Data-Local 
Segment’ 

Please wait...extracting the 
disk file with the selected 
segment: ‘Sample Data-Segment 
Segment’ 

Please wait...extracting the 
disk file with the selected 
segment: ‘SampleSW.P1’ 

Building segment lists… 

Control returns to the Installer 
window. 

Circle one:  PASS / FAIL 
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F.1.20 When installation is complete, check both the 
Currently Installed Segments field and the 
Select Software To Install field. 

NOTE: Resize the Installer window to view all 
segments. 

All sample segments are listed in the 
Currently Installed Segments 
field. 

An asterisk (*) appears next to all sample 
segments in the 
Select Software To Install 
field. 

Circle one:  PASS / FAIL 

 

 

F.2 Verify That All Segments Are Installed Onto the Hard Disk On the Candidate Platform (kpccp)  

F.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Verify that Sample Aggregate Segment, 
Sample Aggregate Child Segment, Sample 
Data-Global Segment, Sample Data-Local 
Segment, Sample Data-Segment Segment, 
and Sample Software Segment are installed onto 
the hard disk. 

In the Terminal window at the command prompt, type 
ls /h 

The following directories are listed: 
SampleAgg 
SampleAggChild 
SampleDataGlobal 
SampleDataLocal 
SampleDataSegment 
SampleSW 

Circle one:  PASS / FAIL 

 

 

F.2.2 Verify that Sample Account Group Segment is 
installed onto the hard disk.  

At the command prompt, type 
ls /h/AcctGrps 

The directory SampleAcctGrp is listed. Circle one:  PASS / FAIL 
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F.2.3 Verify that Sample COE Child Segment is 
installed onto the hard disk.  

At the command prompt, type 
ls /h/COE/Comp 

The directory SampleCOEChild is listed. Circle one:  PASS / FAIL 

 

 

F.2.4 Verify that Sample COTS Segment is installed onto 
the hard disk.  

At the command prompt, type 
ls /h/COTS 

The directory SampleCOTS is listed. Circle one:  PASS / FAIL 

 

 

F.2.5 Verify that Sample Data-Local Segment is 
installed onto the hard disk.  

At the command prompt, type 
ls /h/data/local 

The directory SampleDataLocal is 
listed. 

Circle one:  PASS / FAIL 

 

 

F.2.6 Verify that Sample Data-Global Segment is 
installed onto the hard disk.  

At the command prompt, type 
ls /h/data/global 

The directory SampleDataGlobal is 
listed. 

Circle one:  PASS / FAIL 

 

 

F.2.7 Verify that Sample Data-Segment Segment is 
installed onto the hard disk.  

At the command prompt, type 
ls /h/SampleSW/data 

The directory SampleDataSegment is 
listed. 

Circle one:  PASS / FAIL 
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F.2.8 Verify that SampleSoftware Segment is installed 
onto the hard disk.  

At the command prompt, type 
ls /h/SampleSW/Patches 

The directory P1 is listed. Circle one:  PASS / FAIL 

 

 

F.3 Verify That All Segment Types Can Be Removed By the Segment Installer On the 
Candidate Platform (kpccp) 

 

F.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, select SampleSW.P1 in 
the Currently  Installed Segments field. 

SampleSW.P1 is highlighted. Circle one:  PASS / FAIL 

 

 

F.3.2 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove 
the segments? 

SampleSW.P1 

Circle one:  PASS / FAIL 

 

 

F.3.3 Click Yes. The working box may be blank, or the 
following dialog box will appear: 
Segment deinstallation in 
progress... 

Control returns to the Installer 
window. 

Circle one:  PASS / FAIL 
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F.3.4 When removal is complete, check both the Currently 
Installed Segments field and the 
Select Software To Install field. 

NOTE: Resize the Installer window to view all 
segments. 

The SampleSW.P1 segment is no longer 
listed in the Currently Installed 
Segments field. 

An asterisk (*) no longer appears next to the 
SampleSW.P1 segment in the 
Select Software To Install 
field. 

Circle one:  PASS / FAIL 

 

 

F.3.5 In the Currently Installed Segments field, 
select the following segments: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Data-Global Segment 

Sample Data-Local Segment 

Sample Data-Segment Segment 

Sample Software Segment 

All requested segments in the 
Currently Installed Segments 
field are highlighted. 

Circle one:  PASS / FAIL 
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F.3.6 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove 
the segments? 

Sample Data-Segment Segment 
Sample Data-Local Segment 
Sample Data-Global Segment 
Sample Software Segment 
Sample Aggregate Segment 
Sample COE Child Segment 
Sample COTS Segment 
Sample Account Group Segment 

Circle one:  PASS / FAIL 

 

 

F.3.7 Click Yes. The working box may be blank, or the 
following dialog boxes will appear in 
sequence: 
Segment deinstallation in 
progress... 

Building segment lists… 

DEINSTALL installation 
directory is /h/SampleSW 

Circle one:  PASS / FAIL 

 

 

F.3.8 Click OK. The following dialog box appears: 
DEINSTALL installation 
directory is 
/h/COE/Comp/SampleCOEChild 

Circle one:  PASS / FAIL 
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F.3.9 Click OK. The following dialog box appears: 
DEINSTALL installation 
directory is 
/h/AcctGrps/SampleAcctGrp 

Circle one:  PASS / FAIL 

 

 

F.3.10 Click OK. The following dialog box appears: 
Building segment lists… 

Control returns to the Installer 
window. 

Circle one:  PASS / FAIL 

 

 

F.3.11 When removal is complete, check both the Currently 
Installed Segments field and the 
Select Software To Install field. 

NOTE: Resize the Installer window to view all 
segments. 

All sample segments are no longer listed in 
the Currently Installed 
Segments field. 

An asterisk (*) no longer appears next to 
any segments in the 
Select Software To Install 
field. 

Circle one:  PASS / FAIL 
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G 4.7 Test the Process Descriptor 

G.1 Install Processes Test Segment On the Candidate Platform (kpccp)  

G.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window click Select Source. 

The Select Source dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

G.1.2 In the Device field, select DISK. 

 

The Select File dialog box appears. Circle one:  PASS / FAIL 

 

 

G.1.3 In the Files list box select 
ProcSeg.tar 

ProcSeg.tar is highlighted. Circle one:  PASS / FAIL 

 

 

G.1.4 Click OK. The Select File and Select 
Source dialog boxes disappear.  The 
Installer window reappears. 

Circle one:  PASS / FAIL 

 

 

G.1.5 Click Read Contents. In the Installer window, Processes 
Test Segment is listed under Select 
Software To Install. 

Circle one:  PASS / FAIL 

 

 

G.1.6 Select Processes Test Segment. 

 

Processes Test Segment is 
highlighted and the Disk column in the 
Select Software To Install field 
displays /h. 

Circle one:  PASS / FAIL 
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G.1.7 Click Install. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the 
forefront and shows Processes Test 
Segment listed under Currently 
Installed Segments. 

Circle one:  PASS / FAIL 

 

 

G.1.8 In the Application Manager – SysAdm window 
double-click Reboot System. 

The  Reboot window appears with the 
message: 
Reboot machine? 

 

Setup 

G.1.9 Click Yes. 

 

The machine reboots. Setup 

G.2 Verify Boot, Run-Once, and Periodic Processes Were Started On the Candidate Platform (kpccp)  

G.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Login as secman. 

The desktop appears. Setup 

G.2.2 Open a Terminal window. A Terminal window appears with a 
command line prompt. 

Setup 

G.2.3 At the command prompt type  
su - 

The Password prompt appears. Setup 

G.2.4 At the Password prompt type the root password. The command prompt returns. Setup 
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G.2.5 At the command prompt type 
csh 

The command prompt returns. Setup 

G.2.6 At the command prompt type 
date 

The current system date and time are 
displayed. 

Setup 

 

Date:_____________ 

Time:_____________ 

G.2.7 Wait 5 minutes so that the period process will have had 
time to start. 

 Setup 

G.2.8 At the command prompt type 
/h/ProcSeg/bin/PROC-check-install 

The output contains several lines indicating 
started processes. 

The following process show start time the 
same as the last reboot: 
PROC-boot-process 

PROC-boot-process-coe 

PROC-boot-process-secman 

PROC-run-once-process  

The following processes are started: 
PROC-periodic-process-a 

PROC-periodic-process-b 

 

Circle one:  PASS / FAIL 
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G.3 Verify Session Processes Were Started On the Candidate Platform (kpccp)  

G.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Select Applications > Application Manager 
> DII_APPS > SecAdm. 

The Application Manager – 
SecAdm window appears. 

Setup 

 

 

G.3.2 In the Application Manager – SecAdm dialog 
box, double-click APM Client. 

An Input dialog box appears asking for 
the master APM authentication key. 

 

Setup 

G.3.3 Enter the master APM authentication Key. Asterisks appear in the text box. Setup 

 

G.3.4 Click OK. The Account and Profile 
Manager dialog box appears. 

Setup 

 

 

G.3.5 Click Profiles. The Profiles tab is displayed. Setup 

 

G.3.6 Select File > New Profile. The Create Profile dialog box 
appears. 

Setup 

 

G.3.7 Click Identification. The Identification tab is displayed. Setup 
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G.3.8 Enter the following value: 

Profile Name: proc_prof 

 

proc_prof appears in the text box. Setup 

 

G.3.9 Click Features. The Features tab is displayed. Setup 

 

G.3.10 Select SOL Processes Test Segment from the 
Segments panel. 

SOL Processes Test Segment is 
highlighted. The SOL Process Test 
Segment-Proc Icon feature appears 
in the Features panel. 

Setup 

 

 

G.3.11 Select Processes Test Segment-Proc Icon in 
the Features panel. 

Processes Test Segment-Proc 
Icon is selected 

Setup 

 

 

G.3.12 Click Hosts. The Hosts tab is displayed. Setup 

 

G.3.13 Double-click kpccp appear in the Available 
Hosts panel. 

kpccp moves to the Assigned Hosts 
panel. 

Setup 

 

G.3.14 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Setup 

 

G.3.15 Click OK. Control returns to the Account and 
Profile Manager dialog box.  

Setup 
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G.3.16 In the Account and Profile Manager dialog 
box, under Accounts, double-click user secman. 

A Modify Account: secman dialog 
box appears. 

Setup 

 

 

G.3.17 Click Profiles. The Profiles tab is displayed. Setup 

 

 

G.3.18 Double-click proc_prof. Profile proc_prof moves to the 
Assigned Profiles panel. 

Setup 

 

 

G.3.19 Click Submit. A Status Summery dialog box appears 
indicating user secman was modified. 

Setup 

 

 

G.3.20 Click OK to clear the Status Summary. Control returns to the Account and 
Profile Manager dialog box. 

Setup 

 

 

G.3.21 Click Profile Selector (the head with a question 
mark). 

The Profile Selector window 
appears. 

Setup 

 

G.3.22 Double-click proc_prof. Profile proc_prof moves to the 
Selected Profiles panel. 

Circle one:  PASS / FAIL 
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G.3.23 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the message: 
PROC: Session process has 
been started. 

Circle one:  PASS / FAIL 

 

 

G.3.24 Click OK. The Profile Selector Results 
window appears stating that the profile was 
successfully assumed. 

Circle one:  PASS / FAIL 

 

 

G.3.25 Click Done. The Profile Selector window and 
the Profile Selector Results 
window disappear. 

Circle one:  PASS / FAIL 

 

 

G.4 Cleanup ProcSeg on the Candidate Platform (kpccp)  

G.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Click Profile Selector (the head with a question 
mark). 

The Profile Selector window 
appears with proc_prof listed in the 
Selected Profiles panel. 

Circle one:  PASS / FAIL 

G.4.2 Double-click SSO Default. Profile SSO Default moves to the 
Selected  Profiles panel. 

proc_prof moves to the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

G.4.3 Click OK. An INFORMATIONAL MESSAGE dialog 
box appears with the message: 
PROC: Session exit process 
has been started. 

Circle one:  PASS / FAIL 
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G.4.4 Click OK. The Profile Selector Results 
window appears stating that the profile was 
successfully assumed. 

Circle one:  PASS / FAIL 

 

 

G.4.5 Click Done. The Profile Selector window and 
the Profile Selector Results 
window disappear. 

Circle one:  PASS / FAIL 

 

 

G.4.6 In the Account and Profile Manager dialog 
box, under Accounts, double-click user secman. 

A Modify Account: secman dialog 
box appears. 

Cleanup 

 

 

G.4.7 Click Profiles. The Profiles tab is displayed. Cleanup  

 

G.4.8 Double-click proc_prof. Profile proc_prof moves to the 
Available Profiles panel. 

Cleanup 

 

 

G.4.9 Click Submit. A Status Summery dialog box appears 
indicating user secman was modified. 

Cleanup 

 

 

G.4.10 Click OK to clear the Status Summary. Control returns to the Account and 
Profile Manager dialog box. 

Cleanup 
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G.4.11 In the Account and Profile Manager dialog 
box, click Profiles. 

The Profiles tab is displayed. Cleanup 

 

 

G.4.12 Select proc_prof. proc_prof is highlighted. Cleanup 

 

G.4.13 Select Edit > Delete. A Confirm window prompts for 
confirmation. 

Cleanup 

 

G.4.14 Click Yes. A Status Summary window appears 
indicating the Profile was successfully 
deleted. 

Cleanup 

 

G.4.15 Click OK. Control returns to the Account and 
Profile Manager dialog box. The 
entry for proc_prof has been removed 
from the Profiles tab. 

Cleanup 

 

G.4.16 Click EXIT in the CDE Menu Bar. The Logout Confirmation window 
appears. 

Cleanup 

 

G.4.17 Click OK. The DII COE LOGIN screen appears. Cleanup 

 

G.4.18 Login as sysadmin. The desktop appears. Cleanup 
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G.4.19 Select Applications > Application Manager 
> DII_APPS > SysAdm. 

The Application Manager – 
SysAdm window appears. 

NOTE:  If SA Default profile is not 
selected, then select it with the Profile 
Selector. 

Cleanup 

G.4.20 Double-click Segment Installer. 

 

The Installer window appears. Cleanup 

G.4.21 In the Installer window, select Processes Test 
Segment in the Currently Installed 
Segments field. 

Processes Test Segment in the 
Currently Installed Segments 
field is highlighted. 

Cleanup 

G.4.22 Click Deinstall Software. 

 

An ENTER A PASSWORD dialog box 
appears. 

Cleanup 

G.4.23 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Cleanup 

 

G.4.24 Click OK. The following dialog box appears: 
Do you really want to remove 
the segments? 

Processes Test Segment 

Cleanup 
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G.4.25 Click Yes. The working box may be blank, or the 
following dialog box will appear: 
Segment deinstallation in 
progress... 

The Installer window returns to the 
forefront. 

Cleanup 

G.4.26 When removal is complete, check the Currently 
Installed Segments field. 

Processes Test Segment is no 
longer listed in the Currently 
Installed Segments field. 

Cleanup 

G.4.27 Open a Terminal window. A Terminal window appears. Cleanup 

 

G.4.28 At the command prompt type  
su 

The Password prompt appears. Startup 

G.4.29 Enter the root password. The command prompt returns. Startup 

 

G.4.30 At the command prompt type  
csh 

The command prompt returns. Startup 

G.4.31 In the Terminal window, at the command prompt, type 
rm /tmp/PROC* 

The command prompt returns. Cleanup 
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H 4.8 Verify Segment Installer Will Process Conflicts Descriptor 

H.1 Install Conflicts Test Segment On the Candidate Platform (kpccp)  

H.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Setup 

H.1.2 In the Device field, click DISK. The DISK option is selected and the 
Select File dialog box appears. 

Setup 

H.1.3 In the Selection text box type 
/kpc/si/conflicts.tar 

/kpc/si/conflicts.tar appears in 
the text box. 

Setup 

H.1.4 Click OK. The Select File and Select 
Source dialog boxes disappear. 

Setup 

H.1.5 Click Read Contents. In the Installer window, Conflicts 
Test Segment is listed under Select 
Software To Install. 

Setup 

H.1.6 Select Conflicts Test Segment. 

 

Conflicts Test Segment is 
highlighted and the Disk column in the 
Select Software To Install field 
displays /h. 

Setup 
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H.1.7 Click Install. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the 
forefront and shows Conflicts Test 
Segment listed under Currently 
Installed Segments. 

Setup 

H.1.8 In the Installer window, select Conflicts Test 
Segment in the 
Currently Installed Segments field. 

Conflicts Test Segment in the 
Currently Installed Segments 
field is highlighted. 

Setup 

H.1.9 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove 
the segments? 

Conflicts Test Segment 

Setup 

H.1.10 Click Yes. The following dialog box appears: 
Segment deinstallation in 
progress... 

The Installer window returns to the 
forefront. 

Setup 
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H.1.11 When removal is complete, check both the Currently 
Installed Segments field and the 
Select Software To Install field. 

Conflicts Test Segment is no 
longer listed in the Currently 
Installed Segments field. 

An asterisk (*) no longer appears next to 
Conflicts Test Segment in the 
Select Software To Install 
field. 

Setup 

H.1.12 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Setup 

H.1.13 In the Device field, click DISK. The DISK option is selected and the 
Select File dialog box appears. 

Setup 

H.1.14 In the Filter box type: 
/kpc/si/* 

In the Files list box select 
segx.tar 

segx.tar is highlighted. Setup 

H.1.15 Click OK. The Select File and Select 
Source dialog boxes disappear. 

Setup 

H.1.16 Click Read Contents. In the Installer window, Test 
Segment segx is listed under Select 
Software To Install. 

Setup 
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H.1.17 Select Test Segment segx. Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/h. 

Setup 

 

H.1.18 Click Install. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the 
forefront and shows Test Segment 
segx listed under Currently 
Installed Segments. 

Setup 

H.1.19 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Setup 

H.1.20 In the Device field, click DISK. The DISK option is selected and the 
Select File dialog box appears. 

Setup 

H.1.21 In the Files list box select 
conflicts.tar 

conflicts.tar is highlighted. Setup 

H.1.22 Click OK. The Select File and Select 
Source dialog boxes disappear. 

Setup 

H.1.23 Click Read Contents. In the Installer window, Conflicts 
Test Segment is listed under Select 
Software To Install. 

Setup 
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H.1.24 Select Conflicts Test Segment. 

 

Conflicts Test Segment is 
highlighted and the Disk column in the 
Select Software To Install field 
displays /h. 

Setup 

H.1.25 Click Install. The following dialog box appears: 
A conflicting segment of 
Conflicts Test Segment was 
found on disk 

Circle one:  PASS / FAIL 

 

 

H.1.26 Click OK. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the 
forefront and does not show Conflicts 
Test Segment listed under 
Currently Installed Segments 
field. 

Circle one:  PASS / FAIL 

 

 

I 4.9 Verify Segment Installer Will Process Requires Descriptor 
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I.1 Install Requires Test Segment and Test Segment segy On the Candidate Platform 
(kpccp) 

 

I.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Setup 

I.1.2 In the Device field, click DISK. The DISK option is selected and the 
Select File dialog box appears. 

Setup 

I.1.3 In the Files list box select 
req_segy.tar 

req_segy.tar is highlighted. Setup 

I.1.4 Click OK. The Select File and Select 
Source dialog boxes disappear. 

Setup 

I.1.5 Click Read Contents. The following segments appear in the 
Select Software To Install 
field: 
Test Segment segy 

Requires Test Segment 

Setup 

I.1.6 Select the following segment: 
Requires Test Segment 

Requires Test Segment is 
highlighted. 

Test Segment segy is not 
highlighted. 

Setup 
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I.1.7 Click Install. The following dialog box appears: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Requires Test 
Segment’ 

Circle one:  PASS / FAIL 

 

 

I.1.8 When installation is complete, check both the 
Currently Installed Segments field and the 
Select Software To Install field. 

Requires Test Segment and Test 
Segment segy are listed in the 
Currently Installed Segments 
field: 

An asterisk (*) appears next to Requires 
Test Segment and Test Segment 
segy in the Select Software To 
Install field. 

Circle one:  PASS / FAIL 
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I.2 Deinstall Requires Test Segment, Test Segment segy, and Test Segment segx On 
the Candidate Platform (kpccp) 

 

I.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Installer window, select the following in the 
Currently Installed Segments field: 
Requires Test Segment 
Test Segment segy 
Test Segment segx 

The three segments in the 
Currently Installed Segments 
field are highlighted. 

Setup 

I.2.2 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove 
the segments? 

Requires Test Segment 
Test Segment segy 
Test Segment segx 

Setup 

I.2.3 Click Yes. The following dialog box appears: 
Segment deinstallation in 
progress... 

The Installer window returns to the 
forefront. 

Cleanup 
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I.2.4 When removal is complete, check the Currently 
Installed Segments field. 

The following segments are no longer listed 
in the 
Currently Installed Segments 
field: 
Requires Test Segment 
Test Segment segy 
Test Segment segx 

Cleanup 

I.3 Verify Requires Test Segment Will No Longer Install On the Candidate Platform (kpccp)  

I.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Select Software to Install field, select 
the following segment: 
Requires Test Segment 

Requires Test Segment is 
highlighted. 

Test Segment segy is not 
highlighted. 

Circle one:  PASS / FAIL 

 

 

I.3.2 Click Install. The following dialog boxes appear in 
sequence: 
Please wait...extracting the 
disk file with the selected 
segment: ‘Requires Test 
Segment’ 

Circle one:  PASS / FAIL 
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I.3.3 When installation is complete, check both the 
Currently Installed Segments field and the 
Select Software To Install field. 

Requires Test Segment should not 
be listed in the Currently Installed 
Segments field: 

An asterisk (*) should not appear next to 
Requires Test Segment in the 
Select Software To Install 
field: 

Circle one:  PASS / FAIL 

 

 

I.3.4 Click Exit. The Installer window disappears. Circle one:  PASS / FAIL 

 

 

J 4.10 Network Installation Server / Network Installation Server Testing - Verify Feature Availability 

J.1 Network Installation Server / Network Installation Server - Main Window  

J.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost) and Candidate Platform (kpccp). 

 

In the Application Manager – SysAdm window, 
double-click Network Installation Server. 

The Network Installation 
Server window appears. 

Circle one:  PASS / FAIL 

 

  

J.1.2 Examine the Network Installation Server 
windows on each platform. 

Size, shape, color and textural information 
on the Candidate Platform is similar to the 
Validation Host.   

Circle one:  PASS / FAIL 
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J.1.3 NOTE: Perform the following steps on the Candidate 
Platform (kpccp) 

Verify at the top of the screen, the following pull-down 
menus and their contents: 
File 
Source 
Installed  
Contents  
Help (Grayed Out) 

 

NOTE:  Each of these Menu Items/Functions are 
duplicates of buttons on the main screen and either choice 
produces the same results. 

The menu items are present and contain: 
File –      Load 
            Exit  

Source -    Select Source 
            Read Contents 

Installed – Release Notes 
            Deinstall 
Software 
            View Installation 
Log 

Contents -  Release Notes 
            Required Software 
            Conflicting 
Software 

Help -      (No Action) 

Circle one:  PASS / FAIL 

 

 

J.1.4 Resize the Network Installation Server 
window. 

The Network Installation 
Server window resizes both larger and 
smaller.  

Circle one:  PASS / FAIL 

 

 

J.1.5 Minimize the Network Installation Server 
window by clicking the dot in the right corner of the title 
bar. 

The Network Installation 
Server window iconifies to the top left 
corner of the screen. 

Circle one:  PASS / FAIL 
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J.1.6 Restore the Network Installation Server 
window by double-clicking on the Installer icon. 

The Network Installation 
Server window restores to its previous  
state. 

Circle one:  PASS / FAIL 

 

 

J.1.7 Relocate the Network Installation Server 
window. 

The Network Installation 
Server window relocates anywhere on the 
screen. 

Circle one:  PASS / FAIL 

 

 

J.1.8 Double-click the upper left corner of the Network 
Installation Server window. 

The Network Installation 
Server window disappears. 

Circle one:  PASS / FAIL 

 

 

J.1.9 In the Application Manager – SysAdm window, 
double-click Network Installation Server.  

The Network Installation 
Server window appears. 

Circle one:  PASS / FAIL 

 

 

J.2 Source Area - Verify Buttons and Fields Are Present On the Candidate Platform (kpccp)  

J.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Verify the following Source fields are present: 

Host: 
Device: 

All fields are present. Circle one:  PASS / FAIL 

 

 

J.2.2 Verify the following buttons are present: 
Select Source 
Read Contents 

All buttons are present. Circle one:  PASS / FAIL 
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J.2.3 Verify information presented in the fields is correct: 

Host:  LOCAL  kpccp 
Device: DAT  

The display reflects the current 
configuration. 

Circle one:  PASS / FAIL 

 

 

J.3 Select Source - Verify the Functionality Of the Select Source Window; Select  Each Option On the 
Candidate Platform (kpccp) 

 

J.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Click Select Source. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

J.3.2 Verify the following radio buttons are present: 

Host:                       Device: 
LOCAL         DISK      EXABYTE 
REMOTE        DAT       OTHER 
              CD-ROM 

All radio buttons are present and LOCAL 
and DAT are selected. 

NOTE: Only certain combination work. 

LOCAL - ALL   
REMOTE � DAT, EXABYTE, OTHER  

NOTE:  DISK and CD-ROM are accessible 
from a remote device if shared and 
mounted. 

Circle one:  PASS / FAIL 

 

 

J.3.3 In the Host field, verify LOCAL is selected. LOCAL is selected. Circle one:  PASS / FAIL 

 

 

J.3.4 In the Device field, select DISK. 

 

The Select File window appears. Circle one:  PASS / FAIL 
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J.3.5 Verify the existence of the following four sections: 
Filter 
Directories 
Files 
Selection 

Each of these sections is present.  The 
filtering section at the top can be used to 
find a particular file. 

Circle one:  PASS / FAIL 

 

 

J.3.6 Verify the existence of four buttons at the bottom of the 
Select File window: 

OK, Filter, Cancel, Help 

All buttons are present. Circle one:  PASS / FAIL 

 

 

J.3.7 Click Cancel. The Select File window disappears. Circle one:  PASS / FAIL 

 

 

J.3.8 Click OK. The Select Source window 
disappears and the Network 
Installation Server window 
reappears. 

Circle one:  PASS / FAIL 

 

 

J.3.9 Verify the information presented in the following fields is 
correct: 

Host:  LOCAL  kpccp 
Device: DISK 

The display reflects the tester�s selections. Circle one:  PASS / FAIL 

 

 

J.3.10 Click Select Source. The Select Source window appears. Circle one:  PASS / FAIL 
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J.3.11 In the Host field, verify LOCAL is selected. 

 

LOCAL is selected. 

 

Circle one:  PASS / FAIL 

 

 

J.3.12 In the Device field, select CD-ROM. The Select File window appears. Circle one:  PASS / FAIL 

 

 

J.3.13 Verify the existence of the following four sections: 
Filter 
Directories 
Files 
Selection 

Each of these sections is present.  The 
filtering section at the top can be used to 
find a particular file. 

Circle one:  PASS / FAIL 

 

 

J.3.14 Verify the existence of four buttons at the bottom of the 
Select File window: 

OK, Filter, Cancel, Help 

All buttons are present. 
 

Circle one:  PASS / FAIL 

 

 

J.3.15 Click Cancel. The Select File window disappears. Circle one:  PASS / FAIL 

 

 

J.3.16 In the Select Source window under Device, Select 
EXABYTE. 

EXABYTE is selected. Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 140 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

J.3.17 In the Select Source window under Device, select 
Other. 

A text box appears for manually entering a 
device. 

Circle one:  PASS / FAIL 

 

 

J.3.18 Enter the device path in the text box, e.g., 
/dev/rmt/0mn. 

The device path appears in the text box. Circle one:  PASS / FAIL 

 

 

J.3.19 Click OK. The Network Installation 
Server window appears and the Source 
field displays:  

Host:  LOCAL kpccp 
Device: <device path> 

where <device path> is the device file 
entered in the previous step, e.g., 
/dev/rmt/0mn 

Circle one:  PASS / FAIL 

 

 

J.3.20 Click Select Source. The Select Source window appears. Circle one:  PASS / FAIL 

 

 

J.3.21 In the Select Source window under Device, click 
DAT. 

The DAT radio button is selected. Circle one:  PASS / FAIL 
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J.3.22 Click OK. The Network Installation 
Server window appears and the Source 
field displays:  

Host:  LOCAL  kpccp 
Device: DAT 

Circle one:  PASS / FAIL 
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J.4 Available Disks Panel Display On the Candidate Platform (kpccp)  

J.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Verify the Available Disks field displays the 
following columns: 
Disk   Actual   Available   Selected   
Reserved 

Verify the button Reserved Space is greyed out. 

  Disk      Actual    Available    Selected    
Reserved 

  /h 
  /home1   8.56MB    6.85MB     0.0 MB    
1.71MB 
  

                                          [ Reserved 
Space ] 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

Circle one:  PASS / FAIL 

 

 

J.5 Available Disks  - Reserved Space  -  Override Disk Space Allocation Window On the Candidate 
Platform (kpccp) 

 

J.5.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Select partition /home1 from the Available Disks 
field. 

/home1 is highlighted. 

 

Circle one:  PASS / FAIL 

 

 

J.5.2 Click Reserved Space under Available Disks. An Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 
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J.5.3 Verify the default value of Override Disk Space 
Limits. 

 

Default reads 80%. 

 

Circle one:  PASS / FAIL 

 

 

J.5.4 Click on the Override Disk Space Limits 
button to show the pull-down menu. 

 

The Override Disk Space Limits 
are: 

80% (selected by default) 
90% 
95% 
99% 

Circle one:  PASS / FAIL 

 

 

J.5.5 Select 90%. The Override Disk Space Limits 
selection changes to 90%.  

 

Circle one:  PASS / FAIL 

 

 

J.5.6 Verify Clear and Set to Default box is not 
selected. 

 

Clear and Set to Default box is 
not selected. 

 

Circle one:  PASS / FAIL 

 

 

J.5.7 Select and deselect the Clear and Set to 
Default box. 

 

The box toggles on and off. Circle one:  PASS / FAIL 

 

 

J.5.8 Click Cancel. The Override Disk Space 
Allocation window disappears and the 
Available Disks values remain 
unchanged. 

Circle one:  PASS / FAIL 
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J.5.9 Click Reserved Space under Available Disks. An Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 

 

 

J.5.10 Click on the Override Disk Space Limits arrow 
to show the pull-down menu. 

 

The Override Disk Space Limits 
pull-down menu appears. 

 

Circle one:  PASS / FAIL 

 

 

J.5.11 Select 99%. 

 

The Override Disk Space Limits 
selection changes to 99%.  

 

Circle one:  PASS / FAIL 

 

 

J.5.12 Click OK. The Available Disks field displays 
the  

 following approximate values: 

   Disk      Actual    Available    Selected    
Reserved 

  /home1   8.56MB    8.47MB     0.0 MB    
0.09MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

Circle one:  PASS / FAIL 

 

 

J.5.13 Click Reserved Space under Available Disks. An Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 
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J.5.14 Verify Override Disk Space Limits selection 
is returned to 80%.   

The Override Disk Space Limits 
selection is returned to 80%. 

Circle one:  PASS / FAIL 

 

 

J.5.15 Click OK. The Available Disks field displays 
the  

 following approximate values: 

  Disk      Actual    Available    Selected    
Reserved 

  /home1   8.56MB    6.85MB     0.0 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

Circle one:  PASS / FAIL 
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J.6 Available Disks  -  Verify the Information Presented For Actual Disk Size Is Correct On the 
Candidate Platform (kpccp) 

 

J.6.1 In the Terminal window, at the command prompt type 
df -k 

The /home1 disk space information is 
listed as follows: 

Kbytes   used    available     Mounted on 

 9751        61        8715           /home1 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

Setup 

 

 

J.6.2 To verify the disk space values shown under 
Available Disks, /home1, perform the following 
calculations: 

Actual = avail(df -k) / 1024 

Reserved = kbytes(df -k) * .9 * .2/1024 

Available = Actual - Reserved 

Results are within 10 K of the values listed 
under Available Disks.  Values 
listed in the Network Installation 
Server main window concur. 

Actual     = 8.56MB 

Reserved = 1.71MB 

Available = 8.56 � 1.71 = 6.85MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

Circle one:  PASS / FAIL 

 

Actual:___________ 

Reserved:_________ 

Available:_________ 

 

J.6.3 In the Source field of the Network Installation 
Server window, click Select Source. 

The Select Source window appears. Circle one:  PASS / FAIL 
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J.6.4 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

J.6.5  In the Filter text box type  
 /kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

J.6.6 In the Files field, double-click bigseg.tar. The Select File window disappears. 
The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

J.6.7 Click Read Contents. The Network Installation 
Server window returns with Big Test 
Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

J.6.8 Select Big Test Segment in the Select 
Software to Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it.  The Selected column in 
the  Available Disks field changes 
from 0.0MB to 0.10MB. 

Circle one:  PASS / FAIL 

 

 

J.6.9 At the bottom of the Network Installation 
Server window, click Load. 

An ENTER A PASSWORD dialog box 
appears asking for the master APM 
authentication key. 

Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 148 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

J.6.10 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.6.11 Click OK. Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Load field. Big Test 
Segment appears in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 

 

 

J.6.12 Verify the  Available Disks, /home1 field values 
have changed. 

 The Available Disks field displays 
the  

 following approximate values: 

Disk       Actual      Available    Selected    
Reserved 

 /home1   8.40MB    6.69MB     0.0 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration. 

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 

 

 

J.6.13 In the Segments Currently Loaded On This 
Network Server field, select Big Test 
Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 
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J.6.14 Select Deinstall Software. A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment  

Circle one:  PASS / FAIL 

 

 

J.6.15 Click Yes. Big Test Segment deinstalls correctly 
and is no longer preceded by an * in the 
Select Software To Load field. 
Big Test Segment no longer appears 
in the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

J.7 Available Disks - Reserve Space 99% � Verify Segment Load On the Candidate Platform (kpccp)  

J.7.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp).  

In the  Terminal window, at the command prompt type 
mkfile 4m /home1/fillspace 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the Observed 
Result column. 

 The command prompt returns.     Setup 

 

 

J.7.2 In the Available Disks field click Reserved 
Space. 

The Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 
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J.7.3 Change the Override Disk Space Limits value 
from 80% to 99%.   

The 99% toggle is selected. Circle one:  PASS / FAIL 

 

 

J.7.4 Click OK. 

 

 The Available Disks field displays 
the  

 following approximate values: 

  Disk      Actual    Available    Selected    
Reserved 

 /home1   4.55MB   4.47MB     0.0 MB    
0.09MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

Circle one:  PASS / FAIL 

 

 

J.7.5 Select Big Test Segment in the Select 
Software to Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. The Selected column in 
the Available Disks field changes 
from 0.0MB to 0.10MB. 

Circle one:  PASS / FAIL 
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J.7.6 At the bottom of the Network Installation 
Server field click Load. 

 Big Test Segment loads correctly and 
is preceded by an * in the Select 
Software To Load field. Big Test 
Segment appears in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 

 

 

J.7.7 In the Available Disks field verify the  /home1 
values have changed. 

 The Available Disks field displays 
the  

 following approximate values: 

  Disk      Actual      Available    Selected   
Reserved 

/home1   4.45MB     4.37MB      0.0 MB    
0.09MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 

 

 

J.7.8 In the Segments Currently Loaded On This 
Network Server field, select Big Test Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 
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J.7.9 Click Deinstall Software. 

 

A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 

 

 

J.7.10 Click Yes. Big Test Segment deinstalls correctly 
and is no longer preceded by an * in the 
Select Software To Load field. 
Big Test Segment no longer appears 
in the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 
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J.8 Available Disks - No Space � Verify Segment Load Roll Over On the Candidate Platform (kpccp)  

J.8.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Available Disks field, click Reserved 
Space. 

 

The Override Disk Space 
Allocation window appears. 

Circle one:  PASS / FAIL 

 

 

J.8.2 Click OK.    The Available Disks field displays 
the  

 following approximate values: 

 Disk      Actual    Available    Selected    
Reserved 

/home1   4.55MB    2.84MB     0.0 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

Circle one:  PASS / FAIL 

 

 

J.8.3 Select Big Test Segment in the Select 
Software To Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it.   

A Warning window appears stating that 
available disk space is not enough and the 
disk will be switched to next available disk. 

Circle one:  PASS / FAIL 
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J.8.4 Click OK in the Warning window. 

 

The Warning window disappears. Circle one:  PASS / FAIL 

 

 

J.8.5 At the bottom of the Network Installation 
Server field, click Load. 

 

Big Test Segment loads correctly and 
is preceded by an * in the Select 
Software To Load field. Big Test 
Segment appears in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 

 

 

J.8.6 In the Available Disks field, verify /home1 
values have remained the same and the segment loaded on 
/h (or the first available disk partition). 

 The Available Disks field displays 
the  

 following approximate values: 

Disk      Actual    Available    Selected    
Reserved 

/home1   4.45MB    2.79MB    0.00 MB    
1.71MB 

NOTE: These values are approximate 
values and may vary slightly depending on 
the disk configuration.  

NOTE: See Known Problems 1 in the 
preamble of this procedure. 

Circle one:  PASS / FAIL 
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J.8.7 In the Segments Currently Loaded On This 
Network Server field, select Big Test Segment. 

 

Big Test Segment is highlighted. 

 

Circle one:  PASS / FAIL 

 

  

 

 

J.8.8 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 

 

 

J.8.9 Click Yes. Big Test Segment deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field. Big Test Segment no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 

 

 

J.8.10 Click Exit. The Network Installation 
Server window disappears. 

Circle one:  PASS / FAIL 
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J.9 Available Disks - No Space � Verify Segment Installation Failure On the Candidate Platform 
(kpccp) 

 

J.9.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window at the command prompt type   
cd /  

The command prompt returns. Setup 

 

 

J.9.2 At the command prompt type 
mv /home2 /newhome2  

The command prompt returns. Setup 

 

 

J.9.3 At the command prompt type 
mkfile 950m /h/fillspace 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the Observed 
Result column. 

NOTE: The file size parameter may vary, depending on 
the size of the /h partition. Create a file large enough to 
fill the /h partition up to at least 85%. 

NOTE: The command may take a few 
moments to complete. 

The command prompt returns. 

Setup 

 

 

J.9.4 In the Application Manager – SysAdm 
window, double-click Network Installation 
Server. 

The Network Installation 
Server window appears. 

Circle one:  PASS / FAIL 
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J.9.5 Click Select Source in the Source field. The Select Source window appears. Circle one:  PASS / FAIL 

 

 

J.9.6 In the Device field, click DISK. 

 

The Select File window appears. Circle one:  PASS / FAIL 

 

 

J.9.7 In the Filter text box type  
/kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

J.9.8 In the Files field, double-click bigseg.tar Control returns to the Network 
Installation Server window. 

Circle one:  PASS / FAIL 

 

 

J.9.9 In the Available Disks field, select /home1. /home1 is highlighted. Circle one:  PASS / FAIL 

 

 

J.9.10 In the Source field, click Read Contents. The Network Installation 
Server window reappears with Big 
Test Segment under the Select 
Software To Load field. 

Circle one:  PASS / FAIL 
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J.9.11 Select Big Test Segment in the Select 
Software To Load field. 

A Warning window appears stating that 
available disk space is not enough. You 
may increase the available disk space using 
the Reserved Space Override. 

Circle one:  PASS / FAIL 

 

 

J.9.12 Click OK. The Warning window disappears. Control 
returns to the Network Installation 
Server window. 

Circle one:  PASS / FAIL 

 

 

J.9.13 Click Exit. The Network Installation 
Server window disappears. 

Circle one:  PASS / FAIL 

 

 

J.9.14 At the command prompt type 
mv /newhome2 /home2 

The command prompt returns. Cleanup 

J.9.15 At the command prompt type 
rm /h/fillspace /home1/fillspace 

The command prompt returns. Cleanup 
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J.10 Segments Currently Loaded On This Network Server Window On the Candidate 
Platform (kpccp) 

 

J.10.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Applications Manager – SysAdm 
window, double-click Network Installation 
Server. 

The Network Installation 
Server window appears. 

Circle one:  PASS / FAIL 

 

 

J.10.2 Verify that the following characteristics appear: 

The Release Notes button is grayed out. 

The Deinstall Software button is grayed out. 

The Load button is grayed out. 

The Exit button is available for selection.  

The characteristics are displayed as noted. 

 

 

Circle one:  PASS / FAIL 

 

 

J.10.3 In the Network Installation Server window, 
in the Available Disks field, select /home1. 

  

/home1 is highlighted. 

 

Circle one:  PASS / FAIL 

 

 

J.10.4 In the Source field, click Select Source. 

  

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

J.10.5 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 
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J.10.6  In the Filter text box type  
 /kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

J.10.7 In the Files field, double-click bigseg.tar. The Select File window disappears. 
The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

J.10.8 Click Read Contents. The Network Installation 
Server window returns with Big Test 
Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

J.10.9 Select Big Test Segment in the Select 
Software To Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it.  The 
Selected field in the Available 
Disks field changes from 0.0MB to 
0.10MB. 

Circle one:  PASS / FAIL 

 

J.10.10 At the bottom of the Network Installation 
Server window select Load. 

An ENTER A PASSWORD dialog box 
appears asking for the master APM 
authentication key. 

Circle one:  PASS / FAIL 
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J.10.11 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

J.10.12 Click OK. Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Load field. Big Test 
Segment appears in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 

 

 

J.10.13 Select Big Test Segment in the Segments 
Currently Loaded On This Network 
Server field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.   

Circle one:  PASS / FAIL 

J.10.14 Verify that the following characteristics appear: 

The Release Notes button is available for selection 
in the Segments Currently Loaded On This 
Network Server field. 

The Deinstall Software button is available for 
selection. 

The Load button is grayed out. 

The Exit button is available for selection. 

The characteristics are displayed as noted. 

 

Circle one:  PASS / FAIL 
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J.10.15 Click Release Notes. 

 

The Big Test Segment RELEASE 
NOTES are displayed. 

Circle one:  PASS / FAIL 

 

 

J.10.16 Click OK. 

 

The RELEASE NOTES window 
disappears. 

Circle one:  PASS / FAIL 

 

 

J.10.17 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 

 

 

J.10.18 Click Yes. Big Test Segment deinstalls correctly 
and is no longer preceded by an * in the 
Select Software To Load field. 
Big Test Segment no longer appears 
in the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

K 4.11 Local Devices Testing 
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K.1 Verify Network Installation Server Can Read Table of Contents and Load Segments From A 
Local Tape Drive (DAT) On the Candidate Platform (kpccp) 

 

K.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Network Installation Server window, 
click Select Source in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

K.1.2 In the Device field, select DAT. DAT is selected. 

 

Circle one:  PASS / FAIL 

 

 

K.1.3 Click OK. The Network Installation 
Server window reappears and the 
Source field displays:  

Host:  LOCAL  kpccp 

Device: DAT 

Circle one:  PASS / FAIL 

 

 

K.1.4 Insert the Test Segment segx tape into the local 
device. 

The tape drive initializes properly. Circle one:  PASS / FAIL 

 

 

K.1.5 In the Source field, click Read Contents. The Network Installation 
Server reads the Table of Contents.  
When complete, the Network 
Installation Server displays Test 
Segment segx in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 
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K.1.6 In the Available Disks field, select /h. /h is highlighted. Circle one:  PASS / FAIL 

 

 

K.1.7 Select Test Segment segx. Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Load field displays /h.  
If it doesn�t, deselect the segment and 
reselect it. 

Circle one:  PASS / FAIL 

 

 

K.1.8 Click Release Notes. The RELEASE NOTES window appears 
with the following header fields: 
Name: Test Segment segx 

Version: 1.2.3.4 

This segment is used when 
testing Segment Installer. 

Circle one:  PASS / FAIL 

 

 

K.1.9  Click OK. The RELEASE NOTES window 
disappears. 

Circle one:  PASS / FAIL 
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K.1.10 In the Select Software To Load field, click 
Requires. 

The REQUIRED SEGMENTS window 
appears with the following header fields: 
NAME: Test Segment segx 

VERSION: 1.2.3.4 

NAME                     
VERSION 

COE Component Parent      
4.0.0.0 

Circle one:  PASS / FAIL 

 

 

K.1.11  Click OK. The REQUIRED SEGMENTS window 
disappears. 

Circle one:  PASS / FAIL 

 

 

K.1.12 In the Select Software To Load field, click 
Conflicts. 

The CONFLICTING SEGMENTS window 
appears with the following header fields: 
NAME: Test Segment segx 

VERSION: 1.2.3.4 

NAME                     
VERSION Dummy Conflict 
Segment    (blank) 

Circle one:  PASS / FAIL 

 

 

K.1.13  Click OK. The CONFLICTING SEGMENTS window 
disappears. 

Circle one:  PASS / FAIL 
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K.1.14 Click Load. Test Segment segx loads accordingly 
under /h. Once loaded, it appears under 
the Select Software To Load field 
marked by an asterisk and is listed under 
the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

K.2 Verify Segment Loads and Deinstalls Correctly On the Candidate Platform (kpccp)  

K.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log window appears. 

 

Circle one:  PASS / FAIL 

 

 

K.2.2 Verify the segment loaded correctly. The Install Log indicates:  
Test Segment segx 1.2.3.4 
successfully loaded on the 
kpccp Network Server. 

Circle one:  PASS / FAIL 

 

 

K.2.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

K.2.4 In the Terminal window, at the command prompt, type  
ls /h/NET_SERVER 

The contents of the directory is listed with:  
segx:SOFTWARE:1.2.3.4:ALL 

Circle one:  PASS / FAIL 
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K.2.5 In the Network Installation Server window, 
verify Test Segment segx is listed under 
Segments Currently Loaded On This 
Network Server. 

Test Segment segx is listed. Circle one:  PASS / FAIL 

 

 

K.2.6 Under Segments Currently Loaded On This 
Network Server field select Test Segment segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

K.2.7 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

K.2.8 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 

 

 

K.2.9 On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log window indicates:  
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 
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K.2.10 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

K.3 Load A Segment To An Alternate Location  On the Candidate Platform (kpccp)  

K.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

 

In the Available Disks field, select  /home1. 

/home1 is highlighted. Circle one:  PASS / FAIL 

 

 

K.3.2 In the Select Software to Load field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 

K.3.3 Click Load. Test Segment segx loads accordingly 
under /home1.  Once loaded, it appears 
under Select Software To Load 
marked by an asterisk and is listed under 
Segments Currently Loaded On 
This Network Server. 

Circle one:  PASS / FAIL 
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K.4 Verify Successful Load Of Test Segment segx On the Alternate Location On the Candidate 
Platform (kpccp) 

 

K.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window, at the command prompt, type  
ls /home1/NET_SERVER 

The contents of the directory is listed with:  
segx:SOFTWARE:1.2.3.4:ALL 

Circle one:  PASS / FAIL 

 

 

K.4.2 In the Network Installation Server window, 
select Test Segment segx in the Segments 
Currently Loaded On This Network 
Server field. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

K.4.3 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

K.4.4 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 
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K.5 Verify Network Installation Server  Can Read Table Of Contents and Load Segments From A 
Local CD-ROM Drive On the Candidate Platform (kpccp) 

 

K.5.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Insert the KPC Test Data CD-ROM into the CD-
ROM drive. 

The CD-ROM is inserted. Circle one:  PASS / FAIL 

 

 

K.5.2 In the Network Installation Server window, 
click Select Source in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

K.5.3 In the Device field, select CD-ROM.  The Select File window appears. Circle one:  PASS / FAIL 

 

 

K.5.4 Enter the following in the Selection text box: 
/cdrom/kpc_4206/segx.tar 

/cdrom/kpc_4206/segx.tar appears 
in the text box. 

Circle one:  PASS / FAIL 

 

 

K.5.5 Click OK. The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 
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K.5.6 In the Source field, click Read Contents. The Network Installation 
Server reads the Table of Contents.  
When complete, the Network 
Installation Server displays the 
Select Software To Load field.  

Circle one:  PASS / FAIL 

 

 

K.5.7 In the Available Disks field, verify /home1 is 
selected. 

/home1 is highlighted. Circle one:  PASS / FAIL 

 

 

K.5.8 In the Select Software To Load field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 

K.5.9 Click Load. Test Segment segx loads accordingly 
under /home1. Once loaded, it appears 
under Select Software To Load 
marked by an asterisk and is listed under 
Segments Currently Loaded On 
This Network Server. 

Circle one:  PASS / FAIL 
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K.6 Verify Segment Loads and Deinstalls Correctly On the Candidate Platform (kpccp)  

K.6.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log window appears. 

 

Circle one:  PASS / FAIL 

 

 

K.6.2 Verify the segment loaded correctly. The Install Log indicates:  
Test Segment segx 1.2.3.4 
successfully loaded on kpccp 
Network Server. 

Circle one:  PASS / FAIL 

 

 

K.6.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

K.6.4 In the Terminal window, at the command prompt, type  
ls /home1/NET_SERVER 

The contents of the directory is listed with:  
segx:SOFTWARE:1.2.3.4:ALL 

Circle one:  PASS / FAIL 

 

 

K.6.5 In the Network Installation Server window, 
verify Test Segment segx is listed under 
Segments Currently Loaded On This 
Network Server. 

Test Segment segx is listed. Circle one:  PASS / FAIL 

 

 

K.6.6 In the Segments Currently Loaded On This 
Network Server field, select Test Segment 
segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 
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K.6.7 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

K.6.8 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 

 

 

K.6.9 On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log window indicates: 
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 

 

 

K.6.10 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

K.6.11 In the Terminal window, at the command prompt, type  
ls /home1/NET_SERVER 

No files are listed. Circle one:  PASS / FAIL 

 

 

K.6.12 At the command prompt type  
eject 

The CD-ROM is ejected. Cleanup  
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K.7 Verify Network Installation Server Can Read Table Of Contents and Load Segments From A 
Local Other Device On the Candidate Platform (kpccp) 

 

K.7.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Network Installation Server window, 
click Select Source in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

K.7.2 In the Device field, click OTHER. OTHER is selected. 

A text box appears for manually entering a 
device path. 

Circle one:  PASS / FAIL 

 

 

K.7.3 In the OTHER text box, enter the device path of the local 
tape drive.  e.g.  /dev/rmt/0mn 

The text box accepts user input. Circle one:  PASS / FAIL 

 

 

K.7.4 Click OK. The Network Installation 
Server window reappears with correct 
information in the Source field. 

Circle one:  PASS / FAIL 

 

 

K.7.5 Ensure the Test Segment segx tape is loaded in the 
local tape drive and that /home1 is selected in the 
Available Disks field. 

The tape is loaded and /home1 is selected. Setup 
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K.7.6 In the Source field, click Read Contents. The Network Installation 
Server reads the Table of Contents.  
When complete, The Network 
Installation Server displays the 
Select Software To Load field. 

Circle one:  PASS / FAIL 

 

 

K.7.7 In the Select Software To Load field, select 
Test Segment segx.  

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 

K.7.8 Click Load. Test Segment segx loads accordingly 
under /home1.  Once loaded, it appears 
under Select Software To Load 
marked by an asterisk and is listed under 
Segments Currently Loaded On 
This Network Server. 

Circle one:  PASS / FAIL 

 

 

K.8 Verify Segment Loads and Deinstalls Correctly On the Candidate Platform (kpccp)  

K.8.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log window appears. 

 

Circle one:  PASS / FAIL 

 

 

K.8.2 Verify the segment loaded correctly. The Install Log indicates:  
Test Segment segx 1.2.3.4 
successfully loaded on kpccp 
Network Server. 

Circle one:  PASS / FAIL 
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K.8.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

K.8.4 In the Terminal window, at the command prompt, type  
ls /home1/NET_SERVER 

The contents of the directory is listed with:  
segx:SOFTWARE:1.2.3.4:ALL 

Circle one:  PASS / FAIL 

 

 

K.8.5 In the Network Installation Server window, 
verify Test Segment segx is listed under 
Segments Currently Loaded On This 
Network Server. 

Test Segment segx is listed. Circle one:  PASS / FAIL 

 

 

K.8.6 In the Segments Currently Loaded On This 
Network Server field, select Test Segment 
segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

K.8.7 Click Deinstall Software. A RESPOND TO THE QUESTION 
dialog box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 
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K.8.8 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 

 

 

K.8.9 On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log window indicates:  
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 

 

 

K.8.10 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

K.8.11 In the Terminal window, at the command prompt, type  
ls /home1/NET_SERVER 

No files are listed. Circle one:  PASS / FAIL 

 

 

K.8.12 At the command prompt type  
mt rewoffl  

 

The tape is ejected. Cleanup 



   

© 2003, The Open Group 
Chapter 5,Page 178 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

K.9 Verify Segments Can Be Read and Load Segments From A Local Tape Drive  
 (Select Source  -  EXABYTE)  Optional test if vendor supports Exabyte drives 
 

 

L 4.12 Remote Device Testing 

L.1 Verify Segments Can Be Read, Installed, and De-installed From A Remote Tape Device  (DAT) 
On the Candidate Platform (kpccp) 

 

L.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Network Installation Server window, 
click Select Source in the Source field.  

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

L.1.2 In the Host field, select REMOTE. REMOTE is selected and a NAME text box 
appears. 

Circle one:  PASS / FAIL 

 

 

L.1.3 Type kpchost in the NAME text box. 

 

kpchost appears in the NAME text box. 

 

Circle one:  PASS / FAIL 

 

 

L.1.4 In the Device field, select DAT. DAT is selected. Circle one:  PASS / FAIL 
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L.1.5 Click OK. The Select Source window 
disappears. In the Source window of the 
Network Installation Server, 
the Host: entry says REMOTE and the 
correct machine name.  Also the Device: 
entry selects the tape device you are using. 

Circle one:  PASS / FAIL 

 

 

L.1.6 Insert the Test Segment segx tape into the remote 
device.  

The tape drive initializes properly. Circle one:  PASS / FAIL 

 

 

L.1.7 In the Source field, click Read Contents. The Network Installation 
Server reads the Table of Contents.  
When complete, The Network 
Installation Server displays the 
Select Software To Load field. 

Circle one:  PASS / FAIL 

 

 

L.1.8 Select Test Segment segx. 

 

Test Segment segx is highlighted 
and the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

  
 

L.1.9 Click Load. The segment loads under /home1. Once 
loaded, it appears under Select 
Software To Load marked by an 
asterisk and is listed under Segments 
Currently Loaded On This 
Network Server. 

Circle one:  PASS / FAIL 
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L.1.10 In the Segments Currently Loaded On This 
Network Server field, select Test Segment 
segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

L.1.11 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

L.1.12 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 

 

 

L.2 Verify Segments Can Be Read, Installed, and De-installed From A Remote OTHER Device On the 
Candidate Platform (kpccp)  

 

L.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the  Network Installation Server window, 
click Select Source in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

L.2.2 In the Host field verify that REMOTE is selected. REMOTE is selected. Circle one:  PASS / FAIL 
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L.2.3 In the Device field, click OTHER. A text box appears to the right of the 
OTHER device selection. 

Circle one:  PASS / FAIL 

 

 

L.2.4 In the OTHER text box, enter the appropriate device path 
for the remote tape drive, e.g., /dev/rmt/0mn. 

/dev/rmt/0mn appears in the text box. Circle one:  PASS / FAIL 

 

 

L.2.5 Click OK. The Select Source window 
disappears. In the Source window of the 
Network Installation Server, 
the Host: entry says REMOTE and the 
correct machine name.  Also the Device: 
entry displays the other device path. 

Circle one:  PASS / FAIL 

 

 

L.2.6 Under Source, click Read Contents. The Network Installation 
Server window will expand down to add 
a Select Software To Load section. 

Circle one:  PASS / FAIL 

 

 

L.2.7 Select Test Segment segx. 

 

Test Segment segx is highlighted 
and the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 
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L.2.8 Click Load. The segment loads under /home1. Once 
loaded, it appears under Select 
Software To Load marked by an 
asterisk and is listed under Segments 
Currently Loaded On This 
Network Server. 

Circle one:  PASS / FAIL 

 

 

L.2.9 In the Segments Currently Loaded On This 
Network Server field, select Test Segment 
segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

L.2.10 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

L.2.11 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 
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L.2.12 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

At the command prompt type  
mt rewoffl  

 

The tape is ejected. Cleanup 

L.3 Verify Segments Can Be Read, Installed, and De-installed From A Remote DISK Drive On the 
Candidate Platform (kpccp) 

 

L.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Network Installation Server window, 
click Select Source, in the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

L.3.2 In the Host field, click REMOTE. REMOTE is selected. Circle one:  PASS / FAIL 

 

L.3.3 Type kpchost in the NAME text box.  kpchost appears in the NAME text box. Circle one:  PASS / FAIL 

 

L.3.4 In the Device field, click DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

L.3.5 In the Filter text box type:  
/kpchostdsk/si/* [r] 

/kpchostdsk/si/* appears in the text 
box. 

Circle one:  PASS / FAIL 
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L.3.6 In the Files field, double-click bigseg.tar. The Select File window disappears.  

The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

L.3.7 Click Read Contents. The Network Installation 
Server window returns with Big Test 
Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

L.3.8 Select Big Test Segment in the Select 
Software to Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it.  The Selected field in the 
Available Disks field changes from 
0.0MB to 0.10MB. 

Circle one:  PASS / FAIL 

 

 

L.3.9 At the bottom of the Network Installation 
Server window, click Load. 

Big Test Segment loads accordingly 
under /home1.  Once loaded, it appears 
under Select Software To Load 
marked by an asterisk and is listed under 
Segments Currently Loaded On 
This Network Server. 

Circle one:  PASS / FAIL 

 

 

L.3.10 In the Segments Currently Loaded On This 
Network Server field, select Big Test Segment. 

Big Test Segment is highlighted. Circle one:  PASS / FAIL 
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L.3.11 Click Deinstall Software. 

 

A RESPOND TO THE QUESTION dialog 
box appears with the message:  
Do you really want to remove 
the segments? 

Big Test Segment 

Circle one:  PASS / FAIL 

 

 

L.3.12 Click Yes. Big Test Segment deinstalls correctly 
and is not preceded by an * in the Select 
Software To Load field.  Big Test 
Segment no longer appears in the 
Segments Currently Loaded On 
This Network Server field. 

Circle one:  PASS / FAIL 

 

  

 

L.3.13 Click Exit. The Network Installation 
Server window disappears. 

Circle one:  PASS / FAIL 

 

 

L.4 Verify Segments Can Be Read and Loaded From A Remote CD-ROM Drive    

L.4.1 NOTE: Perform the following steps on the Validation 
host (kpchost). 

Insert the KPC Test Data CD-ROM into the CD-
ROM drive. 

The CD-ROM is inserted. Setup 

L.4.2 In the Terminal window, at the command prompt type 
share –o ro=kpccp /cdrom/kpc_4206 

The command prompt returns. Circle one:  PASS / FAIL 
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L.4.3 At the command prompt type 
share  

The following text is displayed: 
/kpc ro=kpccp 

/home2 ro,root=kpccp 

/cdrom/kpc_4206 ro=kpccp 

Circle one:  PASS / FAIL 

L.4.4 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window type: 
mount kpchost:/cdrom/kpc_4206 [s] 
/kpchostcdrom 

The command prompt returns. Circle one:  PASS / FAIL 

 

L.4.5 In the Applications Manager – Sys Admin 
window, double click Network Installation 
Server. 

The Network Installation 
Server window appears. 

Circle one:  PASS / FAIL 

 

 

L.4.6 In the Source field, click Select Source. The Select Source window appears. Circle one:  PASS / FAIL 

 

 

L.4.7 In the Host field, select REMOTE. REMOTE is selected and a NAME text box 
appears. 

Circle one:  PASS / FAIL 

 

 

L.4.8 Type kpchost in the NAME text box. 

 

kpchost appears in the NAME text box. 

 

Circle one:  PASS / FAIL 
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L.4.9 In the Device field, click CD-ROM. The Select File window appears. Circle one:  PASS / FAIL 

 

 

L.4.10 Enter the following in the Selection text box: 
/kpchostcdrom/segx.tar 

/kpchostcdrom/segx.tar appears in 
the text box. 

Circle one:  PASS / FAIL 

 

 

L.4.11 Click OK. The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

L.4.12 In the Source field, click Read Contents. The Network Installation 
Server reads the Table of Contents.  
When complete, the Network 
Installation Server displays the 
Select Software To Load field.  

Circle one:  PASS / FAIL 

 

 

L.4.13 In the Available Disks field select /home1. /home1 is highlighted. Circle one:  PASS / FAIL 

 

 

L.4.14 In the Select Software to Load field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home1.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 
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L.4.15 Click Load. An ENTER A PASSWORD dialog box 
appears asking for the master APM 
authentication key. 

Circle one:  PASS / FAIL 

 

 

L.4.16 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

L.4.17 Click OK. Test Segment segx loads accordingly 
under /home1.  Once loaded, it appears 
under Select Software To Load 
marked by an asterisk and is listed under 
Segments Currently Loaded On 
This Network Server. 

Circle one:  PASS / FAIL 

 

L.4.18 In the Segments Currently Loaded On This 
Network Server field, select Test Segment 
segx. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

L.4.19 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 
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L.4.20 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To Load 
field.  Test Segment segx no longer 
appears in the Segments Currently 
Loaded On This Network Server 
field. 

Circle one:  PASS / FAIL 

 

 

L.4.21 Click Exit. The Network Installation 
Server window closes. 

Circle one:  PASS / FAIL 

 

L.5 Cleanup � Eject the CD-ROM on the Validation Host (kpchost)  

L.5.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Terminal window, at the command prompt type  
unshare /cdrom/kpc_4206 

The command prompt returns. Cleanup 

 

L.5.2 At the command prompt type 
share  

The following text is displayed: 
/kpc ro=kpccp 

/home2 ro,root=kpccp 

Cleanup  

L.5.3 At the command prompt type  
eject 

The CD-ROM is ejected. Cleanup  
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L.6 Verify Segments Can Be Read and Load Segments From A Remote Tape Drive  (Select Source  -  
EXABYTE) 
Optional test if vendor supports Exabyte drives 

Circle one:  PASS / FAIL 
 
 

M 4.13 Network Installation Server / Network Installation Server Testing � Load Many Segments 

M.1 Network Installation Server / Network Installation Server - Main Window 
On the Candidate Platform (kpccp) 

 

M.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp) 

In the Application Manager – SysAdm window, 
double-click Network Installation Server. 

The Network Installation 
Server window appears. 

 

Circle one:  PASS / FAIL 

 

 

M.1.2 In the Network Installation Server window, 
select the /home2 partition in the Available Disks 
field. 

/home2 is highlighted. Circle one:  PASS / FAIL 

 

 

M.1.3 In the Source field, click Select Source. 

  

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

M.1.4 In the Host field, verify LOCAL is selected. LOCAL is selected. Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 191 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

M.1.5 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

M.1.6  In the Filter text box type  
 /kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

M.1.7 In the Files field, double-click bigseg.tar. The Select File window disappears. 
The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

M.1.8 In the Source field, click Read Contents. The Network Installation 
Server window returns with Big Test 
Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

M.1.9 Select Big Test Segment in the Select 
Software to Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home2.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 

M.1.10 At the bottom of the Network Installation 
Server window, click Load. 

An ENTER A PASSWORD dialog box 
appears asking for the master APM 
authentication key. 

Circle one:  PASS / FAIL 
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M.1.11 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

M.1.12 Click OK. Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Load field. Big Test 
Segment appears in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 

 

 

M.1.13 In the Source field, click Select Source.  

 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

M.1.14 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

M.1.15 In the Files field, double-click badcpu.tar. The Select File window disappears.  

The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

M.1.16 In the Source field, click Read Contents. The Network Installation 
Server window returns with Bad CPU 
Test Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 
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M.1.17 Select Bad CPU Test Segment in the Select 
Software to Load field. 

Bad CPU Test Segment is 
highlighted and the Disk column in the 
Select Software To Load field 
displays /home2.  If it doesn�t, deselect the 
segment and reselect it. 

Circle one:  PASS / FAIL 

 

 

M.1.18 At the bottom of the Network Installation 
Server window, click Load. 

Bad CPU Test Segment installs 
correctly and is preceded by an * in the 
Select Software To Load field. 
Bad CPU Test Segment appears in 
the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

M.1.19 In the Source field, click Select Source.  

 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

M.1.20 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

M.1.21 In the Files field, double-click community.tar. The Select File window disappears. 
The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 
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M.1.22 In the Source field, click Read Contents. The Network Installation 
Server window returns with Community 
Test Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

M.1.23 Select Community Test Segment in the Select 
Software to Load field. 

Community Test Segment is 
highlighted and the Disk column in the 
Select Software To Load field 
displays /home2.  If it doesn�t, deselect the 
segment and reselect it. 

Circle one:  PASS / FAIL 

 

 

M.1.24 At the bottom of the Network Installation 
Server window, click Load. 

Community Test Segment installs 
correctly and is preceded by an * in the 
Select Software To Load field. 
Community Test Segment appears 
in the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

M.1.25 In the Source field, click Select Source.  

 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

M.1.26 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 
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M.1.27 In the Files field, double-click conflicts.tar. The Select File window disappears.  

The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

M.1.28 In the Source field, click Read Contents. The Network Installation 
Server window returns with Conflicts 
Test Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

M.1.29 Select Conflicts Test Segment in the Select 
Software to Load field. 

Conflicts Test Segment is 
highlighted and the Disk column in the 
Select Software To Load field 
displays /home2.  If it doesn�t, deselect the 
segment and reselect it. 

Circle one:  PASS / FAIL 

 

 

M.1.30 At the bottom of the Network Installation 
Server window, click Load. 

Conflicts Test Segment installs 
correctly and is preceded by an * in the 
Select Software To Load field. 
Conflicts Test Segment appears 
in the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

M.1.31 In the Source field, click Select Source.  

 

The Select Source window appears. Circle one:  PASS / FAIL 
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M.1.32 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

M.1.33 In the Files field, double-click req_segy.tar. The Select File window disappears.  

The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

M.1.34 In the Source field, click Read Contents. The Network Installation 
Server window returns with Requires 
Test Segment and Test Segment 
segy appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

M.1.35 Select Requires Test Segment and Test 
Segment segy in the Select Software To 
Load field. 

Requires Test Segment and Test 
Segment segy are highlighted. 

Circle one:  PASS / FAIL 

 

 

M.1.36 At the bottom of the Network Installation 
Server window, click Load. 

Requires Test Segment and Test 
Segment segy installs correctly and is 
preceded by an * in the Select 
Software To Load field. Requires 
Test Segment and Test Segment 
segy appear in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 
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M.1.37 In the Source field, click Select Source.  

 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

M.1.38 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

M.1.39 In the Files field, double-click segx.tar. The Select File window disappears. 
The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

M.1.40 In the Source field, click Read Contents. The Network Installation 
Server window returns with Test 
Segment segx appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

M.1.41 Select Test Segment segx in the Select 
Software to Load field. 

Test Segment segx is highlighted 
and the Disk column in the Select 
Software To Load field displays 
/home2.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 
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M.1.42 At the bottom of the Network Installation 
Server window, click Load. 

Test Segment segx installs correctly 
and is preceded by an * in the Select 
Software To Load field. Test 
Segment segx appears in the 
Segments Currently Loaded On 
This Network Server field. 

Circle one:  PASS / FAIL 

 

 

M.1.43 In the Source field, click Select Source. The Select Source window appears. Circle one:  PASS / FAIL 

 

 

M.1.44 In the Device field, click DISK. The Select File dialog box appears. Circle one:  PASS / FAIL 

 

 

M.1.45 In the Files field, double-click all_types.tar. The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 
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M.1.46 In the Source field, click Read Contents. 

NOTE: Resize the Network Installation 
Server window to view all segments. 

The following segments appear in the 
Select Software to Load field: 
Sample Aggregate Segment 
Sample Account Group Segment 
Sample COE Child Segment 
Sample COTS Segment 
Sample Data-Global Segment 
Sample Data-Local Segment 
Sample Data-Segment Segment 
Sample Software Segment 
SampleSW.P1 

Circle one:  PASS / FAIL 

 

 

M.1.47 Select all segments in the Select Software To 
Load field. 

All requested segments in the Select   
Software To Load field are 
highlighted. 

Circle one:  PASS / FAIL 

 

 

M.1.48 Click Load. All the selected segments install correctly 
and are preceded by an * in the Select 
Software To Load field. All the 
selected segments appear in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 
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M.2 Verify Segments Loaded Correctly On the Network Installation Server On the 
Candidate Platform (kpccp) 

 

M.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp) 

In the Terminal window at the command prompt type 
cd /home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

M.2.2 At the command prompt type  
ls -l 

The list includes NET_SERVER. Circle one:  PASS / FAIL 

 

 

M.2.3 At the command prompt type  
cd NET_SERVER 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

M.2.4 At the command prompt type 
ls -l 

The list includes the 17 segments listed in 
the Segments Currently Loaded 
On This Network Server field. 

NOTE: Sample Aggregate Child is 
not listed on the Network 
Installation Server. 

Circle one:  PASS / FAIL 

 

 

M.2.5 At the command prompt type 
cd bigseg:SOFTWARE:1.2.3.4:ALL 

The command prompt returns. Circle one:  PASS / FAIL 
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M.2.6 At the command prompt type  
ls -l 

One file and one directory appear:  
SegDescrip 
bigseg:SOFTWARE:1.2.3.4:ALL.t
ar 

Circle one:  PASS / FAIL 

 

 

M.2.7 At the command prompt type 
cd /h/data/global/SysAdm/TOC 

The command prompt returns Circle one:  PASS / FAIL 

 

 

M.2.8 At the command prompt type  
ls -l 

The list includes the 17 segments listed in 
the Segments Currently Loaded 
On This Network Server field. 

Circle one:  PASS / FAIL 

 

 

M.2.9 At the command prompt type 
cd bigseg:SOFTWARE:1.2.3.4:ALL 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

M.2.10 At the command prompt type  
ls -l 

The directory SegDescrip appears.       Circle one:  PASS / FAIL 

 
 

M.2.11 At the command prompt type 
cd SegDescrip 

The command prompt returns Circle one:  PASS / FAIL 
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M.2.12 At the command prompt type 
ls -l 

The following files appear: 
DEINSTALL 
FileAtttribs 
ReleaseNotes 
SegInfo 
SegName 
VERSION 
Validated 
cpp 

Circle one:  PASS / FAIL 

 

 

N Verify  Segment Installer On the Candidate Platform (kpccp) Can Read Table Of Contents and Install 
Segments From the Network Installation Server / Network Installation Server 

N.1 Network Installation Server - Main Window On the Candidate Platform (kpccp)  

N.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Application Manager – SysAdm window, 
double-click Segment Installer. 

The Installer window appears. Circle one:  PASS / FAIL 

 

 

N.1.2 In the Available Disks field, select /h. /h is highlighted and the Disk column in 
the Select Software To Install 
field displays /h.  If it doesn�t, deselect the 
segment and reselect it. 

Circle one:  PASS / FAIL 

 

 

N.1.3 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 
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N.1.4 In the Device field, click NETWORK.  NETWORK is selected. 

 

Circle one:  PASS / FAIL 

 

 

N.1.5 Click OK. The Installer window appears. Circle one:  PASS / FAIL 

 

 

N.1.6 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, the 
Installer displays a Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

N.1.7 In the Select Software to Install field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/h.  If it doesn�t, deselect the segment and 
reselect it. 

Circle one:  PASS / FAIL 

 

 

N.1.8 Click Install. An ENTER A PASSWORD dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

N.1.9 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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N.1.10 Click OK. Test Segment segx installs 
accordingly under /h. Once installed, it 
appears under Select Software To 
Install marked by an asterisk and is 
listed under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

 

 

N.2 Verify Segment Installs and Deinstalls Correctly On the Candidate Platform (kpccp)  

N.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

 

On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window appears. 

 

Circle one:  PASS / FAIL 

 

 

N.2.2 Verify the segment installed correctly. The Install Log indicates:  
Segment (Test Segment segx) 
successfully installed. 

Circle one:  PASS / FAIL 

 

 

N.2.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

N.2.4 At the command prompt type 
ls -l /h/segx 

The directory segx is listed with Integ, 
Scripts, SegDescrip, bin, and data 
subdirectories. 

Circle one:  PASS / FAIL 
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N.2.5 In the Installer window, select Test Segment 
segx in the Currently Installed Segments 
field. 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

 

N.2.6 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

N.2.7 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To 
Install field.  Test Segment segx 
no longer appears in the Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 
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O Verify Segment Installer On the Validation Host (kpchost) Can Read Table of Contents and Install Segments From 
the Network Installation Server / Network Installation Server 

O.1 Segment Installer - Main Window On the Validation Host (kpchost)  

O.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost) 

In the Application Manager – SysAdm window, 
double-click Segment Installer. 

The Installer window appears. Circle one:  PASS / FAIL 

 

 

O.1.2 In the Available Disks field, select /h. /h is highlighted. Circle one:  PASS / FAIL 

 

 

O.1.3 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

O.1.4 In the Device field, click NETWORK.  NETWORK is selected. 

 

Circle one:  PASS / FAIL 

 

 

O.1.5 Click OK. The Installer window appears. Circle one:  PASS / FAIL 
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O.1.6 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, the 
Installer displays a Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

O.1.7 In the Select Software to Install field, select 
Test Segment segx. 

Test Segment segx is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/h.  If it doesn�t, deselect the segment and 
reselect it. 

Circle one:  PASS / FAIL 

 

 

O.1.8 Click Install. An ENTER A PASSWORD dialog box 
appears. 

Circle one:  PASS / FAIL 

 

 

O.1.9 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

 

O.1.10 Click OK. Test Segment segx installs 
accordingly under /h. Once installed, it 
appears under Select Software To 
Install marked by an asterisk and is 
listed under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 
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O.2 Verify Segment Installs and Deinstalls Correctly On the Validation Host (kpchost)  

O.2.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

 

On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window appears. 

 

Circle one:  PASS / FAIL 

 

 

O.2.2 Verify the segment installed correctly. The Install Log indicates:  
Segment (Test Segment segx) 
successfully installed. 

Circle one:  PASS / FAIL 

 

 

O.2.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

O.2.4 At the command prompt type 
ls  -l  /h/segx 

The directory segx is listed with Integ, 
Scripts, SegDescrip, bin, and data 
subdirectories. 

Circle one:  PASS / FAIL 

 

 

O.2.5 In the Installer window, select Test Segment 
segx in the Currently Installed Segments 
field.  

Test Segment segx is highlighted. Circle one:  PASS / FAIL 
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O.2.6 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Test Segment segx 

Circle one:  PASS / FAIL 

 

 

O.2.7 Click Yes. Test Segment segx deinstalls 
correctly and is no longer preceded by an * 
in the Select Software To 
Install field.  Test Segment segx 
no longer appears in the Currently 
Installed Segments field. 

Circle one:  PASS / FAIL 

 

 

O.2.8 On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log indicates:  
Segment (Test Segment segx) 
successfully de-installed. 

Circle one:  PASS / FAIL 

 

 

O.2.9 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

  

 

O.2.10 Click Exit in the bottom menu bar of the Installer 
window. 

The Installer window disappears. Circle one:  PASS / FAIL 
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P 4.14 Network Installation Server / Network Installation Server Testing � Verify Segments Deinstall Correctly 

P.1 Network Installation Server / Network Installation Server - Main Window 
On the Candidate Platform (kpccp) 

 

P.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Segments Currently Loaded On This 
Network Server field of the Network 
Installation Server, select all 16 segments. 

All 16 segments are highlighted. Circle one:  PASS / FAIL 

 

 

P.1.2 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

(16 segments are listed). 

Circle one:  PASS / FAIL 

 

 

P.1.3 Click Yes. The segments de-install and are not listed 
under Segments Currently 
Loaded On This Network Server. 

Note:  A known problem may prevent the 
last segment in the list from being unloaded.  
If this occurs, select the remaining segment 
and unload it.  This is not a failure of this 
step 

Circle one:  PASS / FAIL 
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P.1.4 On the Network Installation Server menu bar, 
select Installed > View Installation Log. 

The Install Log indicates:  

(all test segments) successfully de-
installed. 

Circle one:  PASS / FAIL 

 

 

P.1.5 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

  

 

P.1.6 Click Exit in the bottom menu bar of the Network 
Installation Server. 

The Network Installation 
Server window disappears. 

Circle one:  PASS / FAIL 

 

 

Q 4.15 Network Installation Server / Network Installation Server Testing � Load Segment 

Q.1 Network Installation Server / Network Installation Server - Main Window 
On the Validation Host (kpchost) 

 

Q.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Network Installation Server window, 
select the /home2 partition in the Available Disks 
field. 

/home2 is highlighted. Circle one:  PASS / FAIL 

 

 

Q.1.2 In the Source field click Select Source. 

  

The Select Source window appears. Circle one:  PASS / FAIL 
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Q.1.3 In the Host field, verify LOCAL is selected. LOCAL is selected. Circle one:  PASS / FAIL 

 

 

Q.1.4 In the Device field, select DISK. The Select File window appears. Circle one:  PASS / FAIL 

 

 

Q.1.5  In the Filter text, box type  
 /kpc/si/* [r] 

/kpc/si/* appears in the text box. Circle one:  PASS / FAIL 

 

 

Q.1.6 In the Files field, double-click bigseg.tar. The Select File window disappears. 
The Network Installation 
Server window reappears. 

Circle one:  PASS / FAIL 

 

 

Q.1.7 In the Source field, click Read Contents. The Network Installation 
Server window returns with Big Test 
Segment appearing in the Select 
Software To Load field. 

Circle one:  PASS / FAIL 

 

 

Q.1.8 Select Big Test Segment in the Select 
Software To Load field. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Load field displays 
/home2.  If it doesn�t, deselect the segment 
and reselect it. 

Circle one:  PASS / FAIL 

 

 



   

© 2003, The Open Group 
Chapter 5,Page 213 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

Q.1.9 At the bottom of the Network Installation 
Server window, click Load. 

Big Test Segment installs correctly 
and is preceded by an * in the Select 
Software To Load field. Big Test 
Segment appears in the Segments 
Currently Loaded On This 
Network Server field. 

Circle one:  PASS / FAIL 

 

 

R 4.16 Verify Segment Installer On the Candidate Platform (kpccp) Can Read Table Of Contents and Install Segments 
From the Network Installation Server / Network Installation Server 

R.1 Segment Installer - Main Window On the Candidate Platform (kpccp)  

R.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Available Disks field of the Installer 
window, select /h. 

/h is highlighted. Circle one:  PASS / FAIL 

 

 

R.1.2 In the Installer window, click Select Source in 
the Source field. 

The Select Source window appears. Circle one:  PASS / FAIL 

 

 

R.1.3 In the Device field, click NETWORK.  NETWORK is selected. 

 

Circle one:  PASS / FAIL 

 

 

R.1.4 Click OK. The Installer window appears. Circle one:  PASS / FAIL 
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R.1.5 In the Source field, click Read Contents. The Installer reads the Table of 
Contents.  When complete, the 
Installer displays a Select 
Software To Install field. 

Circle one:  PASS / FAIL 

 

 

R.1.6 In the Select Software To Install field, select 
Big Test Segment. 

Big Test Segment is highlighted and 
the Disk column in the Select 
Software To Install field displays 
/h.  If it doesn�t, deselect the segment and 
reselect it. 

Circle one:  PASS / FAIL 

 

 

R.1.7 Click Install. Big Test Segment installs accordingly 
under /h. Once installed, it appears under 
Select Software To Install 
marked by an asterisk and is listed under 
Currently Installed Segments. 

Circle one:  PASS / FAIL 

 

 

R.2 Verify Segment Installs and Deinstalls Correctly On the Candidate Platform (kpccp)  

R.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

 

On the Installer menu bar, select Installed > 
View Installation Log. 

The Install Log window appears. 

Note: If the Network Installation 
Server died previously and was re-
opened, the Installation Log will 
not be available.  Skip this and the next two 
steps. 

Circle one:  PASS / FAIL 

 

 

R.2.2 Verify the segment installed correctly. The Install Log indicates:  
Segment (Big Test Segment) 
successfully installed. 

Circle one:  PASS / FAIL 
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R.2.3 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

 

R.2.4 At the command prompt type 
ls  -l  /h/bigseg 

The directory bigseg is listed with 
Integ, Scripts, SegDescrip, bin, 
and data subdirectories. 

Circle one:  PASS / FAIL 

 

 

R.2.5 In the Installer window, select Big Test 
Segment in the Currently Installed 
Segments field.  

Big Test Segment is highlighted. Circle one:  PASS / FAIL 

 

 

R.2.6 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Big Test Segment  

Circle one:  PASS / FAIL 

 

 

R.2.7 Click Yes. Big Test Segment deinstalls correctly 
and is no longer preceded by an * in the 
Select Software To Install 
field.  Big Test Segment no longer 
appears in the Currently Installed 
Segments field. 

Circle one:  PASS / FAIL 
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R.2.8 Click Exit in the bottom menu bar of the Installer 
window. 

The Installer window disappears. Circle one:  PASS / FAIL 

 

 

S 4.17 Network Installation Server / Network Installation Server Testing � Verify Segments De-install 
Correctly 

S.1 Network Installation Server / Network Installation Server - Main Window 
On the Validation Host (kpchost) 

 

S.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Segments Currently Loaded On This 
Network Server field, select Big Test 
Segment. 

Big Test Segment is highlighted. Cleanup 

 

 

S.1.2 Click Deinstall Software. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

Big Test Segment 

Cleanup 

 

 

S.1.3 Click Yes. The segment de-installs and is no longer 
listed under the Segments Currently 
Loaded On This Network Server 
field. 

Cleanup 
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S.1.4 Click Exit in the bottom menu bar of the Network 
Installation Server. 

The Network Installation 
Server window disappears. 

Cleanup 
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T 4.18 Launch Segment Installer From the Command Line 

T.1 Launch Segment Installer From the Command Line On the Candidate Platform (kpccp)  

T.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Open a new Terminal window. 

A Terminal window appears with a 
command line prompt. 

Startup 
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T.1.2 At the command prompt type  
/h/COE/bin/COEInstaller –h 

The following appears: 

Usage:  COEInstaller [flags} 
-h �H   Display this help message. 
-c   <file> Read command line arguments 
from the 
        named <file>. 
-d    Set the debug flag. 
-s    Run in installation server mode. 
-v    Show verbose messages while the tool 
runs. 
-V   Display the tool�s version number. 
-w   Suppress all warnings. 
This tool displays a list of 
configuration definitions or segments 

that may be installed from tape, disk 
(e.g., a network segment server), 

or other electronic media. By 
default, this tool does not write any 

output to stdout. This tool writes 
information to a status log that  

indicates installation progress, 
which segments have been installed,  

and other information that might be 
useful to the site administrator. 

 

Circle one:  PASS / FAIL 
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T.1.3 In the Terminal window, at the command prompt type 
the following as sysadmin: 
/h/COE/bin/COEInstaller –v 

The Installer window opens. Circle one:  PASS / FAIL 

 

 

T.1.4 Click Exit in the bottom menu bar of the Installer. The Installer window disappears. Circle one:  PASS / FAIL 

 

 

T.1.5 In the Terminal window select 
Window > Close 

The Terminal window closes. Circle one:  PASS / FAIL 
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U 

4.19  Segment Installation Post Test Cleanup Candidate Platform Cleanup 

    NOTE:  These steps restore the Test Cell to pretest conditions. 
   These steps or a restore from backup may be preformed at the tester�s discretion.  
 
  

U.1 Launch Edit Local Hosts and Remove kpchost Entry On the Candidate Platform (kpccp)  

U.1.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Application Manager – SysAdm window, 
double-click Edit Local Hosts. 

The Edit Hosts window appears. Cleanup 

U.1.2  Select kpchost.  kpchost is highlighted. Cleanup 

 

U.1.3  Click Delete. A Confirmation Required window 
appears. 

Cleanup 

 

U.1.4  Click Yes. The Confirmation Required 
window disappears. 

Cleanup 

 

U.1.5  Click Close. 

 

The Edit Hosts window disappears. Cleanup 
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U.2 Modify /etc/inetd.conf and /.rhosts To Disable rsh (Close Security For Remote Shell) 
On the Candidate Platform (kpccp) 

 

U.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Terminal window, at the command prompt type  
su  

NOTE: Do not use the "-" option. 

The Password prompt appears. Cleanup 

U.2.2 Enter the root password. The command prompt returns. Cleanup 

 

U.2.3 At the command prompt type  
csh 

The command prompt returns. Cleanup 

U.2.4 In the Terminal window, at the command prompt type 
vi /etc/inetd.conf 

The file /etc/inetd.conf is opened 
for editing. 

Cleanup 

 

U.2.5 Type 
/shell 

The vi editor will place the cursor on the 
line that contains: 
shell 

Cleanup 

 

U.2.6 Type  
n 

until the cursor is at the beginning of the line containing 
shell stream tcp nowait root 

The cursor is over the s on the line with  
shell stream tcp nowait root 

Cleanup 
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U.2.7 Type 
i 

The vi editor will enter insert mode. Cleanup 

 

U.2.8 Type 
# 

The vi editor will add the # symbol. Cleanup 

 

U.2.9 Press 
[esc] 

The vi exits the Insert Mode. Cleanup 

 

U.2.10 Type 
:wq! 

The vi editor will write to and exit the file. 

The command prompt returns. 

Cleanup 

 

U.2.11 At the command prompt type 
ps –eaf | grep inetd 

Process information for inetd appears 
with the process id in the second column. 

Cleanup 

 

U.2.12 At the command prompt type 

kill –HUP <pid> 

where <pid> is the process ID found in the previous step. 

The command prompt appears. Cleanup 

 

U.2.13 In the Terminal window, at the command prompt type 
vi /.rhosts 

The file /.rhosts is opened for editing. Cleanup 

 

U.2.14 Type 
dd 

The vi editor removes kpchost. Cleanup 

 

U.2.15 Type 
i 

The vi editor will enter insert mode. Cleanup 
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U.2.16 Type 
-  

The vi editor inserts - to the file. Cleanup 

 

U.2.17 Press 
[esc] 

The vi exits the Insert Mode. Cleanup 

 

U.2.18 Type 
:wq! 

The vi editor will write to and exit the file. 

The command prompt returns. 

Cleanup 

 

U.3 Unexport /h/data/global and /home2 Directories From the Candidate Platform (kpccp)  

U.3.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Application Manager - SysAdm 
window, double-click Disk Manager. 

The Disk Manager window appears. Cleanup 

 

U.3.2 Select the row that contains the / partition in the 
Mounted On column. 

The / row is highlighted. Cleanup 

 

U.3.3 Click Export FS. The Export/Unexport File 
Systems window appears. 

Cleanup 

U.3.4 Click Current. The following text is displayed: 
/h/data/global  -o 
rw,root=kpchost 
/home2 –o ro,root=kpchost 

Cleanup 

U.3.5 Click OK. The Current Exports window 
disappears. 

Cleanup 
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U.3.6 In the pathname text box, type:  
/h/data/global 

/h/data/global appears in the 
pathname text box. 

Cleanup 

U.3.7 Click Unexport. A Confirmation window appears 
asking: UnExport this directory 
permanently? 

Cleanup 

U.3.8 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Cleanup 

U.3.9 Click Export FS. The Export/Unexport File 
Systems window appears. 

Cleanup 

U.3.10 In the pathname text box, type:  
/home2 

/home2 appears in the pathname text 
box. 

Cleanup 

U.3.11 Click Unexport. A Confirmation window appears 
asking: UnExport this directory 
permanently? 

Cleanup 

U.3.12 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Cleanup 

U.3.13 Click Export FS. The Export/Unexport File 
Systems window appears. 

Cleanup 

U.3.14 Click Current. The Current Exports window is 
empty. 

Cleanup 
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U.3.15 Click OK. The Current Exports window 
disappears. 

Cleanup 

 

U.3.16 Click Cancel. The Export/Unexport File 
Systems window disappears. 

Cleanup 

U.4 Unmount /kpc and /cdrom/kpc_4206 Directories From the Validation Host (kpchost) On the 
Candidate Platform (kpccp) 

 

U.4.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

In the Disk Manager window, select the row that 
contains the /kpchostdsk in the Mounted On 
column. 

The /kpchostdsk row is highlighted. Cleanup 

 

U.4.2 Click Unmount. A Confirmation window asks:   
Unmount the File System 
Permanently? 

Cleanup 

U.4.3 Click  Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. /kpchostdsk disappears as a 
file system.  

Cleanup 

U.4.4 Select the row that contains the /kpchostcdrom in 
the Mounted On column. 

The /kpchostcdrom row is highlighted. Cleanup 

 

U.4.5 Click Unmount. A Confirmation window asks:   
Unmount the File System 
Permanently? 

Cleanup 
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U.4.6 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. /kpchostcdrom disappears as 
a file system.  

Cleanup 

U.4.7 Click Exit.  The Disk Manager window disappears. Cleanup 

 

U.5  Remove Directories On the Candidate Platform (kpccp)  

U.5.1  NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

At the command prompt type 
cd / 

The command prompt returns. Cleanup 

U.5.2 At the command prompt type 
rmdir /kpchostdsk /kpchostcdrom 

The command prompt returns. Cleanup 

 

U.6 Test Data De-installation  

U.6.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Select Applications > Application Manager 
> DII_APPS. 

The Application Manager window 
appears. 

Cleanup 

 

U.6.2 Double-click Segment Installer in the 
Application Manager – SysAdm window. 

The  Installer window appears. Cleanup  

 

U.6.3 In the Currently Installed Segments list  
select KPC Test Data for 4200P6. 

KPC Test Data for 4200P6 is 
highlighted 

Cleanup  
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U.6.4 Click Deinstall Software. 

 

An ENTER A PASSWORD dialog box 
appears. 

Cleanup 

U.6.5 Enter the Master APM Authentication key in the text box. Asterisks appear in the text box. Cleanup 

 

U.6.6 Click OK. A RESPOND TO THE QUESTION dialog 
box asks:  
Do you really want to remove 
the segments? 

KPC Test Data for 4200P6 

Cleanup 

U.6.7 Click Yes. KPC Test Data for 4200P6 
deinstalls correctly and is no longer 
preceded by an * in the Select 
Software To Install field. KPC 
Test Data for 4200P6 no longer 
appears in the Currently Installed 
Segments field. 

Cleanup  

U.6.8 Click Exit. The Installer window disappears. Cleanup  
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V 

4.20  Segment Installation Post Test Cleanup Validation Host Cleanup 

    NOTE:  These steps restore the Test Cell to pretest conditions. 
   These step or a restore from backup may be preformed at the tester�s discretion.  
 
 

V.1 Launch Edit Local Hosts and Remove kpccp Entry On the Validation Host (kpchost)  

V.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Application Manager – SysAdm window, 
double-click Edit Local Hosts. 

The Edit Hosts window appears. Cleanup 

V.1.2  Select kpccp.  kpccp is highlighted. Cleanup 

 

V.1.3  Click Delete. A Confirmation Required window 
appears. 

Cleanup 

 

V.1.4  Click Yes. The Confirmation Required 
window disappears. 

Cleanup 

 

V.1.5  Click Close. The Edit Hosts window disappears. Cleanup 

 



   

© 2003, The Open Group 
Chapter 5,Page 230 

Revision: 1.0 
 

 

 

 Operator Action Expected Result Observed Result 

V.2 Modify /etc/inetd.conf and /.rhosts To Disable rsh (Close Security For Remote Shell) 
On the Validation Host (kpchost) 

 

V.2.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Terminal window, at the command prompt type 
vi /etc/inetd.conf 

The file /etc/inetd.conf is opened 
for editing. 

Cleanup 

 

V.2.2 Type 
/shell 

The vi editor will place the cursor on the 
line that contains: 
shell 

Cleanup 

 

V.2.3 Type  
n 

until the cursor is at the beginning of the line containing 
shell stream tcp nowait root 

The cursor is over the s on the line with  
shell stream tcp nowait root 

Cleanup 

V.2.4 Type 
i 

The vi editor will enter insert mode. Cleanup 

 

V.2.5 Type 
# 

The vi editor will add the # symbol. Cleanup 

 

V.2.6 Press 
[esc] 

The vi editor exits Insert Mode. Cleanup 

 

V.2.7 Type 
:wq! 

The vi editor will write to and exit the file. 

The command prompt returns. 

Cleanup 
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V.2.8 At the command prompt type 
ps –eaf | grep inetd 

Process information for inetd appears 
with the process id in the second column. 

Cleanup 

 

V.2.9 At the command prompt type 

kill –HUP <pid> 

where <pid> is the process ID found in the previous step. 

The command prompt appears. Cleanup 

 

V.2.10 In the Terminal window, at the command prompt type 
vi /.rhosts 

The file /.rhosts is opened for editing. Cleanup 

 

V.2.11 Type 
dd 

The vi editor removes kpccp. Cleanup 

 

V.2.12 Type 
i 

The vi editor will enter insert mode. Cleanup 

 

V.2.13 Type 
-  

The vi editor inserts - to the file. Cleanup 

 

V.2.14 Press 
[esc] 

The vi editor exits Insert Mode. Cleanup 

 

V.2.15 Type 
:wq! 

The vi editor will write to and exit the file. 

The command prompt returns. 

Cleanup 
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V.3 Unexport /kpc Directory From the Validation Host (kpchost)  

V.3.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

In the Application Manager - SysAdm 
window, double-click Disk Manager. 

The Disk Manager window appears. Cleanup 

 

V.3.2 Select the row that contains the / partition in the 
Mounted On column. 

The / row is highlighted. Cleanup 

 

V.3.3 Click Export FS. The Export/Unexport File 
Systems window appears. 

Cleanup 

V.3.4 Click Current. The following text is displayed: 
/kpc ro=kpccp 

/home2 –o ro,root=kpccp 

Cleanup 

V.3.5 Click OK. The Current Exported File 
Systems window disappears. 

Cleanup 

 

V.3.6 In the pathname text box, type:  
/kpc 

/kpc appears in the pathname text box. Cleanup 

V.3.7 Click Unexport. A Confirmation window appears 
asking: UnExport this directory 
permanently? 

Cleanup 

V.3.8 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Cleanup 
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V.3.9 Click Export FS. The Export/Unexport File 
Systems window appears. 

Cleanup 

V.3.10 In the pathname text box, type:  
/home2 

/home2 appears in the pathname text 
box. 

Cleanup 

V.3.11 Click Unexport. A Confirmation window appears 
asking: UnExport this directory 
permanently? 

Cleanup 

V.3.12 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. 

Cleanup 

V.3.13 Click Export FS. The Export/Unexport File 
Systems window appears. 

Cleanup 

V.3.14 Click Current. The Current Exported File 
Systems window is empty. 

Cleanup 

 

V.3.15 Click OK. The Current Exports window 
disappears. 

Cleanup 

 

V.3.16 Click Cancel. The Export/Unexport File 
Systems window disappears. 

Cleanup 
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V.4 Unmount /h/data/global Directory From the Candidate Platform (kpccp) On the Validation 
Host (kpchost) 

 

V.4.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

Select the row that contains the /h/data/global in 
the Mounted On column. 

The /h/data/global row is 
highlighted. 

Cleanup 

 

V.4.2 Click Unmount. A Confirmation window asks:   
Unmount the File System 
Permanently? 

Cleanup 

V.4.3 Click Yes. The Confirmation window disappears 
and control returns to the Disk Manager 
window. /h/data/global disappears as 
a file system.  

Cleanup 

V.4.4 Click Exit.  The Disk Manager window disappears. Cleanup 

 

Z 
4.21 Log Out On the Candidate Platform (kpccp) and Validation Host (kpchost) 

Z.1 Validation Host (kpchost) Log Out  

Z.1.1 NOTE: Perform the following steps on the Validation 
Host (kpchost). 

Close all open windows. 

All open windows close. Cleanup 

Z.1.2 Click EXIT in the CDE Menu Bar. The Logout Confirmation window 
appears. 

Cleanup 
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Z.1.3 Click OK. The DII COE LOGIN screen appears. Cleanup 

 

Z.2 Candidate Platform (kpccp) Log Out  

Z.2.1 NOTE: Perform the following steps on the Candidate 
Platform (kpccp). 

Close all open windows. 

All open windows close. Cleanup 

Z.2.2 Click EXIT in the CDE Menu Bar. The Logout Confirmation window 
appears. 

Cleanup 

 

Z.2.3 Click OK. The DII COE LOGIN screen appears. Cleanup 

 

End of Test Validation Procedure  
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Appendix A Procedure for creating a test data tape that includes segx, which is required for this test. 

 

ZZ Setup � Create Test Data Tape That Includes segx 

ZZ.1 Setup � Install COE Developer’s Toolkit and Put Test Segment segx On Tape On the 
Candidate Platform (kpccp) 

 

ZZ.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Login as secman. 

The desktop appears. Setup 

ZZ.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager window appears. Setup 

 

ZZ.1.3 Double-click APM Key Server in the 
Application Manager – SecAdm window. 

The APM Key Server window appears. Setup  

 

ZZ.1.4 Enter the Master APM authentication key, and 
click Start. 

A Started dialog box appears. Setup 

ZZ.1.5 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

ZZ.1.6 At the command prompt type  
 su  

The Password prompt returns. Setup 

ZZ.1.7 Enter the root password. The command prompt returns. Setup 
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ZZ.1.8 At the command prompt type  
 csh 

The command prompt returns. Setup 

ZZ.1.9 Insert a blank tape into the tape drive. The tape is inserted. Setup 

 

ZZ.1.10 At the command prompt type 
mt rew 

NOTE: This command is OS specific and assumes 
that /dev/rmt/0m is the default tape device 
address. Use the relevant command on the OS 
being tested and note it in the Observed Result 
column. 

The tape is rewound. Setup 

ZZ.1.11 At the command prompt type 
/h/DII_DEV/bin/MakeInstall –t [s] 
<device path> -p /kpc/tk segx  

where <device path> is the device address of a �no 
rewind� tape device. (e.g. /dev/rmt/0mn) 

Messages/information will appear in the 
Terminal window indicating the process steps 
being executed by MakeInstall. The following 
prompt appears: 
Enter the size of the tape in 
MByte or type ‘q’ to quit. 

Setup 

ZZ.1.12 At the prompt type 
80 

The following prompt appears: 
Processing Segment /kpc/tk/segx 

Setup 

ZZ.1.13 At the prompt type 
NO 

The following prompt appears: 
Processing segment: /kpc/tk/MIseg 

Enter your name for the Tape 
Header: 

Setup 
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ZZ.1.14 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Setup 

ZZ.1.15 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters) : 

Setup 

ZZ.1.16 Press ENTER. MakeInstall will continue and display the following 
information: 

1. A segment description table. 

2. The number of segments to be written to output 
device (1). 

3. Space requirements for segment. 

The following prompt appears: 
Insert tape #1 

Press any key to continue. 

Setup 

ZZ.1.17 Press ENTER. The following prompt appears: 

DII Install tape completed. 

Setup 
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ZZ.1.18 At the command prompt type 
mt rewoffl 

NOTE: This command is OS specific and assumes 
that /dev/rmt/0m is the default tape device 
address. Use the relevant command on the OS 
being tested and note it in the Observed Result 
column. 

NOTE: This tape may be used for all subsequent 
Segment Installer Validation Tests. 
 

The tape is rewound and ejected. Cleanup 

End of Appendix A 
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1. Overview 

1.1 Introduction 

This chapter defines the Remote Installation Manual Validation Procedure and is part 
of the required set of test procedures to be used in the certification of products to 
the Open Brand COE Platform Product Standard1.  

2. Test Procedure 

2.1 Scope  

The Remote Installation Validation Procedure is a manual test that provides a 
detailed test of the remote installation capability of the kernel. The test is run in two 
directions. First the kernel is installed interactively on the Candidate Platform, a 
remote installation package is created on the Candidate Platform and transferred to 
the Validation Host. Then the installation package is remotely executed on the 
Validation Host to install the kernel. In the second part of the test, the kernel is 
interactively installed on the Validation Host and remotely installed on the Candidate 
Platform. Note that this this test provides its own setup apart from that described in 
the current version of the COE Setup Procedures for Kernel Platform Compliance 
(KPC) Validation Cell for Kernel V4.2.0.0P6 (Solaris 8) document.  This test 
references Kernel Version 4.2.0.5, but it is anticipated that the vendor will supply a 
Kernel Version 4.2.0.0P6.  Either Kernel Version will satisfy this test procedure. 

 
Description of test items that will be tested using the Remote Installation Validation 
Procedure is as follows: 

A. Install a clean OS on each machine, per the Setup Procedures for KPC Validation 
Cell for Kernel 4200P6 and perform necessary setup steps prior to kernel 
installation. 

B. Install the kernel on the APM master. 

C. Export the APM master�s public key and create the installation package. 

D. Distribute the installation package. 

E. Install the kernel on the client. 

F. Perform an automatic merge host. 

G. Add new users to each host. 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 H. Run COESegInstall on the client. 

Z. Log out of the Validation Host (kpchost) and the Candidate Platform (kpccp) 

 

2.2 Test Data/Media Required   

The following segments are required to execute this test: 

OnlineDocs Segment Version 4.2.0.0. 

2.3 Setup/Equipment Required 

This test requires a Validation Host and Candidate Platform setup according to the 
following configurations. In particular, this test provides its own setup apart from 
that described in the current version of the Template Setup Procedures for a COE Validation 
Cell  . 

Configuration 1: 

APM Master (Candidate Platform) and APM Client (Validation Host) 

Configuration 2: 

APM Master (Validation Host) and APM Client (Candidate Platform) 

 

2.4 Test Data/Media Required 

COE Kernel and Toolkit Source Code, Test Data, and Documentation for Version 
4200P6 Version 1.0.0. 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003  

Initial Release 

 

 



 

 

3. Test Procedure Submission Form 

 

Test Title: Remote Installation Validation Procedure  

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 5 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 

 Operator Action Expected Result Observed Result 

A 
4.1 Configuration 1 Setup 

A.1 OS Setup Of Configuration 1 (Candidate Platform and Validation Host)  

A.1.1 Install the OS on both machines, per the Setup 
Procedures for Template Setup Procedures 
for a COE Validation Cell   

The OS is installed on both machines, per the 
Setup Procedures for KPC 
Validation Cell for Kernel 42P6 
(Solaris 8). 

Setup 

A.2 Edit the /etc/host Files (Candidate Platform and Validation Host)  

A.2.1 On the Candidate Platform and Validation Host, in 
the Terminal window, type: 
 cd /etc 

  The command prompt returns. Setup 

A.2.2 Type: 
 vi hosts 

The hosts file is ready for editing. Setup 

A.2.3 Use the arrow keys to move the cursor to the last 
line of text 

The cursor is position on the last line of text. Setup 

A.2.4 Type:  
 o  

A new line is opened in insert mode. Setup 



© 2002, The Open Group 
Chapter 6, page 6 

 
 

 

 

 Operator Action Expected Result Observed Result 

A.2.5 On the Validation Host type: 
 204.34.175.194  kpchost 

On the Candidate Platform type: 
 204.34.175.195  kpccp 

The alternate system�s name and IP addressed are 
entered into each host�s /etc/host file. 

Setup 

A.2.6 Press [Esc]. 

 

The hosts file is closed for editing. Setup 

A.2.7 Type:  
 :wq! 

 

The hosts file is saved and exited.  Setup 

A.3 Verify That The Times On Each System To Be Merged Are Within 20 Minutes Of Each Other 
NOTE: This is important. APM authentication functions will fail if the clocks are out of 
synchronization by more than 20 minutes. 

 

A.3.1 On each machine, log in as root. 

 

The desktop appears. Setup 

A.3.2 Open a Terminal window. 

 

A Terminal window appears. Setup 

A.3.3 Type: 
 date -u 

The date and time are displayed. Setup 
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A.3.4 Verify that the times of both systems are within 20 
minutes of each other.  If not, on the Candidate 
Platform, in a Terminal window type:  
 rdate kpchost 

NOTE: This command may be operating system 
specific. A similar command or sequence of 
commands should be used to synchronize the times 
on both systems. 

The times of both systems are identical. Setup 

A.4 Enable FTP and Remote Login (Validation Host)  

A.4.1 On the Validation Host, in the Terminal 
window, type:  
 vi /etc/default/login 

The file login is open and ready for editing. Setup 

A.4.2 Use the arrow keys to move the cursor to the 
beginning of the line that starts with CONSOLE. 

The cursor is a the beginning of the correct line. Setup 

A.4.3 Type: 
 i# 

The # character is inserted at the beginning of the 
line. 

Setup 

A.4.4 Press [Esc]. 

 

The file login is closed for editing. Setup 

A.4.5 Type:  
 :w! 

 

The file login is saved. Setup 
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A.4.6 Type: 
 :e /etc/ftpusers  

The file ftpusers is open and ready for editing. Setup 

A.4.7 Use the arrow keys to move the cursor to the 
beginning of the line that starts with root. 

The cursor is a the beginning of the correct line. Setup 

A.4.8 Type:  
 i# 

The # character is inserted at the beginning of the 
line. 

Setup 

A.4.9 Press [Esc]. The file ftpusers is closed for editing. Setup 

A.4.10 Type:  
 :wq! 

The file ftpusers is saved and exited. Setup 

B 4.2  Install The Kernel On The APM Master 

B.1  Install The Kernel On The APM Master (Candidate Platform)  

B.1.1 On the Candidate Platform, type: 
 mkdir /pkg /packages  

 The command prompt returns. Setup 

B.1.2 Insert the 4.2.0.0P6 Kernel and Toolkit 
Source Code CD-ROM into the CD-ROM 
drive. 

The media is loaded onto the system. Setup 

B.1.3 At the command prompt, type: 
 cd /pkg 

The command prompt returns. Setup 
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B.1.4 At the command prompt, type: 
cp –pr 

/cdrom/kpc_4206/seg/4205kern_sol.t
ar.Z /pkg 

The command prompt returns. Setup 

B.1.5 At the command prompt type: 
 uncompress 4205kern_sol.tar.Z 

The command prompt returns. Setup 

B.1.6 At the command prompt, type: 
 tar xf 4205kern_sol.tar 

The command prompt returns. Setup 

B.1.7 At the command prompt, type: 
 rm 4205kern_sol.tar 

The command prompt returns. Setup 

B.1.8 Install the kernel by typing: 
 ./inst.dii 

The kernel begins to install and prompts the tester 
for input. 

Circle one:  PASS / FAIL 
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C 
4.3 Export the APM master�s public key and create the installation package. 

C.1 Export the APM Master�s Public Key (Candidate Platform)  

C.1.1 On the Candidate Platform, log in as secman. 

 

 The desktop appears.  Circle one:  PASS / FAIL 

 

 

C.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

C.1.3 Double-click APM Key Server to launch the 
Key Server. 

 

The Key Server window appears. Circle one:  PASS / FAIL 

 

 

C.1.4 Enter the Master APM Authentication key.  

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

 

C.1.5 Click Start. 

 

An Information window appears stating the 
Key Server started successfully. 

Circle one:  PASS / FAIL 
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C.1.6 Click OK. 

 

The Information and Key Server windows 
close. 

Circle one:  PASS / FAIL 

 

 

C.1.7 On the Candidate Platform, log in as keyman. 

  

The desktop appears. Circle one:  PASS / FAIL 

 

 

C.1.8 Select Applications > Application 
Manager > DII_APPS > APM > Public 
Key Manager 

The Public Key Manager window appears. Circle one:  PASS / FAIL 

 

 

C.1.9 Click Export. 

 

The Save Public Key File window 
appears. 

Circle one:  PASS / FAIL 

 

 

C.1.10 In the Enter path or folder name: 
textbox, type: 
 /h/COE/Comp/APM/data 

/h/COE/Comp/APM/data appears in the 
Enter path or folder name: textbox. 

Circle one:  PASS / FAIL 

 

 

C.1.11 In the Enter file name: textbox, type 
keyfile.txt. 

keyfile.txt appears in the Enter file 
name: textbox. 

Circle one:  PASS / FAIL 

 

C.1.12 Click Save. A confirmation appears with the file location listed. Circle one:  PASS / FAIL 
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C.1.13 Click OK. 

 

Control returns to the Public Key Manager 
window. 

Circle one:  PASS / FAIL 

 

C.1.14 Click Cancel. The Public Key Manager window disappears. Circle one:  PASS / FAIL 

C.2 Create The Kernel Installation Package (Candidate Platform)  

C.2.1 On the Candidate Platform, open a Terminal 
window. 

A Terminal window appears. Circle one:  PASS / FAIL 

C.2.2 Type:  
 su - 

A password prompt appears. Circle one:  PASS / FAIL 

C.2.3 Type the root password. The command prompt returns. Circle one:  PASS / FAIL 

C.2.4 Type: 
 csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

C.2.5 Type: 
cp 
/h/COE/Comp/APM/data/keyfile.txt 
/pkg 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

C.2.6 Type: 
 cd /pkg 

The command prompt returns. Circle one:  PASS / FAIL 
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C.2.7 Type: 
./MakePackage –o 
/packages/kernel.pkg 
–p /pkg –c “inst.dii –silent –
keyfile keyfile.txt”  

The kernel.pkg file is created in the 
/packages directory. 

Circle one:  PASS / FAIL 

 

 

D 4.4 Distribute the installation package. 

NOTE: This procedure uses ftp to distribute the installation package. Other distribution mechanisms may be used. 

D.1 FTP Package To Clients (Candidate Platform)  

D.1.1 On the Candidate Platform, type:  
 cd /packages 

The command prompt returns. Setup 

 

D.1.2 Type:  
 ftp kpchost 

A Name prompt returns. Setup  

 

D.1.3 Type: 
 root 

A password prompt appears. Setup  

 

D.1.4 Type the root password. 

 

An ftp> prompt appears. Setup  

 

D.1.5 Type: 
 cd /tmp 

The command prompt returns. Setup  
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D.1.6 Type: 
 bin 

The command prompt returns. Setup  

 

D.1.7 Type: 
 put kernel.pkg 

The command prompt returns. Setup  

 

D.1.8 Type: 
 bye 

The # command prompt returns. Setup  

 

E 4.5 Install the kernel on the client. 

E.1 Remotely Install Kernel (Candidate Platform)  

E.1.1 On the Candidate Platform, type: 
 rlogin kpchost –l root 

A password prompt appears. Setup 

E.1.2 Type the root password. 

 

The command prompt returns. Setup 

E.1.3 Type: 
 cd /tmp 

The command prompt returns. Setup 

E.1.4 Type: 
 chmod +x kernel.pkg 

The command prompt returns. Setup 

E.1.5 Type: 
 ./kernel.pkg 

The kernel installs on the Validation Host.  Wait 
for the kernel installation process to complete prior 
to advancing to the next step. 

Circle one:  PASS / FAIL 
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F 4.6 Perform an automatic merge host. 

F.1 Distribute Keys (Candidate Platform)  

F.1.1 On the Candidate Platform, open a new 
Terminal window. 

A new Terminal window appears. 

 

Setup 

F.1.2 Type: 
vi /h/COE/Comp/APM/data/HostList 

A file named HostList is created and opened for 
editing. 

Setup 

F.1.3 Type: 
 i 

The editor is in insert mode. Setup 

F.1.4 Type:  
 kpchost 

kpchost appears in the HostList file. Setup 

F.1.5 Press [Esc]. 

 

The file HostList is closed for editing. Setup 

F.1.6 Type: 
  :wq! 

The file HostList is exited. Setup 

F.1.7 Select Applications Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

F.1.8 Enter the Master APM authentication key. 

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 
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F.1.9 Click Set Client’s Local Key. 

 

The Hosts List window appears. Circle one:  PASS / FAIL 

 

F.1.10 Click Import Host List. 

 

The Open Host List File window appears. Circle one:  PASS / FAIL 

 

F.1.11 Verify that the path name is  
 /h/COE/Comp/APM/data  

and select the HostList file. 

The HostList file is highlighted. Circle one:  PASS / FAIL 

 

 

F.1.12 Click OK. 

 

An Information window appears. Circle one:  PASS / FAIL 

 

F.1.13 Click OK. The Information window closes and 
kpchost is listed. 

Circle one:  PASS / FAIL 

 

F.1.14 Click Select Hosts Without Keys. 

 

kpchost is highlighted. Circle one:  PASS / FAIL 

 

F.1.15 Click Generate Keys. 

 

An Information dialog box appears stating: 

Key generation complete. 

Circle one:  PASS / FAIL 

 

F.1.16 Click OK. 

 

The dialog box disappears. Circle one:  PASS / FAIL 
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F.1.17 Click Distribute Keys. 

 

An Information dialog box appears stating: 

Key distribution complete. 

Circle one:  PASS / FAIL 

 

F.1.18 Click OK. 

 

The dialog box disappears. Circle one:  PASS / FAIL 

 

F.1.19 Close the Hosts List and Authentication 
Manager windows. 

The windows close. Circle one:  PASS / FAIL 

 

F.2 Automated Merge (Candidate Platform)  

F.2.1 On the Candidate Platform, log in as secman. 

 

The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

F.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm > 
Merge Host. 

The MergeHost Tool window appears. Circle one:  PASS / FAIL 

 
 

F.2.3 Click Merge a List of New Hosts. 

 

The Select Hosts to Merge window 
appears with kpchost listed. 

Circle one:  PASS / FAIL 

 

F.2.4 Click Highlight All Available. 

 

kpchost in the Available pane is highlighted. Circle one:  PASS / FAIL 

 

F.2.5 Click the right arrow button. 

 
kpchost moves to the Selected pane. Circle one:  PASS / FAIL 
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F.2.6 Click OK. 

 

An Input dialog box appears requesting the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

F.2.7 Enter the master APM authentication key. 

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

F.2.8 Click OK. 

 

The merge host process completes with no user 
interaction.  Wait for the merge host process to 
complete before advancing to the next step. 

A Done dialog box appears. 

Circle one:  PASS / FAIL 

 

F.2.9 Click OK. 

 

The Done dialog box disappears. Circle one:  PASS / FAIL 

 

F.2.10 Click Cancel twice to close the Select Hosts 
to Merge and MergeHost Tool windows. 

The windows close. Circle one:  PASS / FAIL 

 

G 4.7 Add new users to each host. 

G.1 Create Users (Candidate Platform)  

G.1.1 On the Candidate Platform, log in as secman. 

 

The desktop appears. Setup 

G.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm > APM 
Client 

An Input window appears. Setup 
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G.1.3 Enter the APM Master authentication key. 

 

Asterisks appear in the textbox. Setup 

G.1.4 Click OK. The Account and Profile Manager 
window appears. 

Setup 

G.1.5 Select File > New Account. 

 

The Create Account window appears. Setup 

G.1.6 Create a new User with the following parameters: 

Login: � UnixTest 
Password: - <Password> 
Default Group � other 
Hosts � select both hosts 

The User UnixTest parameters are entered. Circle one:  PASS / FAIL 

 

 

G.1.7 Click Submit. 

 

The Status Summary window appears showing 
the new account successfully added to both hosts. 

Circle one:  PASS / FAIL 

 

G.1.8 Click OK. 

 

The Status Summary window disappears. Circle one:  PASS / FAIL 
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G.2 Log in To Client Machine (Validation Host)  

G.2.1 Log in to the Validation Host as UnixTest. Login is allowed. Circle one:  PASS / FAIL 

H 4.8 Configuration 2 Setup 

H.1 OS Setup Of Configuration 2 (Validation Host and Candidate Platform)  

H.1.1 Install the OS on both machines, per the Setup 
Procedures for KPC Validation Cell 
for Kernel 4206 (Solaris 8). 

The OS is installed on both machines, per the 
Setup Procedures for KPC 
Validation Cell for Kernel 4206 
(Solaris 8). 

Setup 

H.2 Edit the /etc/host Files (Candidate Platform and Validation Host)  

H.2.1 On the Candidate Platform and Validation Host, in 
the Terminal window, type: 
 cd /etc 

  The command prompt returns. Setup 

H.2.2 Type: 
 vi hosts 

The hosts file is ready for editing. Setup 

H.2.3 Use the arrow keys to move the cursor to the last 
line of text. 

The cursor is position on the last line of text. Setup 

H.2.4 Type:  
 o  

A new line is opened in insert mode. Setup 
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H.2.5 On the Validation Host type: 
204.34.175.194  kpchost 

On the Candidate Platform type: 
204.34.175.195  kpccp 

The alternate system�s name and IP addressed are 
entered into each host�s /etc/host file. 

Setup 

H.2.6 Press [Esc]. 

 

The hosts file is closed for editing. Setup 

H.2.7 Type:  
 :wq! 

The hosts file is saved and exited.  Setup 

H.3 Verify That The Times On Each System To Be Merged Are Within 20 Minutes Of Each Other 
NOTE: This is important. APM authentication functions will fail if the clocks are out of 
synchronization by more than 20 minutes. 

 

H.3.1 On each machine, log in as root. 

 

The desktop appears. Setup 

H.3.2 Open a Terminal window. 

 

A Terminal window appears. Setup 

H.3.3 Type: 
 date -u 

The date and time are displayed. Setup 
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H.3.4 Verify that the times of both systems are within 20 
minutes of each other.  If not, on the Validation 
Host, in a Terminal window type:  
 rdate kpccp 

NOTE: This command may be operating system 
specific. A similar command or sequence of 
commands should be used to synchronize the times 
on both systems. 

The times of both systems are identical. Setup 

H.4 Enable FTP and Remote Login (Candidate Platform)  

H.4.1 On the Candidate Platform, in the Terminal 
window, type:  
 vi /etc/default/login 

The file login is open and ready for editing. Setup 

H.4.2 Use the arrow keys to move the cursor to the 
beginning of the line that starts with CONSOLE. 

The cursor is a the beginning of the correct line. Setup 

H.4.3 Type:  
 i# 

The # character is inserted at the beginning of the 
line. 

Setup 

H.4.4 Press [Esc]. 

 

The file login is closed for editing. Setup 

H.4.5 Type:  
 :w! 

The file login is saved. Setup 
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H.4.6 Type: 
 :e /etc/ftpusers  

The file ftpusers is open and ready for editing. Setup 

H.4.7 Use the arrow keys to move the cursor to the 
beginning of the line that starts with root. 

The cursor is a the beginning of the correct line. Setup 

H.4.8 Type:  
 i# 

The # character is inserted at the beginning of the 
line. 

Setup 

H.4.9 Press [Esc]. 

 

The file ftpusers is closed for editing. Setup 

H.4.10 Type: 
 :wq! 

The file ftpusers is exited. Setup 

I 4.9 Install The Kernel On The APM Master 

I.1  Install The Kernel On The APM Master (Validation Host)  

I.1.1 On the Validation Host, type:  
 mkdir /pkg /packages  

 The command prompt returns. Setup 

I.1.2 Insert the 4.2.0.0P6 Kernel and Toolkit 
Source Code CD-ROM into the CD-ROM 
drive. 

The media is loaded onto the system. Setup 

I.1.3 At the command prompt, type: 
 cd /pkg 

The command prompt returns. Setup 
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I.1.4 At the command prompt, type: 
cp –pr 

/cdrom/kpc_4206/seg/4205kern_sol.t
ar.Z /pkg 

The command prompt returns. Setup 

I.1.5 At the command prompt type: 
 uncompress 4205kern_sol.tar.Z 

The command prompt returns. Setup 

I.1.6 At the command prompt, type: 
 tar xf 4205kern_sol.tar 

The command prompt returns. Setup 

I.1.7 At the command prompt, type: 
 rm 4205kern_sol.tar 

The command prompt returns. Setup 

I.1.8 Install the kernel by typing: 
 ./inst.dii 

The kernel begins to install and prompts the tester 
for iput. 

Circle one:  PASS / FAIL 

J 4.10 Export the APM master�s public key and create the installation package. 

J.1 Export the APM Master�s Public Key (Validation Host)  

J.1.1 On the Validation Host, log in as secman. 

 

 The desktop appears.  Circle one:  PASS / FAIL 

 

J.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm 

The Application Manager – SecAdm 
window appears. 

Circle one:  PASS / FAIL 
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J.1.3 Double-click APM Key Server to launch the 
Key Server. 

The Key Server window appears. Circle one:  PASS / FAIL 

J.1.4 Enter the Master APM Authentication key and 
click Start. 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

J.1.5 Click Start. An Information window appears stating the 
Key Server started successfully. 

Circle one:  PASS / FAIL 

 

J.1.6 Click OK. 

 

The Information and Key Server windows 
close. 

Circle one:  PASS / FAIL 

 

J.1.7 On the Validation Host, log in as keyman. 

  

The desktop appears. Circle one:  PASS / FAIL 

 

J.1.8 Select Applications > Application 
Manager > DII_APPS > APM > Public 
Key Manager 

The Public Key Manager window appears. Circle one:  PASS / FAIL 

 

J.1.9 Click Export. 

 

The Save Public Key File window 
appears. 

Circle one:  PASS / FAIL 

 

J.1.10 In the Enter path or folder name: 
textbox, type: 
 /h/COE/Comp/APM/data 

/h/COE/Comp/APM/data appears in the 
Enter path or folder name: textbox. 

Circle one:  PASS / FAIL 

 

 

J.1.11 In the Enter file name: textbox, type 
keyfile.txt. 

keyfile.txt appears in the Enter file 
name: textbox. 

Circle one:  PASS / FAIL 
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J.1.12 Click Save. 

 

A confirmation appears with the file location listed. Circle one:  PASS / FAIL 

 

J.1.13 Click OK. 

 

Control returns to the Public Key Manager 
window. 

Circle one:  PASS / FAIL 

 

J.1.14 Click Cancel. 

 

The Public Key Manager window disappears. Circle one:  PASS / FAIL 

 

K 4.11 Create The Kernel Installation Package (Validation Host) 

K.1 Create The Kernel Installation Package on the Validation Host  

K.1.1 On the Validation Host, open a Terminal 
window. 

A Terminal window appears. Circle one:  PASS / FAIL 

 

K.1.2 Type:  
 su - 

A password prompt appears. Circle one:  PASS / FAIL 

 

K.1.3 Type the root password. 

 

The command prompt returns. Circle one:  PASS / FAIL 

 

K.1.4 Type: 
 csh 

The command prompt returns. Circle one:  PASS / FAIL 
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K.1.5 Type: 
cp 
/h/COE/Comp/APM/data/keyfile.txt 
/pkg 

The command prompt returns. Circle one:  PASS / FAIL 

 

K.1.6 Type: 
 cd /pkg 

The command prompt returns. Circle one:  PASS / FAIL 

 

K.1.7 Type: 
./MakePackage –o 
/packages/kernel.pkg 
–p /pkg –c “inst.dii –silent –
keyfile keyfile.txt”  

The kernel.pkg file is created in the 
/packages directory. 

Circle one:  PASS / FAIL 

 

 

L 
4.12 Distribute the installation package. 

NOTE: This procedure uses ftp to distribute the installation package. Other distribution mechanisms may be used. 

L.1 FTP Package To Clients (Validation Host)  

L.1.1 On the Validation Host, type:  
 cd /packages 

The command prompt returns. Setup 

 

L.1.2 Type:  
 ftp kpccp 

A Name prompt returns. Setup  

 

L.1.3 Type: 
 root 

A password prompt appears. Setup  

 



© 2002, The Open Group 
Chapter 6, page 28 

 
 

 

 

 Operator Action Expected Result Observed Result 

L.1.4 Type the root password. 

 

An ftp> prompt appears. Setup  

 

L.1.5 Type: 
 cd /tmp 

The command prompt returns. Setup  

 

L.1.6 Type: 
 bin 

The command prompt returns. Setup  

 

L.1.7 Type: 
 put kernel.pkg 

The command prompt returns. Setup  

 

L.1.8 Type: 
 bye 

The # command prompt returns. Setup  

 

M 4.13 Install the kernel on the client. 

M.1 Remotely Install Kernel (Validation Host)  

M.1.1 On the Validation Host, type: 
 rlogin kpccp -l root 

A password prompt appears. Setup 

M.1.2 Type the root password. 

 

The command prompt returns. Setup 

M.1.3 Type: 
 cd /tmp 

The command prompt returns. Setup 
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M.1.4 Type: 
 chmod +x kernel.pkg 

The command prompt returns. Setup 

M.1.5 Type: 
 ./kernel.pkg 

The kernel installs on the Candidate Platform.  
Wait for the kernel installation process to complete 
prior to advancing to the next step. 

Circle one:  PASS / FAIL 

N 4.14 Perform an automatic merge host. 

N.1 Distribute Keys (Validation Host)  

N.1.1 On the Validation Host, open a new Terminal 
window. 

A new Terminal window appears. Setup 

N.1.2 Type: 
vi /h/COE/Comp/APM/data/HostList 

A file named HostList is created and opened for 
editing. 

Setup 

N.1.3 Type: 
 i 

The editor is in insert mode. Setup 

N.1.4 Type:  
 kpccp 

kpccp appears in the HostList file. Setup 

N.1.5 Press [Esc]. 

 

The file HostList is closed for editing. Setup 

N.1.6 Type: 
:wq! 

The file HostList is exited. Setup 
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N.1.7 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

N.1.8 Enter the Master APM authentication key. 

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

N.1.9 Click Set Client’s Local Key. 

 

The Hosts List window appears. Circle one:  PASS / FAIL 

 

N.1.10 Click Import Host List. 

 

The Open Host List File window appears. Circle one:  PASS / FAIL 

 

N.1.11 Verify that the path name is  
 /h/COE/Comp/APM/data  

and select the HostList file. 

The HostList file is highlighted. Circle one:  PASS / FAIL 

 

 

N.1.12 Click OK. 

 

An Information window appears. Circle one:  PASS / FAIL 

 

N.1.13 Click OK. 

 

The Information window closes and kpccp is 
listed. 

Circle one:  PASS / FAIL 

 

N.1.14 Click Select Hosts Without Keys. 

 

kpccp is highlighted. Circle one:  PASS / FAIL 
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N.1.15 Click Generate Keys. 

 

An Information dialog box appears stating: 
Key generation complete. 

Circle one:  PASS / FAIL 

 

N.1.16 Click OK. 

 

The dialog box disappears. Circle one:  PASS / FAIL 

 

N.1.17 Click Distribute Keys. 

 

An Information dialog box appears stating: 
Key distribution complete. 

Circle one:  PASS / FAIL 

 

N.1.18 Click OK. 

 

The dialog box disappears. Circle one:  PASS / FAIL 

 

N.1.19 Close the Hosts List and Authentication 
Manager windows. 

The windows close. Circle one:  PASS / FAIL 

 

N.2 Automated Merge (Validation Host)  

N.2.1 On the Validation Host, log in as secman. The DII COE LOGIN screen appears.  

N.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm > 
Merge Host. 

The MergeHost Tool window appears. Circle one:  PASS / FAIL 

 

N.2.3 Click Merge a List of New Hosts. 

 

The Select Hosts to Merge window 
appears with kpccp listed. 

Circle one:  PASS / FAIL 

 

N.2.4 Click Highlight All Available. 

 

kpccp in the Available pane is highlighted. Circle one:  PASS / FAIL 
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N.2.5 Click the right arrow button. 

 
kpccp moves to the Selected pane. Circle one:  PASS / FAIL 

 

N.2.6 Click OK. 

 

An Input dialog box appears requesting the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

N.2.7 Enter the master APM authentication key. 

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

N.2.8 Click OK. 

 

The merge host process completes with no user 
interaction.  Wait for the merge host process to 
complete before advancing to the next step 

A Done dialog box appears. 

Circle one:  PASS / FAIL 

 

 

N.2.9 Click OK. 

 

The Done dialog box disappears. Circle one:  PASS / FAIL 

 

N.2.10 Click Cancel twice to close the Select Hosts 
to Merge and MergeHost Tool windows. 

The windows close. Circle one:  PASS / FAIL 
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O 4.15 Add new users to each host. 

O.1 Create Users (Validation Host)  

O.1.1 On the Validation Host, log in as secman. 

 

The desktop appears.  

O.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm > APM 
Client 

An Input window appears. Setup 

O.1.3 Enter the APM Master authentication key. 

 

Asterisks appear in the textbox. Setup 

O.1.4 Click OK. The Account and Profile Manager 
window appears. 

Setup 

O.1.5 Select File > New Account. 

 

The Create Account window appears. Setup 

O.1.6 Create a new User with the following parameters: 

Login: � UnixTest 
Password: - <Password> 
Default Group � other 
Hosts � select both hosts 

The User UnixTest parameters are entered. Circle one:  PASS / FAIL 

 

 

O.1.7 Click Submit. 

 

The Status Summary window appears showing 
the new account successfully added to both hosts. 

Circle one:  PASS / FAIL 
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O.1.8 Click OK. 

 

The Status Summary window disappears. Circle one:  PASS / FAIL 

 

O.2 Log in To Client Machine (Candidate Platform)  

O.2.1 Log in to the Candidate Platform as UnixTest. 

 

Login is allowed. Circle one:  PASS / FAIL 

Z 
4.16 Log out of the Validation Host (kpchost) and the Candidate Platform (kpccp) 

 

End of Test Validation Procedure 
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1. Overview 

1.1 Introduction 

This chapter defines the Developer�s Toolkit and Runtime Manual Validation 
Procedure and is part of the required set of test procedures to be used in the 
certification of products to the Open Brand COE Platform Product Standard1.  

 

2. Test Purpose 

2.1 Scope: 

This test provides a detailed test of the developer tools in the COE Developer�s 
Toolkit in addition to the routines in the COE Runtime API.  Testing will be preformed 
on sample segments. 

2.2 Description of test items 

The following functions will be exercised:  

A. Login 

B. Verify the �Help� (-h and �H) and �Version� (-V) Options for all 
Developer Tools 

C. TimeStamp 

D. MakeAttribs 

E. CalcSpace- computes the space (in bytes) required for the segment specified 
and updates the Hardware descriptor accordingly.  

F. VerUpdate 

G. Verify Functionality and Options of VerifySeg 

H. Verify Functionality and Options of MakeInstall 

I. Verify Functionality and Options of CanInstall 

J. Verify Functionality and Options of TestInstall and TestRemove 

K. Public API Test 

Z. Logout 
 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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The following tools are tested: 

CalcSpace - computes the space (in bytes) required for the segment specified and 
updates the Hardware descriptor accordingly.  

CanInstall - tests a segment to see if it can be installed.  If performs the same test 
that Segment Installer does at installation time.  This tool provides the developer an 
easy way to test the installation of a segment without using the Segment Installer. 

MakeAtribs - recursively traverses every subdirectory beneath a segment�s home 
directory and creates a descriptor file FileAttribs. 

permits:owner:group:filename 

 

At installation time the installation tools perform the following statement for each 
entry: 

 

  chmod permits $INSTALL_DIR/filename 

  chown owner $INSTALL_DIR/filename 

  chgrp owner $INSTALL_DIR/filename 

 

Testing will ensure that no file owned by root nor any files have permissions greater 
than 777. 

 

TestInstall - is used to temporarily install a segment that already resides on disk.  
The same operations as Segment Installer will be performed except that it does not 
need to read the segment from tape (e.g., it is already on disk), and the segment 
may be in any arbitrary location.  

 

TestRemove - used to remove a segment that was installed by TestInstall 

 

TimeStamp - puts the current time and date into the VERSION descriptor. 

Time Stamp is intended to assist the configuration management process by allowing 
the time stamp to be updated just prior to running VerifySeg. 

 

VerUpdate - used to update the VERSION descriptor.  VerUpdate updates the 
segment version number, date and time in the VERSION descriptor file.  If no version 
number is specified, the tool increments the version number contained in the 
descriptor file.  Testing will be performed on sample segments to ensure 
functionality. 
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VerifySeg - validates that a segment conforms to the COE Compliance rules for 
defining a segment.   

 

VerifySeg - uses information in the SegDescript subdirectory and must be run 
whenever the segment is modified.  VerifySeg is a validation process that will be run 
against sample segments to verify compliance. 

 

COEFindSeg - returns information about requested segments.  Testing includes 
verification of parameters such as help, version, directory, segment name, type 
segment attribute and error status. 

 

COEAskUser - is intended for use in the PostInstall script to display a message to the 
user and have the user respond with a Yes or No, True or False or Accept or Cancel; 
basic testing of creating prompt windows using the COEAskUser tool and responding 
with correct response; and for verification of valid parameters. 

 

COEMsg - is intended to be used by PreInstall, PostInstall and DEINSTALL to display 
an information message to the user;  basic testing of creating prompt window using 
the COEMsg tool during PreInstall, PostInstall and DEINSTALL; and for verification of 
valid parameters. 

 

COEPrompt - is intended to be used by PreInstall, PostInstall and DEINSTALL to 
display an information message to the user; basic testing of creating prompt window 
using the COEMsg tool during PreInstall, PostInstall and DEINSTALL; and for 
verification of valid parameters. 

 

COEPromptPasswd - is similar to COEPrompt in syntax and operation.  It is intended 
to be used in PreInstall and PostInstall to prompt a user to enter a password. The 
user�s response is echoed on the screen.  It is also used for basic testing of creating 
prompt windows using the COEMsg tool during PreInstall and  PostInstall; to prompt 
user for password; and for verification of valid parameters. 

2.3 Test Data/Media Required   

The following segments are required to execute this test: 

COE Developer�s Toolkit Version 4.2.0.5 

2.4 Setup/Equipment Required 

The COE Kernel 4.2.0.0P6 and the KPC Test Data segment have been installed on the 
test platform. The working directory is /kpc/tk.  
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2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003 

Initial Release 

 

 



 

 

3. Test Procedure Submission Form 

 

Test Title: Developer�s Toolkit and Runtime Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 6  hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 

 

 Operator Action Expected Result Observed Result 

A 
4.1 Setup  

A.1 Test Data Installation  

A.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Login as sysadmin. 

The desktop appears. Startup 

A.1.2 Insert the DII COE Kernel and Toolkit Source 
Code, Test Data, and Documentation CD-ROM 
into the CD-ROM drive. 

The CD-ROM is inserted. Startup 

A.1.3 Select Applications > Application 
Manager > DII_APPS. 

The Application Manager window appears. Startup  

 

A.1.4 Double-click Segment Installer in the 
Application Manager – SysAdm window. 

The  Installer window appears. Setup  

 

A.1.5 Click Select Source. Select Source is selected. Setup  
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 Operator Action Expected Result Observed Result 

A.1.6 Click CD-ROM. CD-ROM is selected. Setup  

 

A.1.7 Click TD42P6.tar. TD42P6.tar is selected. Setup  

 

A.1.8 Click OK. The Installer window reappears. Setup  

 

A.1.9 Click Read Contents. The Installer window disappears while 
message boxes appear informing that the system is 
Checking media and then Read Contents 
in progress. 

The Installer window reappears with KPC 
Test Data for 4200P6 Version 
1.0.0.0 listed under Select Software To 
Install. 

Setup  

 

A.1.10 Select the KPC Test Data for 4200P6 Version 
1.0.0.0.  

KPC Test Data for 4200P6 Version 
1.0.0.0 is highlighted. 

Setup  

 

A.1.11 Click Install. AN ENTER A PASSWORD dialog box appears. Setup  

 

A.1.12 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Setup  
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 Operator Action Expected Result Observed Result 

A.1.13 Click OK. The dialog box disappears.  

A RESPOND TO THE MESSAGE dialog box 
appears with the message  
Please insert CD Volume #1 for the 
segment ‘KPC Test Data for 4200P6! 
When you are ready press the OK 
button. 

Setup  

A.1.14 Click OK. The Installer window reappears. Setup  
 

A.1.15 Verify that KPC Test Data for 4200P6 
appears in the list under Currently 
Installed Segments. 

KPC Test Data for 4200P6 appears in the 
list under Currently Installed 
Segments. 

Setup  

 

A.1.16 Eject the CD-ROM. The CD-ROM ejects. Setup  

 

A.2 Install the Developer�s Toolkit on the Candidate Platform (kpccp)  

A.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Load the DII COE Developer’s Toolkit 
tape into the tape drive or CD into the CD drive. 

The tape or CD loads. Startup 

A.2.2 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Startup 

A.2.3 At the command prompt type  
su – 

The Password prompt returns. Startup 
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 Operator Action Expected Result Observed Result 

A.2.4 At the Password prompt type the root 
password. 

The command prompt returns. Startup 

A.2.5 At the command prompt type  
csh 

The command prompt returns. Startup 

A.2.6 At the command prompt type  
/h/COE/Comp/APM/bin/APM_KeyServer 

The Key Server dialog box appears. Startup 

A.2.7 Enter the Master APM Authentication key and 
click OK. 

A confirmation dialog box appears indicating that 
the key server has started. 

Startup 

A.2.8 Click OK. The dialog boxes disappear. 

 

Startup 

A.2.9 If installing from tape: 
At the command prompt type 
cd /tmp [r] 

tar xvf /dev/rmt/Xm 

The command prompt returns. Startup 

A.2.10 At the command prompt type 
cd /h 

The command prompt returns. Startup 
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A.2.11 At the command prompt type 

/cdrom/cdrom0/DIIDEV_mp (for CD)  

or 
/cdrom/cdrom0/seg/DIIDEV_4205_sol_mp 
(for the KPC CD)  

or 

/tmp/DIIDEV_mp (for tape) 

File names are displayed in the Terminal 
window as they are extracted. 

The command prompt returns. 

Startup 

A.2.12 At the command prompt type  
echo $shell 

/bin/csh is displayed and a command prompt 
returns. 

Setup 

A.2.13 At the command prompt type 
set path=($path /h/DII_DEV/bin) 

The command prompt returns. Setup 
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 Operator Action Expected Result Observed Result 

B 
4.2 Verify the �Help� (-h and �H) and �Version� (-V) Options For All Developer Tools 

B.1 Execute the �h, -H, -V Test Script  

B.1.1 NOTE: Perform the following step on the 
Candidate Platform (kpccp).  

At the command prompt type  
cd /kpc/tk 

The command prompt returns. Startup 

B.1.2 At the command prompt type 
./TKhHV.test 

The following messages appear: 
There should be no differences 
between the files in TkhHVout.orig 
and TkhKVout.new 

Done 

NOTE: The TkhHVout.orig file assumes a Toolkit 
version 4.2.0.5 (the latest Solaris 8 released 
version). If the vendor�s supplied toolkit is version 
4.2.0.6, a difference will appear. This is not a 
failure of this step. 

Circle one:  PASS / FAIL 
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C 4.3 TimeStamp 

C.1 Verify Valid Parameters  

C.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cd /kpc/tk/TSseg/SegDescrip 

The command prompt returns. Setup 

C.1.2 At the command prompt type 
more VERSION 

The VERSION file is viewed and the date and time 
fields noted. 

Circle one:  PASS / FAIL 

 

 

 

Date:_____________ 

Time:_____________ 

C.1.3 At the command prompt type 
TimeStamp –p /kpc/tk TSseg 

The command prompt returns. Circle one:  PASS / FAIL 

 

C.1.4 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

C.1.5 At the command prompt type 
date 

The current system date and time are displayed. Circle one:  PASS / FAIL 

 

 

 

Date:_____________ 

Time:_____________ 

C.1.6 At the command prompt type 
more VERSION 

TimeStamp updated the VERSION file to reflect 
the current date and a time that is very close to the 
current system time. 

Circle one:  PASS / FAIL 

 

 

 

Date:_____________ 

Time:_____________ 

C.2 Verify Invalid Parameters/Entries 
NOTE: The tool should error with invalid entries 

 

C.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TimeStamp  

The tool�s help is displayed and a command prompt 
returns. 

Circle one:  PASS / FAIL 

 

 

C.2.2 At the command prompt type 
TimeStamp Tester 

Error message will indicate that segment specified 
does not exist. 

Circle one:  PASS / FAIL 
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C.3 Verify Invalid VERSION Files  

C.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
more VERSION 

The VERSION file is viewed and the date and time 
fields noted.  

Setup 

 

Date:_____________ 

Time:_____________ 

C.3.2 At the command prompt type 
cp –p /kpc/tk/TSdata/version4 
./VERSION 

The command prompt returns. Setup 

C.3.3 At the command prompt type 
TimeStamp –p /kpc/tk TSseg  

The tool displays an error message.  
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 

 

 

C.3.4 At the command prompt type 
more VERSION 

This test case has an invalid version and no time 
(.2.0.0.1 : 10/25/94). 

Circle one:  PASS / FAIL 

 

C.3.5 At the command prompt type  
cp –p /kpc/tk/TSdata/version2 ./VERSION 

The command prompt returns. Setup 

C.3.6 At the command prompt type 
TimeStamp –p /kpc/tk TSseg  

The tool displays an error message. 
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 
 

C.3.7 At the command prompt type 
more VERSION 

This test case has an invalid version and no time 
(0.0.1 : 10/25/94). 

Circle one:  PASS / FAIL 
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C.3.8 At the command prompt type 
cp –p /kpc/tk/TSdata/version1 ./VERSION 

The command prompt returns. Setup 

 

C.3.9 At the command prompt type 
TimeStamp –p /kpc/tk TSseg 

The tool displays an error message.  
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 

 

C.3.10 At the command prompt type 
more VERSION 

This test case has an invalid version and no time 
(0.1 : 10/25/94). 

Circle one:  PASS / FAIL 

 

C.3.11 At the command prompt type 
cp –p /kpc/tk/TSdata/version0 ./VERSION 

The command prompt returns. Setup 

C.3.12 At the command prompt type 
TimeStamp –p /kpc/tk TSseg  

The tool displays an error message. 
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 

 

 

C.3.13 At the command prompt type 
more VERSION 

This test case has an invalid version and no time 
(1 : 10/25/94). 

Circle one:  PASS / FAIL 

 

C.3.14 At the command prompt type 
cp –p /kpc/tk/TSdata/version_none 
./VERSION 

The command prompt returns. Setup 

C.3.15 At the command prompt type 
TimeStamp –p /kpc/tk TSseg 

The tool displays an error message.  
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 
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C.3.16 At the command prompt type 
more VERSION 

This test case has an invalid version  
( 10/25/94 : 13:45). 

Circle one:  PASS / FAIL 

 

C.3.17 At the command prompt type 
rm VERSION 

The command prompt returns. Setup 

C.3.18 At the command prompt type 
TimeStamp –p /kpc/tk TSseg  

The tool displays an error message: 
ERROR, Unable To Get [VERSION] 
Descriptor Information 

Circle one:  PASS / FAIL 

 
 

C.3.19 At the command prompt type 
more VERSION 

An error message is displayed indicating there is no 
VERSION file. 

Circle one:  PASS / FAIL 

 

C.3.20 At the command prompt type 
cp –p /kpc/tk/TSdata/versionA 
./VERSION 

The command prompt returns. 

 

Setup 

C.3.21 At the command prompt type 
TimeStamp –p /kpc/tk TSseg   

The tool displays an error message.  
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 

 

 

C.3.22 At the command prompt type 
more VERSION 

This test case has an invalid version 
(A.B.C.D: 10/25/94 : 17:34). 

Circle one:  PASS / FAIL 
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C.4 Verify Tool Functionality With Valid Versions But Invalid Dates and Times 
NOTE:  The tool should update the VERSION file correctly when run against VERSION files 
containing invalid dates and times 

 

C.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –p 
/kpc/tk/TSdata/version_no_time [s] 
./VERSION 

The command prompt returns. Setup 

 

C.4.2 At the command prompt type 
TimeStamp –p /kpc/tk TSseg 

The command prompt returns. 

No errors or warnings returned. 

Circle one:  PASS / FAIL 

C.4.3 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

C.4.4 At the command prompt type 
date 

The current system date and time are displayed. Circle one:  PASS / FAIL 

 

  

 

Date:_____________ 

Time:_____________ 
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C.4.5 At the command prompt type 
more VERSION 

TimeStamp updated the VERSION file to reflect 
the current date and a time that is very close to the 
current system time 

Circle one:  PASS / FAIL 

 

  

 

Date:_____________ 

Time:_____________ 

C.5 Verify Tool Functionality With Invalid VERSION File Formats  

C.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –p /kpc/tk/TSdata/version_semi [s] 
./VERSION 

The command prompt returns. Setup 

C.5.2 At the command prompt type 
TimeStamp –p /kpc/tk TSseg 

The tool displays an error message.  
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 

 

 

C.5.3 At the command prompt type 
more VERSION 

This test case has a valid version, date and time, but 
also contains invalid separators  (3.0.0.1 ; 
10/25/94 ; 23:22). 

Circle one:  PASS / FAIL 

 

 

C.5.4 At the command prompt type 
cp –p /kpc/tk/TSdata/version_space 
[s] ./VERSION 

The command prompt returns. Setup 
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C.5.5 At the command prompt type 
TimeStamp –p /kpc/tk TSseg  

The tool displays an error message.  
[VERSION] segment version number 
does not conform to the COE. 

Circle one:  PASS / FAIL 

 

 

C.5.6 At the command prompt type 
more VERSION 

This test case has a valid version, date and time, but 
doesn�t contain separators, (3.0.0.1  
10/25/94 22:22). 

Circle one:  PASS / FAIL 

 

C.5.7 At the command prompt type 
cp –p /kpc/tk/TSdata/VERSION.orig 
[s] ./VERSION 

The command prompt returns. Cleanup 

D 4.4 MakeAttribs 

D.1 Verify Correct Functionality When Files of Varying Permission and Ownership Exist. Pipe the 
Results To an Output File So That They Can Be Viewed and Compared To the Baseline File 

 

D.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type  
cd /kpc/tk 

The command prompt returns. Setup 

D.1.2   At the command prompt type 
 rm –f MAseg/SegDescrip/FileAttribs 

The command prompt returns. Setup 

D.1.3 At the command prompt type  
MakeAttribs –p . MAseg >& tmp/MAout.new 

The command prompt returns. Circle one:  PASS / FAIL 
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D.1.4 At the command prompt type  
echo $status 

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

D.1.5 At the command prompt type 
diff tmp/MAout.new 
MAdata/MAout.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

D.1.6 At the command prompt type  
diff MAseg/SegDescrip/FileAttribs 
[s] 
MAdata/FileAttribs.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

D.1.7 At the command prompt type  
rm MAseg/SegDescrip/FileAttribs 

The command prompt returns. Cleanup 

D.2 Running Tool With Verbose �v Parameter  

D.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type  
MakeAttribs –v –p . MAseg >& 
tmp/MAout-v.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

D.2.2 At the command prompt type  
echo $status 

A status of 0 (indicating success) is displayed. Circle one:  PASS / FAIL 

 

D.2.3 At the command prompt type  
diff tmp/MAout-v.new MAdata/MAout-
v.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 
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D.2.4 At the command prompt type 
diff MAseg/SegDescrip/FileAttribs 
[s]  
MAdata/FileAttribs-v.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

D.2.5 At the command prompt type  
rm MAseg/SegDescrip/FileAttribs 

The command prompt returns. Cleanup 

D.3 Run the Tool With Suppress Warning �w Parameter  

D.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type  
MakeAttribs –w –p . MAseg >& 
tmp/MAout-w.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

D.3.2 At the command prompt type  
echo $status 

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

D.3.3 At the command prompt type 
diff tmp/MAout-w.new MAdata/MAout-
w.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

D.3.4 At the command prompt type 
diff MAseg/SegDescrip/FileAttribs 
[s] 
MAdata/FileAttribs-w.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

D.3.5 At the command prompt type  
rm MAseg/SegDescrip/FileAttribs 

The command prompt returns. Cleanup 
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D.4 Test the Tool To See If It Defaults To /h When the Path Is Not Specified As Stated In the Help 
Option. At the Same Time, Test the Tool You See If It Is Overwriting the FileAttribs File As It 
Should 

 

D.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type  
cp –pr MAseg  /h 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

D.4.2 At the command prompt type  
MakeAttribs MAseg 

Warnings will indicate files have execute 
permissions set, have permissions greater than 777, 
or have permissions equal to 777 and system will 
return a command prompt. 

Circle one:  PASS / FAIL 

 

 

D.4.3 At the command prompt type  
echo $status 

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

D.4.4 At the command prompt type 
date 

Date and time from the system is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

D.4.5 At the command prompt type  
ls –la /h/MAseg/SegDescrip 

Files including FileAttribs under 
/h/MAseg/SegDescrip are listed and a 
command prompt returns. FileAttribs has a 
current date and current time. 

Circle one:  PASS / FAIL 
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D.5 Cleaning Up System After Testing This Tool  

D.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type  
rm –rf  /h/MAseg 

The command prompt returns. Cleanup 

D.5.2 At the command prompt type  
rm tmp/* 

The command prompt returns. Cleanup 

E 4.5 CalcSpace 

E.1 Verify Tool With Basic Parameters  

E.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

At the command prompt type 
cd /kpc/tk 

The command prompt returns.  Circle one:  PASS / FAIL 

 

 

E.1.2 At the command prompt type 
more CSseg/SegDescrip/SegInfo 

Verify the CalcSpace tool computes the space (in 
bytes) required for the segment specified.  

The $DISK keyword has the following data: 
$DISK:1000:1000 

Circle one:  PASS / FAIL 

 

 

E.1.3 At the command prompt type 
CalcSpace –v –p . CSseg 

The size of the segment will output to the screen. 
Some warnings may also be displayed. 

Circle one:  PASS / FAIL 

 

E.1.4 At the command prompt type 
echo $status  

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 
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E.1.5 At the command prompt type 
more CSseg/SegDescrip/SegInfo 

The Hardware descriptor will be updated 
accordingly to the size value calculated and 
returned by the CalcSpace tool. The reserve value 
is still 1000. 

Circle one:  PASS / FAIL 

 

 

E.1.6 At the command prompt type 
CalcSpace –p . CSseg >& 
tmp/CSout.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

E.1.7 At the command prompt type 
echo $status 

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

E.1.8 At the command prompt type 
diff tmp/CSout.new 
CSdata/CSout.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

E.2 Run Tool With the Verbose -v Parameter  

E.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CalcSpace –v –p . CSseg >& 
tmp/CSout-v.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

E.2.2 At the command prompt type 
echo $status 

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

E.2.3 At the command prompt type 
diff tmp/CSout-v.new CSdata/CSout-
v.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 
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E.3 Run the Tool With Suppress Warning �w Parameter  

E.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CalcSpace –w –p . CSseg >& 
tmp/CSout-w.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

E.3.2 At the command prompt type 
echo $status 

A status of 0 (indicating success) is displayed and a 
command prompt returns. 

Circle one:  PASS / FAIL 

 

E.3.3 At the command prompt type 
diff tmp/CSout-w.new CSdata/CSout-
w.orig 

The command prompt returns with no messages. Circle one:  PASS / FAIL 

 

E.4 Verify That An Error Is Returned If A Segment Is Missing SegInfo  

E.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
mv CSseg/SegDescrip/SegInfo [s] 
CSseg/SegDescrip/SegInfo.orig  

The command prompt returns. Setup 

E.4.2 At the command prompt type 
CalcSpace –p . CSseg 

An error message is displayed stating that the 
required SegInfo file is not found. 

Circle one:  PASS / FAIL 

 

E.4.3 At the command prompt type 
mv CSseg/SegDescrip/SegInfo.orig 
[s] 
CSseg/SegDescrip/SegInfo 

The command prompt returns. Cleanup 



© 2003, The Open Group 
Chapter 7, page 27 

 
 

 

 

 Operator Action Expected Result Observed Result 

F 4.6 VerUpdate 

F.1 Verify Basic Parameters  

F.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cd /kpc/tk/VUseg/SegDescrip 

The command prompt returns. Setup 

F.1.2 At the command prompt type 
more VERSION  

The version is viewed and noted. Circle one:  PASS / FAIL 

 

 

 

Version:______________ 

Date:_________________ 

Time:_________________ 

F.1.3 At the command prompt type 
VerUpdate –p /kpc/tk VUseg 

The following message is displayed: 
No Version Number Update Is 
Specified On The Command Line. The 
fourth digit of the Segment 
Version Number will be 
Automatically Incremented. The 
version number 1.2.3.5 has been 
inserted into the VERSION file. 

Circle one:  PASS / FAIL 
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F.1.4 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.1.5 At the command prompt type 
date 

The current system date and time are displayed. Circle one:  PASS / FAIL 

 

 

 

Date:_________________ 

Time:_______________ 

F.1.6 At the command prompt type 
more VERSION 

VerUpdate updated the VERSION file to reflect the 
incremented version number and current date and 
time. 

Circle one:  PASS / FAIL 

 

 

 

Version:_______________ 

Date:_________________ 

Time:_________________ 

F.1.7 At the command prompt type 
cp –rp /kpc/tk/VUseg /h/ValidSeg 

The command prompt returns. Circle one:  PASS / FAIL 
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F.1.8 At the command prompt type 
more [s]  
/h/ValidSeg/SegDescrip/VERSION 

The VERSION file is viewed and noted. 

 

Circle one:  PASS / FAIL 

 

 

 

Version:_______________ 

Date:_________________ 

Time:_________________ 

F.1.9 At the command prompt type 
VerUpdate ValidSeg 

The following message is displayed: 
No Version Number Update Is 
Specified On The Command Line. The 
fourth digit of the Segment 
Version Number Will Be 
Automatically Incremented. The 
version number 1.2.3.6 has been 
inserted into the VERSION file. 

Circle one:  PASS / FAIL 

 

 

F.1.10 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.1.11 At the command prompt type 
date 

The current system date and time are displayed. Circle one:  PASS / FAIL 

 

  

Date:_________________ 

Time:_________________ 
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F.1.12 At the command prompt type 
more /h/ValidSeg/SegDescrip/VERSION 

VerUpdate updated the VERSION file to reflect 
the incremented version number and current date 
and time. 

Circle one:  PASS / FAIL 

 

  

 

Version:_______________ 

Date:_________________ 

Time:_________________ 

F.1.13 At the command prompt type 
more VERSION 

The VERSION file is viewed and noted. 

  

  

Circle one:  PASS / FAIL 

 

 

 

Version:_______________ 

Date:_________________ 

Time:_________________ 

F.1.14 At the command prompt type 
VerUpdate –d 1 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 2.2.3.5 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.15 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 
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F.1.16 At the command prompt type 
more VERSION 

The version number is changed to 2.2.3.5. 

  

Circle one:  PASS / FAIL 

 

F.1.17 At the command prompt type 
VerUpdate –d 2 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 2.3.3.5 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.18 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.1.19 At the command prompt type 
more VERSION 

The version number is changed to 2.3.3.5. Circle one:  PASS / FAIL 

 

F.1.20 At the command prompt type 
VerUpdate –d 3 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 2.3.4.5 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.21 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.1.22 At the command prompt type 
more VERSION 

The version number is changed to 2.3.4.5. Circle one:  PASS / FAIL 

 

F.1.23 At the command prompt type 
VerUpdate –d 4 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 2.3.4.6 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 
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F.1.24 At the command prompt type 
echo $status 

0 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.1.25 At the command prompt type 
more VERSION 

The version number is changed to 2.3.4.6. Circle one:  PASS / FAIL 

 

F.1.26 At the command prompt type 
VerUpdate –d 12 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 3.4.4.6 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.27 At the command prompt type 
echo $status 

0 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.1.28 At the command prompt type 
more VERSION 

The version number is changed to 3.4.4.6. Circle one:  PASS / FAIL 

 

F.1.29 At the command prompt type 
VerUpdate –d 1234 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 4.5.5.7 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.30 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.1.31 At the command prompt type 
more VERSION 

The version number is changed to 4.5.5.7. Circle one:  PASS / FAIL 
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F.1.32 At the command prompt type 
VerUpdate –d 31 –p /kpc/tk VUseg 

The following message is displayed: 
The version number 5.5.6.7 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.33 At the command prompt type 
echo $status 

 0 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.1.34 At the command prompt type 
more VERSION 

The version number is changed to 5.5.6.7. Circle one:  PASS / FAIL 

 

F.1.35 At the command prompt type 
VerUpdate –p /kpc/tk VUseg 

The following message is displayed: 
The version number 5.5.6.8 has 
been inserted into the VERSION 
file. 

Circle one:  PASS / FAIL 

 

 

F.1.36 At the command prompt type 
echo $status 

 0 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.1.37 At the command prompt type 
more VERSION 

The version number is changed to 5.5.6.8. Circle one:  PASS / FAIL 

 

F.1.38 At the command prompt type 
cp –p /kpc/tk/VUdata/version_sol 
./VERSION 

The command prompt returns. Setup 
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F.1.39 At the command prompt type 
more VERSION 

The VERSION file is viewed and noted. Circle one:  PASS / FAIL 

 

  

 

Version:_______________ 

Date:_________________ 

Time:_________________ 

F.2 Verify Invalid Parameters/Entries   

F.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerUpdate 

The tool�s help is displayed and a command prompt 
returns. 

  

  

Circle one:  PASS / FAIL 

 

  

F.2.2 At the command prompt type 
echo $status 

255 is displayed. Circle one:  PASS / FAIL 

 

F.2.3 At the command prompt type 
VerUpdate Tester 

Error message will indicate that segment specified 
does not exist. 

Circle one:  PASS / FAIL 

F.2.4 At the command prompt type 
echo $status 

255 is displayed. 

 

Circle one:  PASS / FAIL 
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F.2.5 At the command prompt type 
VerUpdate –i 2.0 –p /kpc/tk VUseg 

The following message is displayed: 
VerUpdate: Validate Version Length 
From 7 Up To 32 Characters Long 
(example 1.0.0.0) Not 3 

Circle one:  PASS / FAIL 

 

 

F.2.6 At the command prompt type 
echo $status 

255 is displayed. Circle one:  PASS / FAIL 

 

F.2.7 At the command prompt type 
more VERSION 

The version number is still 1.2.3.4/SOL . Circle one:  PASS / FAIL 

 

F.2.8 At the command prompt type 
VerUpdate –i 2.1.1.1.1 –p /kpc/tk 
VUseg 

The following error message is displayed: 
VerUpdate: Invalid Version Format: 
2.1.1.1.1, Use Format 1.0.0.0 

Circle one:  PASS / FAIL 

F.2.9 At the command prompt type 
echo $status 

255 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.2.10 At the command prompt type 
more VERSION 

The version number is still 1.2.3.4/SOL . Circle one:  PASS / FAIL 

 

F.2.11 At the command prompt type 
VerUpdate –i 2.0.0.. –p /kpc/tk 
VUseg 

The following error message is displayed: 
VerUpdate: Invalid Version Format: 
2.0.0.., Use Format 1.0.0.0 

Circle one:  PASS / FAIL 

 

F.2.12 At the command prompt type 
echo $status 

255 is displayed. Circle one:  PASS / FAIL 

 

F.2.13 At the command prompt type 
more VERSION 

The version number is still 1.2.3.4/SOL . Circle one:  PASS / FAIL 
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F.2.14 At the command prompt type 
VerUpdate –i .2.1. –p /kpc/tk 
VUseg 

The following message is displayed: 
VerUpdate: Validate Version Length 
From 7 Up To 32 Characters Long 
(example 1.0.0.0) Not 5 

Circle one:  PASS / FAIL 

  

 

F.2.15 At the command prompt type 
echo $status 

255 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.2.16 At the command prompt type 
more VERSION 

The version number is still 1.2.3.4/SOL . Circle one:  PASS / FAIL 

F.3 Verify Function With Invalid VERSION Files  

F.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –p /kpc/tk/VUdata/version_none 
./VERSION 

The command prompt returns. Setup  

 

F.3.2 At the command prompt type 
more VERSION 

The VERSION file is viewed and noted. The 
version number field is blank. 

Circle one:  PASS / FAIL 

 

  

 

Version:____________ 

Date:_______________ 

Time:_______________ 
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F.3.3 At the command prompt type 
VerUpdate –p /kpc/tk VUseg 

The following message is displayed: 
No Version Number Found In File. 
Version Number Set To 1.0.0.0. The 
version number 1.0.0.0 has been 
inserted into the VERSION file. 

Circle one:  PASS / FAIL 

 

  

 

F.3.4 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.3.5 At the command prompt type 
more VERSION 

The version number is 1.0.0.0. Circle one:  PASS / FAIL 

F.3.6 At the command prompt type 
cp –p 
/kpc/tk/VUdata/version_no_time 
./VERSION 

The command prompt returns. Setup 

F.3.7 At the command prompt type 
more VERSION 

The VERSION file is viewed and noted. The time 
field is blank. 

Circle one:  PASS / FAIL 

 

  

 

Version:_______________ 

Date:_________________ 

Time:_________________ 
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F.3.8 At the command prompt type 
VerUpdate –p /kpc/tk  VUseg 

The following message is displayed: 
No Version Number Update Is 
Specified On The Command Line. The 
fourth digit of the Segment 
Version Number Will Be 
Automatically Incremented. The 
version number 1.2.3.5 has been 
inserted into the VERSION file. 

Circle one:  PASS / FAIL 

 

  

 

F.3.9 At the command prompt type 
echo $status 

0 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.3.10 At the command prompt type 
more VERSION 

The version number is 1.2.3.5. 

The current date and time are displayed. 

Circle one:  PASS / FAIL 

F.3.11 At the command prompt type 
cp –p 
/kpc/tk/VUdata/version_no_date 
./VERSION 

The command prompt returns.  Setup 

F.3.12 At the command prompt type 
more VERSION 

The VERSION file is viewed and noted. The date 
and time fields are blank. 

 

Circle one:  PASS / FAIL 

 

  

 

Version:_______________ 

Date:_________________ 

Time:_________________ 
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F.3.13 At the command prompt type 
VerUpdate –p /kpc/tk VUseg 

The following messages are displayed: 
[VERSION] segment version date is 
missing. 

No Version Number Update Is 
Specified On The Command Line. The 
fourth digit of the Segment 
Version Number Will Be 
Automatically Incremented. The 
version number 1.2.3.5 has been 
inserted into the VERSION file. 

Circle one:  PASS / FAIL 

 

  

 

F.3.14 At the command prompt type 
echo $status 

0 is displayed. 

 

Circle one:  PASS / FAIL 

 

F.3.15 At the command prompt type 
more VERSION 

The version number is 1.2.3.5.  

The current date and time are displayed. 

Circle one:  PASS / FAIL 

F.4 Verify Tool Functionality With No VERSION File  

F.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
rm VERSION 

The command prompt returns. Setup 

F.4.2 At the command prompt type 
VerUpdate –p /kpc/tk VUseg 

The following message is displayed: 
No Version File Found. Version 
Number Set To 1.0.0.0 

Circle one:  PASS / FAIL 
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F.4.3 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

 

F.4.4 At the command prompt type 
more VERSION 

The version number is 1.0.0.0. 

The current date and time are displayed. 

Circle one:  PASS / FAIL 

 

F.4.5 At the command prompt type 
rm VERSION 

The command prompt returns. Setup 

F.4.6 At the command prompt type 
VerUpdate –i 3.3.3.3 –p /kpc/tk VUseg 

The following message is displayed: 
No Version File Found. Version 
Number Set To 3.3.3.3 

Circle one:  PASS / FAIL 

 

 

F.4.7 At the command prompt type 
echo $status 

0 is displayed. Circle one:  PASS / FAIL 

F.4.8 At the command prompt type 
more VERSION 

The version number is 3.3.3.3. 

The current date and time are displayed. 

Circle one:  PASS / FAIL 

F.4.9 At the command prompt type 
cp /kpc/tk/VUdata/VERSION.orig 
./VERSION 

The command prompt returns. Cleanup 
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G 4.7 Verify Functionality and Options Of VerifySeg 

G.1 Verify the VerifySeg �-p� Option  

G.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cd /kpc/tk 

The command prompt returns.  

G.1.2 At the command prompt type 
VerifySeg –p . VSseg >& 
tmp/VSOutput.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

G.1.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.1.4 At the command prompt type 
diff tmp/VSOutput.new 
VSseg/Integ/VSOutput 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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G.2 Verify the VerifySeg �-v� Option  

G.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –v –p . VSseg >& 
tmp/VSout-v.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.2.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

G.2.3 At the command prompt type 
diff tmp/VSout-v.new VSdata/VSout-
v.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 

 

G.3 Verify the VerifySeg �-w� Option  

G.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –w –p . VSseg >& 
tmp/VSout-w.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.3.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.3.3 At the command prompt type 
diff tmp/VSout-w.new VSdata/VSout-
w.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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G.4 Verify the VerifySeg �-C� Option  

G.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –p VSdata/VSargs /h 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.4.2 At the command prompt type 
VerifySeg –C VSargs >& tmp/VSout-
C.new 

The command prompt returns. Circle one:  PASS / FAIL 
 

G.4.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.4.4 At the command prompt type 
diff tmp/VSout-C.new VSdata/VSout-
C.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 

 

G.4.5 At the command prompt type 
rm -f /h/VSargs 

The command prompt returns. Cleanup 



© 2003, The Open Group 
Chapter 7, page 44 

 
 

 

 

 Operator Action Expected Result Observed Result 

G.5 Verify the VerifySeg �-e� Option  

G.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –e –p . VSseg >& 
tmp/VSout-e.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.5.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.5.3 At the command prompt type 
diff tmp/VSout-e.new VSdata/VSout-
e.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 

 

G.6 Verify the VerifySeg �-f� Option  

G.6.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –f –p . VSseg >& tmp/VSout-f.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.6.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.6.3 At the command prompt type 
diff tmp/VSout-f.new VSdata/VSout-
f.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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G.7 Verify the VerifySeg �-o� Option  

G.7.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –o –p . VSseg >& 
tmp/VSout-o.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.7.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.7.3 At the command prompt type 
diff tmp/VSout-o.new VSdata/VSout-
o.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 

 

G.8 Verify the VerifySeg �-s� Option  

G.8.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –s SegInfo –p . VSseg >& 
[s] tmp/VSout-s.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.8.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

G.8.3 At the command prompt type 
diff tmp/VSout-s.new VSdata/VSout-
s.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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G.9 Verify the VerifySeg �-t� Option  

G.9.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –t >& tmp/VSout-t.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.9.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

G.9.3 At the command prompt type 
diff tmp/VSout-t.new VSdata/VSout-
t.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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G.10 Verify the VerifySeg �-x� Option  

G.10.1 NOTE: Perform the following step on the 
Candidate Platform (kpccp).  

At the command prompt type 
./VS-x.test 

The following messages appear: 
There should be no differences 
between the files in 
VSdata/VSout-x.orig and 
VSdata/VSout-x.new 

Done 

The message No match may also appear. 

Circle one:  PASS / FAIL 

 

 

G.11 Verify that VerifySeg�s Validation Mechanisms Detect COE Violations and Report Basic Segment 
Errors 

 

G.11.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –p VSdata/SegName.err [s] 
VSseg/SegDescrip/SegName 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.11.2 At the command prompt type 
VerifySeg –p . VSseg >& 
tmp/VSout_err.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

G.11.3 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 
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G.11.4 Compare the VerifySeg output with the default 
output. Type: 
diff tmp/VSout_err.new 
VSdata/VSout_err.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 

 

 

G.11.5 At the command prompt type 
cp –p VSdata/SegName.orig [s] 
VSseg/SegDescrip/SegName 

The command prompt returns. Cleanup 

G.12 Verify That VerifySeg�s Validation Mechanisms Detect Segment Anomalies and Report Basic 
Segment Warnings 

 

G.12.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –p . VSseg_w >& 
tmp/VSout_warn.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.12.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

 

G.12.3 At the command prompt type 
diff tmp/VSout_warn.new 
VSdata/VSout_warn.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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G.13 Verify That VerifySeg Can Properly Validate Segments of Each Segment Type  

G.13.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
./VS-type.test 

The following messages appear in the terminal 
window: 
There should be no differences 
between the files in 
VSdata/VSout-type.orig and 
VSdata/VSout-type.new 

Done  

The message No match may also appear. 

Circle one:  PASS / FAIL 

 

 

G.14 Verify the VerifySeg Can Properly Process the Process Descriptor  

G.14.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
VerifySeg –p . ProcSeg >& 
tmp/VSout-proc.new 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

G.14.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

G.14.3 At the command prompt type 
diff tmp/VSout-proc.new 
VSdata/VSout-proc.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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H 4.8 Verify Functionality and Options Of MakeInstall 

H.1 Verify the MakeInstall �-p� Option Using A Tape  

H.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Insert a blank tape into the tape drive. 

The tape is accepted. Setup 

H.1.2 At the command prompt type 
mt rew 

NOTE: This command is OS specific and assumes 
that /dev/rmt/0m is the default tape device 
address. Use the relevant command on the OS 
being tested and note it in the Observed Result 
column. 

The tape is rewound. Setup 

H.1.3 At the command prompt type 
MakeInstall –t /dev/rmt/0mn -p . MIseg  

Note: 0 is the device address of a �no rewind� tape 
device and may differ on your system. 

Messages/information will appear in the 
Terminal window indicating the process steps 
being executed by MakeInstall. The following 
prompt appears: 
Enter the size of the tape in 
MByte or type ‘q’ to quit. 

Circle one:  PASS / FAIL 

 

 

H.1.4 At the prompt type 
80 

The following prompt appears: 
Processing segment: /kpc/tk/MIseg 

Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 
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H.1.5 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

 

H.1.6 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters) : 

Circle one:  PASS / FAIL 

 

 

H.1.7 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (1) 

Space requirements for segment 

The following prompt appears: 
Insert tape #1 

Press any key to continue. 

Circle one:  PASS / FAIL 

 

 

H.1.8 Press ENTER. The following message appears: 
DII Install tape completed 

Circle one:  PASS / FAIL 

 

 

H.1.9 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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H.1.10 At the command prompt type 
mt rewoffl 

NOTE: This command is OS specific and assumes 
that /dev/rmt/0m is the default tape device 
address. Use the relevant command on the OS 
being tested and note it in the Observed Result 
column. 

The tape is rewound and ejected. Cleanup 

H.2 Verify the MakeInstall �-o� Option  

H.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Insert the tape in the tape drive. 

The tape loads Circle one:  PASS / FAIL 

 

 

H.2.2 At the command prompt type 
MakeInstall –o tmp/MIseg –p . MIseg 

Messages/information will appear in the 
Terminal window indicating the process steps 
being executed by MakeInstall. The following 
prompt appears: 
Processing segment: /kpc/tk/MIseg 

Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

H.2.3 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 
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H.2.4 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters): 

Circle one:  PASS / FAIL 

 

 

H.2.5 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (1) 

Space requirements for segment 

The command prompt returns. 

Circle one:  PASS / FAIL 

 

 

H.2.6 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

H.3 Evaluate MakeInstall Segment Output  

H.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
ls tmp 

Listed is a tar file named MIseg.tar created by 
MakeInstall which contains the 
MakeInstall/segmented image of the MIseg 
segment. 

Circle one:  PASS / FAIL 
 

 

H.3.2 At the command prompt type 
tar tvf tmp/MIseg.tar 

The Table of Contents information for 
MIseg.tar appears. 

Circle one:  PASS / FAIL 
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H.3.3 At the command prompt type 
more MIdata/tvf_MIseg.orig 

With the exception of the date and time, the 
contents of the control file tvf_MIseg.orig is 
identical to the Table of Contents listing given in 
the previous step. 

Circle one:  PASS / FAIL 

 

 

H.4 Verify the MakeInstall �-f� Option  

H.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
MakeInstall –f –o tmp/MIseg -p . MIseg 

Messages/information will appear in the terminal 
window indicating the process steps being executed 
by MakeInstall. The following prompt appears: 
Processing segment: /kpc/tk/MIseg 

Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

 

H.4.2 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

H.4.3 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters): 

Circle one:  PASS / FAIL 
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H.4.4 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (1) 

Space requirements for segment 

In addition, the following messages appear: 
Writing DIIHeader –C [s] 
/tmp/xxxx.MkIns distrib ... 

Writing TOC ... 

Writing MIseg ... 

Writing [s] 
MIseg:SOFTWARE:1.2.3.4:ALL.tar ... 

where xxxx is a temporary filename that may vary. 

The command prompt returns. 

Circle one:  PASS / FAIL 

 

 

H.4.5 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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H.5 Verify the MakeInstall �-s� Option  

H.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
MakeInstall –o tmp/MIseg -p . –s MIseg MIseg2 

Messages/information will appear in the terminal 
window indicating the process steps being executed 
by MakeInstall. The following prompt appears: 
Processing segment: /kpc/tk/MIseg 

Processing segment: /kpc/tk/MIseg2 

Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

 

H.5.2 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

H.5.3 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters) : 

Circle one:  PASS / FAIL 

 

 

H.5.4 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (2) 

Space requirements for segment 

The command prompt returns. 

Circle one:  PASS / FAIL 
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H.5.5 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

H.6 Verify the MakeInstall �-S� Option  

H.6.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
MakeInstall –o tmp/MIseg –p . [s] 
–S MIdata/MIlist MIdata/MIlist2  

Messages/information will appear in the terminal 
window indicating the process steps being executed 
by MakeInstall. The following prompt appears: 
Processing segment: /kpc/tk/MIseg 

Processing segment: /kpc/tk/MIseg2 

Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

 

H.6.2 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

H.6.3 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters): 

Circle one:  PASS / FAIL 
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H.6.4 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (2) 

Space requirements for segment 

The command prompt returns. 

Circle one:  PASS / FAIL 

 

 

H.6.5 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

H.7 Verify the MakeInstall �-v� Option  

H.7.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
MakeInstall –v –o tmp/MIseg –p . 
MIseg 

Messages/information will appear in the terminal 
window indicating the process steps being executed 
by MakeInstall. The following message appears: 
Processing segment: /kpc/tk/MIseg 

Six verbose messages appear indicated by lines 
beginning with (V)-----. 

The following prompt appears: 
Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

 

H.7.2 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 
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H.7.3 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters) : 

Circle one:  PASS / FAIL 

 

 

H.7.4 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (1) 

Space requirements for segment 

Six verbose messages appear indicated by lines 
beginning with (V)-----. 

The command prompt returns. 

Circle one:  PASS / FAIL 

 

 

H.7.5 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

H.8 Verify the MakeInstall �-x� Option  

H.8.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
MakeInstall –x -p . MIseg 

The following message appears: 
Processing segment: /kpc/tk/MIseg 

DII Install validation completed 

Circle one:  PASS / FAIL 

 

 

H.8.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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H.9 Verify That the MakeInstall Tool Can Detect That VerifySeg Has Not Been Run On A Segment  

H.9.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
mv MIseg/SegDescrip/Validated tmp 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

H.9.2 At the command prompt type 
MakeInstall –o tmp/MIseg –p . 
MIseg 

The following message appears: 
Processing segment: /kpc/tk/MIseg 

In addition, the following fatal error appears: 
Segment “MakeInstall Segment” in 
directory “/kpc/tk/MIseg” has been 
altered. Please run “VerifySeg” to 
validate the segment. 

Circle one:  PASS / FAIL 
 

 

H.9.3 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 

 

H.9.4 At the command prompt type 
mv tmp/Validated MIseg/SegDescrip 

The command prompt returns. Circle one:  PASS / FAIL 
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H.10 Verify the MakeInstall Segment Output Using the COEInstaller For Each Segment Type  

H.10.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
MakeInstall –o tmp/all_types -p . [s] 
–S MIdata/all_types_list 

Messages/information will appear in the 
Terminal window indicating the process steps 
being executed by MakeInstall. Prompts appear 
requesting if the COE Component Parent segment 
is to be added to the segment installation list. 

NOTE: If a warning appears indicating that the 
lib directory is non-standard for end-user, the test 
does not fail. You may safely ignore this warning. 

Circle one:  PASS / FAIL 

 

 

H.10.2 Type n for each of the 10 prompts requesting 
COE Component Parent. 

After all COE Component Parent prompts are 
dismissed, the following prompt appears: 
Enter your name for the Tape 
Header: 

Circle one:  PASS / FAIL 

 

 

H.10.3 Press ENTER. The following prompt appears: 
Enter a serial number for the Tape 
Header: 

Circle one:  PASS / FAIL 

H.10.4 Press ENTER. The following prompt appears: 
Enter any desired comment to put 
in the Tape Header (up to 255 
characters): 

Circle one:  PASS / FAIL 
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H.10.5 Press ENTER. MakeInstall will continue and display the following 
information: 

A segment description table 

The number of segments to be written to output 
device (10) 

Space requirements for segment 

Number of records processed 

(i.e. 

# records in   # records out) 

The command prompt returns. 

Circle one:  PASS / FAIL 

 

 

H.10.6 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

H.11 Verify That All Segment Types Placed On Disk Using MakeInstall Can Be Read and Processed By 
The COE Segment Installer 

 

H.11.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the  Installer window, click Select 
Source. 

The Select Source window appears. Setup 

H.11.2 In the Device panel, click DISK. The DISK option is selected and the 
Select File dialog box appears. 

Setup 
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H.11.3 In the Filter text box, select the text and replace 
it with: 
/kpc/tk/tmp/* 

/kpc/tk/tmp/* appears in the Filter text 
box. 

Setup 

H.11.4 Click OK. all_types.tar appears in the 
Filter text box. 

Setup 

H.11.5 In the Files panel, double-click on the following 
entry: 
all_types.tar 

The Installer window returns. Circle one:  PASS / FAIL 

 

 

H.11.6 Click Read Contents. 

NOTE: Resize the Installer window to view 
all segments. 

The following segments appear in the 
Select Software To Install panel: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Data-Global Segment 

Sample Data-Local Segment 

Sample Data-Segment Segment 

Sample Software Segment 

SampleSW.P1 

Circle one:  PASS / FAIL 
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H.11.7 Select the following segments in the 
Select Software To Install panel: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Software Segment 

All requested segments in the 
Select Software To Install panel are 
highlighted. 

Circle one:  PASS / FAIL 

 

 

H.11.8 Click Install. The following dialog boxes appear in sequence: 
Please wait...extracting the disk 
file with the selected segment: 
‘Sample Aggregate Segment’ 

Please wait...extracting the disk 
file with the selected segment: 
‘Sample Aggregate Child Segment’ 

PreInstall installation directory 
is /h/AcctGrps/SampleAcctGrp 

Circle one:  PASS / FAIL 

 

 

H.11.9 Click OK. The following dialog boxes appear in sequence: 
Please wait...extracting the disk 
file with the selected segment: 
‘Sample Account Group Segment’ 

PostInstall installation directory 
is /h/AcctGrps/SampleAcctGrp 

Circle one:  PASS / FAIL 
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H.11.10 Click OK. The following dialog box appears: 
PreInstall installation directory 
is /h/COE/Comp/SampleCOEChild 

Circle one:  PASS / FAIL 

 

 

H.11.11 Click OK. The following dialog boxes appear in sequence: 
Please wait...extracting the disk 
file with the selected segment: 
‘Sample COE Child Segment’ 
PostInstall installation directory 
is /h/ COE/Comp/SampleCOEChild 

Circle one:  PASS / FAIL 

 

 

H.11.12 Click OK. The following dialog boxes appear in sequence: 
Please wait...extracting the disk 
file with the selected segment: 
‘Sample COTS Segment’ 
PreInstall installation directory 
is /h/SampleSW 

Circle one:  PASS / FAIL 

 

 

H.11.13 Click OK. The following dialog boxes appear in sequence: 
Please wait...extracting the disk 
file with the selected segment: 
‘Sample Software Segment’ 
PostInstall installation directory 
is /h/SampleSW 

Circle one:  PASS / FAIL 
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H.11.14 Click OK. The following dialog box appears: 
Building Segment Lists 

The Installer window returns to the forefront. 

Circle one:  PASS / FAIL 

 

 

H.11.15 When installation is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

NOTE: Resize the Installer window to view 
all segments. 

The following segments are listed in the 
Currently Installed Segments panel: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Software Segment 

An asterisk (*) appears next to the aforementioned 
segments in the 
Select Software To Install panel: 

Circle one:  PASS / FAIL 

 

 

H.11.16 Select the following segments in the 
Select Software To Install panel: 
Sample Data-Global Segment 

Sample Data-Local Segment 

Sample Data-Segment Segment 

SampleSW.P1 

All requested segments in the 
Select Software To Install panel are 
highlighted. 

Circle one:  PASS / FAIL 
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H.11.17 Click Install. The following dialog boxes appear in sequence: 
Please wait...extracting the disk 
file with the selected segment: 
‘Sample Data-Global Segment’ 

Please wait...extracting the disk 
file with the selected segment: 
‘Sample Data-Local Segment’ 

Please wait...extracting the disk 
file with the selected segment: 
‘Sample Data-Segment Segment’ 

Please wait...extracting the disk 
file with the selected segment: 
‘SampleSW.P1’ 

Building segment lists… 

The Installer window returns to the forefront. 

Circle one:  PASS / FAIL 

 

 

H.11.18 When installation is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

NOTE: Resize the Installer window to view 
all segments. 

All sample segments are listed in the Currently 
Installed Segments panel. 

An asterisk (*) appears next to all sample segments 
in the Select Software To Install panel. 

Circle one:  PASS / FAIL 
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H.12 Verify that All Segments Are Installed Onto the Hard Disk  

H.12.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Terminal window, at the command 
prompt type 
ls /h 

The following directories are listed: 
SampleAgg 

SampleAggChild 

SampleDataGlobal 

SampleDataLocal 

SampleDataSegment 

SampleSW 

Circle one:  PASS / FAIL 

 

 

H.12.2 At the command prompt type 
ls /h/AcctGrps 

The directory SampleAcctGrp is listed. Circle one:  PASS / FAIL 

 

H.12.3 At the command prompt type 
ls /h/COE/Comp 

The directory SampleCOEChild is listed. Circle one:  PASS / FAIL 

 

H.12.4 At the command prompt type 
ls /h/COTS 

The directory SampleCOTS is listed. Circle one:  PASS / FAIL 

 

H.12.5 At the command prompt type 
ls /h/data/local 

The directory SampleDataLocal is listed. Circle one:  PASS / FAIL 

 

H.12.6 At the command prompt type 
ls /h/data/global 

The directory SampleDataGlobal is listed. Circle one:  PASS / FAIL 

 

H.12.7 At the command prompt type 
ls /h/SampleSW/data 

The directory SampleDataSegment is listed. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 7, page 69 

 
 

 

 

 Operator Action Expected Result Observed Result 

H.12.8 At the command prompt type 
ls /h/SampleSW/Patches 

The directory P1 is listed. Circle one:  PASS / FAIL 

 

H.13 Verify that All Segment Types Placed On Disk Using MakeInstall and Installed Onto The Hard 
Disk Can Be Removed by the COE Segment Installer 

 

H.13.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Installer window, select the 
SampleSW.P1 segment in the 
Currently Installed Segments panel. 

The SampleSW.P1 segment in the 
Currently Installed Segments panel is 
highlighted. 

Circle one:  PASS / FAIL 

 

 

H.13.2 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove the 
segments? 

SampleSW.P1 

Circle one:  PASS / FAIL 

 

 

H.13.3 Click Yes. The following dialog box appears: 
Segment deinstallation in 
progress... 

The Installer window returns to the forefront. 

Circle one:  PASS / FAIL 

 

 

H.13.4 When removal is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

NOTE: Resize the Installer window to view 
all segments. 

The SampleSW.P1 segment is no longer listed in 
the Currently Installed Segments 
panel. 

An asterisk (*) no longer appears next to the 
SampleSW.P1 segment in the 
Select Software To Install panel. 

Circle one:  PASS / FAIL 
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H.13.5 In the Currently Installed Segments 
panel, select the following segments: 
Sample Aggregate Segment 

Sample Account Group Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Data-Global Segment 

Sample Data-Local Segment 

Sample Data-Segment Segment 

Sample Software Segment 

All requested segments in the 
Currently Installed Segments panel 
are highlighted. 

Circle one:  PASS / FAIL 

 

 

H.13.6 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove the 
segments? 

Sample Data-Segment Segment 

Sample Data-Local Segment 

Sample Data-Global Segment 

Sample Software Segment 

Sample Aggregate Segment 

Sample COE Child Segment 

Sample COTS Segment 

Sample Account Group Segment 

Circle one:  PASS / FAIL 
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H.13.7 Click Yes. The following dialog boxes appear in sequence: 
Segment deinstallation in 
progress... 

Building segment lists… 

DEINSTALL installation directory 
is /h/SampleSW 

Circle one:  PASS / FAIL 

 

 

H.13.8 Click OK. The following dialog box appears: 
DEINSTALL installation directory 
is /h/COE/Comp/SampleCOEChild 

Circle one:  PASS / FAIL 

 

 

H.13.9 Click OK. The following dialog box appears: 
DEINSTALL installation directory 
is /h/AcctGrps/SampleAcctGrp 

Circle one:  PASS / FAIL 

 

 

H.13.10 Click OK. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the forefront. 

Circle one:  PASS / FAIL 

 

 

H.13.11 When removal is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

NOTE: Resize the Installer window to view 
all segments. 

No sample segments are listed in the Currently 
Installed Segments panel. 

No asterisk (*) appears next to any segments in the 
Select Software To Install panel. 

Circle one:  PASS / FAIL 
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I 4.9 Verify Functionality and Options Of CanInstall 

I.1 Verify the CanInstall �p Option  

I.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Terminal window, at the command 
prompt type 
CanInstall –p . segx 

The following message is displayed:  
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.1.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.2 Verify CanInstall Uses /h If No Path Is Specified  

I.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –pr segx /h 

The segx directory is copied to /h and system 
will return a command prompt. 

Setup 

I.2.2 At the command prompt type 
CanInstall segx 

The following message is displayed:  
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.2.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.2.4 At the command prompt type 
rm –rf /h/segx 

The segx directory is removed from /h and 
system will return a command prompt. 

Cleanup 
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I.3 Verify CanInstall With Invalid Parameters  

I.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall 

The tool�s help text will display and system will 
return a command prompt. 

Circle one:  PASS / FAIL 

 

 

I.3.2 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 

I.3.3 At the command prompt type 
CanInstall Tester 

The following error message is displayed: 
Directory Not Found: 
/Tester…Exiting 

Circle one:  PASS / FAIL 

 

 

I.3.4 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 

 

I.4 Verify CanInstall Returns An Error If Validated File Is Missing  

I.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
mv segx/SegDescrip/Validated tmp 

The command prompt returns. Setup 

I.4.2 At the command prompt type 
CanInstall –p . segx 

The following error message is displayed: 
Could Not Validate “/kpc/tk/segx” 
Re-Run “VerifySeg”…Exiting 

Circle one:  PASS / FAIL 
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I.4.3 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 

 

I.4.4 At the command prompt type 
mv tmp/Validated segx/SegDescrip 

The command prompt returns. Cleanup 

I.5 Verify CanInstall Will Process Conflicts Descriptor  

I.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . conflicts 

The following message appears: 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.5.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.5.3 In the Installer window, click Select 
Source. 

The Select Source window appears. Setup 

I.5.4 In the Device panel, click DISK. The Select File dialog box appears. Setup 

I.5.5 In the Filter text box, select the text and replace 
it with: 
/kpc/si/* [r] 

/kpc/si/* appears in the Filter text box. Setup 

I.5.6 In the Files panel, double-click on the following 
entry: 
segx.tar 

The Installer window returns. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 7, page 75 

 
 

 

 

 Operator Action Expected Result Observed Result 

I.5.7 Click Read Contents. The following segment appears in the 
Select Software To Install panel: 
Test Segment segx 

Circle one:  PASS / FAIL 

 

I.5.8 Select the following segment: 
Test Segment segx 

Test Segment segx is highlighted. Circle one:  PASS / FAIL 

 

I.5.9 Click Install. The following dialog box appears: 
Please wait...extracting the disk 
file with the selected segment: 
‘Test Segment segx’ 

Circle one:  PASS / FAIL 

 

 

I.5.10 When installation is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

Test Segment segx is listed in the 
Currently Installed Segments panel: 

An asterisk (*) appears next to Test Segment 
segx in the Select Software To 
Install panel. 

Circle one:  PASS / FAIL 

 

 

I.5.11 In the Terminal window, at the command 
prompt type 
CanInstall –p . conflicts 

The following error message appears: 
A conflicting segment of 
/kpc/tk/conflicts was found on 
disk! 

Circle one:  PASS / FAIL 

 

 

I.5.12 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 
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I.6 Verify CanInstall Will Process Requires Descriptor  

I.6.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Installer window, click Select 
Source. 

The Select Source window appears. Setup 

I.6.2 In the Device panel, click DISK. The Select File dialog box appears. Setup 

I.6.3 If the following does not appear in the Filter 
text box, select the text and replace it with: 
/kpc/si/* [r] 

/kpc/si/* appears in the Filter text box. Setup 

I.6.4 In the Files panel, double-click on the following 
entry: 
req_segy.tar 

The Installer window returns. Circle one:  PASS / FAIL 

 

 

I.6.5 Click Read Contents. The following segments appear in the 
Select Software To Install panel: 
Test Segment segy 

Requires Test Segment 

Circle one:  PASS / FAIL 

 

 

I.6.6 Select the following segment: 
Test Segment segy 

Test Segment segy is highlighted. Circle one:  PASS / FAIL 

 

I.6.7 Click Install. The following dialog box appears: 
Please wait...extracting the disk 
file with the selected segment: 
‘Test Segment segy’ 

Circle one:  PASS / FAIL 
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I.6.8 When installation is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

Test Segment segy is listed in the 
Currently Installed Segments panel: 

An asterisk (*) appears next to Test Segment 
segy in the Select Software To 
Install panel: 

Circle one:  PASS / FAIL 

 

 

I.6.9 At the command prompt type 
CanInstall –p . requires 

The following error message appears: 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.6.10 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.6.11 In the Installer window, select the Test 
Segment segx and Test Segment segy 
segments in the Currently Installed 
Segments panel. 

The Test Segment segx and Test 
Segment segy segments in the Currently 
Installed Segments panel are highlighted. 

Circle one:  PASS / FAIL 

 

 

I.6.12 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove the 
segments? 

Test Segment segx 

Test Segment segy 

Circle one:  PASS / FAIL 
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I.6.13 Click Yes. The following dialog box appears: 
Segment deinstallation in 
progress... 

The Installer window returns to the forefront. 

Circle one:  PASS / FAIL 

 

 

I.6.14 When removal is complete, check both the 
Currently Installed Segments panel 
and the Select Software To Install 
panel. 

The Test Segment segx and Test 
Segment segy segments are no longer listed in 
the Currently Installed Segments 
panel. 

An asterisk (*) no longer appears next to the Test 
Segment segx and Test Segment segy 
segments in the 
Select Software To Install panel. 

Circle one:  PASS / FAIL 

 

 

I.6.15 In the Terminal window, at the command 
prompt type 
CanInstall –p . requires 

The following warning message appears: 
[Requires] A Segment directory 
‘h/segx’ is not found for segment 
‘Test Segment segx’ 

The following error message appears: 
ALL required segments for 
/kpc/tk/requires weren’t found on 
disk! 

Circle one:  PASS / FAIL 

 
 

I.6.16 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 
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I.7 Verify the CanInstall �v Option  

I.7.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –v -p . segx 

Many verbose (V) messages will appear followed 
by the following message: 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.7.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
 

I.8 Verify the CanInstall �w Option  

I.8.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall -p . segx_w 

The following warning message appears: 
[Conflicts] Segment Home directory 
(/h) specified is not COE 
compliant. Conflict Segment path 
was not found. This is suspicious 
and may indicate an error. 

The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.8.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.8.3 At the command prompt type 
CanInstall –w -p . segx_w 

The following message appears: 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

I.8.4 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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I.9 Verify CanInstall Will Process $CPU Keyword  

I.9.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall -p . badcpu 

The following error messages appear: 
COEProcessHardware: Incompatible 
CPU 

Incompatible hardware type for 
segment located at /kpc/tk/badcpu 

Circle one:  PASS / FAIL 

 

 

I.9.2 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 

 

I.10 Run Tool With Sample Software Segment  

I.10.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleSW 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.10.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.11 Install Sample Software Segment So That Data and Patch Software Will Pass CanInstall  

I.11.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

In the Installer window, click Select 
Source. 

The Select Source window appears. Setup 

I.11.2 In the Device panel, click DISK. The Select File dialog box appears. Setup 
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I.11.3 If the following does not appear in the Filter 
text box, select the text and replace it with: 
/kpc/si/* [r] 

/kpc/si/* appears in the Filter text box. Setup 

I.11.4 In the Files panel, double-click on the following 
entry: 
all_types.tar 

The Installer window returns. Setup 

I.11.5 Click Read Contents. Sample Software segments appear in the 
Select Software To Install panel. 

Setup 

I.11.6 Select the following segment: 
Sample Software Segment 

Sample Software Segment is highlighted. Setup 

I.11.7 Click Install. The following dialog box appears: 
PreInstall installation directory 
is /h/SampleSW  

Setup 

I.11.8 Click OK. The following dialog boxes appear in sequence: 
Please wait...Extracting the disk 
file with the selected segment: 
‘Sample Software Segment’ 

PostInstall installation directory 
is /h/SampleSW  

Setup 



© 2003, The Open Group 
Chapter 7, page 82 

 
 

 

 

 Operator Action Expected Result Observed Result 

I.11.9 Click OK. The Installer window returns. 

Sample Software Segment is listed in the 
Currently Installed Segments panel. 

An asterisk (*) appears next to Sample 
Software Segment in the Select 
Software To Install panel. 

Setup 

I.12 Run Tool With Sample Account Group Segment  

I.12.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleAcctGrp 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.12.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.13 Run Tool With Sample Aggregate Segment  

I.13.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleAgg 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.13.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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I.14 Run Tool With Sample Aggregate Child Segment  

I.14.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleAggChild 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.14.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.15 Run Tool With Sample COE Child Segment  

I.15.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleCOEChild 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.15.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.16 Run Tool With Sample COTS Segment  

I.16.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleCOTS 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.16.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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I.17 Run Tool With Sample Data Global Segment  

I.17.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleDataGlobal 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.17.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.18 Run Tool With Sample Data Local Segment  

I.18.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleDataLocal 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.18.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.19 Run Tool With Sample Data Segment  

I.19.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleDataSegment 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.19.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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I.20 Run Tool With Sample Software Patch Segment  

I.20.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
CanInstall –p . SampleSW.P1 

The following message is displayed. 
The segment can be successfully 
installed without error! 

Circle one:  PASS / FAIL 

 

 

I.20.2 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

I.20.3 In the Installer window, select Sample 
Software Segment in the Currently 
Installed Segments panel. 

Sample Software Segment is highlighted. Cleanup 

I.20.4 Click Deinstall Software. The following dialog box appears: 
Do you really want to remove the 
segments? 

Sample Software Segment 

Cleanup 

I.20.5 Click Yes. The following dialog boxes appear in sequence: 
Segment deinstallation in 
progress... 

Building segment lists… 

DEINSTALL installation directory 
is /h/SampleSW 

Cleanup 
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I.20.6 Click OK. The following dialog box appears: 
Building segment lists… 

The Installer window returns to the forefront. 

Cleanup 

J 4.10 Verify Functionality and Options Of TestInstall and TestRemove 

J.1 Verify the TestInstall and TestRemove �p Option  

J.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –p . segx 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.1.2 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of segx 

Circle one:  PASS / FAIL 

 

 

J.1.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.1.4 At the command prompt type 
ls –l segx/SegDescrip 

Verify that Installed is one of the files listed. Circle one:  PASS / FAIL 

 

J.1.5 At the command prompt type 
ls –l /h 

Verify that the following softlink is listed: 
segx -> /kpc/tk/segx 

Circle one:  PASS / FAIL 
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J.1.6 At the command prompt type 
TestRemove –p . segx 

 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.1.7 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Removal of Segment 
segx. 

Circle one:  PASS / FAIL 

 

 

J.1.8 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.1.9 At the command prompt type 
ls –l segx/SegDescrip 

Verify that Installed is not listed. Circle one:  PASS / FAIL 

 

J.1.10 At the command prompt type 
ls –l /h 

Verify that segx is not listed. Circle one:  PASS / FAIL 

 

J.2 Verify TestInstall and TestRemove Uses /h If No Path Is Specified  

J.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –pr segx /h 

The segx directory is copied to /h and system 
will return a command prompt. 

Setup 

J.2.2 At the command prompt type 
TestInstall segx 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 
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J.2.3 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of segx 

Circle one:  PASS / FAIL 

 

 

J.2.4 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.2.5 At the command prompt type 
ls –l /h/segx/SegDescrip 

Verify that Installed is one of the files listed. Circle one:  PASS / FAIL 

 

J.2.6 At the command prompt type 
TestRemove segx 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.2.7 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Removal of Segment 
segx. 

Circle one:  PASS / FAIL 

 

 

J.2.8 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.2.9 At the command prompt type 
ls –l /h/segx/SegDescrip 

Verify that Installed is not listed. Circle one:  PASS / FAIL 

 

J.2.10 At the command prompt type 
rm –rf /h/segx 

The segx directory is removed from /h and 
system will return a command prompt 

Cleanup 
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J.3 Verify TestInstall and TestRemove �C Option  

J.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –p TIRdata –C cmd.file 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.3.2 At the command prompt type 
y 

Many verbose messages (V) and descriptor name 
and content messages (O) appear followed by the 
following message: 
Successful Installation of segx 

Circle one:  PASS / FAIL 
 

 

J.3.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.3.4 At the command prompt type 
ls –l /h 

Verify that the following softlink is listed: 
segx -> /kpc/tk/segx 

Circle one:  PASS / FAIL 

 

 

J.3.5 At the command prompt type 
TestRemove –p TIRdata –C cmd.file 

 

Several descriptor name messages (O) appear 
followed by the following message: 
Successful Removal of Segment 
segx. 

Circle one:  PASS / FAIL 

 

 

J.3.6 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.3.7 At the command prompt type 
ls –l /h 

Verify that segx is not listed. Circle one:  PASS / FAIL 
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J.4 Verify TestInstall and TestRemove �e Option  

J.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –e –p . segx 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.4.2 At the command prompt type 
y 

Many descriptor name and content messages (O) 
appear followed by the following message: 
Successful Installation of segx 

Circle one:  PASS / FAIL 
 

 

J.4.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.4.4 At the command prompt type 
ls –l /h 

Verify that the following softlink is listed: 
segx -> /kpc/tk/segx 

Circle one:  PASS / FAIL 

 

J.4.5 At the command prompt type 
TestRemove –e –p . segx 

 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.4.6 At the command prompt type 
y 

Several descriptor name messages (O) appear 
followed by the following message: 
Successful Removal of Segment 
segx. 

Circle one:  PASS / FAIL 

 

 

J.4.7 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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J.4.8 At the command prompt type 
ls –l /h 

Verify that segx is not listed. Circle one:  PASS / FAIL 

 

J.5 Verify TestInstall and TestRemove �f Option  

J.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –f –p . segx 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.5.2 At the command prompt type 
y 

Many descriptor name messages (O) appear 
followed by the following message: 
Successful Installation of segx 

Circle one:  PASS / FAIL 

 

 

J.5.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.5.4 At the command prompt type 
ls –l /h 

Verify that the following softlink is listed: 
segx -> /kpc/tk/segx 

Circle one:  PASS / FAIL 

 

J.5.5 At the command prompt type 
TestRemove –f –p . segx 

 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.5.6 At the command prompt type 
y 

Several descriptor name messages (O) appear 
followed by the following message: 
Successful Removal of Segment 
segx. 

Circle one:  PASS / FAIL 
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J.5.7 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.5.8 At the command prompt type 
ls –l /h 

Verify that segx is not listed. Circle one:  PASS / FAIL 

 

J.6 Verify TestInstall and TestRemove Will Process the Community Descriptor  

J.6.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cp –p TIRin-com/* TIRout-com.new 

The command prompt returns. Setup 

J.6.2 At the command prompt type 
TestInstall –p . community 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.6.3 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of 
community 

Circle one:  PASS / FAIL 

 

 

J.6.4 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.6.5 At the command prompt type 
TestRemove –p . community 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 
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J.6.6 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Removal of Segment 
community. 

Circle one:  PASS / FAIL 

 

 

J.6.7 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.6.8 At the command prompt type 
diff TIRout-com.new TIRout-com.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 

 

J.7 Verify TestInstall Will Process Conflicts Descriptor  

J.7.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –p . conflicts 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.7.2 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of 
conflicts 

Circle one:  PASS / FAIL 

 

 

J.7.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.7.4 At the command prompt type 
TestRemove –p . conflicts 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 
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J.7.5 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Removal of Segment 
conflicts. 

Circle one:  PASS / FAIL 

 

 

J.7.6 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.7.7 At the command prompt type 
TestInstall –p . segx 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.7.8 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of segx 

Circle one:  PASS / FAIL 

 

 

J.7.9 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.7.10 At the command prompt type 
TestInstall –p . conflicts 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 
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J.7.11 At the command prompt type 
y 

Processing messages appear followed by the 
following error message: 
[Conflicts] Segment Home directory 
(/h/segx) specified was not found.  
Conflict Segment path was found in 
another location (/kpc/tk/segx). 
This is suspicious and may 
indicate an error. 

Can’t install segment conflicts 

Installation was not completed for 
conflicts 

Circle one:  PASS / FAIL 

 

 

J.7.12 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 

 

J.8 Verify TestInstall Will Process Requires Descriptor  

J.8.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –p . segy 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.8.2 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of segy 

Circle one:  PASS / FAIL 
 

J.8.3 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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J.8.4 At the command prompt type 
TestInstall –p . requires 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.8.5 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Successful Installation of 
requires 

Circle one:  PASS / FAIL 

 

 

J.8.6 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.8.7 At the command prompt type 
TestRemove –p . segx segy 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.8.8 At the command prompt type 
y 

Processing messages appear including the 
following messages: 
Successful Removal of Segment 
segy. 

Successful Removal of Segment 
segx. 

Circle one:  PASS / FAIL 

 

 

J.8.9 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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J.8.10 At the command prompt type 
TestInstall –p . requires 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.8.11 At the command prompt type 
y 

Processing messages appear followed by the 
following warning and error messages: 
(W)---------------------------| 

[Requires] A Segment directory 
‘/h/segx’ is not found for segment 
‘Test Segment segx’ 

(E)---------------------------| 

All required segments for 
/kpc/tk/requires weren’t found on 
disk! 

Can’t install segment requires 

Installation was not completed for 
requires 

Circle one:  PASS / FAIL 

 

 

J.8.12 At the command prompt type 
echo $status 

A number other than 0 is returned. Circle one:  PASS / FAIL 
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J.9 Install All Segments At Once  

J.9.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
TestInstall –p TIRdata –C cmd.all_types 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestInstall? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.9.2 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PreInstall for 
Segment SampleAcctGrp ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.3 At the command prompt type 
y 

An dINFORMATION MESSAGE box appears 
with the text: 
Preinstall installation directory 
is /h/SampleAcctGrp 

Circle one:  PASS / FAIL 

 

 

J.9.4 Click OK. Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleAcctGrp ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.5 At the command prompt type 
y 

A dialog box appears with the text: 
Postinstall installation directory 
is /kpc/tk/SampleAcctGrp 

Circle one:  PASS / FAIL 
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J.9.6 Click OK. Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleAgg ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.7 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleAggChild ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.8 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PreInstall for 
Segment SampleCOEChild ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.9 At the command prompt type 
y 

An INFORMATIONAL MESSAGE box appears 
with the text: 
Preinstall installation directory 
is /h/SampleCOEChild 

Circle one:  PASS / FAIL 

 

 

J.9.10 Click OK. Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleCOEChild ? (y/n) 

Circle one:  PASS / FAIL 

 

J.9.11 At the command prompt type 
y 

An INFORMATIONAL MESSAGE box appears 
with the text: 
Postinstall installation directory 
is /kpc/tk/SampleCOEChild 

Circle one:  PASS / FAIL 
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J.9.12 Click OK. Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleCOTS ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.13 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PreInstall for 
Segment SampleSW ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.14 At the command prompt type 
y 

An INFORMATIONAL MESSAGE  box appears 
with the text: 
Preinstall installation directory 
is /h/SampleSW 

Circle one:  PASS / FAIL 

 

 

J.9.15 Click OK. Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleSW ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.16 At the command prompt type 
y 

An INFORMATIONAL MESSAGE box appears 
with the text: 
Postinstall installation directory 
is /kpc/tk/SampleSW 

Circle one:  PASS / FAIL 

 

 

J.9.17 Click OK. Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleDataGlobal ? (y/n) 

Circle one:  PASS / FAIL 
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J.9.18 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleDataLocal ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.19 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleDataSegment ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.20 At the command prompt type 
y 

Processing messages appear followed by the 
following message: 
Do you want to run PostInstall for 
Segment SampleSW.P1 ? (y/n) 

Circle one:  PASS / FAIL 

 

 

J.9.21 At the command prompt type 
y 

The following message appears: 
Successful Installation of 
SampleSW.P1 

Circle one:  PASS / FAIL 

 

 

J.9.22 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 
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J.9.23 At the command prompt type 
ls –l /h 

Verify that the following softlinks are listed: 
SampleAgg -> /kpc/tk/SampleAgg 

SampleAggChild -> 
/kpc/tk/SampleAggChild 

SampleDataGlobal -> 
/kpc/tk/SampleDataGlobal 

SampleDataLocal -> 
/kpc/tk/SampleDataLocal 

SampleDataSegment -> 
/kpc/tk/SampleDataSegment 

SampleSW -> /kpc/tk/SampleSW 

Circle one:  PASS / FAIL 

 

 

J.9.24 At the command prompt type 
ls –l /h/AcctGrps 

Verify that the following softlink is listed: 
SampleAcctGrp -> 
/kpc/tk/SampleAcctGrp 

Circle one:  PASS / FAIL 

 

J.9.25 At the command prompt type 
ls –l /h/COE/Comp 

Verify that the following softlink is listed: 
SampleCOEChild -> 
/kpc/tk/SampleCOEChild 

Circle one:  PASS / FAIL 

 

J.9.26 At the command prompt type 
ls –l /h/COTS 

Verify that the following softlink is listed: 
SampleCOTS -> /kpc/tk/SampleCOTS 

Circle one:  PASS / FAIL 

 

J.9.27 At the command prompt type 
ls –l /h/data/local 

The directory SampleDataLocal is listed. Circle one:  PASS / FAIL 
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J.9.28 At the command prompt type 
ls –l /h/data/global 

The directory SampleDataGlobal is listed. Circle one:  PASS / FAIL 

 

J.9.29 At the command prompt type 
ls –l /h/SampleSW/data 

The directory SampleDataSegment is listed. Circle one:  PASS / FAIL 

 

J.9.30 At the command prompt type 
ls –l /h/SampleSW/Patches 

Verify that the following softlink is listed: 
P1-> /kpc/tk/SampleSW.P1 

Circle one:  PASS / FAIL 

 

J.9.31 At the command prompt type 
TestRemove –p TIRdata –C 
cmd.all_types 

 

A warning message appears followed by the 
following message: 
Do you want to continue with 
TestRemove? (y/n): 

Circle one:  PASS / FAIL 

 

 

J.9.32 At the command prompt type 
y 

An INFORMATIONAL MESSAGE box appears 
with the text: 
DEINSTALL installation directory 
is /kpc/tk/SampleSW 

Circle one:  PASS / FAIL 

 

 

J.9.33 Click OK. An INFORMATIONAL MESSAGE box appears 
with the text: 
DEINSTALL installation directory 
is /kpc/tk/SampleCOEChild 

Circle one:  PASS / FAIL 

 

 

J.9.34 Click OK. An INFORMATIONAL MESSAGE box appears 
with the text: 
DEINSTALL installation directory 
is /kpc/tk/SampleAcctGrp 

Circle one:  PASS / FAIL 
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J.9.35 Click OK. Processing messages appear followed by the 
following message: 
Successful Removal of Segment 
SampleAcctGrp. 

Circle one:  PASS / FAIL 

 

 

J.9.36 At the command prompt type 
echo $status 

0 is returned. Circle one:  PASS / FAIL 

 

J.9.37 At the command prompt type 
ls /h 

Verify that the following are not listed: 
SampleAgg 

SampleDataGlobal 

SampleDataLocal 

SampleDataSegment 

SampleSW 

Circle one:  PASS / FAIL 

 

 

J.9.38 At the command prompt type 
ls /h/AcctGrps 

Verify that the following is not listed: 
SampleAcctGrp 

Circle one:  PASS / FAIL 

 

J.9.39 At the command prompt type 
ls /h/COE/Comp 

Verify that the following is not listed: 
SampleCOEChild 

Circle one:  PASS / FAIL 

 

J.9.40 At the command prompt type 
ls /h/COTS 

Verify that the following is not listed: 
SampleCOTS -> /kpc/tk/SampleCOTS 

Circle one:  PASS / FAIL 

 

J.9.41 At the command prompt type 
ls /h/data/local/SampleDataLocal 

Verify that no files are listed. Circle one:  PASS / FAIL 
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J.9.42 At the command prompt type 
ls –l /h/data/global 

Verify that the following is not listed: 
SampleDataGlobal 

Circle one:  PASS / FAIL 

 

J.9.43 At the command prompt type 
rm  -r SampleDataGlobal 

The command prompt returns. Cleanup 

J.9.44 At the command prompt type 
cp –pr 
/h/KPC/data/tk/SampleDataGlobal 
[s] SampleDataGlobal 

The command prompt returns. Cleanup 

K 4.11 Public API Test 

K.1 Execute the API Test Script  

K.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

At the command prompt type 
cd /kpc/api 

The command prompt returns. Setup 

K.1.2 At the command prompt type 
./api_script > api_script_out.new 

The command prompt returns. Setup 

K.1.3 At the command prompt type 
diff api_script_out.new api_script_out.orig 

The command prompt returns with no differences 
displayed. 

Circle one:  PASS / FAIL 
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L 4.12 Remove The Toolkit and Test Data Segments 

L.1 Deinstall the Toolkit Segment  

L.1.1 In the Currently Installed Segments 
field of the Installer window, select DII COE 
Developer’s Toolkit. 

DII COE Developer’s Toolkit is 
highlighted. 

Circle one:  PASS / FAIL 

 

 

L.1.2 Click Deinstall Software. 

 

A RESPONSE TO THE QUESTION dialog box 
asks: Do you really want to remove 
the segments? 

DII COE Developer’s Toolkit 

Cleanup 

L.1.3 Click Yes. The segment deinstalls and is not listed under 
Currently Installed Segments. 

Circle one:  PASS / FAIL 

 

L.2 Deinstall the Test Data Segment  

L.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Select Applications > Application 
Manager > DII_APPS. 

The Application Manager window appears. Cleanup 

 

L.2.2 Double-click Segment Installer in the 
Application Manager – SysAdm window. 

The  Installer window appears. Cleanup  

 

L.2.3 In the Currently Installed Segments 
list, select KPC Test Data for 4200P6. 

KPC Test Data for 4200P6 is highlighted Cleanup  
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L.2.4 Click Deinstall Software. 

 

A RESPOND TO THE QUESTION dialog box 
asks:  
Do you really want to remove the 
segments? 

KPC Test Data for 4200P6 

Cleanup 

L.2.5 Click Yes. KPC Test Data for 4200P6 deinstalls 
correctly and is no longer preceded by an * in the 
Select Software To Install field. KPC 
Test Data for 4200P4 no longer appears 
in the Currently Installed Segments 
field. 

Cleanup  

L.2.6 Click Exit. The Installer window disappears. Cleanup  

 

Z 4.13 Logout  

Z.1 Log out of the Candidate Platform  

Z.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp).  

Click Exit from CDE. 

The Logout Confirmation window appears. Shutdown 

Z.1.2 Click OK. The system exits and the DII COE LOGIN screen 
appears. 

Shutdown 

End of Test Validation Procedure 
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1. Overview 

1.1 Introduction 

This chapter defines the Audit Log File Manual Validation Procedure and is part of the 
required set of test procedures to be used in the certification of products to the Open 
Brand COE Platform Product Standard1.  

2. Test Procedure 

2.1 Scope  

The Audit Log File Manager validation procedure is a manual test that provides a 
detailed test of the Audit Log File Manager. 

2.2 Description of test items 

The following functions will be exercised:  

A. Login 

B. Verify Default Audit Log File Configuration Settings 

C. Create Sample Audit Log Files and Determine Disk Usage Parameters 

D. Verify Proper Monitoring of Log Files 

E. Verify Proper Monitoring of System Audit Log Files 

F. Verify Display Notification of Audit Log File Events 

G. Verify that Audit Log File Manager Settings are Preserved Upon Exiting 

H. Verify E-Mail Notification of Audit Log File Events 

I. Verify Audit Log Notification for 85% Disk Capacity Usage 

J. Verify that Audit Log Files are Properly Deleted 

K. Verify that the Defaults Button Properly Restores Default Values 

L. Restore the System to Original Settings 

Z. Log out. 

 

 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 2.3 Test Data/Media Required   

None 

2.4 Setup/Equipment Required 

This test requires a Validation Host and Candidate Platform configured as specified in the 
current version of the Template Setup Procedures for a COE Validation Cell document. 

2.5 Test Data/Media Required 

None 

2.6 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.7 Change History 

June 02, 2003 

Initial Release 

 

 



 

 

3. Test Procedure Submission Form 

 

Test Title: Audit Log File Manager Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 2 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 Operator Action Expected Result Observed Result 

A 4.1 Login 

A.1 Log In As secman and Invoke the Audit Log File Manager  

A.1.1 Log in as secman. An informational window appears indicating that 
login processing is complete. 

Startup 

 

A.1.2 Click OK to dismiss the informational window. The informational window closes. Startup 

 

A.1.3 Launch the Audit Log File Manager by 
selecting Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Startup 

A.1.4 Double-click Audit Log File Manager. The Audit Log File Manager window 
appears. 

Circle one:  PASS / FAIL 
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B 4.2 Verify Default Audit Log File Configuration Settings 

B.1 Verify the Monitored Log Files  

B.1.1 Click Monitored Log Files.... The Log File(s) to Monitor dialog box 
appears, displaying a list of files. 

Circle one:  PASS / FAIL 

 

B.1.2 Write down the pathname of the first file listed in the 
dialog box. 

Pathname of the first file listed in the dialog box: 

  _____________________________________ 
 

Setup 

 

B.1.3 Check the total size shown in the text box at the bottom 
of the dialog box (the number after the slash). 

NOTE: If the total size shown is less than 2 kilobytes, 
log out and in several times in order to increase the log 
file content.  Then, restart step A.1.3. 

The total size shown is more than 2 kilobytes. Circle one:  PASS / FAIL 
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B.1.4 Verify that the following files are listed, each preceded 
by a checked checkbox and followed by its size in 
kilobytes: 
/var/adm/utmp 
/var/adm/utmpx 
/var/adm/wtmp 
/var/adm/wtmpx 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

The /var/adm/utmp, /var/adm/utmpx, 
/var/adm/wtmp, and /var/adm/wtmpx 
files are listed. 

Circle one:  PASS / FAIL 

 

 

B.1.5 Click Cancel. The Log File(s) to Monitor dialog box 
is dismissed. 

Circle one:  PASS / FAIL 

 

B.2 Verify the Monitored System Files  

B.2.1 Click Monitored System Files .... The System Audit File(s) to 
Monitor dialog box appears, displaying a list of 
files. 

Circle one:  PASS / FAIL 

 

B.2.2 Write down the pathname of the first file or directory 
listed in the dialog box. 

Pathname of the first file or directory listed in the 
dialog box: 

  _____________________________________ 
 

Setup 
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B.2.3 Verify that the following directories are listed, each 
followed by its size in kilobytes (you may need to use 
the scrollbars to see them): 

/security1 (grayed out, preceded by a checked 
checkbox and followed by an indented list of 0 or more 
files and their sizes) 

/security2 (grayed out, preceded by a checked 
checkbox and followed by an indented list of 0 or more 
files and their sizes) 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

The /security1 and /security2 directories 
are listed. 

 

Circle one:  PASS / FAIL 

 

 

B.2.4 Click Cancel. The System Audit File(s) to 
Monitor dialog box is dismissed. 

Circle one:  PASS / FAIL 

 

C 4.3 Create Sample Audit Log Files and Determine Disk Usage Parameters 

C.1 Open A Terminal Window and Create All Files  

C.1.1 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Setup 

C.1.2 At the command prompt type 

su -  

The Password prompt returns. Setup 
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C.1.3 Enter the root password. User root is logged in. Setup 

 

C.1.4 At the command prompt type 
csh 

A csh prompt is displayed. Setup 

 

C.1.5 At the command prompt type 
mkdir /fred_1 
mkfile 100b /fred_1/test_1 
mkfile 100b /fred_1/test_2 
mkfile 100b /fred_2 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

C.2 Determine Disk Usage Parameters  

C.2.1 At the command prompt type 
df –k 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

A list of disk usage parameters appears. Circle one:  PASS / FAIL 

 

 

Test Partitions (e.g. /var and /security1): 

  
C.2.2 Write down the disk usage (used column), and the 

available capacity (avail column) of the partition(s) 
on which the two files you wrote down earlier reside. 
These partition(s) will be referred to later as the test 

titi
Available capacity (avail column): 

Setup 
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Disk usage (used column): 

 partitions. 

  

 

Number of disk blocks required for 76% fill: 
NOTE: Blocks on Solaris are 512 bytes (or ½ 
kilobyte.) 

C.2.3 For each of the test partition(s) from the step above, 
determine the number of disk blocks that would be 
required to fill the partition to 76% of its capacity. 

Use the formula:  ((1.52 * avail) � (0.48 * used)), 
rounded up to the next integer value. 

For example:  If the /var partition is one of the test 
partitions, and 301,132 kilobytes are used and 218,484 
kilobytes are available, to fill it to about 76% capacity 
would require: 

(1.52 x 218484) � (0.48 x 301132) blocks, or 
187552.32 blocks. 

 

  

Setup  
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C.2.4 Create a file named fill in the top directory of each 
of the test partitions, with the size(s) computed in the 
previous step, using the following command: 
mkfile <blks>b /<part>/fill 

Where <part> is the name of the test partition and 
<blks> is the number of disk blocks required for 76% 
fill. 

For example:  Type 
mkfile 187553b /var/fill 

to push the /var partition to over 75% of its capacity. 

NOTE:  The commands may take some time to 
execute, depending on the size specified and the speed 
of the target system. 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

The command prompt returns. Setup  

 

C.2.5 At the command prompt type 
df –k 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

In the capacity column, the output shows each of 
the test partitions using at least 76% disk space. 

NOTE: If the test partitions are not using 76% 
disk space, double-check your calculations and 
repeat steps C.2.2 and C.2.3.  

Setup  
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D 4.4 Verify Proper Monitoring Of Log Files 

D.1 Modify the Audit Log File List  

D.1.1 In the Audit Log File Manager window, Click 
Modify Log File List .... 

The Modify Log File List dialog box 
appears with any empty text area. 

Circle one:  PASS / FAIL 

 

D.1.2 In the Modify Log File List dialog box, Click 
Add File .... 

The Input dialog box appears with the 
following prompt: 
Enter Log File to Monitor: 

Circle one:  PASS / FAIL 

 

D.1.3 Type /fred_1 in the Input dialog box. The text /fred_1 appears in the Input dialog 
box. 

Circle one:  PASS / FAIL 

 

D.1.4 Click OK. The Input dialog box is dismissed. The text 
/fred_1 appears in the 
Modify Log File List dialog box text 
area. 

Circle one:  PASS / FAIL 

 

D.1.5 In the Modify Log File List dialog box, Click 
Add File .... 

The Input dialog box appears with the 
following prompt: 
Enter Log File to Monitor: 

Circle one:  PASS / FAIL 

 

D.1.6 Type /fred_2 in the Input dialog box. The text /fred_2 appears in the Input dialog 
box. 

Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 8, page 13 

 
 

 

 

 Operator Action Expected Result Observed Result 

D.1.7 Click OK. The Input dialog box is dismissed. Both 
/fred_1 and /fred_2 appear in the 
Modify Log File List dialog box text 
area. 

Circle one:  PASS / FAIL 

 

D.1.8 Click Quit. The Modify Log File List dialog box is 
dismissed. 

Circle one:  PASS / FAIL 

 

D.1.9 Click Monitored Log Files.... The Log File(s) to Monitor dialog box 
appears, displaying a list of files. 

Circle one:  PASS / FAIL 

 

D.1.10 In the Log File(s) to Monitor dialog box, 
verify the following information: 

/fred_1 (dir: ### Kb) is listed near the bottom, 
with ### replaced by a number slightly greater than 
100.  A check box (without a checkmark) precedes the 
directory name. 

(50 Kb) test_1 is listed next (indented). 

(50 Kb) test_2 is listed next (indented). 

/fred_2 (50 Kb) is listed next.  A check box 
(without a checkmark) precedes the file name. 

All information is listed as indicated. Circle one:  PASS / FAIL 

 

 

D.1.11 Write down the files and/or directories which follow 
checkmarks in the window along with their sizes.  
These will be referred to later as the log file list.  This 
list should not include the files listed under directories. 

Log file list: 

 
 

Setup  
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D.1.12 Write down the first number listed in the 
Selected/Total Size text box for later use (it 
will be called the log file total). 

Log file total: 

 
 

Setup  

D.1.13 Verify that the second number is greater than the first 
number by the sum of the kilobytes listed after the 
/fred_1 directory and the /fred_2 file. 

The second number is greater than the first 
number by the sum of the kilobytes listed after the 
/fred_1 directory and the /fred_2 file. 

Circle one:  PASS / FAIL 

 

D.1.14 Set the checkmarks for both /fred_1 and /fred_2. The numbers displayed in the 
Selected/Total Size text box become 
equal. 

Circle one:  PASS / FAIL 

 

D.1.15 Click OK. The Log File(s) to Monitor dialog box 
is dismissed. 

Circle one:  PASS / FAIL 

 

E 4.5 Verify Proper Monitoring Of System Audit Log Files 

E.1 Modify the System Audit File List  

E.1.1 In the Audit Log File Manager window, Click 
Modify System File List.... 

The Modify System Audit File List 
dialog box appears with any empty text area. 

Circle one:  PASS / FAIL 

 

E.1.2 In the Modify System Audit File List 
dialog box, Click Add File .... 

The Input dialog box appears with the 
following prompt: 
Enter System File to Monitor: 

Circle one:  PASS / FAIL 

 

 

E.1.3 Type /fred_1 in the Input dialog box. The text /fred_1 appears in the Input dialog 
box. 

Circle one:  PASS / FAIL 
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E.1.4 Click OK. The Input dialog box is dismissed. The text 
/fred_1 appears in the 
Modify System Audit File List dialog 
box text area. 

Circle one:  PASS / FAIL 

 

 

E.1.5 In the Modify System Audit File List 
dialog box, Click Add File .... 

The Input dialog box appears with the 
following prompt: 
Enter System File to Monitor: 

Circle one:  PASS / FAIL 

 

E.1.6 Type /fred_2 in the Input dialog box. The text /fred_2 appears in the Input dialog 
box. 

Circle one:  PASS / FAIL 

 

E.1.7 Click OK. The Input dialog box is dismissed. Both 
/fred_1 and /fred_2 appear in the 
Modify System Audit File List dialog 
box text area. 

Circle one:  PASS / FAIL 

 

 

E.1.8 Click Quit. The Modify Log File List dialog box is 
dismissed. 

Circle one:  PASS / FAIL 

 

E.1.9 Click Monitored System Files.... The System Audit File(s) to 
Monitor dialog box appears, displaying a list of 
files. 

Circle one:  PASS / FAIL 
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E.1.10 In the System Audit File(s) to Monitor 
dialog box, verify the following information: 

/fred_1 (dir: ### Kb) is listed near the 
bottom, with ### replaced by a number slightly greater 
than 100.  A check box (without a checkmark) precedes 
the directory name. 

(50 Kb) test_1 is listed next (indented). 

(50 Kb) test_2 is listed next (indented). 

/fred_2 (50 Kb) is listed next.  A check box 
(without a checkmark) precedes the file name. 

All information is listed as indicated. Circle one:  PASS / FAIL 

 

 

E.1.11 Write down the files and/or directories which follow 
checkmarks in the window along with their sizes.  
These will be referred to later as the system audit file 
list.  This list should not include the files listed under 
directories. 

System audit file list: 

 
 

Setup  

 

E.1.12 Write down the first number listed in the 
Selected/Total Size text box for later use (it 
will be called the system audit file total). 

System audit file total: 
 

 

Setup  

E.1.13 Verify that the second number is greater than the first 
number by the sum of the kilobytes listed after 
/fred_1 and /fred_2. 

The second number is greater than the first 
number by the sum of the kilobytes listed after 
/fred_1 and /fred_2. 

Circle one:  PASS / FAIL 
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E.1.14 Set the checkmark for /fred_2. The Selected/Total Size text box changes 
appropriately (The two displayed values should 
now differ by the kilobyte size of the /fred_1 
directory). 

Circle one:  PASS / FAIL 

 

 

E.1.15 Click OK. The System Audit File(s) to 
Monitor dialog box is dismissed. 

Circle one:  PASS / FAIL 

 

F 4.6 Verify Display Notification Of Audit Log File Events 

F.1 Set the Audit Log File Manager Parameters  

F.1.1 In the Audit Log File Manager window, Click 
the Enable radio button next to the Log File 
Manager: label. 

The Enable radio button next to the Log File 
Manager: label is selected. 

Circle one:  PASS / FAIL 

 

F.1.2 Determine the time of the next coming hour (i.e. 4:00) 
and set the Execution Time drop-down selection 
box to that time. 

The Execution Time drop-down selection 
box is set to the time of the next coming hour. 

Circle one:  PASS / FAIL 

 

F.1.3 Set the Issue Disk Capacity Warning check 
box, and set the associated drop-down selection value 
to 75%. 

The Issue Disk Capacity Warning 
check box is enabled and the value is set to 75%. 

Circle one:  PASS / FAIL 

 

F.1.4 Set the Notify when total size of 
monitored log files exceeds text box to the 
log file total noted earlier, plus 1. 

The Notify when total size of 
monitored log files exceeds text box 
is set to the log file total plus 1. 

Circle one:  PASS / FAIL 
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F.1.5 Set the Notify when total size of system 
audit files exceeds text box to the system 
audit file total noted earlier, plus 1. 

The Notify when total size of 
system audit files exceeds text box is 
set to the system audit file total plus 1. 

Circle one:  PASS / FAIL 

 

F.1.6 Click the Enable radio button next to the 
Popup Notification label. 

The Enable radio button next to the 
Popup Notification label is selected. 

Circle one:  PASS / FAIL 

 

 

F.1.7 Set the Email Notification text box to blank. The Email Notification text box is blank. Circle one:  PASS / FAIL 

 

F.1.8 In the Audit Log File Manager window, Click 
Apply. 

The Audit Log File Manager window 
remains visible. 

Circle one:  PASS / FAIL 

 

F.1.9 In the Terminal window, type 
date 

The system date and time are displayed. Setup  
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F.2 Mark All E-Mail Messages As Read  

F.2.1 Determine if there is new e-mail by one of the 
following conditions. 

A small arrow above the envelope icon on the COE 
desktop taskbar is highlighted.  

The envelope pops up in the mail tray.  

If neither of these conditions is true, then no new e-mail 
is available, skip to step F.2.4. 

If the icon is highlighted, new e-mail is available. 
Otherwise, no new e-mail is available. Either 
condition is acceptable. 

Setup  

 

F.2.2 If there is new e-mail, launch the mail tool by clicking 
on the envelope icon, clicking on each of the current 
messages until all have been read. 

The mail client opens and all messages are 
marked as read. 

Setup  

 

F.2.3 Close the mail client window. The mail client window is dismissed. Setup  

 

F.2.4 Wait until one minute before the top of the hour (in 
system time). At the top of the hour the following 
message window should pop up. 

An INFORMATIONAL MESSAGE dialog box 
appears with the following message: 
Message from COELogFileManager:  
The following file system(s) 
containing logs have exceeded the 
75% usage threshold specified in 
Audit Log File Manager: 

The message is followed by a list of the test 
partitions that were deliberately oversized earlier 
and their usage percentages. 

Circle one:  PASS / FAIL 
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F.2.5 Click OK. The INFORMATIONAL MESSAGE dialog box is 
dismissed. 

A second INFORMATIONAL MESSAGE dialog 
box appears with the following message: 
Message from COELogFileManager:  
The following monitored log 
file(s) have exceeded the ### Kb 
cumulative disk usage threshold 
specified in Audit Log File 
Manager: 

The message is followed by a list of files identical 
to those written earlier as the log file list (plus 
/fred_1 and /fred_2) and their sizes in kilobytes. 

Circle one:  PASS / FAIL 
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F.2.6 Click OK. The INFORMATIONAL MESSAGE dialog box is 
dismissed. 

A third INFORMATIONAL MESSAGE dialog box 
appears with the following message: 
Message from COELogFileManager:  
The following monitored system 
audit file(s) have exceeded the 
### Kb cumulative disk usage 
threshold specified in Audit Log 
File Manager: 

The message is followed by a list of files identical 
to those written earlier as the system audit file list 
(plus /fred_2) and their sizes in kilobytes. 

Circle one:  PASS / FAIL 

 

 

F.2.7 Click OK. The INFORMATIONAL MESSAGE dialog box is 
dismissed. 

No further INFORMATIONAL MESSAGE dialog 
boxes appear. 

Circle one:  PASS / FAIL 
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G 4.7 Verify That Audit Log File Manager Settings Are Preserved Upon Exiting 

G.1 Record All Settings  
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G.1.1 Write down the current settings in the Audit Log 
File Manager window. 

Settings in the Audit Log File Manager 
window: 
Log File Manager: 
( ) Enable   ( ) Disable 
Execution Time: 
Once each day 
Issue Disk Capacity Warning: 
( ) Checked   ( ) Unchecked 
Capacity: 
% Used 
Notify when total size of 
monitored log files exceeds:  

 
Notify when total size of system 
audit files exceeds:  

 
Popup Notification: 
( ) Enable   ( ) Disable 
Email Notification: 

Setup  

 

G.2 Close and Restart the Audit Log File Manager  
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G.2.1 In the Audit Log File Manager window, click 
OK. 

The Audit Log File Manager window 
closes. 

Circle one:  PASS / FAIL 

 

G.2.2 From the Application Manager – SecAdm 
window, restart the Audit Log File Manager by 
double-clicking Audit Log File Manager. 

The Audit Log File Manager window 
appears with all settings unchanged from the 
settings made earlier. 

 

Circle one:  PASS / FAIL 

 

H 4.8 Verify E-Mail Notification Of Audit Log File Events 

H.1 Set the Audit Log File Manager Parameters  

H.1.1 Click the Disable radio button next to the 
Popup Notification label. 

The Disable radio button next to the 
Popup Notification label is selected. 

Circle one:  PASS / FAIL 

 

H.1.2 In the Email Notification text box, type 
secman@localhost 

The Email Notification text box displays 
secman@localhost 

Circle one:  PASS / FAIL 

 

H.1.3 In the Audit Log File Manager window, Click 
Apply. 

The Audit Log File Manager window 
remains visible. 

Circle one:  PASS / FAIL 
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H.2 Mark All E-Mail Messages As Read  

H.2.1 Determine if there is new e-mail by one of the 
following conditions. 

A small arrow above the envelope icon on the COE 
desktop taskbar is highlighted.  

The envelope pops up in the mail tray.  

If neither of these conditions is true, then no new e-mail 
is available. 

If the icon is highlighted, new e-mail is available. 
Otherwise, no new e-mail is available. 

Setup  

 

H.2.2 If there is new e-mail, launch the mail tool by clicking 
on the envelope icon, clicking on each of the current 
messages until all have been read. 

The mail client opens and all messages are 
marked as read. 

Setup  

 

H.2.3 Select Mailbox > Close. The mail client window is dismissed. Setup  

 

H.2.4 In the Terminal window, type 
/h/AcctGrps/SecAdm/bin/COELogFileManager & 

 

The command prompt reappears with no error 
messages. 

NOTE: A process ID number may appear in the 
terminal window. 

NOTE:  You may safely ignore error messages 
with the form: 
ERROR: Environment var XXXX not 
defined 

Circle one:  PASS / FAIL 
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H.2.5 Wait one minute. No popup dialog boxes appear. 

On the CDE taskbar, the small arrow above the 
envelope icon is highlighted (indicating that new 
e-mail is now available). 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note 
it in the Observed Result column. 

Circle one:  PASS / FAIL 

 

 

H.2.6 Launch the mail tool by clicking on the mail tray icon. Three new messages appear in the inbox, each 
sent by root with the subject 
COELogFileManager disk usage 
warning 

NOTE: If no messages are listed in Inbox, click 
Get Msg. 

Circle one:  PASS / FAIL 

 

 

H.2.7 In the mail client window, Click each of the three new 
messages, in order, and verify that their contents are 
identical to the earlier generated INFORMATIONAL 
MESSAGE dialog boxes. 

The contents of the mail messages are identical to 
the earlier generated INFORMATIONAL 
MESSAGE dialog boxes. 

Circle one:  PASS / FAIL 
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I 4.9 Verify Audit Log Notification For 85% Disk Capacity Usage 

I.1 Set the Disk Capacity Audit To 85%  

I.1.1 At the root terminal window prompt type 
df –k 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

All test partitions are less than 85% full. 

NOTE: If any test partition is more than 85% full, 
back up or delete files to ensure that the partition 
becomes less than 85% full. 

Circle one:  PASS / FAIL 

 

 

I.1.2 In the Audit Log File Manager window, select 
the Issue Disk Capacity Warning check box, 
if necessary, so that it contains a checkmark, and set the 
Capacity % Used drop-down selection value to 
85%. 

The Issue Disk Capacity Warning 
check box is enabled and the value is set to 85%. 

Circle one:  PASS / FAIL 

 

 

I.2 Verify Audit Log Notification  

I.2.1 Click Monitored System Files.... The System Audit File(s) to 
Monitor dialog box appears, displaying a list of 
files. 

Circle one:  PASS / FAIL 

 

I.2.2 Clear the check box for /fred_2. The /fred_2 check box is disabled. Circle one:  PASS / FAIL 

 

I.2.3 Click OK. The System Audit File(s) to 
Monitor dialog box is dismissed. 

Circle one:  PASS / FAIL 
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I.2.4 In the Audit Log File Manager window, Click 
the Enable radio button next to the Popup 
Notification text label. 

The Enable radio button next to the 
Popup Notification label is selected. 
 

Circle one:  PASS / FAIL 

 

I.2.5 Clear the Email Notification text box. The Email Notification text box is blank. Circle one:  PASS / FAIL 

 

I.2.6 Click Apply. The Audit Log File Manager window 
remains visible. 

Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 8, page 29 

 
 

 

 

 Operator Action Expected Result Observed Result 

I.2.7 In the Terminal window, type 
/h/AcctGrps/SecAdm/bin/COELogFileManager & 

 
NOTE: The following message may also appear 
depending on the size of the monitored system audit 
file(s). 
Message from COELogFileManager: The 
following monitored system audit 
files(s) have exceeded the ### Kb 
cumulative disk usage threshold 
specified in Audit Log File Manager: 

The command prompt reappears with no error 
messages. 

NOTE: A process ID number may appear in the 
terminal window. 

NOTE:  You may safely ignore error messages 
with the form: 
ERROR: Environment var XXXX not 
defined 

An INFORMATIONAL MESSAGE dialog box 
appears with the following message: 
Message from COELogFileManager:  
The following monitored log 
file(s) have exceeded the ### Kb 
cumulative disk usage threshold 
specified in Audit Log File 
Manager: 

The message is followed by a list of files identical 
to those written earlier as the log file list and their 
sizes in kilobytes. 

Circle one:  PASS / FAIL 

 

 

I.2.8 Click OK. The INFORMATIONAL MESSAGE dialog box is 
dismissed. 

No further INFORMATIONAL MESSAGE dialog 
boxes appear. 

Circle one:  PASS / FAIL 
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J 4.10 Verify That Audit Log Files Are Properly Deleted 

J.1 Delete the Sample Audit Log Files  

J.1.1 In the Audit Log File Manager window, Click 
Delete Log File(s).... 

The Log File(s) to Delete dialog box 
appears, with no checkboxes checked.  Verify that 
it contains all of the files from the log file 
list determined earlier. 

Circle one:  PASS / FAIL 

 

 

J.1.2 Select the /fred_1 check box. A checkmark appears next to /fred_1. Circle one:  PASS / FAIL 

 

J.1.3 Click Delete. The Log File(s) to Delete dialog box is 
dismissed. 

Circle one:  PASS / FAIL 

 

J.1.4 In the Audit Log File Manager window, Click 
Delete System File(s).... 

The System Audit File(s) to Delete 
dialog box appears, with no checkboxes selected. 

The dialog box contains all of the files from the 
system audit file list determined earlier. 

The /fred_1 directory no longer contains any 
files and is much smaller (approximately 1 Kb). 

Circle one:  PASS / FAIL 

 

 

J.1.5 Select the /fred_2 check box. A checkmark appears next to /fred_2. Circle one:  PASS / FAIL 

 

J.1.6 Click Delete. The System Audit File(s) to Delete 
dialog box is dismissed. 

Circle one:  PASS / FAIL 
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J.2 Verify That the Files Are Deleted  

J.2.1 In the Audit Log File Manager window, Click 
Delete System File(s).... 

The System Audit File(s) to Delete 
dialog box appears, with no checkboxes selected. 

The dialog box contains all of the files from the 
system audit file list determined earlier. 

The /fred_1 directory no longer contains any 
files and is much smaller (approximately 1 Kb), 
and the /fred_2 file indicates 0 Kb. 

Circle one:  PASS / FAIL 

 

 

J.2.2 Determine whether any of the listed system audit log 
files (in the System Audit File(s) to 
Delete dialog box) contain the substring 
not_terminated in the file name. 

NOTE: If there are no files containing the substring 
not_terminated in the file name, the test does not 
fail. Skip to step K. 

Zero or more system audit log files contain the 
substring not_terminated in the file name. 

Circle one:  PASS / FAIL 

 

 

J.2.3 Select the check box next to the parent directory of one 
of the files containing not_terminated in the file 
name. 

A checkmark appears next to the parent directory. Circle one:  PASS / FAIL 

 

J.2.4 Click Delete. The System Audit File(s) to Delete 
dialog box is dismissed. 

Circle one:  PASS / FAIL 
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J.2.5 In the Audit Log File Manager window, Click 
Delete System File(s).... 

 

The System Audit File(s) to Delete 
dialog box appears, with no checkboxes selected. 

All files associated with the previously deleted 
directory have disappeared, with the exception of 
the files with the substring not_terminated 
in the file name. 

Circle one:  PASS / FAIL 

 

 

J.2.6 Click Cancel button. The System Audit File(s) to Delete 
dialog box is dismissed. 

Circle one:  PASS / FAIL 
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K 4.11 Verify That the Defaults Button Properly Restores Default Values 

K.1 Check the Audit Log File Manager Defaults  

K.1.1 In the Audit Log File Manager window, click 
Defaults. 

Verify that the Audit Log File Manager 
window displays the following settings: 

Log File Manager: Disable 

Execution Time: 14:00 

Issue Disk Capacity Warning: 85% 
Used 
Notify when total size of 
monitored files exceeds: 500 Kb 
Notify when total size of 
system audit files exceeds: 500 Kb 

Popup Notification: Disable 

Email Notification: 
secman@localhost. 

Circle one:  PASS / FAIL 

 

 

L 4.12 Restore the System To Original Settings 

L.1 Remove All Sample Audit Log Files  

L.1.1 In the Audit Log File Manager window, click 
the OK button. 

The Audit Log File Manager window 
closes. 

Circle one:  PASS / FAIL 
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L.1.2 To remove the /fred_1 directory, in the Terminal 
window, type 
rm –rf /fred_1 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

The command prompt returns. Cleanup 

 

 

L.1.3 To remove the test partition filler files, in the 
Terminal window, type 
rm /<part>/fill 

for each of the test partitions noted earlier, where 
<part> is replaced by the partition pathname. 

NOTE: This method is OS specific. Use the relevant 
method on the OS being tested and note it in the 
Observed Result column. 

The command prompt returns. 

NOTE:  It is safe to ignore any messages 
indicating that the fill file is not found. Some of 
the fill files may have been removed by the 
system throughout the duration of the test. 

Cleanup 

 

 

Z 4.13 Log Out 
 

 

End of Test Validation Procedure 
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 1. Overview 

1.1 Introduction 

This document defines the Simple Mail Transport Protocol (SMTP) Interoperability 
Manual Validation Procedure and is part of the required set of test procedures to be 
used in the certification of products to the Open Brand COE Platform Product 
Standard1.  

 

2. Test Procedure 

2.1 Scope: 

This demonstration provides a first order verification of TCP/IP interoperability and 
basic BSD sockets API support for the application platform being certified.  The 
demonstration also provides some assurance of application level interoperability for 
key Simple Mail Transport Protocol (SMTP) services and protocols. The 
demonstration of SMTP electronic mail uses the mailx commands required by the 
ISO/IEC 9945-2 (Posix) specification.  An electronic mail message is read in from a 
file, sent to the sysadmin account on the Validation Host and reflected back to the 
Candidate Platform.  The returned message is displayed and saved to a file.  This 
provides some level of assurance that the Candidate Platform can support sending, 
receiving, display and storage of electronic mail. 

2.2 Description of test items 

The following functions will be exercised:  
 

A. Login 

B. Send Mail Test Message to Validation Host 

C. From Validation Host, Send Response to Test Message 

D. Receive reflected Mail Message and Compare to the Expected Result 

Z. Logout 

 

 

2.3 Test Data/Media Required   

The following test files are required: “smtp_tst.txt” (a test outbound message 
listed in Attachment 1) and “exp_reply.txt” (the expected message text after 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 being reflected from the Validation Host).  Both of these files are available on the 
Validation Host in the “/kpc/smtp” sub-directory. 

2.4 Setup/Equipment Required 

The tester should begin this test procedure using a newly restored Candidate 
Platform and Validation Host 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE).  

2.6 Change History 

June 02, 2003 

Initial Release



 

 

3. Test Procedure Submission Form 

 

Test Title: Simple Mail Transport Protocol (SMTP) Interoperability Demonstration Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 1 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 

 

 

 

Step Operator Action Expected Result Observed Result 

A. 4.1 Setup SMTP on the Validation Host 
  

A.1. Power up the Validation Host and verify that the 
COE LOGIN screen opens. 

The COE LOGIN screen opens with the DoD 
security-warning message and the �Please 
enter your user name” text box. 

Setup 

A.2. In the �Please enter your user name” 
text box enter: 
 sysadmin 

 

The password screen opens with the 
�Please enter your password” text box. 

Setup 

A.3. In the �Please enter your password” 
text box enter the password for sysadmin: 
 password 

 

An Informational Message dialog box 
opens confirming the COE LOGIN process is 
compete. 

Setup 
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Step Operator Action Expected Result Observed Result 
A.4. Click: 

 OK 
The dialog box closes. 

The menu bar, security classification and CDE 
appear. 

Setup 

A.5. Open an XTerm window, right click anywhere on 
the desktop click: 
Applications > Application Manager 
> DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Setup 

A.6. Double Click: 

 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Setup 
 

A.7. Login as sysadmin enter: 

 sysadmin 

 

The password prompt returns. Setup 

 

A.8. Enter the sysadmin password: 

 password 

 

The system returns the command line prompt. Setup 
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Step Operator Action Expected Result Observed Result 
A.9. Ensure that the smtp_tst.txt file is on the Validation 

Host enter: 

 ls �al /kpc/smtp/* 

 

A listing of the files in the /kpc/smtp subdirectory 
is displayed.  Check the ownership and permissions 
of the smtp_tst.txt file and /kpc/smtp 
subdirectories.  If necessary su to root and chmod 
777 the /kpc/smtp subdirectory and files. 

Setup 

A.10. Ensure that the /etc/hosts file contains the proper IP 
addresses enter: 

 more /etc/hosts 

 

The contents of the /etc/hosts file are displayed 
followed by the system prompt.  If not vi edit the 
/etc/hosts file and insert the proper IP addresses. 

  

 

Setup 

A.11. Exit the XTerm window enter: 

 Exit 

 

The XTerm window closes. Setup 

B. 4.2 Setup SMTP on the Candidate 
Platform 

  

B.1. Power up the Candidate Platform and verify that 
the COE LOGIN screen opens. 

The COE LOGIN screen opens with the DoD 
security-warning message and the �Please 
enter your user name” text box. 

Setup 



© 2003, The Open Group 
Chapter 9, page 8 

 
 

 

 

Step Operator Action Expected Result Observed Result 
B.2. In the �Please enter your user name” 

text box enter: 
 sysadmin 

 

The password screen opens with the 
�Please enter your password” text box. 

Setup 

B.3. In the �Please enter your password” 
text box enter the password for sysadmin: 
 password 

 

An Informational Message dialog box 
opens confirming the COE login process is 
compete. 

Setup 

B.4. Click: 
 OK 

The dialog box closes. 

The menu bar, security classification and CDE 
appear. 

Setup 

B.5. Open an XTerm window, right click anywhere on 
the desktop click: 
Applications > Application Manager 
> DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Setup 
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Step Operator Action Expected Result Observed Result 
B.6. Double Click: 

 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Setup 

 

B.7. Login as sysadmin enter: 

 sysadmin 

 

The password prompt returns. Setup 

 

B.8. Enter the sysadmin password: 

 password 
 

The system returns the command line prompt. Setup 

 

B.9. Ensure that the /kpc/smtp directory exists on the 
Candidate Platform enter: 

 ls �al /kpc/smtp 

 

If the /kpc/smtp exists on the Candidate Platform a 
listing of the files in the /kpc/smtp subdirectory is 
displayed.  Check the ownership and permissions 
of the files and subdirectories.  If the subdirectory 
/kpc/smtp does not exist create the subdirectory.  su 
to root, mkdir /kpc/smtp. 

Setup 

B.10. Ensure that the /etc/hosts file contains the proper IP 
addresses enter: 

 more /etc/hosts 

 

The contents of the /etc/hosts file are displayed 
followed by the system prompt.  If not vi edit the 
/etc/hosts file and insert the proper IP addresses. 

  

 

Setup 
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Step Operator Action Expected Result Observed Result 
B.11. Exit the XTerm window enter: 

 Exit 

 

The XTerm window closes. Setup 

C. 4.3 Send Mail Test Message.  

Send Mail From Validation Host to Candidate Platform, From Candidate Platform to Validation Host  

C.1. On the Validation Host open an XTerm window, 
right click anywhere on the desktop click: 
Applications > Application Manager 
> DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

C.2. Double Click: 

 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Circle one:  PASS / FAIL 

C.3. Login as sysadmin enter: 

 sysadmin 

 

The password prompt returns. Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
C.4. Enter the sysadmin password: 

 password 

 

The system returns the command line prompt. Circle one:  PASS / FAIL 

C.5. Send the message file smtp_tst.txt to the 
Candidate Platform enter: 

 

 mailx sysadmin@kpccp.kpc.disa.mil 
  < /kpc/smtp/smtp_tst.txt 
 

The system prompt is returned. 

 

File smtp_tst.txt contains an ASCII message, as 
found in Attachment 1. 

Circle one:  PASS / FAIL 

C.6. On the Candidate Platform open an XTerm 
window, right click anywhere on the desktop click: 
Applications > Application Manager 
> DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

C.7. Double Click: 

 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
C.8. Login as sysadmin enter: 

 sysadmin 

 

The password prompt returns. Circle one:  PASS / FAIL 

C.9. Enter the sysadmin password: 

 password 

 

The system returns the command line prompt. Circle one:  PASS / FAIL 

C.10. Execute the mail program enter: 

 

 mailx 
 

XTerm window displays a mailx prompt. 

 

Mail headers as displayed indicating 1 message 
received from the Validation Host. 

 

Circle one:  PASS / FAIL 

C.11. At the mailx prompt enter:  

 

 headers 

 

Displays the header for the mail message just 
received. 

N 1 sysadmin@mailhost. <date and time> 

 

Circle one:  PASS / FAIL 

C.12. At the mailx prompt enter: 

 

  print 

 

If the message displayed is similar to Attachment 
1, this test step result is PASS, otherwise this test 
step result is FAIL. 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
C.13. At the mailx prompt save the message received as 

a file enter: 

 

 save /kpc/smtp/smtp_tst.txt 

 

The string �/kpc/smtp/smtp_tst.txt�  [newfile]� is 
returned followed by the mailx prompt. 

 

Circle one:  PASS / FAIL 

C.14. Terminate the mailx program at the mailx prompt 
enter: 

 

 quit 
 

Returns a command prompt in the xterm window. 
 

 

Circle one:  PASS / FAIL 

C.15. Send the message file smtp_tst.txt to the 
Validation Host enter: 

 

 mailx sysadmin@kpchost.kpc.disa.mil 
  < /kpc/smtp/smtp_tst.txt 
 

The system prompt is returned. 

 

File smtp_tst.txt contains an ASCII message, as 
found in Attachment 1. 

Circle one:  PASS / FAIL 

C.16. On the Validation Host execute the mail program 
enter: 

 

 mailx 
 

XTerm window displays a mailx prompt. 

 

Mail headers as displayed indicating 1 message 
received from the Validation Host. 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
C.17. At the mailx prompt enter:  

 

 headers 

 

Displays the header for the mail message just 
received. 

N 1 sysadmin@mailhost. <date and time> 

 

Circle one:  PASS / FAIL 

C.18. At the mailx prompt enter: 

 

  print 

 

If the message displayed is similar to Attachment 
1, this test step result is PASS, otherwise this test 
step result is FAIL. 

 

Circle one:  PASS / FAIL 

C.19. At the mailx prompt save the message received as 
a file enter: 

 

 save /kpc/smtp/rcv_msg.txt 

 

The string �/kpc/smtp/rcv_msg.txt�  [newfile]� is 
returned followed by the mailx prompt. 

 

Circle one:  PASS / FAIL 

C.20. Terminate the mailx program at the mailx prompt 
enter: 

 quit 
 

Returns a command prompt in the XTerm window. 
 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 

D. 4.4 Send Reply to Test Message.   

Send Reply: From the Validation Host to Candidate Platform. 

D.1 On the Validation Host send the message file 
rcv_msg.txt to the Candidate Platform enter: 

 

 mailx sysadmin@kpccp.kpc.disa.mil 
  < /kpc/smtp/rcv_msg.txt 
 

The system prompt is returned. 

 

File rcv_msg.txt contains an ASCII message, as 
found in Attachment 1. 

Circle one:  PASS / FAIL 

D.2. On the Candidate Platform execute the mail 
program enter: 

 

 Mailx 
 

XTerm window displays a mailx prompt. 

 

Mail headers as displayed indicating 1 message 
received from the Validation Host. 

 

Circle one:  PASS / FAIL 

D.3. At the mailx prompt enter:  

 

 headers 

 

Displays headers for mail messages received, 
verifies that the reply was received. 

 

N 1 sysadmin@mailhost.<date and time> that first 
message was sent from kpccp to kpchost. 

N 2 sysadmin@mailhost. <date and time> that 
second message was sent from kpccp to kpchost. 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
D.4. At the mailx prompt enter: 

 

  print 

 

If the message displayed is similar to Attachment 
1, this test step result is PASS, otherwise this test 
step result is FAIL. 

 

Circle one:  PASS / FAIL 

D.5. At the mailx prompt save the message received as 
a file enter: 

 

 save /kpc/smtp/reply_msg.txt 

 

The string �/kpc/smtp/reply_msg.txt�  [newfile]� is 
returned followed by the mailx prompt. 

 

Circle one:  PASS / FAIL 

D.6. Terminate the mailx program at the mailx prompt 
enter: 

 

 quit 
 

Returns a command prompt in the xterm window. 
 

 

Circle one:  PASS / FAIL 

D.7. Exit the XTerm window enter: 
 

 Exit 

 

The XTerm window closes. Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
D.8. On the Candidate Platform open an XTerm 

window, right click anywhere on the desktop click: 
Applications > Application Manager 
> DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

D.9. Double Click: 

 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Circle one:  PASS / FAIL 

D.10. Login as sysadmin enter: 

 sysadmin 

 

The password prompt returns. Circle one:  PASS / FAIL 

D.11. Enter the sysadmin password: 

 password 

 

The system returns the command line prompt. Circle one:  PASS / FAIL 

D.12. Execute the mailx program enter: 

 

mailx 

 

The mailx system prompt is returned. Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
D.13. At the mailx prompt enter:  

 

 headers 
 

Displays headers for mail messages received. Circle one:  PASS / FAIL 

D.14. At the mailx prompt enter: 

 

 print # 
 

where # is the number corresponding to the reply 
from the Validation Host. 

Displays reply message received from Validation 
Host. 

 

If message is similar to Attachment 2, this test 
step result is PASS, otherwise this test step result 
is FAIL. 

  

Time stamps must reflect time of test. 

Both headers must be present. 

3.   Message body must be identical to 

      Attachment 2. 

 

Circle one:  PASS / FAIL 

D.15. Delete messages from the Candidate Platform at 
the mailx prompt enter: 

 

  delete  
 

The mailx prompt returns. 
 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
D.16. Terminate the mailx program at the mailx prompt 

enter: 

 quit 
 

Returns a command prompt in the xterm window. 
 

 

Circle one:  PASS / FAIL 

D.17. In the XTerm window at the system prompt enter: 

 

 cat /kpc/smtp/reply_msg.txt 
 

The contents of the reply_msg.txt file are displayed 
and the system prompt is returned.  

 

If message is similar to Attachment 2, this test step 
result is PASS, otherwise this test step result is FAIL. 

 
Time stamps must reflect time of test. 

Both headers must be present. 

Message body must be identical to Attachment 2. 

 

 

 

Circle one:  PASS / FAIL 

D.18. In the XTerm window at the system prompt enter: 

 

 rm /kpc/smtp/* 
 
 
 
 

All of the files in the /kpc/smtp subdirectory are 
deleted and the system prompt returns. 

 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 

Z. 4.5 Sysadmin Logout 
  

Z.1. On the Validation Host click the EXIT button on 
the CDE menu bar: 

 EXIT  

 

Logout confirmation window opens. Logout 

Z.2. Click: 

 OK 
 

System exits and the COE LOGIN screen is 
displayed. 

Logout 

Z.3. On the Candidate Platform click the EXIT button 
on the CDE menu bar: 

 

 EXIT  

 

Logout confirmation window opens. Logout 

Z.4. Click: 

 OK 
 

System exits and the COE LOGIN screen is 
displayed. 

Logout 

 

 

 

End of Test Validation Procedure 
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 1. Overview 

1.1 Introduction 

This chapter defines the File Transfer Protocol (FTP) Interoperability Manual 
Validation Procedure and is part of the required set of test procedures to be used in 
certification of products to The Open Brand COE Platform Product Standard1.  

 

2. Test Procedure 

2.1 Scope: 

This demonstration provides a first order verification of TCP/IP interoperability and 
basic BSD sockets API support for the Candidate Platform being certified.  The 
demonstration also provides some assurance of application level interoperability for 
key File Transfer Protocol (FTP) services and protocols. The demonstration suite for 
ftp uses ASCII and Binary files located on the Validation Host and on the 
Candidate Platform.  Test files located on the remote Validation Host are 
transferred to the Candidate Platform, and key ftp capabilities are exercised from the 
Candidate Platform. Test files located on the Candidate Platform are then transferred 
to the remote Validation Host, and key ftp capabilities are exercised from the remote 
Validation Host. 

2.2 Description of test items 

The following functions will be exercised:  
 

A. Login 
B. Setup Test Data and Confirm Validation Cell Configuration 

C. Setup Test Data and Confirm Candidate Platform Configuration  

D. On the Candidate Platform using ftp download the ascii and binary test 
files from the Validation Host using the get command.  

E. Exercise ftp server operations provided by and initiated on the Candidate 
Platform 

 

 

F. Execute ftp client operations initiated on the Validation Platform.  

G. Delete test files and logout of the remote session. 

Z. Logout 

                                           
1 See http://www.opengroup.org/openbrand/coe 
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2.3 Test Data/Media Required   

The following test files are required: FTPfl.txt, FTPfl.bin.  These test files 
are available on the Validation Host in the “/kpc/ftp” sub-directory. 

2.4 Setup/Equipment Required 

The  COE Validation Host must be running the ftp Service and available to the 
platform under validation.  The Host directory /kpc must be NFS mounted on the 
Candidate Platform on the /kpc directory. 

A local pair of test files, “ftp_cp.txt” and “ftp_cp.bin”, are copied to a 
Candidate Platform “/ftptmp_cp” subdirectory during setup.  Another pair of 
test files, “ftp_vh.txt” and “ftp_vh.bin”, is copied to KPC Validation Host 
subdirectory during setup. 

The destination subdirectories for file transfers are “/ftptmp_vh” for the 
Validation Host, and “/ftptmp_cp” for the Candidate Platform.  In all cases, 
files created by ftp file transfers are named “ftptest<N>”, where N is 1 through 8 
for each test file. 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

 

June 02, 2003 

Initial Release 



 

 

3. Test Procedure Submission Form 

Test Title: File Transfer Protocol (FTP) Interoperability Demonstration 

 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 1 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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 Start of Validation Procedure 

4. Test Procedure 

Step Operator Action Expected Result Observed Result 

A 4.1 Power-Up and Login   

(Optional:  Use if not already powered up or logged in.) 

A.1 On Candidate Platform and Validation Host login as sysadmin    

A.2. Power up the Candidate Platform and verify that the 
COE LOGIN screen opens. 

The COE LOGIN screen opens with the DoD 
security-warning message and the �Please 
enter your user name” text box. 

Setup 

A.3. In the �Please enter your user name” text 
box enter: 
 sysadmin 

 

The password screen opens with the 
�Please enter your password” text 
box. 

Setup 

A.4. In the �Please enter your password” text 
box enter the password for sysadmin: 
 password 

 

An Informational Message dialog box 
opens confirming the COE LOGIN process is 
compete. 

Setup 

A.5. Click: 
 OK 

 

The dialog box closes and the menu bar, security 
classification and CDE are displayed. 

Setup 
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Step Operator Action Expected Result Observed Result 

A.6. Open an XTerm window. 

Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, 
Network Installation Server, 
Reboot System, Segment Installer, 
Set DNS, Set Routes, Set System 
Time, Shutdown System, Text Edit, 
XTerm. 

Setup 

A.7. Double Click the XTerm Icon: 
 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Setup 

 

A.8. Login as sysadmin enter: 
 sysadmin 

 

The password prompt returns. Setup 

 

A.9. Enter the sysadmin password: 
 password 

 

The system prompt returns. Setup 

 

A.10. Invoke super-user privileges: 
 su – root 

 

The password prompt returns. Setup 
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Step Operator Action Expected Result Observed Result 

A.11. Enter the root password: 
 password 

 

The system prompt returns. Setup 

A.12. Ensure that ftp is running on the Candidate Platform 
and Validation Host enter: 

 more /etc/inetd.conf 

 

If the ftp line is commented out.  “vi” edit the 
inetd.conf file and uncomment the line on both 
the Candidate Platform and Validation Host.  
Then reboot both the Candidate Platform and 
Validation Host. 

Setup 

B. 
4.2 Confirm Configuration On the Validation 

Host 

  

B.1. On the Validation Host   

B.2. Open an XTerm window. 

Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons:  (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, 
Network Installation Server, 
Reboot System, Segment Installer, 
Set DNS, Set Routes, Set System 
Time, Shutdown System, Text Edit, 
XTerm. 

Setup 
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Step Operator Action Expected Result Observed Result 

B.3. Double Click the XTerm Icon: 
 Xterm 

 

An XTerm window opens. Setup 

 

B.4. Login as sysadmin enter: 
 sysadmin 

 

The password prompt returns. Setup 

 

B.5. Enter the sysadmin password: 
 password 

 

The system returns the command line prompt. Setup 

 

B.6. Invoke super-user privileges: 
 su – root 

 

The system returns the password prompt. Setup 

B.7. Enter the root password: 
 password 

 

The system prompt returns. Setup 

B.8. Change to the root directory enter:  
 cd / 

 

The system prompt returns. Setup 
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Step Operator Action Expected Result Observed Result 

B.9. Ensure that the ascii  and binary files FTPfl.txt and 
FTPfl.bin are in the /kpc/ftp subdirectory and check 
that the ownership, permissions and size are 
appropriate enter: 
 ls –al /kpc/ftp 

  

The system prompt returns. 

Enter the file size shown for FTPfl.txt: 

_______________bytes 

Enter the file size shown for FTPfl.bin: 

_______________bytes 

 

Setup 

 

B.10. Create a temporary ftp test directory enter:  
 mkdir /ftptmp_vh 

 

The system prompt returns. Setup 

B.11. Change the file permissions enter: 

 chmod 777 /ftptmp_vh 

 

The system prompt returns. Setup 

B.12. Change to the temporary directory enter:  
 cd /ftptmp_vh 

 

The system prompt returns. Setup 
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Step Operator Action Expected Result Observed Result 

B.13. Copy the /kpc/ftp/FTPfl.txt file to the default 
directory and rename the file /ftptmp_vh/ftp_vh.txt 
enter: 
 cp /kpc/ftp/FTPfl.txt 
ftp_vh.txt 

  

The system prompt returns. 

 

Setup 

B.14. Copy the /kpc/ftp/FTPfl.bin file to the default 
directory and rename the file /ftptmp_vh/ftp_vh.bin 
enter: 
 cp /kpc/ftp/FTPfl.bin 
ftp_vh.bin 

 

The system prompt returns. 

 

Setup 

B.15. Ensure that the ascii and binary files have the 
appropriate owner, permissions and are the same size 
as the original txt and bin files enter: 
 ls –al  

The contents of the subdirectory are displayed. 

Enter the file size shown for ftp_vh.txt: 

_______________bytes. 

Enter the file size shown for ftp_vh.bin: 

_______________bytes 

 

Setup 
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Step Operator Action Expected Result Observed Result 

C. 4.3 Confirm Configuration On the Candidate 
Platform 

  

C.1. On the Candidate Platform   

C.2. Open an XTerm window. 

Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons: (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, 
Network Installation Server, 
Reboot System, Segment Installer, 
Set DNS, Set Routes, Set System 
Time, Shutdown System, Text Edit, 
XTerm. 

Setup 

C.3. Double Click the XTerm Icon: 
 XTerm 

 

An XTerm window opens and the login prompt is 
displayed. 

Setup 

 

C.4. Login as sysadmin enter: 
 sysadmin 

 

The password prompt returns. Setup 

 

C.5. Enter the sysadmin password: 
 password 

 

The system returns the command line prompt. Setup 
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C.6. Invoke super-user privileges: 
 su – root 

 

The system returns the password prompt. Setup 

C.7. Enter the root password: 
 password 

 

The system prompt returns. Setup 

C.8. Change to the root directory enter:  
 cd / 

 

The system prompt returns. Setup 

C.9. Create a temporary ftp test directory enter: 
   mkdir /ftptmp_cp 

 

The system prompt returns. Setup 

C.10. Change the file permissions enter: 

 chmod 777 /ftptmp_cp 

 

The system prompt returns. Setup 

C.11. Change to the temporary directory enter:  
 cd /ftptmp_cp 

 

The system prompt returns. Setup 
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D. 
4.4 On the Candidate Platform using ftp 

 download the ascii and binary test files from the 
Validation Host using the get command. 

  

D.1. Execute the ftp program at the XTerm system 
prompte enter: 
 ftp 

 

An ftp prompt is displayed. 
ftp> 

Circle one:  PASS / FAIL 

D.2. At the ftp prompt, connect to the Validation Host.  
Type:  
 open kpchost.kpc.disa.mil 

 

A message confirms that an ftp session is 
established. 

Circle one:  PASS / FAIL 

D.3. Enter sysadmin when prompted: 
 sysadmin 

 

The password prompt returns. Circle one:  PASS / FAIL 

D.4. Enter the sysadmin password when prompted: 
 Password 

 

The ftp prompt returns. Circle one:  PASS / FAIL 
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D.5. At the ftp prompt set the local directory to ftptmp_cp 
enter: 
  lcd /ftptmp_cp 

 

The message “Local directory now 
/ftptmp_cp” is displayed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

D.6. At the ftp prompt set the remote directory to 
ftptmp_vh enter: 
 cd /ftptmp_vh 

 

The message “cd command successful” is 
displayed and the ftp prompt returns. 

Circle one:  PASS / FAIL 

D.7. At the ftp prompt set the file type to ascii enter: 
 ascii 

 

A message, “Type set to A” is displayed. Circle one:  PASS / FAIL 

D.8. At the ftp prompt download the remote file from the 
Validation Host to the Candidate Platform enter: 
 get ftp_vh.txt ftp_cp.txt 

 

A message confirms the ascii file transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

D.9. At the ftp prompt set the file type to binary enter: 
 binary 

 

A message, “Type set to I” is displayed. Circle one:  PASS / FAIL 



© 2002, The Open Group 
Chapter 10, page 15 

 
 

 

 

Step Operator Action Expected Result Observed Result 

D.10. At the ftp prompt download the remote file from the 
Validation Host to the Candidate Platform enter: 
 get ftp_vh.bin ftp_cp.bin 

 

A message confirms the ascii file transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

D.11. Quit ftp enter: 

 quit 

 

The system prompt returns in the XTerm window. Circle one:  PASS / FAIL 

D.12. Ensure that the ascii and binary files have the 
appropriate owner, permissions and are the same size 
as the original txt and bin files enter: 

 ls �al  

The contents of the subdirectory are displayed and 
the system prompt returns. 

Enter the file size shown for ftp_vh.txt: 

_______________bytes. 

Enter the file size shown for ftp_vh.bin: 

_______________bytes 

 

Circle one:  PASS / FAIL 
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E. 
4.5 Execute ftp client operations initiated on the Candidate Platform.  

ftp server runs remotely on the Validation Host. 
Download and upload ascii and binary test files using the get and put commands on the Candidate Platform.  

E.1. On the Candidate Platform open a second Xterm 
window. 

Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons:  (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, 
Network Installation Server, 
Reboot System, Segment Installer, 
Set DNS, Set Routes, Set System 
Time, Shutdown System, Text Edit, 
XTerm. 

Circle one:  PASS / FAIL 

 

 

E.2. Double Click the Xterm Icon: 
 XTerm 

 

A second XTerm window opens. Circle one:  PASS / FAIL 

E.3. Login as sysadmin enter: 
 sysadmin 

 

The password prompt returns. Circle one:  PASS / FAIL 
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E.4. Enter the sysadmin password: 
 password 

 

The system prompt returns. Circle one:  PASS / FAIL 

E.5. In the second Xterm, window execute the ftp program 
enter: 
 ftp 

 

An ftp prompt is displayed. 
ftp> 

Circle one:  PASS / FAIL 

E.6. On the Candidate Platform at the ftp prompt open a 
connection to the Validation Host enter:  
 open kpchost.kpc.disa.mil 

 

A message confirms that an ftp session is 
established and the ftp login prompt is displayed. 

Circle one:  PASS / FAIL 

E.7. At the ftp login prompt enter: 
 sysadmin 

 

The ftp password prompt is displayed. Circle one:  PASS / FAIL 

E.8. Enter the sysadmin password: 
 password 

 

The ftp prompt is returned Circle one:  PASS / FAIL 
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E.9. At the ftp prompt set the local directory to ftptmp_cp 
enter: 

 
  lcd /ftptmp_cp 

 

The message “Local directory now 
/ftptmp_cp” is displayed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

E.10. At the ftp prompt set the remote directory to 
ftptmp_vh enter: 
 cd /ftptmp_vh 

 

The message “cd command successful” is 
displayed and the ftp prompt returns. 

Circle one:  PASS / FAIL 

E.11. At the ftp prompt set the file type to ascii enter: 
 ascii 

 

A message, �Type set to A� is displayed. Circle one:  PASS / FAIL 

E.12. At the ftp prompt download the remote ascii file from 
the Validation Host to the Candidate Platform enter: 
 get ftp_vh.txt ftptest1vh.txt 

 

A message confirms the ascii file transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

E.13. At the ftp prompt upload the local ascii test file from 
the Candidate Platform to the Validation Host enter: 
 put ftp_cp.txt ftptest2cp.txt 

 

A message confirms that an ASCII transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 
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E.14. Switch to the other XTerm window on the Candidate 
Platform to compare the local and downloaded files 
enter:  
 cmp –s /ftptmp_cp/ftp_cp.txt 
ftptest1vh.txt  && echo ‘Files 
are identical’ 

 

If the local and downloaded files are identical, the 
string �Files are identical� is displayed at the 
system prompt. 

Circle one:  PASS / FAIL 

E.15. Ensure that the binary file ftp_cp.bin has the 
appropriate owner, permissions, file type and size 
enter: 
 ls -l ftp_cp.bin 

 

Directory listing for the file opens. 

Enter the file size shown for ftp_cp.bin: 

_______________bytes 

Circle one:  PASS / FAIL 

E.16. On the Validation Host in the XTerm window at the 
system prompt compare the local and uploaded ascii 
files enter:  
 cmp –s ftp_vh.txt 
ftptest2cp.txt && echo  ‘Files are 
identical’ 

 

If the local and uploaded files are identical, the 
string “Files are identical” is displayed 
and the system prompt returns. 

Circle one:  PASS / FAIL 
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E.17. Ensure that the binary file ftp_vh.bin has the 
appropriate owner, permissions, file type and size 
enter: 
 ls -al 

 

The contents of the default subdirectory are 
displayed and the system prompt returns 

Enter the file size shown for ftp_vh.bin: 

______________bytes 

Circle one:  PASS / FAIL 

E.18. On the Candidate Platform at the ftp prompt set the 
file type to binary enter: 
 binary 

 

A message, �Type set to I� is displayed. Circle one:  PASS / FAIL 

E.19. At the ftp prompt download the remote file from the 
Validation Host to the Candidate Platform enter: 
 get ftp_vh.bin ftptest3vh.bin  

 

A message confirms that a binary transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

E.20. At the ftp prompt upload the local binary test file 
from the Candidate Platform to the Validation Host 
enter: 
 put ftp_cp.bin ftptest4cp.bin 

 

A message confirms that a binary upload is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 
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E.21. Switch to the other XTerm window on the Candidate 
Platform and ensure that the binary file ftptest3vh.bin 
has the appropriate owner, permissions, file type and 
size enter: 
 ls -al ftptest3vh.bin 

The contents of the default subdirectory are 
displayed and the system prompt returns 

Enter the file size shown for ftptest3vh.bin: 

______________bytes 

 

Circle one:  PASS / FAIL 

 

E.22. On the Validation Host in the XTerm window at the 
system prompt ensure that the binary file 
ftptest4cp.bin has the appropriate owner, permissions, 
file type and size enter  
 ls -al ftptest4cp.bin 

 

The contents of the default subdirectory are 
displayed and the system prompt returns 

Enter the file size shown for ftptest4cp.bin: 

_______________bytes 

Circle one:  PASS / FAIL 

 

E.23. On the Candidate Platform quit ftp at the ftp prompt 
enter: 
 quit  

and then type exit to close the current XTerm 
window. 

The XTerm window system prompt returns. Circle one:  PASS / FAIL 

E.24. Exit the XTerm window enter: 
 exit 

 

The XTerm window closes. Circle one:  PASS / FAIL 
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F. 
4.6 Execute ftp client operations initiated on the Validation Host.  

ftp server runs remotely on the Candidate Platform. 
Download and upload ascii and binary test files using the get and put commands on the Validation Host. 

F.1. On the Validation Host open a second XTerm 
window. 

Select Applications > Application 
Manager > DII_APPS > SysAdm 

The Application Manager – SysAdm 
window opens with the following icons:  (go up), 
Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, 
Network Installation Server, 
Reboot System, Segment Installer, 
Set DNS, Set Routes, Set System 
Time, Shutdown System, Text Edit, 
XTerm. 

Circle one:  PASS / FAIL 

 

 

F.2. Double Click the XTerm Icon: 
 XTerm 

 

A second XTerm window opens. Circle one:  PASS / FAIL 

F.3. Login as sysadmin enter: 
 sysadmin 

 

The password prompt returns. Circle one:  PASS / FAIL 
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F.4. Enter the sysadmin password: 
 password 

 

The system prompt returns. Circle one:  PASS / FAIL 

F.5. In the second XTerm, window execute the ftp 
program enter: 
 ftp 

 

An ftp prompt is displayed. 

ftp> 

Circle one:  PASS / FAIL 

F.6. On the Validation Host at the ftp prompt open a 
connection to the Candidate Platform enter:  
 open kpccp.kpc.disa.mil 

 

A message confirms that an ftp session is 
established and the ftp login prompt is displayed. 

Circle one:  PASS / FAIL 

F.7. At the ftp login prompt enter: 
 sysadmin 

 

The ftp password prompt is displayed. Circle one:  PASS / FAIL 

F.8. Enter the sysadmin password: 
 Password 

 

The ftp prompt is returned Circle one:  PASS / FAIL 
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F.9. At the ftp prompt set the local directory to ftptmp_vh 
enter: 
  lcd /ftptmp_vh 

 

The message “Local directory now 
/ftptmp_vh” is displayed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

F.10. At the ftp prompt set the remote directory to 
ftptmp_cp enter: 
 cd /ftptmp_cp 

 

The message “cd command successful” is 
displayed and the ftp prompt returns. 

Circle one:  PASS / FAIL 

F.11. At the ftp prompt set the file type to ascii enter: 
 ascii 

 

A message, “Type set to A” is displayed. Circle one:  PASS / FAIL 

F.12. At the ftp prompt download the remote ascii file from 
the Candidate Platform to the Validation Host enter: 
 get ftp_cp.txt ftptest5cp.txt 

 

A message confirms the ascii file transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

F.13. At the ftp prompt upload the local ascii test file from 
the Candidate Platform to the Validation Host enter: 
 put ftp_vh.txt ftptest6cp.txt 

 

A message confirms that an ascii file transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 
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F.14. Switch to the other XTerm window on the Candidate 
Platform to compare the local and downloaded files 
enter:  
 cmp –s /ftptmp_vh/ftp_vh.txt 
ftptest5cp.txt  && echo ‘Files 
are identical’ 

 

If the local and downloaded files are identical, the 
string �Files are identical� is displayed at the 
system prompt. 

Circle one:  PASS / FAIL 

F.15. Ensure that the binary file ftp_cp.bin has the 
appropriate owner, permissions, file type and size 
enter: 
 ls -l ftp_vh.bin 

 

Directory listing for the file opens. 

Enter the file size shown for ftp_vh.bin: 

_______________bytes 

Circle one:  PASS / FAIL 

F.16. On the Validation Host in the XTerm window at the 
system prompt compare the local and uploaded ascii 
files enter:  
 cmp –s ftp_cp.txt 
ftptest6cp.txt && echo  ‘Files are 
identical’ 

 

If the local and uploaded files are identical, the 
string “Files are identical” is displayed 
and the system prompt returns. 

Circle one:  PASS / FAIL 
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F.17. Ensure that the binary file ftp_cp.bin has the 
appropriate owner, permissions, file type and size 
enter: 
 ls -al 

 

The contents of the default subdirectory are 
displayed and the system prompt returns 

Enter the file size shown for ftp_cp.bin: 

______________bytes 

Circle one:  PASS / FAIL 

F.18. On the Candidate Platform at the ftp prompt set the 
file type to binary enter: 
 binary 

 

A message, “Type set to I” is displayed. Circle one:  PASS / FAIL 

F.19. At the ftp prompt download the remote file from the 
Validation Host to the Candidate Platform enter: 
 get ftp_cp.bin ftptest7cp.bin  

 

A message confirms that a binary transfer is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

F.20. At the ftp prompt upload the local binary test file 
from the Candidate Platform to the Validation Host 
enter: 
 put ftp_vh.bin ftptest8vh.bin 

 

A message confirms that a binary upload is in 
progress, then completed and the ftp prompt 
returns. 

Circle one:  PASS / FAIL 

 



© 2002, The Open Group 
Chapter 10, page 27 

 
 

 

 

Step Operator Action Expected Result Observed Result 

F.21. Switch to the other XTerm window on the Candidate 
Platform and ensure that the binary file ftptest3vh.bin 
has the appropriate owner, permissions, file type and 
size enter: 
 ls -al ftptest7vh.bin 

The contents of the default subdirectory are 
displayed and the system prompt returns 

Enter the file size shown for ftptest7cp.bin: 

_______________bytes 

Circle one:  PASS / FAIL 

F.22. On the Validation Host in the XTerm window at the 
system prompt ensure that the binary file 
ftptest4cp.bin has the appropriate owner, permissions, 
file type and size enter  
 ls -al ftptest8vh.bin 

 

The contents of the default subdirectory are 
displayed and the system prompt returns 

Enter the file size shown for ftptest8vh.bin: 

_______________bytes 

Circle one:  PASS / FAIL 

F.23. On the Candidate Platform quit ftp at the ftp prompt 
enter: 
 quit  

and then type exit to close the current xterm 
window. 

The XTerm window system prompt returns. Circle one:  PASS / FAIL 

F.24. Exit the XTterm window enter: 
 exit 

 

The XTerm window closes. Circle one:  PASS / FAIL 
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G 
4.7 Delete test files and logout of the remote session. 

G.1. On the Validation Host remove all test files and the 
ftptmp_vh subdirectory enter: 
  rm /ftptmp_vh/* 

 

System prompt returns. Cleanup 

G.2. Remove the ftp tmp_vh subdirectory enter: 
 rmdir /ftptmp_vh 

 

System prompt returns. Cleanup 

G.3. Ensure that all test files have been removed enter: 
 ls /ftptmp_vh 

 

An error indicating that “/ftptmp_vh” no 
longer exists and the system prompt is returned. 

Cleanup 

G.4. Invoke super-user privileges: 
 su – root 

 

The system returns the password prompt. Cleanup 

G.5. Enter the root password: 
 password 

 

The system prompt returns. Cleanup 
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G.6. Change to the root directory enter: 
 cd / 

 

The system prompt returns. Cleanup 

G.7. On the Candidate Platform enter: 
 rm /ftptmp_cp/* 

 

System prompt returns. Cleanup 

G.8. On the Candidate Platform enter: 
 rmdir /ftptmp_cp 

 

System prompt returns. Cleanup 

G.9. On the Candidate Platform verify that all test files are 
deleted enter: 
 ls /ftptmp_cp 

 

System returns an error indicating that 
“/ftptmp_cp” no longer exists and then 
returns to the command prompt. 

Cleanup 
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Z 4.8 Logout  

(Optional:  Use if no further validation is to be done.) 

Z.1 Logout   

Z.2 Verify sysadmin Logout  

Z.2.1 Log out of the Candidate Platform as sysadmin. The menu bar, security classification and CDE 
desktop appear. 

 Shutdown 

Z.2.2 Click the EXIT button on the CDE menu bar: 

 

 EXIT  

 

Logout confirmation window opens.  Shutdown 

Z.2.3 Click:  
 OK  

 

The system exits and the COE LOGIN screen 
opens. 

 Shutdown 

 

 

 

End of Test Validation Procedure 
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1. Overview 

1.1 Introduction 

This chapter defines the World Wide Web (WWW) Interoperability Manual Validation 
Procedure and is part of the required set of test procedures to be used in the 
certification of products to the Open Brand COE Platform Product Standard1.  

2. Test Procedure 

2.1 Scope: 

This demonstration provides a first order verification of TCP/IP interoperability and 
basic BSD sockets API support for the Candidate Platform.  The demonstration also 
provides some assurance of application level interoperability and the ability to 
support key Hyper-Text Transfer Protocol (HTTP) services and protocols.  This 
procedure is not intended as a comprehensive test and only exercises a subset of 
TCP/IP, HTML and HTTP features. The demonstration of WWW services uses an HTTP 
conforming browser to retrieve a series of HTML 3.2 conforming web pages to and 
display them on the Candidate Platform.  The test pages exercise key TCP/IP, Hyper-
Text Markup Language (HTML), HTTP and forms related capabilities. 

2.2 Description of test items 

The following functions will be exercised:  
 

A. Login 

B. WWW Interoperability Demo Initiation 

C. Basic HTML Data Types 

D. Text Display / Tag Handling 

E. Multi-media Support 

F. Forms and Script Support 

Z. Logout 

 

 

 

 

 
                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 2.3 Test Data/Media Required   

Forms related HTML source files must be edited (frm_inpt.htm, 
frm_slct.htm, and frm_text.htm in the /kpc/www directory) to 
specify the email destination for form submission as the system administrator 
account (“sysadmin”) on Validation Host.  This is accomplished by searching for a 
“mailto:” string and substituting the Validation Host actual hostname into the 
string  “sysadmin@kpchost.kpc.disa.mil”. 

Note to Tester: Be sure to edit these files before they are opened in the browser.  
Once opened, they will be cached, and clicking reload will only reload the cached 
(unedited) file.  �Shift+reload� is required to reload the edited file from the server. 

Forms related HTML source files must be edited to specify the email destination for 
form submission as the system administrator account (“sysadmin”) on Validation 
Host.  This is accomplished by searching for a �mailto:� string, and substituting the 
Validation Host actual hostname into the string  
“sysadmin@kpchost.kpc.disa.mil”. 

2.4 Setup/Equipment Required 

The COE Validation Host must be set up as the WWW Server and network accessible 
to the Candidate Platform.  An HTML 3.2, HTTP 1.0 web-browser installed on the 
Candidate Platform is needed to execute this validation procedure.  The web-browser 
is not included in the COE kernel, and is considered part of the test suite.  If a 
suitable browser is not provided as part of the Candidate Platform system software, a 
browser application with appropriate license(s), browser installation procedure, 
browser installation and execution instructions must be provided. Since the browser 
application is part of the test suite, the browser application need not be segmented, 
and may be invoked using an xterm or other means if necessary. The platform must 
also include a color display capable of displaying the 16 HTML named color entities 
(see step C.1.3). 

 

All other test data must be used without modification.  HTML source may be 
viewed using HTML editing tools, but should not be �saved�.  HTML tools often 
transform numeric character codes into character entity references and force tags 
substitutions without notifying the user.  Executing this test with such 
transformed or modified data would invalidate the test results 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). An individual without color vision impairment must perform step 
C.1.3.   
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 2.6 Change History 

June 02, 2003 

Initial Release
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3. Test Procedure Submission Form 

Test Title: World Wide Web (WWW) Interoperability Demonstration Validation Procedure 

 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 1 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 

 

Step Operator Action Expected Result Observed Result 

A 4.1 Power-up and Login  

 (Optional: Use if not already powered up or logged in.) 

A.1. Verify sysadmin Login    

A.1.1. Power up the Candidate Platform and verify that 
the COE Login screen opens. 

The COE login screen opens with the DoD 
security-warning message and the �Please 
enter your user name” text box. 

 Setup 

A.1.2. In the �Please enter your user name” 
text box enter: 
 sysadmin 

 

The password screen opens with the 
�Please enter your password” text box. 

 Setup 

A.1.3. In the �Please enter your password” 
text box type the password for the sysadmin 
account and press [RETURN]. 

 

An Informational Message dialog box 
opens confirming that COE login processing is 
compete. 

 Setup 
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A.1.4. Click: 
  OK 

  

The dialog box closes. 

The menu bar, security classification and CDE 
open. 

 Setup 

A.2. Mount KPC Test Data.  (Optional: Use if files not already NFS mounted.)  

A.2.1. On the Validation Host (kpchost): 

Select Applications > Application 
Manager > DII_APPS > SysAdm  

 

The Application Manager - SysAdm 
window opens. 

Setup 

A.2.2. Double-click: 
  Disk Manager 

 

The Disk Manager window opens. Setup 

A.2.3. Select the row containing “/” in the Mounted 
On column. 

The row is highlighted. Setup 

A.2.4. Click: 
 Export FS 

 

The Export/Unexport File Systems 
dialog box opens. 

Setup 
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A.2.5. In the options text box enter:   
 rw=kpccp.kpc.disa.mil 
 /kpc/www 

 

A dialog box opens asking “Export this 
directory permanently?  yes or no. 

If the dialog box is displayed as described above, 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Setup 

A.2.6. Click: 
 Export 

 

A confirmation dialog box appears asking if the 
directory should be exported permanently. 

Setup 

A.2.7. Click: 

 Yes 

The dialog box closes. 

kpchost:/kpc is not displayed in the Disk 
Manager window. 

Setup 

A.2.8. Click: 

 Exit 

If the file system appears as above, the test step 
result is PASS, otherwise the test step result is 
FAIL. 

Setup 

A.2.9. On the Candidate Platform (kpccp): 

Select Applications > Application 
Manager > DII_APPS > SysAdm  

 

The Application Manager - SysAdm 
window opens. 

Setup 

A.2.10. Double Click: 
 Disk Manager 

 

The Disk Manager window opens. Setup 
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A.2.11. Click: 
  Mount New 

 

The Mount File System dialog box opens. Setup 

A.2.12. In the �FILE SYSTEM� text box enter: 
 kpchost:/kpc/www 

In the �MOUNT POINT� text box enter: 
 /kpc 

kpchost:/kpc/www appears in the text box. 

If the text box appears as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Setup 

A.2.13. Click: 
  MOUNT 

 

A Confirmation dialog box opens asking if the 
directory should be mounted permanently. 

Setup 

A.2.14. Click: 

 Yes 

 

The dialog box closes. Setup 

A.2.15. Double-click: 

 Disk Manager. 

kpchost:/kpc appears in the Disk Manager 
window. 

If the file system appears as above, the test step 
result is PASS, otherwise the test step result is 
FAIL. 

Setup 



© 2003, The Open Group 
Chapter 11, page 10 

 
 

 

 

Step Operator Action Expected Result Observed Result 

A.3. Segmented Browser Installation (Optional: Install a Segmented Browser)  

A.3.1. Install an HTML 3.2, HTTP 1.0 web-browser on the 
Candidate Platform as part of the test suite, using 
vendor supplied documentation. 

 

Optional: Installation is necessary only if a 
suitable browser is not provided as part of the 
application platform. 

A browser is available for execution on the 
Candidate Platform. 

Setup 

B. 4.2 WWW Interoperability Demo Initiation 

B.1. 
4.2.1.1.1.1 Initialize 

 

B.1.1. Invoke the web browser application per the vendor 
instructions. 

A web Browser window appears on the display. Circle one: PASS/FAIL 

B.1.2. On the Candidate Platform open the following file 
in the Web Browser. 

 

 /kpc/www/kpc_www.htm 

 

 

Click: 

 OK 

 

If the top level, KPC �World Wide Web Test Page� 
loads and displays as in attachment 1 the test 
result is PASS, otherwise the test result is FAIL. 

 

Note: If the page appears as in attachment 2 then 
the browser fails to support the basic HTML 
markup tags. 

Circle one: PASS/FAIL 
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C. 
 

4.3 BASIC HTML DATA TYPES 

C.1. 
4.3.1.1.1.1 Numeric Character Codes 

 

C.1.1. Under �Basic HTML Data Types�, click on the link 
labeled �Numeric Character Codes�. 

The �ISO 8879-1 Numeric Character Codes Test 
Page� is loaded and displayed. 

 Circle one: PASS / FAIL 

C.1.2. Inspect the �Table of Numeric Character Codes�.  
Each cell should be rendered as per attachment 3.  

 

EXCEPTION: The first cell (code �0�) and the fifth 
column (codes �128� through �159� inclusive) are 
not to be considered. 

If the sample text is rendered as in attachment 3, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

C.1.3. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 
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C.2. 
4.3.1.1.1.2 Character Entity References 

 

C.2.1. Under �Basic HTML Data Types�, click on the link 
labeled �Character Entity References�. 

The �ISO 8879-1 Character Entity References Test 
Page� is loaded and displayed. 

 Circle one: PASS / FAIL 

C.2.2. Inspect the �Table of Character Entity References�. 
The contents of the first two columns labeled �ER 
Glyph� and �NE Glyph� respectively, should be 
identical for all rows. 

 

Note: The original data must be used for this test. 

If the contents of the columns match as indicated at 
left, the test result is PASS, otherwise the test result 
is FAIL. 

 Circle one: PASS / FAIL 

C.2.3. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

C.3. 
4.3.1.1.1.3 Color Model Support 

 

C.3.1. Under �Basic HTML Data Types�, click on the link 
labeled �Color Model Support�. 

The �Color Model Support Test Page� is displayed.  Circle one: PASS / FAIL 

C.3.2. Inspect the table �Color Names and SRGB Values�.  
The colors should appear as named, and the colors in 
the corresponding Name, Value and GIF image cells 
should match for each row. 

If the contents match as indicated at left, the test 
result is PASS, otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

C.3.3. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 
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D. 4.4 Text Display / Tag Handling 

D.1. 
4.4.1.1.1.1 Document Structure Tags 

 

D.1.1. Under �Text Display/Tag Handling�, click on the 
link labeled �Document Structure Tags�. 

The KPC �Document Structure Tags Test Page� 
loads and displays. 

 Circle one: PASS / FAIL 

D.1.2. Inspect the page. The page is displayed as a web 
page rather than as HTML source as in attachment 
2 (see step B.1.2).  If the page source is displayed 
as HTML source then the browser fails to support 
the basic HTML markup tags. 

If the page is displayed as a web page, then the 
test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.1.3. Inspect the title of the document, which should be 
displayed as �KPC WWW Test - Document 
Structure Tags�. 

If the title of the document is displayed as 
described at left, the test result is PASS, otherwise 
the test result is FAIL. 

 Circle one: PASS / FAIL 

D.1.4. Inspect the Heading Element table, which should 
render the H1 element using style elements, which 
attract more attention (larger font, bold, italic text) 
than less important ones.  Each successively higher 
numbered header should be rendered so as to attract 
less attention. 

If the header elements are displayed as described 
at left, the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

D.1.5. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 
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D.2. Body Element Tags  

D.2.1. Under �Text Display/Tag Handling�, click on the 
link labeled �Body Element Tags�. 

The KPC �Body Element Tag Test Page� loads and 
displays. 

 Circle one: PASS / FAIL 

D.2.2. Under Structured Text Tags  

D.2.3. Under the �Phrase Elements� header, inspect the 
text samples for �emphasis� and �strong� phrase 
types, which are generally rendered as italic and 
bold font, respectively 

If phrase types �emphasis� and �strong� are 
rendered to differentiate them from normal text, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.2.4. Inspect the text samples for �Code�, �Keyboard 
Input� and �Sample Output� phrase types, which 
are generally rendered using a mono-space font. 

If phrase types �Code�, �Keyboard Input�, and 
�Sample Output� are rendered to differentiate 
them from normal text, the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.5. Inspect the text samples for �Variable� and 
�Citation� phrase types, which are generally 
rendered as italic text. 

If phrase types �Variable� and �Citation� code 
types are rendered to differentiate them from 
normal text, the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.6. Inspect the text samples for �Abbreviation� and 
�Acronym� phrase types, which are used to 
demarcate text for tools and generally rendered as 
normal text. 

If phrase types �Abbreviation� and �Acronym� are 
rendered as normal text, the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.7. Under the �Quotations� header, inspect the sample 
<BLOCKQUOTE> text, which is generally rendered 
as an indented block of text. 

If quoted text is rendered as described at left, the 
test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 
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D.2.8. Under the �Subscripts and Superscripts� header, 
inspect the sample superscript (�123 Superscript�) 
and subscript (�456 Subscript�) text, which is 
generally rendered as text shifted slightly above 
and below the normal text, respectively. 

If Subscript and Superscript text is rendered 
slightly above and below normal text, the test 
result is PASS, otherwise the test result is FAIL 

 Circle one: PASS / FAIL 

D.2.9. Under the �Font Styles� header, inspect the 
sample �teletype� text, which is generally rendered 
using a monospace font. 

If teletype sample text is rendered in a monospace 
font, the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

D.2.10. Inspect the sample �italic� text. If font style text sample italic is rendered in as 
italic text, the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.11. Inspect the sample “bold” text. If font style text sample bold is rendered in as 
bold text, the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.12. Inspect the sample �Big� and �Small� text, and 
compare to the �normal text� sample in the table. 

If the �Big� and �Small� font style text samples 
are rendered in as larger and smaller than normal 
text respectively, the test result is PASS otherwise 
the test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.13. Inspect the sample “Strike and <S>“ text. If Strike and <S> font styles are rendered as 
Strike-through text, the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

D.2.14. Inspect the sample �underline� text. If font style text sample underline is rendered in 
as underline text, the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 



© 2003, The Open Group 
Chapter 11, page 16 

 
 

 

 

Step Operator Action Expected Result Observed Result 

D.2.15. Under Lines and Paragraphs  

D.2.16. Under the �Paragraphs�, header, inspect the 
indented text.  The text sample should be divided 
into two paragraphs separated by white-space. 

If the sample text is rendered as indicated at left, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.2.17. Under the �Line Breaks�, header, inspect the 
indented text.  The two lines in the indented text 
sample should appear on separate lines starting at 
the left margin. 

If the sample text is rendered as indicated at left, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.2.18. Under the �Preformatted Text�, header, inspect the 
preformatted text example.  The sample text 
should appear as a symmetric pyramid shape. 

If the sample text is rendered as indicated at left, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.2.19. Under Alignment and Horizontal Rules  

D.2.20. Under the �Alignment�, header, inspect the aligned 
text example.  Sample text should be left, right, 
and center aligned on successive lines. 

If the sample text is rendered as indicated at left, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.2.21. Under the �Horizontal Rules�, header, inspect the 
horizontal rule examples.  Half width horizontal 
rules should be left, right, and center aligned on 
successive lines, followed by a full width horizontal 
rule. 

If the horizontal rules are rendered as indicated at 
left, the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

D.2.22. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 
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D.3. List Tags  

D.3.1. Under �Text Display/Tag Handling�, click on the 
link labeled �List Tags�. 

The �List Tags Test Page� loads & displays.  Circle one: PASS / FAIL 

D.3.2. Under the �Unordered List� header, inspect the 
three unordered list examples.  The lists should be 
rendered as vertical lists, with disc, circle, and 
square bullet types, and should not be numbered. 

If the bullet types for the three lists are rendered 
as indicated at left, the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

D.3.3. Under the �Ordered List� header, inspect the 
default ordered list example.  The list should be 
rendered as a vertical list, numbered with the 
lowest number on top. 

If the default ordered list is rendered as indicated 
at left, the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

D.3.4. Under the �Ordered List� header, inspect the five 
numbering style samples.  The lists should be 
rendered in step D.3.3 above, except that they are 
labeled with lower case alpha, upper case alpha, 
lower case roman and upper case roman 
numerals, respectively. 

If the five alternate numbering style samples are 
rendered as indicated at left, the test result is 
PASS, otherwise the test result is FAIL. 

C ircle one: PASS / FAIL 

D.3.5. Under the �Definition List� header, inspect the 
Definition list example.  The term being defined is 
on a line, with the definition on the line following 
the term.  The definition is indented.  

If the definition list is rendered as indicated at left, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

D.3.6. Under the �Nested List� header, inspect the 
sample �nested list�.  The lists should be rendered 
as shown in attachment 4.  The indentation and 
ordered/unordered item types should correspond 
with the attachment. 

If the nested list is rendered as indicated at left, 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 
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D.3.7. Under the �DIR and Menu Elements� header, 
inspect the two unordered list examples.  The lists 
should be rendered as vertical lists, and should not 
be numbered. 

If the DIR and Menu Elements are rendered as 
indicated at left, the test result is PASS, otherwise 
the test result is FAIL. 

 Circle one: PASS / FAIL 

D.3.8. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

D.4. Table Tags  

D.4.1. Under �Text Display/Tag Handling�, click on the 
link labeled �Table Tags�. 

The KPC �Table Tag Test Page� loads and displays.  Circle one: PASS / FAIL 

D.4.2. Under the �Sample Basic Table with Captions� 
header, inspect the sample table.  A 3x3 table with 
text aligned in each block should be rendered as in 
attachment 5. 

If the �Sample Basic Table with Captions� is 
rendered as indicated at left, the test result is 
PASS, otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

D.4.3. In the table �Sample Table with Vertical Cell that 
Spans Rows�, compare the left and right sample 
tables with the GIF image in the center.  The left 
and right tables should be rendered to reflect the 
basic cell organization shown in the center GIF 
image.  The GIF image is included in attachment 
6. 

If the left and right tables are rendered to reflect the 
basic cell organization shown in the center GIF 
image, the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

D.4.4. In the table �Sample Table with Horizontal Cell 
that Spans Columns�, compare the left and right 
sample tables with the GIF image in the center.  
The left and right tables should be rendered to 
reflect the basic cell organization shown in the 
center GIF image.  The GIF image is included in 
attachment 6. 

If the left and right tables are rendered to reflect 
the basic cell organization shown in the center GIF 
image, the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 
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D.4.5. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

E. 4.5 MULTI-MEDIA SUPPORT 

E.1. Graphical Data Formats  

E.1.1. Under �Multimedia Support�, click on the link 
labeled �Graphical Data Format�. 

 

Note: This page contains several images, each 
containing a test pattern (see attachment 7) 
stored in a specific graphical format.  Image 
formats included are GIF, JPEG, PNG, TIFF, PCX 
and BMP 

The KPC �Graphical Data Format Test Page� loads 
and displays. 

 Circle one: PASS / FAIL 

E.1.2. Inspect the page.   Image formats supported 
should appear with a label �<Format> Format 
Rendered�.  For any image not supported, a text 
string appears indicating �<Format> not 
Rendered�. 

If the GIF and JPEG formats are supported then 
the test result is PASS, otherwise the test result is 
FAIL. 

 Circle one: PASS / FAIL 

E.1.3. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 
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E.2. Image Map Graphics Support  

E.2.1. Under �Multimedia Support�, click on the link 
labeled �Image Map Graphics�. 

The KPC �Image Map Test Page� loads and 
displays. 

 Circle one: PASS / FAIL 

E.2.2. A GIF test pattern image will appear as in 
attachment 7.  Click on each quarter of the main 
square, labeled �Red�, �Green�, �Blue�, or 
�Texture� in turn. 

 

For each quarter selected, a more detailed GIF 
image of that quarter (see attachment 8) should 
appear. Click on the browser �Back� button to 
return to the �Image Map Test Page�. 

If the detailed image for each quarter appears in 
turn as indicated at left, then the test result is 
PASS, otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

E.2.3. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

E.3. Visual Presentation of Images  

E.3.1. Under �Multimedia Support�, click on the link 
labeled �Visual Presentation of Images�. 

The KPC �Visual Presentation of Images Test Page� 
loads and displays. 

 Circle one: PASS / FAIL 

E.3.2. Inspect bullet item 1 on the page. The three test 
pattern images should be followed by text that is 
aligned with the Top, Middle, and Bottom of the 
images, respectively. 

If the text following the images is aligned as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

E.3.3. Inspect bullet item 2 on the page. The image 
should be aligned on the right margin with a solid 
border.  Text should be wrapped around the image 
on the left side of the image. 

If the image and text are rendered as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 
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E.3.4. Inspect bullet item 3 on the page. The image 
should be aligned on the left margin with no 
border.  Text should be wrapped around the image 
on the right side of the image.  The image should 
be approximately half the size of the image in step 
E.3.3. 

If the image and text are rendered as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

E.3.5. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

F. 4.6 FORMS & SCRIPT SUPPORT 

F.1. Input Elements  

F.1.1. Under �Forms and Script Support�, click on the link 
labeled �Input Elements�. 

The KPC �Forms � Input Element Test Page� loads 
and displays. 

 Circle one: PASS / FAIL 

F.1.2. Inspect the table cell under the title �Text Control 
Type�.  A single line text field should appear under 
the text �Input Name� containing the initial string 
�your name�.  

If the text field is displayed as specified at left, 
then the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

F.1.3. Modify the text field specified in step F.1.2 by 
selecting the word �your�, and substituting the 
word �my� in its place. 

If the text field can be manipulated as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.4. Inspect the table cell under the title �Password 
Control Type�.  A single line text field should 
appear under the text �Input Password� with no 
initial contents.  

If the password field is displayed as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 
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F.1.5. Modify the password field specified in step F.1.4 by 
selecting the field, and typing the characters 
�fullback_4�.  The input text should be rendered in 
such a way as to obscure the characters (e.g. an 
asterisk for each character entered). 

If the password field can be manipulated as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.6. Inspect the table cell under the title �Checkbox 
Control Type�.  Two items (Right, Left) should 
appear under the text �Input Right/Left Handed:� 
with �Right� as the initial selection.  

If the Checkbox field is displayed as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.7. Modify the Checkbox field specified in step F.1.6 
by selecting the �Left� item. A visual indication 
that the �Left� item has been selected should be 
apparent, and the �Right� item should continue to 
be selected. 

If the Checkbox field can be manipulated as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.8. Inspect the table cell under the title �Radio Control 
Type�. A set of three items (Red, Green, Blue) 
should appear under the text �Input Preferred 
Color:� with �Red� as the initial selection. 

If the radio field is displayed as specified at left, 
then the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

F.1.9. Modify the radio field specified in step F.1.8 by 
selecting the �Blue� item. A visual indication that 
the �Blue� item has been selected should be 
apparent, and the �Red� item should no longer be 
selected. 

If the radio field can be manipulated as specified 
at left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 
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F.1.10. Inspect the table cell under the title �File Control 
Type�.  A single line text field should appear under 
the text �File to Submit:� with no initial contents.  
A file browser button should be associated with the 
file field. 

If the file field and browser button are displayed as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 

Note:  The Initial field contents do not appear as 
specified, and this criterion is waived.  All other 
criteria continue to be required. 

 Circle one: PASS / FAIL 

F.1.11. Select the file field specified in step F.1.10 and 
modify the filename to �*.asc�.  Click the �browse� 
button to invoke a file browser and select the file:  

 

�/kpc/WWW/*.html�. 

If the file field and file browser can be manipulated 
as specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.12. Inspect the table cell under the title �Reset Control 
Type�.  Two buttons, labeled �Reset: New Data� 
and �Reset: Error� respectively, should appear 
under the text select �Reset New Data�. 

If the Reset control is displayed as specified at left, 
then the test result is PASS, otherwise the test result 
is FAIL. 

 Circle one: PASS / FAIL 

F.1.13. Inspect the table cell under the title �Hidden 
Control Type�.  A single line of text �Hidden 
Control:� with no other features rendered in the 
cell.  No manipulation of features within the cell 
should be allowed. 

If the Hidden field is displayed as specified at left, 
then the test result is PASS, otherwise the test 
result is FAIL. 

 Circle one: PASS / FAIL 

F.1.14. Inspect the table cell under the title �Image 
Control Type�.  A button with the test pattern on it 
should appear under the text �Click Image to 
Submit Form:� 

If the Image control is displayed as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 
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F.1.15. Click on the image control specified in step F.1.13. 
A notification should be displayed that the form 
has been submitted. 

If the clicking the image control has the effect 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.16. Inspect the table cell under the title �Submit 
Control Type�.  Two buttons, labeled �Submit 
email� and �Submit File Xfer� respectively, should 
appear under the text �Choose Submission 
Method:�. 

If the Submit control is displayed as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.17. Click on the �Submit email� control specified in 
step F.1.15.  A notification should be displayed 
that the form has been submitted. 

If the clicking the image control has the effect 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.18. Click on the �Reset: New Data� control specified in 
step F.1.17.  All of the controls should resume 
their default state.   

Specifically, the controls would display the 
following contents: 

 

1. Text type: �your name� 

2. Password type: <blank> 

3. Checkbox type: �Right handed� 

4. Radio type: �Red� 

5. File type: �sample_data.dat� 

If the clicking the reset control has the effect 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 

Note:  The file field contents do not appear as 
specified, and this criterion is waived.  All other 
criteria continue to be required. 

 Circle one: PASS / FAIL 
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F.1.19. Click on the browser �Back� button to return to 
the top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

F.1.20. Log onto the Validation Host as sysadmin, and open 
an xterm window. 

The xterm displays a system prompt.  Circle one: PASS / FAIL 

F.1.21. On the Validation Host, at the xterm system 
prompt, open an email program by typing �mailx�. 

The xterm displays an email prompt  Circle one: PASS / FAIL 

F.1.22. On the Validation Host, at the email prompt, type 
�h� to verify receipt of the email from the 
candidate platform. 

The headers for the two messages should appear 
on the xterm, followed by an email prompt. 

 Circle one: PASS / FAIL 

F.1.23. On the Validation Host, at the email prompt, type 
�p� to print the messages, and compare them to 
attachment 9. 

 

The bodies of both messages should be identical to 
the attachment.  Note: The message header is not 
relevant to this test. 

If the bodies of both messages are identical to the 
attachment, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.1.24. On the Validation Host, at the email prompt, type 
�d� to delete both email messages.  Type �h� to 
confirm that the messages have been deleted. 

The headers for the two messages should be gone 
from the xterm, followed by an email prompt. 

 Circle one: PASS / FAIL 
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F.2. Selection Elements  

Note: The following steps should be performed on the Candidate Platform, unless otherwise 
noted. 

 

F.2.1. Under �Forms and Script Support�, click on the link 
labeled �Selection Elements�. 

The KPC �Forms � Selection Element Test Page� 
loads and displays. 

 Circle one: PASS / FAIL 

F.2.2. Under �Single Selection without Default� heading, 
inspect the selection element. 

Three items should be available for selection; 
�Red�, �Green�, and �Blue�.  The �Red� item is 
visible, but no item should initially be selected. 

If the indicated �select� control is displayed as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.3. Click the �Red� item on the selection element 
identified in step F.2.2.  A visual indication that the 
�Red� item has been selected should be apparent. 

If clicking the �Red� item has the effect specified 
at left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.4. Click the �Blue� item on the selection element 
identified in step F.2.2.  A visual indication that the 
�Blue� item has been selected should be apparent, 
and the �Red� item should no longer be selected. 

If clicking the �Blue� item has the effect specified 
at left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.5. Under �Single Selection with Default Item Pre-
Selected� heading, inspect the selection element.  
Five items should be initially visible, with a total of 
nine available for selection.  The list of items 
should include nine planets.  A visual indication 
that the �Earth� item has been selected as the 
default should be apparent. 

If the indicated �select� control is displayed as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 
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F.2.6. Click the �Mars� item on the selection element 
identified in step F.2.2.  A visual indication that the 
�Mars� item has been selected should be apparent 
and the �Earth� item should no longer be selected. 

If clicking the �Mars� item has the effect specified 
at left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.7. Under �Multiple Selections with Multiple Defaults� 
heading, inspect the selection element which 
includes a list of metals. 

All eight items should be initially visible, and 
available for selection.  A visual indication that the 
�Copper�, �Iron�, and �Titanium� items have been 
selected as the defaults should be apparent.  The 
�Aluminum�, �Tungsten�, Lead, Magnesium�, and 
�Zinc� items should not be selected. 

If the indicated �select� control is displayed as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.8. Select the �Lead�, and �Magnesium� items on the 
selection element identified in step F.2.7.  A visual 
indication that the �Lead�, and �Magnesium� items 
have been selected should be apparent and the 
other items should remain selected. 

If selecting the �Lead� and �Magnesium� items 
has the effect specified at left, then the test result 
is PASS, otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.9. Click on the �Submit Query� control at the bottom 
of the page.  A notification should be displayed 
that the form has been submitted. 

If the clicking the �submit� control has the effect 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.10. On the Validation Host, at the email prompt, type 
�h� to verify receipt of the email from the 
candidate platform. 

The headers for a message should appear.  Circle one: PASS / FAIL 
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F.2.11. On the Validation Host, at the email prompt, type 
�p� to print the message, and compare it to 
attachment 9. 

 

The body of the message should be identical to the 
attachment.  

 

Note: The message header is not relevant to this 
test. 

If the body of the message is identical to the 
attachment, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.2.12. On the Validation Host, at the email prompt, type 
�d� to delete the email message.  Type �h� to 
confirm that the message has been deleted. 

The header for the message should be gone from 
the xterm, followed by an email prompt. 

 Circle one: PASS / FAIL 

F.2.13. On the Candidate Platform in the browser window, 
click on the browser �Back� button to return to the 
top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

F.3. Text Area Elements  

F.3.1. Under �Forms and Script Support�, click on the link 
labeled �Text Area Elements�. 

The KPC �Forms � Text Area Element Test Page� 
loads and displays. 

Circle one: PASS / FAIL 

F.3.2. Inspect the text area element labeled �Read/Write 
Text Area�. The text area should display 4 rows by 
40 characters.  The text area should initially 
contain the text �This text is default input.� 
followed by 4 rows of 41 numeric characters. 

If the indicated �text area� control is displayed as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 
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F.3.3. Since the sample text exceeds the window length, 
some means to scroll the window vertically and 
horizontally should be apparent.  As an 
alternative, the browser may wrap text lines to 
keep long lines visible with the need for scrolling. 

If the indicated �text area� control scroll method 
(or word wrap) is displayed and operates as 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.3.4. Modify the text area specified in step F.3.3 by 
selecting the word �default�, and substituting the 
word �modified� in it�s place.  Also delete the 4 
rows of 41 numeric characters in the text area. 

If the text field can be manipulated as specified at 
left, then the test result is PASS, otherwise the 
test result is FAIL. 

 Circle one: PASS / FAIL 

F.3.5. Click on the �Submit query� control at the bottom 
of the page.  A notification should be displayed 
that the form has been submitted. 

If the clicking the �submit� control has the effect 
specified at left, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.3.6. On the Validation Host, at the email prompt, type 
�h� to verify receipt of the email from the 
Candidate Platform. 

The header for a message should appear.  Circle one: PASS / FAIL 

F.3.7. On the Validation Host, at the email prompt, type 
�p� to print the message, and compare it to 
attachment 9. 

 

The body of the message should be identical to the 
attachment. 

Note: The message header is not relevant to this 
test. 

If the body of the message is identical to the 
attachment, then the test result is PASS, 
otherwise the test result is FAIL. 

 Circle one: PASS / FAIL 

F.3.8. On the Validation Host, at the email prompt, type 
�d� to delete the email message.  Type �h� to 
confirm that the message has been deleted. 

The header for the message should be gone from 
the xterm, followed by an email prompt. 

 Circle one: PASS / FAIL 
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F.3.9. On the Validation Host in the xterm window, 
terminate the mail program by typing <CTRL>D. 

The xterm returns a system prompt.  Circle one: PASS / FAIL 

F.3.10. Log off of the Validation Host. A login screen appears on the Validation Host 
display. 

 Circle one: PASS / FAIL 

F.3.11. On the Candidate Platform in the browser window, 
click on the browser �Back� button to return to the 
top level WWW Test Page. 

The top level KPC �World Wide Web Test Page� 
loads & displays. 

 Circle one: PASS / FAIL 

F.3.12. On the Candidate Platform, terminate the browser 
program. 

The browser window disappears.  Circle one: PASS / FAIL 
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Z. 4.7 Logout   

(Optional:  Use if no further validation is to be done.) 

Z.1. Unmount the KPC Test Data  

Z.1.1. Unmount the KPC Test Data on the Candidate 
Platform enter: 

 

  umount /kpc 

 

A message confirms that the filesystem has been 
dismounted. 

 Cleanup 

Z.2. DeInstall Segmented Browser (Optional: If a Segmented Browser is installed)  

Z.2.1. DeInstall an HTML 3.2, HTTP 1.0 web-browser on 
the Candidate Platform as part of the test suite, 
using vendor-supplied documentation. 

 

A browser is available for execution on the 
Candidate Platform. 

Cleanup 

Z.3. Verify sysadmin Logout  

Z.3.1. Log out of the Candidate Platform as sysadmin. The menu bar, security classification and CDE 
desktop appear. 

 Shutdown 

Z.3.2. Click the EXIT button on the CDE menu bar: 

 EXIT  

 

Logout confirmation window appears.  Shutdown 
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Z.3.3. Click: 

 OK  

 

The system exits and the COE login screen 
appears. 

 Shutdown 

 

 

End of Test Validation Procedure 
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1. Overview 

1.1 Introduction 

This chapter defines the Network File System (NFS) Manual Validation Procedure and 
is part of the required set of test procedures to be used in the certification of 
products to the Open Brand COE Platform Product Standard1.  

 

2. Test Procedure 

2.1 Scope: 

This demonstration provides a first order verification of TCP/IP interoperability and 
basic BSD sockets API support for the Candidate Platform.  The demonstration also 
provides some assurance of application level interoperability for key Network File 
System (NFS) services and protocols. The demonstration suite for NFS uses a file 
located on the Validation Host and on the Candidate Platform.  A volume located on 
the remote Validation Host is mounted on the Candidate Platform, and key NFS client 
capabilities are exercised from the Candidate Platform.  A volume located on the 
Candidate Platform is then mounted on the Validation Host, and key NFS server 
capabilities of the Candidate Platform are exercised from the Validation Host. 

2.2 Description of test items 

The following functions will be exercised:  
 

A. Login  

B. Set Up Test Data and Confirm Validation Cell Configuration  

C. Exercise NFS Client Operations Initiated on the Candidate Platform  

C.1. Use NFS to Mount the Validation Host (Remote) File System onto the 
Candidate Platform (Local) File System  

D. Exercise NFS Server Operation Provided by the Candidate Platform to a 
Remote Client  

D.2. Log On the Validation Host as Sysadmin  

D.3. Use NFS to Mount a Candidate Platform File System on the Validation Host 
File System  

D.3. Use NFS to 'unmount' the Candidate Platform File System from the 
Validation Host File System  

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 E. Cleanup of Validation Host  

F. Remove KPC_NFS from the Candidate Platform Export List  

G. Re-establish the standard Candidate Platform configuration 

Z. Logout 

2.3 Test Data/Media Required   

The following test file is required: �nfsfl.txt�.  Test data is available on the Validation 
Host in the �/kpc/nfs� sub-directory. 

To determine if the NFS services (daemons) are running, use the system �ps �ef | 
grep nfs� 

Server Deamons:  In order for a machine to share resources over the network, it 
must be running the /usr/lib/nfs/mountd and /usr/lib/nfs/nfsd daemons. 

Client Deamons:  In order for a machine to mount networked resources, it must be 
running the /usr/lib/nfs/lockd and /usr/lib/nfs/statd deamons. 

2.4 Setup/Equipment Required 

The COE Validation Host must be running the NFS Service and must be available to 
the Candidate Platform.  The directory �/kpc� must be NFS exported from the 
Validation Host with world write-able privileges.  The Candidate Platform must be 
running the NFS Service and must be available to the Validation Host.  The 
Candidate Platform has no file systems exported 

The server directory �/kpc� is NFS mounted on the Candidate Platform as �/KPC�.  
The destination subdirectories for file transfers are �/KPCTEST� for the Validation 
Host, and �/KPC_NFS� for the Candidate Platform 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003   

Initial Release 

 



 

 

3. Test Procedure Submission Form 

Test Title: Network File System (NFS) Interoperability Demonstration Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 1 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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 Start of Validation Procedure 

4. Test Procedure 

 

Step Operator Action Expected Result Observed Result 

 A. 4.1 Power-Up and Verify sysadmin Login (Optional: Use if not already powered up or logged in.) 

 A.1. Verify sysadmin Login   

 A.1.1. Power up the Candidate Platform and verify that 
the COE Login screen opens. 

The COE login screen opens with the DoD 
security-warning message and the �Please 
enter your user name” text box. 

Setup 

 A.1.2. In the �Please enter your user name” 
text box enter: 
 sysadmin 

 

The password screen opens with the 
�Please enter your password” text box. 

Setup 

 A.1.3. In the �Please enter your password” 
text box enter the password for sysadmin: 
 password 

 

An Informational Message dialog box 
opens confirming the COE login process is 
compete. 

Setup 
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 A.1.4. Click: 
 OK  

 

The dialog box closes and the menu bar, security 
classification and CDE are displayed. 

 

 

 

Setup 

B. 4.2 Set Up Test Data and Confirm Validation Cell Configuration 

B.1. Set Up Test Data on Candidate Platform.  

B.1.1. On the Candidate Platform (kpccp) right click 
anywhere on the desktop click: 
 Applications > Application 
Manager >  DII_APPS > SysAdm. 

 

The Wokspace menu window opens.  The 
Application Manager – SysAdm window 
opens with the following icons: (go up), Adm 
Tool, Change Machine ID, Create 
Action, DTterm, Disk Manager, Edit 
Local Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, Xterm. 

Circle one:  PASS / FAIL 
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B.1.2. Double-click: 

 Disk Manager.  

The Disk Manager window opens. 

The Disk Manager window displays a list of all 
mounted file systems.  
The file system column contains 
kpchost:  

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

B.1.3. �Unmount� all NFS mounted volumes, if any. 

In the Disk Manager window, select an NFS 
mounted volume, and then select �unmount�.  
Repeat until all NFS volumes are “unmounted”. 

A dialog box may open for each “unmount”, 
asking if you wish the unmount to be permanent.  
Answer “Yes” in all cases, except for “/kpc”. 

The NFS mounted volume(s) closes from the Disk 
Manager window.  

The Candidate Platform is running the NFS service, 
but has no remote volumes mounted. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle one:  PASS / FAIL 

 B.1.4. Open an XTerm window right click anywhere on 
the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Circle one:  PASS / FAIL 

B.1.5. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Circle One:  PASS / FAIL 



© 2003, The Open Group 
Chapter 12, page 8 

 
 

 

 

Step Operator Action Expected Result Observed Result 

B.1.6. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Circle One:  PASS / FAIL 

B.1.7. At the system prompt enter: 
 csh 

 

The system prompt returns. Circle One:  PASS / FAIL 

B.1.8. To change to root directory at the system prompt 
enter: 
 cd / 

 

The system prompt returns. Circle One:  PASS / FAIL 

B.1.9. Create a new directory for NFS export at the 
system prompt enter: 
 mkdir KPC_NFS 

 

The system prompt returns. Circle One:  PASS / FAIL 

B.1.10. Change the permissions of the KPC_NFS directory 
to be world write-able at the system prompt enter: 
 chmod 777 /KPC_NFS 

 

The system prompt returns. Circle One:  PASS / FAIL 
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B.1.11. Confirm the change to permissions of the 
KPC_NFS directory at the system prompt enter:  
 ls -l / 

Directory listing shows that directory KPC_NFS 
has world write-able privileges. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

B.1.12. Relinquish super-user privileges at the system 
prompt enter:   
 Exit 

 

The system prompt returns. Circle One:  PASS / FAIL 

C. 4.3 Exercise NFS Client Operations Initiated On the Candidate Platform 

C.1. Use NFS to Mount the Validation Host (Remote) File System onto the Candidate Platform (Local) 
File System. 

 

C.1.1. On the Validation Host (kpchost) right click 
anywhere on the desktop click: 
 Applications > Application 
Manager >  DII_APPS > SysAdm. 
 

The Wokspace menu window opens.  The 
Application Manager – SysAdm window 
opens with the following icons: (go up), Adm 
Tool, Change Machine ID, Create 
Action, DTterm, Disk Manager, Edit 
Local Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, Xterm.The Application 
Manager – SysAdm window opens. 

Circle one:  PASS / FAIL 
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C.1.2. Open an Xterm window right click anywhere on 
the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Circle one:  PASS / FAIL 

C.1.3. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Circle One:  PASS / FAIL 

C.1.4. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.1.5. At the system prompt enter 
 csh 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.1.6. Change to root directory at the system prompt 
enter: 
 cd / 

 

The system prompt returns. Circle One:  PASS / FAIL 
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C.1.7. Change the permissions of the /kpc directory to be 
world write-able at the system prompt enter: 
 chmod 777 /kpc 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.1.8. Confirm the change to permissions of the /kpc 
directory.  At the system prompt enter:  
 ls -l / 

Directory listing shows that directory /kpc has 
world write-able privileges. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

C.1.9. Relinquish super-user privileges at the system 
prompt enter:   
 Exit 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.1.10. Right click anywhere on the desktop click: 
 Applications > Application 
Manager >  DII_APPS > SysAdm 
 

The Wokspace menu window opens.  The 
Application Manager – SysAdm window 
opens with the following icons: (go up), Adm 
Tool, Change Machine ID, Create 
Action, DTterm, Disk Manager, Edit 
Local Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, Xterm.The Application 
Manager – SysAdm window opens. 

Circle one:  PASS / FAIL 
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C.1.11. Double-click: 
 Disk Manager 

kpchost:/kpc opens in the Disk Manager 
window. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

C.1.12. Select the row containing “/” in the Mounted 
On column. 

The row is highlighted. Circle One:  PASS / FAIL 

C.1.13. Click: 
 Export FS 

 

The  Export/Unexport File Systems 
dialog box opens. 

Circle One:  PASS / FAIL 

C.1.14. In the options text box enter:   
 rw=kpccp 
 Pathname “/kpc/nfs” 

 

A dialog box opens asking “Export this 
directory permanently?  yes or no. 

If the dialog box opens as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Circle One:  PASS / FAIL 

C.1.15. Click: 
 Export 

 

A confirmation dialog box opens asking if the 
directory should be exported permanently. 

Circle One:  PASS / FAIL 

C.1.16. Click: 
 Yes 

 

The dialog boxes closes. Circle One:  PASS / FAIL 



© 2003, The Open Group 
Chapter 12, page 13 

 
 

 

 

Step Operator Action Expected Result Observed Result 

C.1.17. Double-click: 
 Disk Manager 

kpchost:/kpc does not appear in the Disk 
Manager window. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

C.1.18. On the Candidate Platform (kpccp) right click 
anywhere on the desktop click: 
 Applications > Application 
Manager >  DII_APPS > SysAdm. 

 

The Wokspace menu window opens.  The 
Application Manager – SysAdm window 
opens with the following icons: (go up), Adm 
Tool, Change Machine ID, Create 
Action, DTterm, Disk Manager, Edit 
Local Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, Xterm. 

Circle One:  PASS / FAIL 

C.1.19. Double-click: 
 Disk Manager 

 

The Disk Manager window opens. Circle One:  PASS / FAIL 

C.1.20. Click: 
 Mount New 

 

The Mount File System dialog box opens. Circle One:  PASS / FAIL 
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C.1.21. In the �FILE SYSTEM� text box enter: 
 kpchost:/kpc/nfs 

In the �MOUNT POINT� text box enter: 
 /kpc/nfs 

 

kpchost:/kpc opens in the text box. 

If the text box opens as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Circle One:  PASS / FAIL 

C.1.22. Click: 
 MOUNT 

 

A Confirmation dialog box opens asking if the 
directory should be mounted permanently. 

Circle One:  PASS / FAIL 

C.1.23. Click: 

 Yes 

 

The dialog box closes. Circle One:  PASS / FAIL 

C.1.24. Double-click: 
 Disk Manager 

kpchost:/kpc opens in the Disk Manager 
window. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

C.2. Exercise Disk Related Operations  

C.2.1. Open an Xterm window right click anywhere on 
the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Circle one:  PASS / FAIL 
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C.2.2. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Circle One:  PASS / FAIL 

C.2.3. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.2.4. Read a file from the remote volume and display 
enter: 
 cat /kpc/nfs/nfsfl.txt 

 

If the output opens as in attachment 1 (see below), 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Circle One:  PASS / FAIL 

C.2.5. Copy a file from the remote volume to the local 
disk. In the Xterm window enter: 
 cp /kpc/nfs/nfsfl.txt 

 /KPC_NFS/NFStest1.txt 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.2.6. Validate the successful file copy operation enter: 
 cat /KPC_NFS/NFStest1.txt 

 

If the output opens as in attachment 1 (see below), 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Circle One:  PASS / FAIL 
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C.2.7. Copy a file from the local volume to remote 
volume enter: 
 cp /KPC_NFS/NFStest1.txt 
 /kpc/NFStest2.txt 

 

The system prompt returns. Circle One:  PASS / FAIL 

C.2.8. Validate a successful file copy operation enter: 
  cat /kpc/NFStest2.txt 

 

If the output opens as in attachment 1 (see below), 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Circle One:  PASS / FAIL 

C.2.9. Append input to a file on the remote volume.  In 
the Xterm window enter: 
  vi /kpc/NFStest2.txt 

 

The vi editor displays NFStest2.txt in the 
Xterm window. 

Circle One:  PASS / FAIL 

C.2.10. In the Xterm window, move the cursor to the end of 
the file (after �END OF TEST FILE TEXT�). 

Insert the phrase “Data has been appended 
to this file”. 

Save the change enter: 
  <ESC>:wq! 

 

The system prompt returns. Circle One:  PASS / FAIL 
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C.2.11. Validate a successful file update operation enter:  
 cat /kpc/NFStest2.txt 

 

Output should appear as in Attachment 1 with the 
phrase “Data has been appended to 
this file” appended. 

If the output opens as described, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

C.3. Use NFS to ‘unmount’ the Remote Validation Host File System from the Candidate Platform 
(Local) File System 

 

C.3.1. In the Disk Manager window click on the row 
containing the kpchost:/kpc file system:  
 kpchost:/kpc 

  

The row is highlighted. Circle One:  PASS / FAIL 

C.3.2. Click: 

 UNMOUNT 

 

A dialog box opens asking �Do you want to 
permanently unmount this file system?�. 

If the dialog box opens as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Circle One:  PASS / FAIL 

C.3.3. Click: 

 Yes 

 

kpchost:/kpc volume is removed from the Disk 
Manager window. 

The Candidate Platform is running the NFS service, 
but has no remote volumes mounted. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 



© 2003, The Open Group 
Chapter 12, page 18 

 
 

 

 

Step Operator Action Expected Result Observed Result 

C.3.4. Validate a successful “unmount” operation enter: 
 ls -al /kpc/NFStest2.txt 

 

A warning message indicates file not found. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

C.3.5. Relinquish super-user privileges at the system 
prompt enter:   
 Exit 

 

The system prompt returns. Circle One:  PASS / FAIL 

D. 4.4 Exercise NFS Server Operations Provided by the Candidate Platform to a Remote Client 

D.1. Export the Candidate Platform File System  

D.1.1. On the Candidate Platform, in the Disk Manager 
window, select [EXPORTFS].  

Select the line with the root / file system.  

An “Export/Unexport” dialog box opens. 

If the dialog box opens as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Circle One:  PASS / FAIL 

D.1.2. In the “Export/Unexport” dialog box, in the 
“pathname” text box enter: 
 rw=kpchost 

 /KPC_NFS 

Click: 
 EXPORT 

 

A dialog box opens asking �Export this Directory 
Permanently?� 

If the dialog box opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 
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D.1.3. In the Yes/No dialog box click:  

 Yes 

The Disk Manager window lists all mounted file 
systems. 

kpccp:/kpc opens in the Disk Manager window. 

Circle One:  PASS / FAIL 

D.1.4. In the Disk Manager window confirm that the 
file system is exported click:  
 EXPORTFS 

 

The “Export/Unexport” dialog box opens. 

If the dialog box opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

D.1.5. In the �Export Dialog box� click:  

 CURRENT 

An �Exported File Systems� dialog box opens.  
“/KPC_NFS” opens in the list of exported file 
systems.  Qualifiers “rw” appear after the file 
system.  

If file system is listed in the dialog box as described 
above, the test step result is PASS, otherwise the 
test step result is FAIL. 

Circle One:  PASS / FAIL 

D.1.6. In the “Export Dialog box� click: 
 CANCEL 

 

The �Exported File Systems� dialog box closes. Circle One:  PASS / FAIL 

D.2. On the Validation Host, Login as sysadmin  

D.2.1. In the �Please enter your user name” 
text box enter: 
 sysadmin 

The password screen opens with the 
�Please enter your password” text box. 

Circle one:  PASS / FAIL 
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D.2.2. In the �Please enter your password” 
text box enter the sysadmin password: 

 Password 

 

An INFORMATIONAL MESSAGE dialog box 
opens confirming that DII COE LOGIN 
processing is compete. 

Circle one:  PASS / FAIL 

 

 

D.2.3. Click: 
 OK 

 

The dialog box closes and the Menu bar, security 
classification and CDE are displayed. 

Circle One:  PASS / FAIL 

D.2.4. Open an Xterm window right click anywhere on 
the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Circle One:  PASS / FAIL 

D.2.5. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Circle One:  PASS / FAIL 

D.2.6. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Circle One:  PASS / FAIL 
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D.2.7. Create the KPCTEST directory enter: 
 mkdir /KPCTEST 

 

The system prompt returns. Circle One:  PASS / FAIL 

D.2.8. Change to the KPCTEST directory enter: 
 cd /KPCTEST 

 

The system prompt returns. Circle One:  PASS / FAIL 

D.2.9. Change file permissions to world-writable enter: 
 chmod 777 /KPCTEST 

 

The system prompt returns. Circle One:  PASS / FAIL 

D.3. Use NFS to Mount a Candidate Platform File System on the Validation Host File System  

D.3.1. On the Validation Host (kpchost) right click 
anywhere on the desktop click: 
 Applications > Application 
Manager >  DII_APPS > SysAdm. 

 

The Wokspace menu window opens.  The 
Application Manager – SysAdm window 
opens with the following icons: (go up), Adm 
Tool, Change Machine ID, Create 
Action, DTterm, Disk Manager, Edit 
Local Hosts, Network Installation 
Server, Reboot System, Segment 
Installer, Set DNS, Set Routes, 
Set System Time, Shutdown System, 
Text Edit, Xterm. 

Circle One:  PASS / FAIL 
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D.3.2. Double-click: 
 Disk Manager 

 

The Disk Manager window opens. Circle One:  PASS / FAIL 

D.3.3. In the Disk Manager window click: 

 MOUNT NEW   

 

A �mount� dialog box opens. Circle One:  PASS / FAIL 

D.3.4. In the �MOUNT POINT� text box enter: 

 /KPC_NFS 

 

�kpccp:/KPC_NFS� opens in the Disk Manager 
window. 

Disk Manager window lists mounted file systems. 

If the file system opens as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Circle One:  PASS / FAIL 

D.3.5. Click: 
 MOUNT 

  

A Confirmation dialog box opens asking if the 
directory should be mounted permanently. 

Circle One:  PASS / FAIL 

D.3.6. Click: 

 Yes 

 

The dialog box closes. Circle One:  PASS / FAIL 
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D.3.7. Double-click: 
 Disk Manager 

kpchost:/kpc opens in the Disk Manager 
window. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

D.4. Exercise Disk Related Operations.  

D.4.1. In the Xterm window read and display a file from 
the remote volume enter:  
 cat /KPC_NFS/NFStest1.txt 

 

If the output opens as in attachment 1 (see below), 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Circle One:  PASS / FAIL 

D.4.2. In the Xterm window copy a file from the remote 
volume to local disk enter:  
 cp /KPC_NFS/NFStest1.txt 
 /kpc/NFStest3.txt 

 

The system prompt returns. Circle One:  PASS / FAIL 

D.4.3. In the Xterm window verify a successful file copy 
operation enter: 
 cat /kpc/NFStest3.txt 

 

If the output opens as in attachment 1 (see below), 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Circle One:  PASS / FAIL 



© 2003, The Open Group 
Chapter 12, page 24 

 
 

 

 

Step Operator Action Expected Result Observed Result 

D.4.4. In the Xterm window copy a file from the local 
volume to the remote volume enter:  
 cp /kpc/NFStest3.txt 
 /KPC_NFS/NFStest4.txt 

 

The system prompt returns. Circle One:  PASS / FAIL 

D.4.5. In the Xterm window validate a successful file 
copy operation enter: 
 cat /KPC_NFS/NFStest4.txt 

 

If the output opens as in attachment 1 (see below), 
the test step result is PASS, otherwise the test step 
result is FAIL. 

Circle One:  PASS / FAIL 

D.4.6. In the Xterm window append input to a file on the 
remote volume enter:  
 vi /KPC_NFS/NFStest4.txt 

 

The vi editor displays NFStest4.txt in the 
Xterm window. 

Circle One:  PASS / FAIL 

D.4.7. In the Xterm window move the cursor to the end of 
the file (after “END OF TEST FILE TEXT”). 

Insert the phrase �This file has more data�. 

Save the change by entering: 
 <ESC>:wq! 

 

The system prompt returns. Circle One:  PASS / FAIL 
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D.4.8. In the Xterm window verify a successful file update 
operation enter: 
 cat /KPCTEST/NFStest4.txt 

The output should appear as in attachment 1 with  
the phrase, �This file has more data� appended. 

If the output opens as described, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

D.5. Use NFS to ‘unmount’ the Candidate Platform File System from the Validation Host File System. 

NOTE:  When unmounting any system, there can be no processes (including X/Dtterm windows) 
using files inside the directory to be removed in question.  If there are, terminate them or this will 
fail. 

 

D.5.1. In the Disk Manager window click on the row 
containing the kpccp:/KPC_NFS file system:  
 kpccp:/KPC_NFS 

  

The row is highlighted. Circle One:  PASS / FAIL 

D.5.2. Click: 

 UNMOUNT 
 

A dialog box opens asking �Do you want to 
permanently unmount this file system?�. 

Circle One:  PASS / FAIL 

D.5.3. Click: 

 Yes 
The �kpccp:/KPC_NFS� volume is removed from 
the Disk Manager window. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 
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D.5.4. In the Xterm window verify a successful 
“unmount” operation enter:  
 ls -al /KPCTEST/NFStest4.txt 

 

A message indicates the file was not found. 

If a message opens as above , the test step result is 
PASS, otherwise the test step result is FAIL. 

Circle One:  PASS / FAIL 

D.5.5. Relinquish super-user privileges at the system 
prompt enter:   
 Exit 

 

The system prompt returns. Circle One:  PASS / FAIL 

E. 4.5 Cleanup of Validation Host 

E.1. Delete all “NFStestN.txt” files from the Validation Host.  

E.1.1. Open an Xterm window right click anywhere on 
the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Cleanup 

E.1.2. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Cleanup 
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E.1.3. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Cleanup 

E.1.4. Delete the test file NFStest2.txt enter:  
 rm /kpc/NFStest2.txt 

 

The system prompt returns. Cleanup 

E.1.5. Delete the test file NFStest3.txt enter:  
 rm /kpc/NFStest3.txt 

 

The system prompt returns. Cleanup 

E.1.6. Remove the /KPCTEST directory enter:  
 rmdir /KPCTEST 

The directory is removed and the system prompt 
returns. 

 

Cleanup 

E.1.7. Verify the /KPCTEST directory was deleted enter:  
 ls –l / 

 

The listing displayed does not include /KPCTEST. 

The system prompt returns. 

Cleanup 

E.2. Verify sysadmin Logout of the Validation Host.  

E.2.1. Logout of the Validation Host as sysadmin The menu bar, security classification and CDE 
desktop appear. 

Cleanup 
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E.2.2. Click:  

 EXIT 
Logout confirmation window opens. Cleanup 

E.2.3. Click: 

 CONTINUE 

 

System exits and the COE LOGIN screen opens. Cleanup 

E.3. NFS mount /kpc on the Candidate Platform  

E.3.1. Open a Terminal window right click anywhere 
on the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Circle One:  PASS / FAIL 

E.3.2. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Circle One:  PASS / FAIL 

E.3.3. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Circle One:  PASS / FAIL 
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E.3.4. On the Candidate Platform, in the Disk 
Manager window click: 
 MOUNT NEW 

 

A �Mount� dialog box opens. Circle One:  PASS / FAIL 

E.3.5. In the �MOUNT� dialog box, in the file 
system text box enter: 
 kpchost:/kpc 

 

A dialog box opens asking �Do you want to 
permanently mount this file system?�. 

Circle One:  PASS / FAIL 

E.3.6. In the MOUNT POINT text box enter:  
 /kpc 

 

�/kpc� opens in the Disk Manager window. 

Disk Manager window lists mounted file systems. 

If the file system opens as described above, the test 
step result is PASS, otherwise the test step result is 
FAIL. 

Circle One:  PASS / FAIL 

E.3.7. Click: 
 MOUNT 

 

A Confirmation dialog box opens asking if the 
directory should be mounted permanently. 

Circle One:  PASS / FAIL 

E.3.8. Click: 
 Yes 

The Disk Manager window lists mounted file 
systems. 

kpchost:/kpc opens in the Disk Manager 
window. 

Circle One:  PASS / FAIL 
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E.3.9. In the Disk Manager window click: 
 EXIT 

 

The Disk Manager window closes. Circle One:  PASS / FAIL 

E.3.10. List the contents of the /kpc subdirectory enter:  

 ls -al /kpc 
 

A directory list opens including the directory �nfs�. Circle One:  PASS / FAIL 

E.3.11. Relinquish super-user privileges at the system 
prompt enter:   
 Exit 

 

The system prompt returns. Circle One:  PASS / FAIL 

E.3.12. Exit from the Xterm window enter:  
 Exit 

 

The Xterm window closes. Circle One:  PASS / FAIL 

F. 4.6 Remove KPC_NFS from the Candidate Platform export list. 

F.1. Remove KPC_NFS  

F.1.1. In the Disk Manager window highlight the root 
/ file system and click: 
  Exportfs   
 

An �Export/Unexport� dialog box opens. Cleanup 
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F.1.2. In the “pathname” text box enter: 

 /KPC_NFS 
 

/KPC_NFS should be displayed in the pathname 
text box. 

Cleanup 

F.1.3. Click: 

 UNEXPORT 

 

A dialog box opens asking �Unexport this 
Directory Permanently?� 

If the dialog box opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Cleanup 

F.1.4. Click: 

 Yes 
The Disk Manager window lists mounted file 
systems. 

kpccp:/kpc opens in the Disk Manager window. 

Cleanup 

F.1.5. Confirm that the file system is un-exported in 
the Disk Manager window click: 
  EXPORTFS 

 

The �Export/Unexport� dialog box opens. Cleanup 

F.1.6. In the �Export/Unexport� dialog box click:    

 CURRENT 
An “Exported File Systems” dialog box 
opens. 

/KPC_NFS does not appear. 

If the file system opens as above, the test step result 
is PASS, otherwise the test step result is FAIL. 

Cleanup 
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F.1.7. In the �Export Dialog Box�click:   
 CANCEL 

 

The “Exported File Systems” dialog box 
closes. 

Cleanup 

G. 4.7 Re-establish the Standard Candidate Platform Configuration. 

G.1. Delete “NFStestN.txt” files  

G.1.1. Open an Xterm window right click anywhere on 
the desktop click: 
 Tools > Terminal 

 

The Wokspace menu window opens.  The tools 
window opens.  A Terminal window opens with 
a system prompt. 

Cleanup 

G.1.2. At the system prompt enter: 
 su –root 

 

The Password prompt returns. Cleanup 

G.1.3. At the Password prompt enter the root 
password enter: 

 Password 

 

The system prompt returns. Cleanup 

G.1.4. Delete the test file NFStest1.txt enter:   
 rm /KPC_NFS/NFStest1.txt 

 

The system prompt returns. Cleanup 
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G.1.5. Delete the NFStest4 file enter:   
 rm /KPC_NFS/NFStest4.txt 

 

The system prompt returns. Cleanup 

G.2. Remove the Temporary Test Directory.  

G.2.1. Change to the root / directory enter:  
 cd / 

 

The system prompt returns. Cleanup 

G.2.2. Remove the KPC_NFS subdirectory enter:  
 rmdir KPC_NFS 

 

The system prompt returns. Cleanup 

G.2.3. Verify that the KPC_NFS subdirectory has been 
removed enter: 
 ls /KPC_NFS 

 

System message indicates file not found. Cleanup 

G.2.4. Relinquish super-user privileges at the system 
prompt enter:   
 Exit 

 

 

The system prompt returns. Cleanup 
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Z. 4.8 Logout (Optional: Use if no further validation is to be done.) 

Z.1. Unmount NFS filesystems   

Z.1.1. Optional:  Use if any NFS file systems are 
mounted.  In the Application Manager – 
SysAdmin window double click: 

 Disk Manager. 

 

The Disk Manager window list mounted file 
systems. 

Cleanup 

Z.1.2. Optional:  Use if any NFS file systems are 
mounted.  Repeat until all NFS volumes are 
unmounted. 

In the Disk Manager window click: 

   UNMOUNT 

 

The NFS mounted volume(s) closes from the Disk 
Manager window. 

A dialog box opens asking �Do you want to 
permanently unmount this file system?�. 

 

Cleanup 

Z.1.3. Click: 

 Yes 

 

The dialog box closes. Cleanup 

Z.2. Verify sysadmin Logout on Candidate Platform  
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Z.2.1. Log out as sysadmin and exit the CDE click: 

 EXIT 

 

The menu bar, security classification and CDE 
desktop are displayed.  A Logout 
Confirmation window opens. 

Shutdown 

Z.2.3. Click: 

 OK 

 

System exits and the DII COE LOGIN screen 
opens. 

Shutdown 

 

 

End of Test Validation Procedure 
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1. Overview 

1.1 Introduction 

This document defines the TCP/IP �Ping� and DNS Interoperability Manual Validation 
Procedure and is part of the required set of test procedures to be used in the 
certification of products to the Open Brand COE Platform Product Standard1.  

2. Test Procedure 

2.1 Scope: 

This demonstration provides a first order verification of TCP/IP interoperability and 
basic BSD sockets API support for the Candidate Platform. The demonstration also 
provides an initial assurance of application level interoperability prior to 
demonstration of other services and protocols as well as for key Domain Name 
System (DNS) services and protocols. The Ping utility sends a request for simple 
acknowledgment and displays the result to the user. The DNS utility �nslookup� is 
exercised to retrieve and display DNS information about the Validation Host�s DNS 
client. 

2.2 Description of test items 

The following functions will be exercised:  
 

A. Login 

B. Identify Host Names and IP Address 

C. Use "Ping" to Validate the Communication Capability of the Candidate 
Platform  

Z. Logout 

 

2.3 Test Data/Media Required   

None 

 

 

 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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 2.4 Setup/Equipment Required 

The tester should begin this test procedure using a newly restored Candidate 
Platform and Validation Host.  The COE Validation Host must be running TCP/IP and 
DNS Service and must be available to the Candidate Platform.  NIS must not be 
running on the Candidate Platform.  The Candidate Platform must have the Ping 
client program and be configured as a DNS client of the Validation Host. 

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003 

Initial Release 
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3. Test Procedure Submission Form 

 

Test Title: TCP/IP �Ping� and Domain Naming System (DNS) Interoperability Demonstration Validation Procedure  

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 1 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        
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Start of Validation Procedure 

4. Test Procedure 

 

Step Operator Action Expected Result Observed Result 

A. 4.1 Power-Up and Verify Login   

A.1. Power up the Candidate Platform and verify that the 
COE Login screen opens. 

 

The COE login screen opens with the DoD security-
warning message and the �Please enter your user 
name� text box. 

 

Setup 

A.2. In the text box  �Please enter your user name � enter: 

sysadmin 

 

The password screen opens with the �Please enter 
your password� text box. 

Setup 

A.3. In the text box �Please enter your password� enter the 
sysadmin�s password. 
 

password  

 

An Informational Message dialog box opens 
confirming that COE login processing is compete. 

Setup 
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Step Operator Action Expected Result Observed Result 
A.4. Click: 

 OK  

The dialog box closes. 

The menu bar, security classification and CDE 
desktop displayed. 

 

Setup 

B. 4.2  Identify Host Names and IP Addresses 

B.1. On the Candidate Platform, open an Xterm window. 

 
Right click anywhere on the desktop and select  

 

Applications > Application Manager > DII_APPS > 
SysAdm 

The Application Manager � SysAdm window opens 
with the following icons:  

 

(go up), Adm Tool, Change Machine ID, Create 
Action, DTterm, Disk Manager, Edit Local Hosts, 
Network Installation Server, Reboot System, 
Segment Installer, Set DNS, Set Routes, Set System 
Time, Shutdown System, Text Edit, Xterm. 
 

Circle one:  PASS / FAIL 

 

 

B.2. Double Click: 

  Xterm 

An Xterm window opens and the login prompt is 
displayed. 

 

Circle one:  PASS / FAIL 

 

 
B.3. At the login prompt enter: 

 

sysadmin 

  

The password prompted is displayed.  Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
B.4. At the password prompt enter the sysadmin�s 

password. 

 

password  

 

The system prompt is returned. Circle one:  PASS / FAIL 

B.5. Check for Network Information Services (NIS) 
enter:   

 

ps �eaf|grep nis 

 

 

 

No NIS/NIS+ related processes should be present, 
including: 

 

1. nis_cachemanager 

2. rpc.nisd �Y 

3. rpc.nispasswdd 

 

(the grep of nis (i.e. grep nis) may be present and 
is acceptable.)  If NIS/NIS+ processes are 
present, remove NIS and restart this test 
procedure.   To remove NIS, select Network > 
Servers > NIS > remove NIS and follow the 
instructions.    

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
B.6. Check for Network Information Services (NIS) 

enter:  

 

ps �eaf|grep yp 

 

 

 

 

No NIS related processes should be present, 
including: 

 

1.  ypbind 

2.  ypserv 

3.  yppasswdd 

 
(the grep of yp may be present and is acceptable.) 
If NIS processes are present, remove NIS and 
restart this test procedure.  To remove NIS, select  
Network > Servers > NIS > remove NIS and 
follow the instructions. 

 

Circle one:  PASS / FAIL 

B.7. Check for Domain Name Service (DNS) enter: 

 

nslookup. 

 

The screen returns the following: 

 

Default Server: 

kpchost.kpc.disa.mil 

address 204.34.175.194 
 

followed by a > command prompt. 

 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
B.8. Check the listing of hosts enter: 

 

 ls �d kpc.disa.mil  

 
 

A listing of hosts and their IP addresses is 
displayed, followed by a > command prompt. 

 

If correct information is displayed for all Validation 
Cell hosts, test result is PASS otherwise the result is 
FAIL. 
 
Validation Host 

  Name:  ______________ 

  IP Address:  __________ 

 

Cell Network Printer 

  Name:  ______________ 

  IP Address:  __________ 

 

Candidate Platform 

  Name:  ______________ 

  IP Address:  __________ 
 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
B.9. Exit the nslookup prompt, 

  

Type:   

exit 
 

The nslookup utility is closed and the XTerm  
command prompt returns. 

Circle one:  PASS / FAIL 

C. 4.3 Use Ping to Validate the Communication of the Candidate Platform 

C.1. Invoke Super User in the XTerm window enter: 

 

su �root 

 

The password prompt is returned.  Circle one:  PASS / FAIL 

C.2. At the password prompt enter the root password: 

 

password  

 

A system command prompt returns in the XTerm 
window. 

Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 
C.3. Initiate a repetitive ping command.  At the system 

command prompt, 

 

Type: 
 ping –I 2 kpchost 

 
 

 

 

 

 

 

 

 

The following example is returned: 

 

pinging kpchost with 32 bytes of data 

 

reply from <host>: bytes=<32> 

time=<80ms> TTL=<249> 

reply from <host>: bytes=<32> 

time=<80ms> TTL=<249> 

: 

: 
 

If the result is similar to the expected response 
(parameters reported and values may vary), test 
result is PASS otherwise the test step result is 
FAIL. 

 

Circle one:  PASS / FAIL 

C.4. 

 

Halt the ping process enter: 

 

Ctrl Z 

 

Pinging of remote host stops. Circle one:  PASS / FAIL 
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Step Operator Action Expected Result Observed Result 

Z. 4.4 Verify sysadmin Logout 

Z.1. Click the EXIT button on the CDE menu bar. 

 EXIT 

 

Logout confirmation window opens. Logout 

 

Z.2. Click: 

 OK 

 

System exits and the COE login screen is 
displayed. 

Logout 

 

 

 

End of Test Validation Procedure 
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